Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 Jul 2014, 02:52
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
POU (mettre à jour les puplets de Puppy Linux)
Moderators: Béèm, darkerror05
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 8 of 12 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, 11, 12 Next
Author Message
ASRI éducation


Joined: 09 May 2009
Posts: 2338
Location: France

PostPosted: Tue 31 Dec 2013, 07:34    Post_subject:  

Argolance wrote:
Bonjour,
Quote:
Exact, je ne sais pas quoi faire pour résoudre ce problème, cela doit être tout simple, mais je ne trouve pas.
Si tu as une piste de résolution (ou mieux, une solution).
Le soucis c'est que ça ne le fait pas à tous les coups mais seulement après une manipulation que je n'arrive pas à reproduire... Confused

C'est le dysfonctionnement principal qu'il nous faut résoudre (car pour le reste c'est presque réglé, cf. ci-dessous).
J'encourage donc tous les contributeurs potentiels à cogiter !

Argolance wrote:
Quote:
Je ne souhaite pas diminuer les fonctionnalités de POU, mais je suis prêt à améliorer la vie des utilisateurs novices.
Je vais cogiter à une simplification de l'interface.
Toutes ces fonctionnalités sont nécessaires et je te suis quand tu ne souhaites pas les diminuer. Mais je me demande s'il ne serait pas plus simple, au lieu d'onglets supplémentaires dans l'interface principale, de faire une fenêtre distincte pour la configuration, accessible via un simple bouton situé sur cette interface principale?

Ok, je vais tester ta solution.

Argolance wrote:
Quote:
Rien n'empêche de créer des paquets cumulatifs, mais je vais tout de même améliorer l'installation silencieuse. Après, ce sera aux développeurs de puplets de décider.
Ce genre de script qui pourrait être "standalone" mérite d'être mené à terme car très utile en d'autres circonstances et sans équivalent ailleurs. Conjugué à la proposition de augras, ce serait le top!

Je sais qu'il ne faut pas vendre la peau de l'ours avant de l'avoir tué (je ne sais pas si cette expression sera comprise par l'ensemble de la communauté francophone), mais je crois pouvoir dire que nous allons bientôt bénéficier de ces deux possibilités. J'ai bien avancé sur le sujet et les premiers résultats sont encourageants.

Argolance wrote:
Remarque: le fichier d'aide complète ne peut pas être affiché, que ce soit en anglais ou en français car le dossier /usr/local/pou/help et son contenu sont manquants.

Toi, tu n'as pas installé le paquet NLS. Laughing

Argolance wrote:
Quote:
Autre chose, je ne sais pas si tu as remarqué, mais depuis pou-0.0.3 tu es co-auteur du script. Tu as donc la liberté de proposer/critiquer/etc.

Non, je n'avais pas vu... ce qui ne m'a pas empêché de prendre la liberté de proposer/critiquer/etc. Very Happy

Et je t'encourage évidemment à continuer !

Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send_private_message Visit_website 
Argolance


Joined: 06 Jan 2008
Posts: 1803
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 31 Dec 2013, 08:07    Post_subject:  

Hello,
ASRI wrote:
Non, ce n'est pas une bonne solution.
Je préfère que nous trouvions le moyen d'utiliser directement les icônes gtk déjà présentes dans toutes les distros actuelles (d'autant que les icônes gtk sont correctement reconnues par le GUI principal de POU).
Ce n'est pas la meilleure mais c'est la seule que j'ai trouvée! Embarassed Et je peux te dire que j'ai retourné le problème dans (presque) tous les sens...

Cordialement.

_________________

Back to top
View user's profile Send_private_message Visit_website 
Argolance


Joined: 06 Jan 2008
Posts: 1803
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 31 Dec 2013, 08:10    Post_subject:  

Hello,
Quote:
Toi, tu n'as pas installé le paquet NLS. Laughing
Ben oui, mais alors, ne faudrait-il pas au moins que le fichier d'aide en anglais soit inclus dans le paquet principal?

Cordialement.

_________________

Back to top
View user's profile Send_private_message Visit_website 
ASRI éducation


Joined: 09 May 2009
Posts: 2338
Location: France

PostPosted: Tue 31 Dec 2013, 08:13    Post_subject:  

Argolance wrote:
ASRI wrote:
Non, ce n'est pas une bonne solution.
Je préfère que nous trouvions le moyen d'utiliser directement les icônes gtk déjà présentes dans toutes les distros actuelles (d'autant que les icônes gtk sont correctement reconnues par le GUI principal de POU).
Ce n'est pas la meilleure mais c'est la seule que j'ai trouvée! Embarassed Et je peux te dire que j'ai retourné le problème dans (presque) tous les sens...

C'est donc dans le "presque" que nous allons trouver la solution !

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send_private_message Visit_website 
ASRI éducation


Joined: 09 May 2009
Posts: 2338
Location: France

PostPosted: Tue 31 Dec 2013, 08:17    Post_subject:  

Argolance wrote:
Quote:
Toi, tu n'as pas installé le paquet NLS. Laughing
Ben oui, mais alors, ne faudrait-il pas au moins que le fichier d'aide en anglais soit inclus dans le paquet principal?

Bof, car le NLS est destiné à accueillir tout ce qui est localisé. Cela permet de différencier le développement du script et les contributions des traducteurs.
Pour rappel, POU est destiné à être intégré dans l'iso. Il est peu probable que le développeur de puplet n'installe pas le NLS (ou alors il s'en apercevra avant de mettre son iso en ligne).
Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send_private_message Visit_website 
Argolance


Joined: 06 Jan 2008
Posts: 1803
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 31 Dec 2013, 08:44    Post_subject:  

Hello,
D'après ce que je vois sur l'image (http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=73369), Toutou Rolx se comporte comme si la dernière version de yad n'était pas installée, opérationnelle, pas prise en compte. Je me demande s'il ne faudrait pas voir si l'ancienne est bien écrasée par la nouvelle, bref, voir s'il n'y en a pas deux sur l'iso, un lien qu'il faudrait rediriger sur la nouvelle et supprimer l'ancienne.

Cordialement.

_________________

Back to top
View user's profile Send_private_message Visit_website 
Argolance


Joined: 06 Jan 2008
Posts: 1803
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 31 Dec 2013, 08:48    Post_subject:  

Hello,
Quote:
Bof, car le NLS est destiné à accueillir tout ce qui est localisé.

Les scripts gettextisés n'ont pas besoin de fichier mo en anglais. Pour les anglophones, n'avoir pas besoin d'aller chercher le fichier d'aide en anglais puisqu'il serait directement présent dans le paquet serait peut-être plus simple et logique? Je pose juste la question...

Cordialement.

_________________

Back to top
View user's profile Send_private_message Visit_website 
ASRI éducation


Joined: 09 May 2009
Posts: 2338
Location: France

PostPosted: Tue 31 Dec 2013, 08:55    Post_subject:  

Argolance wrote:
Hello,
Quote:
Bof, car le NLS est destiné à accueillir tout ce qui est localisé.

Les scripts gettextisés n'ont pas besoin de fichier mo en anglais. Pour les anglophones, n'avoir pas besoin d'aller chercher le fichier d'aide en anglais puisqu'il serait directement présent dans le paquet serait peut-être plus simple et logique? Je pose juste la question...

Cordialement.

Je suis d'accord, mais l'aide complète (au format html) n'est pas gettextée. Le script repère la locale utilisée, puis affiche le fichier html lié. L'aide complète ne fait donc pas partie du script.
Very Happy

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send_private_message Visit_website 
ASRI éducation


Joined: 09 May 2009
Posts: 2338
Location: France

PostPosted: Tue 31 Dec 2013, 08:56    Post_subject:  

Argolance wrote:
Hello,
D'après ce que je vois sur l'image (http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=73369), Toutou Rolx se comporte comme si la dernière version de yad n'était pas installée, opérationnelle, pas prise en compte. Je me demande s'il ne faudrait pas voir si l'ancienne est bien écrasée par la nouvelle, bref, voir s'il n'y en a pas deux sur l'iso, un lien qu'il faudrait rediriger sur la nouvelle et supprimer l'ancienne.

Cordialement.

Ok, je vais chercher dans cette direction.
D'autant qu'avec Puppy Precise je viens d'avoir le même problème.

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send_private_message Visit_website 
augras

Joined: 11 Nov 2013
Posts: 523
Location: france

PostPosted: Tue 31 Dec 2013, 09:15    Post_subject:  

Bonjour,
Sur rolx tout ce que j'ai essayé fonctionne sauf pour afficher l'icône tray : cette fichue icône n'apparaît jamais quoi que je fasse !
Au démarrage j'ai un message qui dit que poo est prévu pour mettre à jour puppy 0.0.0 mais que j'ai toutou rolx 5.5 et qu'il n'est pas approprié. J'avais ce message précédemment aussi.
Philippe
Back to top
View user's profile Send_private_message 
ASRI éducation


Joined: 09 May 2009
Posts: 2338
Location: France

PostPosted: Tue 31 Dec 2013, 09:24    Post_subject:  

augras wrote:
Sur rolx tout ce que j'ai essayé fonctionne sauf pour afficher l'icône tray : cette fichue icône n'apparaît jamais quoi que je fasse

Ce n'est pas normal. Même sans installer la dépendance "yad-0.23", l'icône tray doit s'afficher.
Tu es le premier à me faire cette remarque. Bizarre. A vérifier...
Ou alors, c'est que tu as déjà installé tous les paquets disponibles. Dans ce cas tu actives le GUI principal via le menu de Rolx, puis dans l'onglet Options tu cliques sur le bouton History, puis dans l'onglet Options tu cliques sur Reset all (cela efface l'historique des paquets installés).

augras wrote:
Au démarrage j'ai un message qui dit que poo est prévu pour mettre à jour puppy 0.0.0 mais que j'ai toutou rolx 5.5 et qu'il n'est pas approprié. J'avais ce message précédemment aussi.

C'est normal (et c'est voulu) puisque les paquets testés ne sont destinés à aucun OS en particulier.
Cette fonction évite aux utilisateurs de penser que les paquets de test sont destinés à leur OS.
Lorsque POU sera intégré/configuré pour une puplet précise, ce message ne sera plus affiché (ce sera bientôt le cas avec Rolx).

Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send_private_message Visit_website 
Argolance


Joined: 06 Jan 2008
Posts: 1803
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 31 Dec 2013, 09:56    Post_subject:  

Bonjour,
augras wrote:
Sur rolx tout ce que j'ai essayé fonctionne sauf pour afficher l'icône tray : cette fichue icône n'apparaît jamais quoi que je fasse !
Au démarrage j'ai un message qui dit que poo est prévu pour mettre à jour puppy 0.0.0 mais que j'ai toutou rolx 5.5 et qu'il n'est pas approprié. J'avais ce message précédemment aussi.
Question bête, mais as-tu coché la case "Use tray" ou (et) activé l’icône en cliquant sur le bouton "Activate tray"? Cette dernière opération devrait afficher l'icône, sinon dis-nous ce qu'il y a à ce sujet dans /tmp/xerrs.log, y compris après redémarrage du serveur X.

Cordialement.

_________________

Back to top
View user's profile Send_private_message Visit_website 
augras

Joined: 11 Nov 2013
Posts: 523
Location: france

PostPosted: Tue 31 Dec 2013, 09:57    Post_subject:  

J'avais tout installé !
Je me suis contenté de désinstaller un paquet et dans option d'activer icon tray et bien entendu ça fonctionne.
Philippe
Back to top
View user's profile Send_private_message 
ASRI éducation


Joined: 09 May 2009
Posts: 2338
Location: France

PostPosted: Tue 31 Dec 2013, 10:03    Post_subject:  

augras wrote:
J'avais tout installé !
Je me suis contenté de désinstaller un paquet et dans option d'activer icon tray et bien entendu ça fonctionne.
Philippe

A chaque problème, sa solution !
Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send_private_message Visit_website 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Tue 31 Dec 2013, 13:29    Post_subject:  

Bonjour à toutes et tous,

Concernant l'affichage dans la barre des tâches, sous Rolx, je n'ai constaté aucun problème, à part celui des deux icônes qui ne veulent pas s'afficher, noté précédemment et résolu provisoirement.

Bonne soirée Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 8 of 12 Posts_count   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, 11, 12 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0996s ][ Queries: 12 (0.0055s) ][ GZIP on ]