Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 20:51
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
How to compile Gambas 3.4.1?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Sat 18 May 2013, 07:13    Post subject:  How to compile Gambas 3.4.1?  

i want to compile the new Gambas 3.4.1 for lucid / Lazy Puppy

i have done so fare:
loading: qt4-4.8.0.sfs, qt4_DEV-4.8.0.sfs, LP2_DevX.sfs
the files for Gambas into a sub of root.
start a roxterm and following lines:

Code:
export PKG_CONFIG_PATH=/opt/qt4/lib/pkgconfig/
mkdir $HOME/gambas-puppylinux
./reconf-all && ./configure --prefix=$HOME/gambas-puppylinux && make && make install


In the end, gambas is not generated and I get error messages
Code:
Unable to met pkg-config requirement: Qt3Support
|| gb.qt4 is disabled
|| Unable to met pkg-config requirement: Qt3Support
|| gb.qt4.ext is disabled
|| Unable to met pkg-config requirement: QtDBus
|| gb.qt4.webkit is disabled
|| Unable to met pkg-config requirement: QtOpenGL
|| gb.qt4.opengl is disabled

it looks as if some files are missing or?
Where can I find Qt3Support, QtDBus, QtOpenGL

Code:
Logfile:
||
|| Unable to find file: libintl.so
|| This library may be located inside the system C library, so you can ignore that warning...
|| Unable to find file: libiconv.so
|| This library may be located inside the system C library, so you can ignore that warning...
|| Unable to met pkg-config requirement: libffi
|| Unable to find file: ffi.h
|| Unable to find file: libffi.so
|| libffi is disabled
|| libffi is disabled
||
|| Unable to find file: mysql.h
|| Unable to find file: my_config.h
|| Unable to find file: libmysqlclient.so
|| gb.db.mysql is disabled
||
|| Unable to find file: sql.h
|| Unable to find file: sqlext.h
|| Unable to find file: sqltypes.h
|| Unable to find file: libodbc.so
|| gb.db.odbc is disabled
||
|| Unable to find file: libpq-fe.h
|| Unable to find file: postgres.h
|| Unable to find file: pg_type.h
|| Unable to find file: libpq.so
|| gb.db.postgresql is disabled
||
|| Unable to find file: sqlite.h
|| Unable to find file: libsqlite.so
|| gb.db.sqlite2 is disabled
||
|| Unable to met pkg-config requirement: gmime-2.6
|| Unable to met pkg-config requirement: gmime-2.4
|| gb.mime is disabled
||
|| Unable to met pkg-config requirement: sdl
|| Unable to met pkg-config requirement: > 1.2.8
|| Unable to met pkg-config requirement: SDL_ttf
|| Unable to met pkg-config requirement: glew
|| Unable to find file: GL/glew.h
|| Unable to find file: SDL_ttf.h
|| Unable to find file: libSDL_ttf.so
|| Unable to find file: libGLEW.so
|| gb.sdl is disabled
||
|| gb.sdl.sound is disabled
||
|| Unable to met pkg-config requirement: libv4lconvert
|| gb.v4l is disabled
|| gb.v4l is disabled
||
|| Unable to met pkg-config requirement: Qt3Support
|| gb.qt4 is disabled
|| Unable to met pkg-config requirement: Qt3Support
|| gb.qt4.ext is disabled
|| gb.qt4.webkit is disabled
|| Unable to met pkg-config requirement: QtOpenGL
|| gb.qt4.opengl is disabled
||
|| Unable to met pkg-config requirement: gtkglext-1.0
|| gb.gtk.opengl is disabled
||
|| Unable to met pkg-config requirement: glew
|| gb.opengl is disabled
|| Unable to met pkg-config requirement: glew
|| gb.opengl.glsl is disabled
|| gb.opengl.glu is disabled
||
|| Unable to met pkg-config requirement: imlib2 >= 1.4.0
|| gb.image.imlib is disabled
||
|| Unable to met pkg-config requirement: gsl
|| Unable to find file: gsl/gsl_cblas.h
|| Unable to find file: gsl/gsl_math.h
|| Unable to find file: libgslcblas.so
|| Unable to find file: libgsl.so
|| gb.gsl is disabled
||
|| Unable to met pkg-config requirement: gstreamer-0.10 >= 0.10.31
|| Unable to met pkg-config requirement: gstreamer-interfaces-0.10
|| gb.media is disabled
||

||
|| THESE COMPONENTS ARE DISABLED:
|| - gb.db.mysql
|| - gb.db.odbc
|| - gb.db.postgresql
|| - gb.db.sqlite2
|| - gb.gsl
|| - gb.gtk.opengl
|| - gb.image.imlib
|| - gb.jit
|| - gb.media
|| - gb.mime
|| - gb.opengl
|| - gb.opengl.glsl
|| - gb.opengl.glu
|| - gb.qt4
|| - gb.qt4.ext
|| - gb.qt4.opengl
|| - gb.qt4.webkit
|| - gb.sdl
|| - gb.sdl.sound
|| - gb.v4l
||


Greetings

Wolfgang
Back to top
View user's profile Send private message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Wed 22 May 2013, 17:19    Post subject:  

Is there really no who can help me to generate a current Gambas for Puppy? Embarassed
Nobody needs this great development program?

Greetings

Wolfgang
Back to top
View user's profile Send private message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Fri 21 Jun 2013, 16:17    Post subject:  

Hi,

Hoermirauf has build a gambas3.sfs

http://murga-linux.com/puppy/viewtopic.php?search_id=126731973&t=86134

in lucid / lazy i get the error: "gbr3: /lib/libc.so.6: version 'GLIBC_2.15' not found"

Were can i get this libc-version and can i include in lucid?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0467s ][ Queries: 11 (0.0046s) ][ GZIP on ]