Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 16:46
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Upup Raring 3.8.7 with non-PAE 3.8.7 kernel, created using
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 16 of 25 [371 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18, ..., 23, 24, 25 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 28 Apr 2013, 18:15    Post subject:  

OscarTalks. That sounds like a bug. You could file a link to your report in Barry`s blog. He might have idea what could be wrong. Sis_drv.so has been included and it is in appropriate location. Just checked.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Sun 28 Apr 2013, 19:04    Post subject:  

Just a quick note if anyone else has been unable to play flash videos.....the included Flash 11 in Raring doesn't work with some older cpus (including my trusty Athlon XP).Reverting back to Flash 10 solves it.
Back to top
View user's profile Send private message 
majorfoo

Joined: 07 Mar 2011
Posts: 445
Location: Wish I knew

PostPosted: Sun 28 Apr 2013, 22:08    Post subject:  

Full install to ext3 partition
Everything works OTB

Added following
installed pkgs.png
 Description   
 Filesize   40.17 KB
 Viewed   658 Time(s)

installed pkgs.png

Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4817
Location: GB

PostPosted: Mon 29 Apr 2013, 01:46    Post subject:  

Confirm that the SiS bug is back. But the FlashPlayer issue is a show-stopper for Brits (and possible overseas subscribers to BBC). Then there's the browser choice - good/bad to see rodin confirms SM reported crash.
Back to top
View user's profile Send private message 
linux28

Joined: 05 Apr 2009
Posts: 211

PostPosted: Mon 29 Apr 2013, 04:31    Post subject:  

(xfce4-terminal:9663): GLib-WARNING **: (/build/buildd/glib2.0-2.36.0/./glib/gerror.c:390):g_error_new_valist: runtime check failed: (domain != 0)
Failed to connect to session manager:



sakura

** (sakura:9407): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 574
Location: UK

PostPosted: Mon 29 Apr 2013, 05:45    Post subject: Testing Upup Raring version 3.8.7  

Hi Pemasu,

The above runs fine from a DVD-R with Ext2 savefile on a fat32 SD card. It is very quick and notably light on memory usage.

I installed your browser-support-fix-0.0.1.pet followed by Chromium and updated flash to the very latest. No problems playing
Swf files or BBC TV online.

What I did find however, is a problem with f2fs support which was not an issue with UpupPrecise k3.8.3.1. Basically on a fat32/f2fs USB2 stick it does
not see and therefore find the main sfs when it is placed on the f2fs partition. On the same stick I am booting k3.8.3.1 with this code:

Code:
LABEL p3831
MENU LABEL  UpupPre k3.8.3.1    28/04/13
KERNEL /p3831/vmlinuz
APPEND initrd=/p3831/initrd.gz pmedia=usbflash psavemark=2


If I use similar code as below the sfs is not found. If I force the issue with additional codes as shown, the sfs loads but then results in a kernel panic
only soluble by a hard power off.

Code:
LABEL p387
MENU LABEL  UpupRar k3.8.7      28/04/13
KERNEL /p387/vmlinuz
# APPEND initrd=/p387/initrd.gz pmedia=usbflash psavemark=2
APPEND initrd=/p387/initrd.gz pmedia=usbflash pupsfs=sdb2:/p387/puppy_raring_3.8.7.sfs psavemark=2 pdev1=sdb2


It would seem that the f2fs drivers are not being loaded by the kernel at boot time. I am not clear whether this is a feature of the later kernel or a compile option.

_________________
Regards ETP
Accessibility Pups: -- Magoo -- The Pup With No Name -- MouseCam -- Obedient
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 29 Apr 2013, 08:44    Post subject:  

Quote:
But the FlashPlayer issue is a show-stopper for Brits

There is latest flashplayer included in Upup Precise 3.8.7. I upgraded it because I got complaint about including older version.

So...with old comp which does not accept 11 version, downgrade to use 10 version. Oh....how I do that ?....Easy....just click: Menu > Internet > GetFlash Install Flashplayer and choose Flashplayer10. And download that older version which downgrades the installed Flashplayer11 and older comp can use flashplayer again.

ETP. Thank you of the feedback. My mistake. I had included f2fs as module...not built in...as it should have been.
It means kernel recompile. I will update to the latest kernel version at this situation. Lets see how it behaves. Lol.
And BIG thanks of your bug finding !
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 574
Location: UK

PostPosted: Mon 29 Apr 2013, 11:10    Post subject:  

Hi Pemasu,

k 3.9 with the much anticipated improvements to f2fs and much besides has just been released. Smile
http://www.zdnet.com/linux-3-9-kernel-release-offers-ssd-caching-and-server-performance-improvements-7000014649/

Happy compiling.

_________________
Regards ETP
Accessibility Pups: -- Magoo -- The Pup With No Name -- MouseCam -- Obedient
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 29 Apr 2013, 11:20    Post subject:  

ETP. I have to wait aufs 3.9 version. It probably takes 2 weeks to one month before it is available. As much as I would like to compile it right away.
Back to top
View user's profile Send private message 
linux28

Joined: 05 Apr 2009
Posts: 211

PostPosted: Mon 29 Apr 2013, 12:07    Post subject:  

wait 3.9 version Crying or Very sad Crying or Very sad Crying or Very sad
Just installed 3.8.7, configuration, wait for 3.9, look forward to faster
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4817
Location: GB

PostPosted: Mon 29 Apr 2013, 12:18    Post subject:  

Quote:
flashplayer

Tried several - no luck. I keep several on USB stick after previous issues!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 29 Apr 2013, 12:22    Post subject:  

http://distro.ibiblio.org/quirky/pet_packages-common/flashplayer10-10.3.183.23.pet

This is the older one which has been in my builds earlier. If it does not work, then the problem lies somewhere else.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 29 Apr 2013, 14:31    Post subject:  

https://bugzilla.mozilla.org/show_bug.cgi?id=672671
scroll to the bottom.

it is related to this bug with glib 2.36, which Ubuntu Raring uses:
Code:
GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed


We can only wait until Mozilla.org fixes the bug. It affects Thunderbird, Seamonkey and Firefox. For me it causes Thunderbird hanging after prolonged idle period.

Should I swap to the Chromium browser while waiting ?
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Mon 29 Apr 2013, 15:40    Post subject:  

pemasu wrote:
https://bugzilla.mozilla.org/show_bug.cgi?id=672671
scroll to the bottom.

it is related to this bug with glib 2.36, which Ubuntu Raring uses:
Code:
GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed


We can only wait until Mozilla.org fixes the bug. It affects Thunderbird, Seamonkey and Firefox. For me it causes Thunderbird hanging after prolonged idle period.

Should I swap to the Chromium browser while waiting ?


FWIW, the error message doesn't bother me and I'll continue using SeaMonkey personally so feel free to use your choice of browser. The choice of web browsers in Puppy always leads to a bunch of divided opinions anyway. Laughing

I only reported it because that's the purpose of testing........
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 29 Apr 2013, 15:49    Post subject:  

Quote:
The choice of web browsers in Puppy always leads to a bunch of divided opinions anyway. Laughing


Yeah....seen those. I have kept myself out of them so far Smile
Basically it is easy here. I dont offer official Puppy, so I can decide what I put to the build. But in this case I am somewhat willing to listen the opinions.
Now there is real reason for thinking. Seamonkey has crashed according to the feedback. Okay....keeping it at the update channel and when bug fixed version pops up....I believe people will update quickly.

Or...it can be also that glib 2.36 get ubuntu patch. Who knows....
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 16 of 25 [371 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18, ..., 23, 24, 25 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0904s ][ Queries: 12 (0.0133s) ][ GZIP on ]