Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Mar 2019, 07:34
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Fatdog stopped liking my TV
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message

Joined: 25 Mar 2013
Posts: 57

PostPosted: Mon 25 Mar 2013, 17:44    Post subject:  Fatdog stopped liking my TV
Subject description: HDMI sound left behind

Since I have never posted before feel free to point me to the correct discussion forum. I have been using Puppy versions for years. We use Fatdog64 on a number of netbooks and laptops for multimedia. Maybe this is more a constructive feedback item than a problem: the latest version (620) stopped passing sound through HDMI on my largest Philips bigscreen TV. I can say this because it works on other HDMI TV's and on multiple machines with identical boot sequences.

Therefore, this distribution stopped liking my biggest TV. Not a big deal. I downgraded Fatdog rather than use Windows 8, which after one week of use erected opaque nag screens in the middle of my family movies instructing me to call them long distance to validate my brand new purchase.

If I didn't know better I'd say 620 "thinks" everything is playing...it gives no error...which seems like there is a mysterious undocumented "mute function" it either invokes in my TV (which can render sound in every other way) or in itself. Everything including VLC says it's playing through the same card it plays through on other TV's with the same Zarfy settings flawlessly. I'm thinking my biggest bigscreen has dropped off some firmware validation list somewhere, somehow.

I suspect this may arise elsewhere so it is more an FYI..or maybe an excuse for some really even bigger TV purchase... or someone might point me at a really simple reason (like my save folder has a datatable of TV serials that is full of my other ones that work and there is no more room for my big one...or some such other thing I am universally clueless about...except all the same symptoms follow using no savefile)
Back to top
View user's profile Send private message 
Ted Dog

Joined: 13 Sep 2005
Posts: 4013
Location: Heart of Texas

PostPosted: Mon 25 Mar 2013, 17:53    Post subject:  

Choose the last settings in the ASLA sound wizard for HDMI, after every reboot. It does not seem to 'stick' for some reason.
Back to top
View user's profile Send private message 

Joined: 25 Mar 2013
Posts: 57

PostPosted: Tue 26 Mar 2013, 12:43    Post subject: Thanks for that response  

I just tried that, and it appears Fatdog saves the the alsa profile from boot to boot as I boot it attached to other TV's and sound is fine. Either that or the detection/boot profile is the same in the control panel configuration: the default is the correct card. I don't know what generates the little speaker icon on the lower toolbar but it never appears for HDMI, whether it is passing through sound or not. If I use this same distro on a non-HDMI computer the icon appears and has control/mute possibilities. It seems somehow that this is missing for HDMI sound and possibly muted in its lack of a viewable state...just for this particular TV--like it gets that from an unsupported handshake(?)
Back to top
View user's profile Send private message 

Joined: 11 Nov 2005
Posts: 1536
Location: florida

PostPosted: Wed 27 Mar 2013, 22:13    Post subject:  


If you choose HDMI as your default, there is no volume level to set so there is no volume level control in lxpanel. However it can be muted. See Sound Problems in the FAQs.

Note that 620 is still under development, in fact James just checked in some changes to the sound card wizard.
Back to top
View user's profile Send private message 

Joined: 25 Mar 2013
Posts: 57

PostPosted: Wed 03 Apr 2013, 11:11    Post subject: Thanks for the responses  

I upgraded to the Beta2 iso and the result is identical. Nothing is muted as far as the "MM": it is "00". Fatdog "thinks" it is unmuted out the HDMI yet there is no passthrough; with everything identical I get sound on other TV's. I think there is something in the way it handshakes with the latest drivers, as I "hear" and audible snap during boot while I watch the command lines on the TV screen...then the sound disappears when it "blanks down and reconnects".

There are other changes in these last upgrades, like one of my Netbooks boots to a dimmed state, etc. As I said, I'm not one who calls 911 when I have an older working version. This was more of an FYI as someone might run into this somewhere, someday.

And point well taken. I won't bother anyone with anything that has a beta version evolving with it...I don't even think a ticket would have been in order here...it may be some unenforced HDMI standard that has evolved.

Fatdog is superb and the price is right.
Back to top
View user's profile Send private message 

Joined: 25 Mar 2013
Posts: 57

PostPosted: Wed 03 Apr 2013, 17:26    Post subject: A partial solution for those interested  

I finally got some HDMI sound out of this big TV. Two methods work: booting with the TV off and/or cable disconnected.

This has its drawbacks since Zarfy no longer seems to remember the correct resolution in the save folder. Therefore, I can watch a movie in approximately 1900x1200 on a 1360x768 screen and get sound. When I reset Zarfy to the correct resolution the sound on all MPEG2 files disappears.
In other words VOB files from disk and unencrypted DVD5's in the drive play perfectly: video only. However FLV video plays WITH sound through the HDMI in VLC under the exact same circumstance. Like the card works with one codec and only thinks it is with the other.

So, in case this was now a codec/VLC issue, for informational sake I installed MPlayer-1.0rc4.pet. This might prove useful, I thought, since I can no longer seem to reliably drag a whole VIDEO_TS folder into VLC without getting MRL errors. However upon invoking MPlayer it promptly informed me I lacked (?) libdvso4.so, and I don't have the facility in that test environment to chase dependencies. 611 went back on that TV.

However it DID kind of work...I could probably reposition VLC in a corner of the screen and watch with HDMI sound but incorrect resolutions are not what I was taught to use. Yet it is still clearly that TV since the same distro works flawlessly on other TV's. I hope this helps someone someday.
Back to top
View user's profile Send private message 

Joined: 26 Feb 2007
Posts: 3278
Location: The Blue Marble

PostPosted: Thu 04 Apr 2013, 00:44    Post subject:  

That is indeed strange, that resizing with zarfy kills the sound. Also odd that it works with FLV but not with DVD/VOB. Do you have any other - AVI, WMV files to try? What I can think of at the moment is that your VOB / DVD has 5.1 sounds and that simply isn't downmixed to stereo for the HDMI.

However I can't explain why it works with 611 and not with 620beta Rolling Eyes May be kirk has other ideas Rolling Eyes

What is your graphic card?

As for mplayer pet, you need to install lives_support.pet for the missing libs. These libs used to be part of the base iso, but when we dropped kino (for avidemux) we packaged them into lives_support.pet as they were needed by lives. Apparently it is also needed by mplayer, thanks for pointing that one out Embarassed

Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 

Joined: 25 Mar 2013
Posts: 57

PostPosted: Sat 06 Apr 2013, 15:03    Post subject: Thanks for the help  

It took a little while to get it functional again. Answers follow:

1)Plays .avi, .mp4, .mp3, .flv, webm (although Xarchiver wants it first), but no .vob or physical dvd (video fine). VLC reports no audio errors and decodes output buffer = input buffer (just nothing audible, but zero discarded/dropped packets). When choosing various audio tracks in vob media it "thinks it is playing lpcm and dts (whichever)" but errors out on AC3 reporting "audio device iec958:AES0... could not be used". AC3 plays fine on all other of my TV's (none of which are Philips, btw), given same parameters.

2)Although I tried other laptop/notebook(s) the one I am testing now is Acer Aspire 5253, AMD C-50, dual-core, 4GB, ATI Radeon, AMD High Def'n Audio dolby digital, Conexant High Def'n speakers (they work fine), HDMI to a Philips 105S2. Puppy reports ATI Tech Device 9804 Vendor 1002, and
Azalia (Intel HDA rev40) Device 4383 Vendor 1002.

For this one 611 has been the "answer". We will play with Mplayer which we use on Lupu on older machines and until VLC behaves. For some reason I can drag very large VIDEO_TS folders on this same machine in Win7 into VLC and they play/down-mix, etc., while this Linux version of VLC chokes on the same and spews MRL errors opting to play one VOB at a time with visible gaps between. One cannot ask the world of an operating system running from a USB as opposed to one on a hard disk designed for the hardware, but often with folders in the under 4Gb range it unexpectedly does the same. That appears to be a VLC issue because once upon a time it didn't, even when I played the same ones out of a dynamically encrypted volume.

Again, we appreciate your fine work, and are grateful admirers. Congratulations.
Back to top
View user's profile Send private message 

Joined: 25 Mar 2013
Posts: 57

PostPosted: Thu 11 Apr 2013, 17:32    Post subject: Better with latest Beta(3)  

Just a note here: with the latest Fatdog64 beta ISO this situation has become clearer. The newer sound card chooser (not the deprecated wizard), although it failed to keep its setting between reboots, needed no initial reboot to work.

VLC, no mater what I invoked would not play much. It played OGG audio beautifully through HDMI, but only everything else through the laptop speakers when asked.

MPlayer played everything except VOB through the HDMI. Polite suggestion:
typing in long path strings with lots of options in the terminal emulator can reach a degree of fatigue. I was in a lab (late 1970's Silicon Valley) where everyone had a wireless workstation (yes, well before wireless and even cell phones) and the command line was more robust. If you have ever tried/used Backtrack take a look at that command line--it is a lot of fun.
One note: Mplayer audio did not work at all with any of the new soundcard wizard's plug-ins activated.

Xine did the best of the three since we are heavy into multiple subtitle streams, but it would still not render sound in a VOB or DVD through HDMI. Asking it to downmix sound to two channels also gave nothing.

Zarfy was now well-behaved boot to boot. All of these players reported no frames dropped and "thought" they were outputting sound (and MAY have been) but some rendered certain codecs and others didn't audibly.

This was just FYI since I am going through this anyway. The only way sound has passed through HDMI (since 611) has been once while Zarfy mis-detected the resolution of the HDMI monitor.
Back to top
View user's profile Send private message 

Joined: 25 Mar 2013
Posts: 57

PostPosted: Sun 21 Apr 2013, 16:33    Post subject: New 620 works outof the box  

Just for posterity's sake here is the post mortem on
my burning the new 620 non-beta ISO:

1)Booting to HDMI detected screen as 1280 instead of 1360.
Chose HDMI soundcard with new wizard and no plugins. Rebooted
with savefile on EXT2 hard disk and all files: even DVD's played
great in new VLC (dragged 7Gb VIDEO_TS folder onto icon and it
played whole thing. All other video files/formats played great(!).

2)Changed HDMI monitor screen to 1360 so we could go fullscreen
with VLC and see feet, heads, etc., and sound disappeared on all
files except .ogg sound.

3)Re-selected soundcard and rebooted. Still no sound. Attempted to
resize back to 1280 HDMI resolution and rebooted. No sound. Rebooted.

4)Intrigued by new game Armagetron; got blank screen with cursor.
Hour later still there. Felt stupid, admonished self for talking to strange app no combination of hotkeys could escape from: hard-rebooted.

No sound with soundcard plugins, without, or in any form except (again) simple .ogg file which passed though loud and clear.

5)Conjecture: Zarfy blanks the screen and creates a new HDMI handshake which doesn't speak HDCP, and disallows what it assumes
are prohibited sound codecs even when they are not copy-protected(?).
This hardly explains why the last Beta sound played but not this release with the exact same flv's...

6)None of this matters since it appears I can upgrade VLC for 611
and have the best of both worlds.

Will use cool new release for web!
Back to top
View user's profile Send private message 

Joined: 25 Mar 2013
Posts: 57

PostPosted: Sat 15 Jun 2013, 22:48    Post subject: Newsflash  

I decided to abandon save files and folders and dedicate
a USB key to each machine playing DVDs off hard disk we watch.

That way I could keep my fussy TV on and older distro.

And now, for the very first time I had another TV experience sound
issues over HDMI. I post this for posterity:

1) Same usb key with no change files ever after remastering was used to play on Acer Netbook. Played every format great (latest Fatdog distro) over HDMI.

2) I went on vacation and used the same key and Acer for internet.
Very careful not to save any changes, even booting with no savefile

3)Came home and plugged into same TV with same HDMI and no sound!
Wondered if USB took update somehow with no save enabled(?)

4)Discovered no error in VLC which thought files were playing through
same soundcard they always had (just no sound). Discovered
sound (ON TV) had been calibrated down to zero. Since this is
a documented function of some TV's to prevent speaker destruction
from loud audio thought smoking gun had been uncovered.

5)Turned sound on TV up. Still no audio, and still no errors reported.
Decided some sort of "remembrance" was going on between the
HDMI port and the TV since when I went on vacation it was the first
time the netbook had been used without HDMI, and when I came back
something had "changed".

6)Reset sound to low on TV. After 1 reboot got limited sound and went to turn the Acer display off in Zarfy to just keep the TV on via HDMI. Sound disappeared exactly as other problem TV.

7)Everything played perfectly as originally advertised after
second reboot...all (and always) with no active savefile.

Seemed interesting...like firmware in HDMI ports were running their
own little party when plugged vs. unplugged, then finally plugged again. Have
also tried many iterations plugging/powering AFTER boot, but never
with these particular results.
Back to top
View user's profile Send private message 

Joined: 25 Mar 2013
Posts: 57

PostPosted: Mon 02 Dec 2013, 12:17    Post subject: Problem resolved  

...by buying another really big TV, which incidentally, required me to upgrade to Fatdog 630 to get the resolution correct...then it worked 1st time nicely.

All I can say is that is that I have gone on a bit of a spree with big LCD's in every room and there seems to be a new documented feature allowing a TV to "control the HDMI device" on some of them. This never appeared as an option on my older Philips.

The significance appears to be this: when Windows boots attached to HDMI I notice it going through a series of mute/unmute sequences before the sound is finalized on the TV. I now believe at least some of this was initialized by the TV not wanting its speakers blown after sensing what audio components were connected.

In Fatdog the HDMI has no audio control to witness, and by every indication it "thinks" sound is being output but is possibly muted in some undocumented fashion by the TV, which then fails to unmute it in it's final bootstate(?)

This is just my guess as I have put this problem aside hopefully forever, and am simply recording this in hope of being of use to someone else.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0595s ][ Queries: 11 (0.0097s) ][ GZIP on ]