Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 23:43
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
lameSMBxplorer Problems (on puppy-4.1.2-k2.6.25.16-se
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
brianh

Joined: 04 Aug 2009
Posts: 75

PostPosted: Sat 23 Feb 2013, 07:16    Post_subject:  lameSMBxplorer Problems (on puppy-4.1.2-k2.6.25.16-se
Sub_title: Trying to find a faster NAS discovery than Pnethood.
 

Trying to find a faster way to mount the Samba share on my NAS drive than Pnethood, I installed
lameSMBxplorer-0.2.2b.pet
Then ran from Rox Terminal:
lameSMBqmount <servername> <sharename>
it gave the error:
Dependency: gtkdialog-0.7.20 required
Used the Puppy dependency checker but it found no problems with lameSMBxplorer
So I tried other versions:
lameSMBxplorer-0.2.1b.pet
lameSMBxplorer-0.1.8b.pet
They all gave the same error
So I installed
gtkdialog3-0.7.20-patched2-pup2.pet
Still no joy running lameSMBqmount but now I get the error:
gtkdialog3: symbol lookup error: gtkdialog3: undefined symbol: zcfree
When I run Pnethood
I presume the gtkdialog install broke the Pnethood UI. Unfortunately it also broke the UI for the Puppy package installer so I can't de-install anything.
To recover the mess, I copied the Puppy master files back to my hard drive from the live CD and reinstalled the pets I need, so all's well except Pnethood still takes ages to probe my NAS drive.
Anyone thoughts?
Brian
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Sat 23 Feb 2013, 09:29    Post_subject:  

IIRC, LameSMBxplorer was built with a special version of gtkdialog and doesn't work with any of the standard versions.

However, try YASSM. I tested it in Puppy 4.12 and it worked fine after one patch.

1. Go to the folder /usr/local/yassm

2. Open the file samba-login in a text editor.

3. On Line 207, change "mount.cifs" to "mount -t cifs"

YASSM opens my NAS box very quickly. But this can depend on how your network is configured.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0385s ][ Queries: 11 (0.0029s) ][ GZIP on ]