Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 16:02
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Precise 5.4.3 / XFCE4 / keyboard(s) dead
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 19 Feb 2013
Posts: 2

PostPosted: Wed 20 Feb 2013, 00:28    Post_subject:  Precise 5.4.3 / XFCE4 / keyboard(s) dead
Sub_title: Installed XFCE4 on Asus EEE 901, no keyboard works

This has been repeated twice.

1. Installed the latest Precise 5.4.3
2. tested out the system, keyboards work
3. Installed XFCE4 and XFCE4 goodies
4. rebooted
5. During boot, before jwm or xfce4 gets control, the keyboards work (esc and enter worked on the boot selection screen, keyboards work in wizards)
6. AFTER either window manager starts, the netbook keyboard and a USB keyboard are dead. This is so in text editors, consoles.
7. When I log out, the keyboards are working again.

This is on an Asus EEE 901 netbook, using a usb keyboard. Both keyboards function.

I am using the US english / Dvorak keyboard layout.

What I've Tried -

In the first install, after the keyboards stopped working, I looked at Xorg.conf - the keyboard section had what looked like bad values, so I fixed them to say I was using the en language, dvorak variant. Rebooted, that did not work. Then I removed the keyboard section entirely. Rebooted. The x wizard came up, I went through setup again, it set up the xorg.conf with en lang and dvorak variant. Rebooted. Keyboards still totally inactive. I used the keyboard wizard to set the keyboard to UK english, international keyboard. Rebooted. Keyboards still totally inactive.

So - I re-installed Precision 5.4.3, the keyboards worked fine. I installed VLC and xfe and rebooted. The keyboards worked fine. I installed XFCE4, XFCE4 goodies, and Slim. Rebooted. (I have made no changes to run Slim, so I go directly to the window manager.) The keyboards were totally inactive in jwm. I used cut-and-paste to update the window manager invocation to xfce4, rebooted - and the keyboards are dead in xfce4, too. In this install, I had also specified a us keyboard and dvorak variant. So as a final test of this, I edited xorg.conf and commented out the dvorak line. Rebooted. Keyboards are still dead.

I'm stumped. It's not jwm or xfce4, the behavior is the same with both of them. And the keyboards are fine both before a window manager takes control and after I log out, the window manager ends, and I go to line mode.

It looks like an X problem, but I don't know where to look other than xorg.conf, which I have not succeeded with.

Any suggestions for how to fix this??

Back to top
View user's profile Send_private_message 

Joined: 19 Feb 2013
Posts: 2

PostPosted: Thu 21 Feb 2013, 22:19    Post_subject: giving up for now  

I've tried several other things, to no avail - so I'm sticking to jwm for now.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0397s ][ Queries: 11 (0.0035s) ][ GZIP on ]