Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 11:11
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Slacko 5.5 Final
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 27 [394 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10, 11, ..., 25, 26, 27 Next
Author Message
tlchost

Joined: 05 Aug 2007
Posts: 1727
Location: Baltimore, Maryland USA

PostPosted: Tue 12 Feb 2013, 07:42    Post subject: SFS problems - Pup Control Panel  

Beta 5403 - Selecting SFS files to load at boot not operating correctly. When files are selected, they are added to /etc/rs.d/BOOTCONFIG correctly.

Pup Control Panel > Manager > Boot Manager does not show files as loaded,
SFS-Loaad-on-the-fly shows the sfs files are loaded.

Bootable USB, 16 gigs memory

Thom
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Tue 12 Feb 2013, 08:09    Post subject:  

Mick
I have an idea I want to test with gtkdialog-splash. Give me a day or 2, since it require some rewrite and I am in lack of time today.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Tue 12 Feb 2013, 08:14    Post subject:  

zigbert wrote:
Also
Be aware that the bottom fix does not fix the case where text contains more than one line.


Sigmund
Yes, was aware that's why "fix" was quoted Wink . Same situation in the standard version anyway. It is good enough for rerwin's frisbee modifications so that's good enough for me.

Ok, just caught your latest post, no rush ATM Cool

tlchost wrote:
Beta 5403 - Selecting SFS files to load at boot not operating correctly. When files are selected, they are added to /etc/rs.d/BOOTCONFIG correctly.

Pup Control Panel > Manager > Boot Manager does not show files as loaded,
SFS-Loaad-on-the-fly shows the sfs files are loaded.
I'll look into this but I think it may be a naming issue of the sfs. Thanks for report.
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Tue 12 Feb 2013, 12:16    Post subject: Slacko 5.4.1 Beta
Subject description: 5403
 

I tried a frugal install of both the pae and non-pae versions of 5403
and I got the same result with both on my hp desktop pc with intel
graphics.
Things seemed normal on first boot, got to the desktop with
network,sound, working and proper graphics driver.
Rebooted creating save file.
I installed a few pets, then installed some apps from ppm.
While the ppm was working I noticed some missing icons here and there,
when everthing finished installing I rebooted but when back at the
desktop the screen was full of red triangles and the drive icons were
little red x's.
Same story with both versions of 5403.
I guess it has to do with the new font size wrecking the rox filer
pinboard (after seeing the message from ETP)
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1117

PostPosted: Tue 12 Feb 2013, 13:14    Post subject: Rox-Filer bug
Subject description: patch
 

Hello 01micko Very Happy

Last year, there was a bug in ROX-Filer patched by npierce. The patch wasn't applied to Slacko, it remained until version 5.4. I can't tell if the new beta has the bug, no broadband to download here, so I'm posting the link to the information and the patch:

http://bkhome.org/blog/?viewDetailed=02758
roxbug22473.jpg
 Description   What you should see when you right-click an icon
 Filesize   41.35 KB
 Viewed   470 Time(s)

roxbug22473.jpg

roxbug26350.jpg
 Description   What you get when you right-click an icon
 Filesize   41.1 KB
 Viewed   467 Time(s)

roxbug26350.jpg


_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Tue 12 Feb 2013, 13:38    Post subject:  

Ok, this one is for testing.

I used this testscript Laughing
Code:
#!/bin/sh
TEXT=hello
while [ A != B ]; do
   for I in top-left top top-right bottom-right bottom bottom-left; do
      gtkdialog-splash -placement $I -bg red -timeout 1 -text "$TEXT" &
      TEXT="$TEXT hello"
      sleep 0.25
   done
done


It offers accurate placement in all corners and center is now the actually center (not a guess as earlier).

- It also adds -font -align and -icon_width parameters
gtkdialog-splash.gz
Description 
gz

 Download 
Filename  gtkdialog-splash.gz 
Filesize  4 KB 
Downloaded  83 Time(s) 

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
mavrothal


Joined: 24 Aug 2009
Posts: 1697

PostPosted: Tue 12 Feb 2013, 14:55    Post subject:  

Hi Mick,
just managed to update my 5.4 tp 5.4.0.3 ( Embarassed ) without any issues.
I like the new JWM but I can find no way to decrease the font size, both in the menus and in the windows. Changes in /root/.jwm/ does not appear to have an effect, so will you spare me some searching/reading and point me to the right direction(besides global font size)?
Thx.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
drblock2

Joined: 19 Jan 2009
Posts: 141

PostPosted: Tue 12 Feb 2013, 16:06    Post subject: Slacko 5.4.0.3
Subject description: Looking real good!
 

01micko

Installed 5.4.0.3 linux_kernel-3.2.33-slacko_4g and am very positively impressed. Here some details and suggestions:

I used the save file from 5.4-PAE, but it updated without incident.

I downloaded the devx 5.4.0.2 and renamed to 5.4.0.3 also the appropriate kernel sources.

No problem in updating VirtualBox with the utility provided: /etc/init.d/vboxdrv setup

The proprietary nvidia driver 173.14.35 also compiled with the new kernel and delivered an extremely respectable 3000 fps.

The global font size 96pt did not work well with my monitor(1280 x 1024), but this was easily resolved by reducing the point size to 72.

The built-in Opera 12.14 (as with earlier versions) does not download and play audio files (.mp3, ogg, flac, etc.). The reason for this is that Opera relies on the current gecko plugins (in /usr/lib/mozilla/plugins/) and these do not work. When replaced by the older mplayer plugins, the problem is resolved. For detailed discussion see http://murga-linux.com/puppy/viewtopic.php?t=65426&start=155. This is clearly a problem for the Opera developers, but easily resolved so that Opera can be used as the default browser.

There is also a strange problem with the spell checker in SoftMaker freeoffice. Once again, not your responsibility, I mention it only because freeoffice textmaker has been discussed as a replacement for abiword and the problem was not present in Slacko 5.2.3.7 (k3.1.10-slacko_4ga) and perhaps you can shed some light on this. The problem is described here: http://murga-linux.com/puppy/viewtopic.php?t=82904&start=55.

Finally, a small problem I noted with slacko 5.4 (but did not report). When rebooting from the menu, nothing happens. When I drop out of X with CTR+ALT+BkSpc reboot proceeds without any further action.

All and all, Slacko 5.4.0.3 makes a solid impression.
Back to top
View user's profile Send private message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Tue 12 Feb 2013, 16:17    Post subject: gma500  

Russian Puppy forum member RoDoN has gma500 card and he was testing new Slacko-5.4.0.3 and he asked me to help with translation.
After start of X he had his mouse pointer disappeared. It was working but it was invisible. He managed to fix it by editing xorg.conf. He added this line:
Code:
Option     "SWCursor"       "ON"

But after run of xorgwizard this setting is overwritten like this:
Code:
#Option     "SWcursor"              # [<bool>]

He also said that in Section Device of xorg.conf it is better to write:
Code:
Identifier "gma500_gfx"

instead of
Code:
Identifier  "Card0"
Back to top
View user's profile Send private message 
tlchost

Joined: 05 Aug 2007
Posts: 1727
Location: Baltimore, Maryland USA

PostPosted: Tue 12 Feb 2013, 16:24    Post subject:  

01micko wrote:


tlchost wrote:
Beta 5403 - Selecting SFS files to load at boot not operating correctly. When files are selected, they are added to /etc/rs.d/BOOTCONFIG correctly.

Pup Control Panel > Manager > Boot Manager does not show files as loaded,
SFS-Loaad-on-the-fly shows the sfs files are loaded.


I'll look into this but I think it may be a naming issue of the sfs. Thanks for report.


Would a valid test be to load an sfs in whatever you say is the correct naming convention(the LibreOffice .sfs did not laod and that was created in the beta software?

Thom
Back to top
View user's profile Send private message Visit poster's website 
SFR


Joined: 26 Oct 2011
Posts: 1078

PostPosted: Tue 12 Feb 2013, 16:34    Post subject:  

tlchost wrote:
Pup Control Panel > Manager > Boot Manager does not show files as loaded

I can confirm this - it seems to be Xdialog related:
Code:
Xdialog --buildlist "test" 0 0 5 abc abc off def def on

displays all items only in the left pane.

@Mick:
What can I say - disregarding those few issues reported above, 5.4.0.3 is practically perfect, at least for me. Very Happy

Thanks for the great job &
Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Tue 12 Feb 2013, 17:19    Post subject:  

full resolution!

A suggestion.
Since the mouse-settings(X) is rather aggressive (read accelerated), I will suggest to include a link to PupX in the mouse wizard. If I were new to Puppy, I doubt I ever found the correct setting. The menu states: 'PupX set properties of X' - What does THAT mean Wink

And when we're talking about menu explanaitons. What is 'JWM configuration' for a user not familiar with JWM?

I have a feeling that ROX is faster when it comes to rendering of huge directories. /usr/bin/ is now really snappy to enter.

No issues so far...


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Tue 12 Feb 2013, 17:40    Post subject: Re: gma500  

rodin.s wrote:
Russian Puppy forum member RoDoN has gma500 card and he was testing new Slacko-5.4.0.3 and he asked me to help with translation.
After start of X he had his mouse pointer disappeared. It was working but it was invisible. He managed to fix it by editing xorg.conf. He added this line:
Code:
Option     "SWCursor"       "ON"

But after run of xorgwizard this setting is overwritten like this:
Code:
#Option     "SWcursor"              # [<bool>]

He also said that in Section Device of xorg.conf it is better to write:
Code:
Identifier "gma500_gfx"

instead of
Code:
Identifier  "Card0"


OK, thanks for that. There is supposed to be a gui popup that suggests to hit "Enter" and it fixes xorg.conf. I might have it too early in /usr/sbin/delayedrun It's at /usr/sbin/zcedar.sh. You can gettext if you like and I'll add the "on" parameter.

Do you know what's up with Xdialog? I used your version from the previous slacko-5.4 dev thread.

------------------------------------------------------------------------------------------

zigbert wrote:
A suggestion.
Since the mouse-settings(X) is rather aggressive (read accelerated), I will suggest to include a link to PupX in the mouse wizard. If I were new to Puppy, I doubt I ever found the correct setting. The menu states: 'PupX set properties of X' - What does THAT mean Wink

Ok, sounds like an idea, and yes some descriptions are a bit geeky Shocked

--------------------------------------------------------------------------------------------

billtoo wrote:
I installed a few pets, then installed some apps from ppm.
While the ppm was working I noticed some missing icons here and there,
when everthing finished installing I rebooted but when back at the
desktop the screen was full of red triangles and the drive icons were
little red x's.

I don't think it's the font thing. It's my rebelliousness. Barry has a symlink that exists in woof to do with the pixbuf loaders. I hate that idea and run the correct command to update the pixbuf loaders. I have tried many times to convince Barry that this is a bad idea. This has never been a problem until now. Guess I'll have to swallow my pride and conform to non conformity!

If you haven't trashed those savefiles, run
Code:
gdk-pixbuf-query-loaders --update-cache
then restart X.
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Tue 12 Feb 2013, 17:46    Post subject:  

SFR

Thanks for your earlier report about k3.8rc7 and the "BUG". I now have enough info I think to present the case for change to rc.sysinit to Barry. You know, I have been experiencing the bug all along on my laptop with USB install on VFAT, The snapmerge runs really slow but since the fix it runs properly. I'll just have to add a test to not apply the fix if kernel is >= 3.8.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Tue 12 Feb 2013, 18:34    Post subject: Re: gma500  

01micko wrote:




billtoo wrote:
I installed a few pets, then installed some apps from ppm.
While the ppm was working I noticed some missing icons here and there,
when everthing finished installing I rebooted but when back at the
desktop the screen was full of red triangles and the drive icons were
little red x's.

I don't think it's the font thing. It's my rebelliousness. Barry has a symlink that exists in woof to do with the pixbuf loaders. I hate that idea and run the correct command to update the pixbuf loaders. I have tried many times to convince Barry that this is a bad idea. This has never been a problem until now. Guess I'll have to swallow my pride and conform to non conformity!

If you haven't trashed those savefiles, run
Code:
gdk-pixbuf-query-loaders --update-cache
then restart X.


I tried your fix but it didn't work so I renamed the save file (non
pae version) and rebooted to start anew.
Everything was good on first boot, I rebooted and created a new save
file.
When I got back to the desktop everything was okay, I didn't install
any pets but I started ppm and installed qt-482 then exited ppm and
rebooted again.
Back at the desktop everything is still good, went into ppm and
installed kdegames, while it was working I noticed my firewall icon in
the tray was missing, I let it finish installing kdegames, exited,
tried one of the games and it worked.
Rebooted again to a screen full of upside down red triangles and small
red x's where the drive icons should be.
Kdegames is the culprit for some reason.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 9 of 27 [394 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10, 11, ..., 25, 26, 27 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1171s ][ Queries: 12 (0.0074s) ][ GZIP on ]