Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Jul 2014, 21:39
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How do I get Puppy 5.2.8 to talk to HP PSC-1300 -- Solved
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Hotdog


Joined: 29 Sep 2011
Posts: 107
Location: Georgia USA

PostPosted: Wed 12 Dec 2012, 00:50    Post_subject:  How do I get Puppy 5.2.8 to talk to HP PSC-1300 -- Solved  

Am using Puppy 5.2.8, HD install, HP PSC-1300 all-in-one USB printer, CUPS v1.4.3, hpliplite-3.10.5 and foomatic-filters-4.0.4-i486. When sending a test page to the printer from CUPS the attempt ends with a status of "stopped".
CUPS error log shows:
Code:
E [11/Dec/2012:23:18:37 -0500] Unable to execute /usr/lib/cups/filter/hpcups: No such file or directory
E [11/Dec/2012:23:18:37 -0500] [Job 248] Unable to start filter "hpcups" - Success.
E [11/Dec/2012:23:18:37 -0500] [Job 248] Stopping job because the scheduler could not execute a filter.

The first line of /usr/lib/cups/filter/foomatic-rip-hplip has been edited to #!/usr/bin/perl -U. I have made a soft link like so: ln -s /usr/bin/foomatic-rip /usr/lib/cups/filter/.

What can be done to make CUPS recognize and use the foomatic filters?

_________________
Puppy 528, Full Install

Edited_time_total
Back to top
View user's profile Send_private_message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Wed 12 Dec 2012, 07:26    Post_subject:  

The version of hpliplite you are using is quite old. Your printer should work using newer versions.
You can find them, together with instructions at
http://murga-linux.com/puppy/viewtopic.php?p=439468&search_id=1199979754#439468

Another -alternative- option you can try is described in this threat
http://murga-linux.com/puppy/viewtopic.php?p=444080&search_id=1199979754#444080
Back to top
View user's profile Send_private_message 
Hotdog


Joined: 29 Sep 2011
Posts: 107
Location: Georgia USA

PostPosted: Wed 12 Dec 2012, 21:06    Post_subject:  

lluamco,

Thank you. The newer hpliplite-3.12.11 and soft link did the job. Foomatic filters not required. I appreciate you taking the time to respond!

_________________
Puppy 528, Full Install
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0489s ][ Queries: 11 (0.0038s) ][ GZIP on ]