Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 07 Feb 2016, 20:05
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Mypaint 1.1.0 precise
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Author Message
666philb


Joined: 07 Feb 2010
Posts: 2851
Location: wales

PostPosted: Wed 20 Mar 2013, 13:57    Post subject:  

hi fabio t,

it's not python that's conficting, it's some libs in the bluetooth pet........ i haven't got bluetooth so can't test...

here's a pet to try, uninstall the old one first http://dl.dropbox.com/u/19554672/bluetooth-0.5_test_fix.pet

it removes some libs that conflict with mypaint, but the whole .pet could do with updating. if bluetooth still works with the test pet, i'll try and update the whole thing.

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 90
Location: Italy

PostPosted: Thu 21 Mar 2013, 19:02    Post subject:  

Thank you very much 666philb,

I've downloaded your .pet and try a few test to try different configuration of Precise with Mypaint.

There are several suprises!

In fact your package don't prevent Mypaint to work, but Mypaint don't work for me because don't find his icons...

Tomorrow I'll tell you the test on Precise and results, stange results!

What are files and libraries different between Your file and the original? In this differences are the answers to my install problems.

666philb wrote:
hi fabio t,

it's not python that's conficting, it's some libs in the bluetooth pet........ i haven't got bluetooth so can't test...

here's a pet to try, uninstall the old one first http://dl.dropbox.com/u/19554672/bluetooth-0.5_test_fix.pet

it removes some libs that conflict with mypaint, but the whole .pet could do with updating. if bluetooth still works with the test pet, i'll try and update the whole thing.
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 90
Location: Italy

PostPosted: Fri 22 Mar 2013, 19:08    Post subject:  

Ok, I'm back.

Description of strange abearance of PC & mypaint & bluetooth:

Restart Precise from scratch.

Reboot Precise pfix=ram.
Setup language and create a new precisesave.4fs
Reboot
In BootManager config bootup: load mypaint.1.1.0.sfs
Reboot.
Launch in terminal window (rxvt) : mypaint (enter)
Mypaint don't launch and complains that cannot find his icons.

Install Bluetooth.0.5.fix.pet (my file).
Launch in terminal window (rxvt) : mypaint (enter)
Mypaint don't launch and complains several Python errors.

But Bluetooth icon appears in the status bottom bar.

Uninstall Bluetooth 0.5.
Reboot.
Launch in terminal window (rxvt) : mypaint (enter)
Mypaint WORKS! Icons founded!

But Bluetooth don't works.

Now I Install Bluetooth.0.5.test.fix.pet (your file)
Reboot
Bluetooth WORKS and MYPAINT WORKS! Shocked Shocked

Bluetooth icon appears in the status bottom bar.

Now I decide to try your file:

Restart from scratch.
Reboot Precise from Ram.
Setup language and create a new precisesave_1.4fs
Reboot.
In BootManager config bootup: load mypaint.1.1.0.sfs
Reboot.
Launch in terminal window (rxvt) : mypaint (enter)
Mypaint don't launch and complains that cannot find his icons.

Install Bluetooth.0.5.test.fix.pet (your file).
Launch in terminal window (rxvt) : mypaint (enter)
Mypaint don't launch and complains that cannot find his icons (NO MORE PYTHON ERRORS!)
And Bluetooth mouse works.

But Bluetooth icon don't appear in the status bottom bar; There is instead a white icon with a red cross inside.

It seems that bluetooth 0.5 (my file) sets correctly icon directory or path to icon directory.

What difference there is from two version of bluetooth.0.5 mine and yours?

Thank you for help.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 2851
Location: wales

PostPosted: Sun 24 Mar 2013, 10:22    Post subject:  

hi fabio t

the only difference is i removed two libs from my .pet 'libxcb-xlib.so.0.0.0' and 'libxcb.so.1.1.0' the tashbar icon shouldn't be affected .... did you try rebooting?

as i said there are more libs in the bluetooth pet that conflict with and overwrite precises own libs. i'll try and post a precise version of the bluetooth pet for you to test this week sometime.

cheers

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
Fabio T

Joined: 31 Aug 2007
Posts: 90
Location: Italy

PostPosted: Sun 24 Mar 2013, 11:25    Post subject:  

> > > S O L V E D ! ! ! < < <

After several tries I've found problem core.

It's bad indexed icon cache.

Initially I followed instructions in site https://gna.org/bugs/?18460.

But file 'icon-theme.cache' isn't in /usr/local/share/icons/hicolor but is in /usr/share/icons/hicolor !

Then it's only sufficient to modify and launch this command from command line:

gtk-update-icon-cache -tf /usr/share/icons/hicolor

It reindexs mypaint icons (and bluetooth icon that reappears after restart X)

After this command mypaint 1.1.0 works correctly.

If you can create a precise bluetooth adapted file I thank you very much.

666philb wrote:
hi fabio t

the only difference is i removed two libs from my .pet 'libxcb-xlib.so.0.0.0' and 'libxcb.so.1.1.0' the tashbar icon shouldn't be affected .... did you try rebooting?

as i said there are more libs in the bluetooth pet that conflict with and overwrite precises own libs. i'll try and post a precise version of the bluetooth pet for you to test this week sometime.

cheers


EDIT: I've enclose my hint in software.

I enclose here file application.py with modified message.

To use quickly, copy it in /usr/share/mypaint/gui


If anyone wants it is possible to recompile .sfs file with this new file
application.py.zip
Description 
zip

 Download 
Filename  application.py.zip 
Filesize  33.76 KB 
Downloaded  287 Time(s) 
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 6416
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 01 Jan 2016, 04:22    Post subject: sfs loaded in my graphics suitcase  

sfs loaded in my graphics suitcase
Mypaint is part of he brand new Vincent van Puppy (2016) released for our artists using Puppy
Based on upup Raring.
root# mypaint
ImportError: numpy.core.multiarray failed to import Sad Sad Sad
Where is this machin ??? Pfind ne trouve pas.

_________________
Puppy is muscular, not fat !
Back to top
View user's profile Send private message Yahoo Messenger 
musher0


Joined: 04 Jan 2009
Posts: 6818
Location: Gatineau (Qc), Canada

PostPosted: Fri 01 Jan 2016, 13:47    Post subject:  

In the above: "machin" is French for "thingy". Smile
_________________
musher0
/ Save the Pupsaves International (SPI) Wink
/ Internationale pour la préservation des pupsaves (IPP) Wink
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 4054
Location: Ontario

PostPosted: Sat 02 Jan 2016, 11:58    Post subject:  

Quote:
ImportError: numpy.core.multiarray failed to import


mypaint is very sensitive to the versions of python and numpy

numpy has to be compiled with multiarray support.

I would guess that the version of numpy you have wasn't the version
that mypaint was compiled with.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 6416
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 03 Jan 2016, 06:25    Post subject: Mypaint dowloaded from PPM will not work.  

don 570, that would meant that Mypaint dowloaded from PPM will not work.
I keep van pup because MyPaint intalls well, i did'nt check deeper, because i'm learning how to use it.
Quickpet in upup Raring does not load MyPaint, but drives you to this topic... strange. Perhaps they didn't succeed in compiling... did they ?
Quickpet.jpg
 Description   PPM tahrpup 6.0.2 provides MyPaint (11MB) without trouble
 Filesize   54.81 KB
 Viewed   20 Time(s)

Quickpet.jpg


_________________
Puppy is muscular, not fat !
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0658s ][ Queries: 12 (0.0075s) ][ GZIP on ]