Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 06:19
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to use wireless Officejet 6600 in Lucid 528? (Solved)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
jafadmin

Joined: 19 Mar 2009
Posts: 444

PostPosted: Sat 24 Nov 2012, 16:42    Post subject:  How to use wireless Officejet 6600 in Lucid 528? (Solved)  

I've got a wireless Officejet 6600 and CUPS automatically detects the printer. I tell it to use the hp-officejet_6600.ppd file, but it still won't print. Printed items just sit there in the queue.

After searching and reading lots of threads here on the subject I'm really confused about what I need to do to make this work.

Lucid 5.28, Cups 1.4.3,

I'd appreciate any help. I've just never set up a printer with cups before.

Thanks in advance

jafa

Last edited by jafadmin on Sat 24 Nov 2012, 19:50; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9356
Location: Stratford, Ontario

PostPosted: Sat 24 Nov 2012, 16:59    Post subject: Re: Need Help: CUPS on 5.28-4 with Officejet 6600
Subject description: I'm completely confused
 

jafadmin wrote:
I've got a wireless Officejet 6600 and CUPS automatically detects the printer. I tell it to use the hp-officejet_6600.ppd file, but it still won't print.

Where did you get the PPD file? This is one of the great Puppy myths - that you can install a printer just by supplying its PPD file. Unfortunately, the source of this information is repeated in each new Puppy.

Quote:
After searching and reading lots of threads here on the subject I'm really confused about what I need to do to make this work.

Have you read here? The hplip_print-3.12.10a.pet supports your printer.
Back to top
View user's profile Send private message 
jafadmin

Joined: 19 Mar 2009
Posts: 444

PostPosted: Sat 24 Nov 2012, 17:14    Post subject: Re: Need Help: CUPS on 5.28-4 with Officejet 6600
Subject description: I'm completely confused
 

rcrsn51 wrote:

Have you read here? The hplip_print-3.12.10a.pet supports your printer.


I installed it but it jumps from the 6500 driver to the 6700 driver, and no 6600 driver that I can see? Maybe I'm just getting blind, or just don't have the chops for cups ..

[EDIT] Ok, wait. I went back to look again and a 6600 driver showed up. Same results though. I'm going to reboot to see if that helps anything.

None of the similar (6500, 6700) drivers are printing either.

I really appreciate your help.
Back to top
View user's profile Send private message 
jafadmin

Joined: 19 Mar 2009
Posts: 444

PostPosted: Sat 24 Nov 2012, 17:31    Post subject:  

Ok, after the above, here's a screenshot of what I have.

You know, everything looks perfect, but the printer doesn't even blink a light when I try to print. Any clues would be appreciated...
cups-screen.png
 Description   After reboot
 Filesize   89.45 KB
 Viewed   860 Time(s)

cups-screen.png

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9356
Location: Stratford, Ontario

PostPosted: Sat 24 Nov 2012, 17:44    Post subject:  

1. Run "cancel -a" to kill any old print jobs.

2. Do you have the Puppy firewall installed? It will conflict with networked printers.

3. Attach the printer directly with a USB cable and try again.

4. In the event that you installed some other incompatible stuff, I would do a temporary fresh install using "puppy pfix=ram". Install the hplip_print package and run CUPS again.

I have a wireless Officejet 4500. I installed it Lupu 528 with hplip_print-3.12.10a.pet and it worked fine.

Quote:
5.28-4

What version is that?
Back to top
View user's profile Send private message 
jafadmin

Joined: 19 Mar 2009
Posts: 444

PostPosted: Sat 24 Nov 2012, 17:50    Post subject:  

I guess I meant 5.28.004, but it's up to .005 now

http://distro.ibiblio.org/puppylinux/puppy-5.2.8/

Ok, I'll try the temp install.

Thank you very much.

[EDIT] Booted with a 5.28 LiveCD and installed the pet and it worked almost perfectly.

At first only showed 6500 and 6700 models. I picked the 6500 to see what would happen and it printed the test page perfectly. Went back to try other drivers and the 6600 driver showed up again! Crazy.

Now I need to figure out how to get my regular install fixed. I have too much invested in it to just wipe it out and start over. I mean 6 months investment.

Well, thanks, for you help, friend. You are a treasure around here. Cool
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9356
Location: Stratford, Ontario

PostPosted: Sat 24 Nov 2012, 18:46    Post subject:  

If your printer is auto-detected, CUPS will move it to the TOP of the Models list. So if you immediately start scrolling down, you can miss it.

Here are some things to try with your current setup.

1. Open the file /etc/cups/cupsd.conf.

2. Change "loglevel info" to "loglevel debug".

3. Restart CUPS with "/etc/init.d/cups restart".

4. Run a print job.

5. Open the file /var/log/cups/error_log.

6. Start at the bottom and work up, looking for error messages.
Back to top
View user's profile Send private message 
jafadmin

Joined: 19 Mar 2009
Posts: 444

PostPosted: Sat 24 Nov 2012, 19:08    Post subject:  

The only thing that looks like errors is:

Code:

D [24/Nov/2012:14:59:28 -0800] Get-Jobs ipp://localhost:631/printers/HP_Officejet_6600
D [24/Nov/2012:14:59:28 -0800] Returning IPP successful-ok for Get-Jobs (ipp://localhost:631/printers/HP_Officejet_6600) from localhost
D [24/Nov/2012:14:59:28 -0800] cupsdReadClient: 14 WAITING Closing on EOF
D [24/Nov/2012:14:59:28 -0800] cupsdCloseClient: 14
D [24/Nov/2012:14:59:28 -0800] cupsdSetBusyState: Dirty files
D [24/Nov/2012:14:59:28 -0800] PID 19693 (/usr/lib/cups/cgi-bin/printers.cgi) exited with no errors.
D [24/Nov/2012:14:59:28 -0800] cupsdReadClient: 10 GET /favicon.ico HTTP/1.1
D [24/Nov/2012:14:59:28 -0800] cupsdSetBusyState: Active clients and dirty files
D [24/Nov/2012:14:59:28 -0800] cupsdAuthorize: No authentication data provided.
D [24/Nov/2012:14:59:28 -0800] cupsdReadClient: 10 Closing because Keep-Alive disabled
D [24/Nov/2012:14:59:28 -0800] cupsdCloseClient: 10
D


But I have no idea what it means.
Back to top
View user's profile Send private message 
jafadmin

Joined: 19 Mar 2009
Posts: 444

PostPosted: Sat 24 Nov 2012, 19:31    Post subject:  

More:

Code:

D [24/Nov/2012:15:18:47 -0800] [Job 10] envp[26]="CUPS_FILETYPE=document"
D [24/Nov/2012:15:18:47 -0800] [Job 10] envp[27]="FINAL_CONTENT_TYPE=printer/HP_Officejet_6600"
I [24/Nov/2012:15:18:47 -0800] [Job 10] Started filter /usr/lib/cups/filter/pdftopdf (PID 3652)
E [24/Nov/2012:15:18:47 -0800] Unable to execute /usr/lib/cups/filter/pdftoraster: insecure file permissions (0100777)
E [24/Nov/2012:15:18:47 -0800] [Job 10] Unable to start filter "pdftoraster" - Operation not permitted.
D [24/Nov/2012:15:18:47 -0800] Discarding unused job-state-changed event...
E [24/Nov/2012:15:18:47 -0800] [Job 10] Stopping job because the scheduler could not execute a filter.
D [24/Nov/2012:15:18:47 -0800] cupsdMarkDirty(----J-)
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9356
Location: Stratford, Ontario

PostPosted: Sat 24 Nov 2012, 19:46    Post subject:  

I ran Lupu 528 and looked at the file /usr/lib/cups/filter/pdftoraster. It is owned by root:root and has permissions rwx r-x r-x.

What have you got?

The easiest way to break CUPS is to install some incompatible DEB, PET or SFS that alters the Puppy file ownership/permission structure. Once it's happened, it can be very difficult to fix.
Back to top
View user's profile Send private message 
jafadmin

Joined: 19 Mar 2009
Posts: 444

PostPosted: Sat 24 Nov 2012, 19:49    Post subject:  

rcrsn51 wrote:
I ran Lupu 528 and looked at the file /usr/lib/cups/filter/pdftoraster. It is owned by root:root and has permissions rwx r-x r-x.

What have you got?

The easiest way to break CUPS is to install some incompatible DEB, PET or SFS that alters the Puppy file ownership/permission structure. Once it's happened, it can be very difficult to fix.


That fixed it. I changed the permissions to match "pdftopdf" and everything works.

Wow, thanks! You da man,


This is soooo cool .....

jafa
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9356
Location: Stratford, Ontario

PostPosted: Sat 24 Nov 2012, 19:55    Post subject:  

Excellent.

The next thing you will want to try is using the scanner on your Officejet across the network. Read here about how to set this up in Peasyscan.

Your Peasyscan configuration file will probably look like this
Code:
<uri>hpaio:/net/Officejet_6600?ip=192.168.100.50</uri>

Last edited by rcrsn51 on Sat 24 Nov 2012, 20:01; edited 1 time in total
Back to top
View user's profile Send private message 
jafadmin

Joined: 19 Mar 2009
Posts: 444

PostPosted: Sat 24 Nov 2012, 19:59    Post subject:  

rcrsn51 wrote:
Excellent.

The next thing you will want to try is using the scanner on your Officejet across the network. Read here about how to set this up in Peasyscan.


You are correct, sir! Thanks!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0789s ][ Queries: 12 (0.0059s) ][ GZIP on ]