Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 21 Nov 2014, 04:48
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Upup Precise 54X7 using latest woof at time
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 11 [163 Posts]   Goto page: 1, 2, 3, ..., 9, 10, 11 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 17 Nov 2012, 03:07    Post subject:  Upup Precise 54X7 using latest woof at time
Subject description: Somewhat enhanced version of the offcial Precise Puppy
 

Download link: http://www.smokey01.com/pemasu/UpupPrecise/UpupPrecise54X7/

Link to the announcement post: http://www.murga-linux.com/puppy/viewtopic.php?p=676952#676952

Link to the announcement post of 5.4.X.6: http://www.murga-linux.com/puppy/viewtopic.php?p=673579#673579

Upup Precise 5.4.X.5 has been uploaded. I use latest woof available with updates. This version has fixes at the time of 5.4.2.2. service pack. Upup Precise has some enhancements compared to official release. Xchat, Uget coupled with aria2c, Pmusic, laptop tools, acpi stuff, xbindkeys for keybinding.

The kernel is official PAE kernel. Acpi_call and rtl2832u (dvb-usb) driver has been added ( thanks 666philb ).

In this latest release I have swapped Aqualung with tray app enabled version (thanks Billtoo), there is wrapper script so that only one tray app will appear, Pmusic-3.0.6 ( with all dependencies ), ffconvert with latest fix for spaces in names, gtkdialog 0.8.3 revision 493, which will probably be the next stable version.
Pburn, Pschedule updated ( thanks Zigbert ), funny rox-clock ( you can drag it to the Pinboard, thanks Jamesbond).
Fixed version of pdvdrsab ( thanks Thunor and Peebee ).

Last but not the least is the new Frisbee - dhcpcd - sns integrated network manager-connectivity framework, created by rerwin, using Jemimah`s work, existing puppy scripts with modifications. Peebee has been active tester and he has given a lot feedback everywhere where it has been needed. Thanks to both of them.
Thunor has given valuable feedback of the gtkdialog components.

Please give feedback about network connectivity, switching between Frisbee and SNS, stabillity etc...
As Peebee posted previously, there is still probably minor bugs.

Rerwin also patched dhcpcd 5.6.4 ( latest version ) with dropwait patch so that the connection should be better with poor signal.

Have fun !

Download link: http://www.smokey01.com/pemasu/UpupPrecise/UpupPrecise54X7/

Kernel sources: http://bkhome.org/sources/kernel-3.2.29/

Previous announcement:
I changed themes more suitable for me, swapped ayttm with patched xchat ( compiled in Precise Puppy ), added sfs download manager to download Precise Puppy sfs applications from my repo, uploaded several sfs applications into it, added brand new Pmusic 3.0.0 with caps-alsaequal-pequalizer, updated gtkdialog to the latest revision, network_tray updated to 01micko hack, dhcpcd updated, I did add quite a lot rox right clicks based on Don570 work, added my used laptop tools enhancements.

I did swap also glib to akash_rawal patched version. It has several benefits.

PPM database updating is now astonishing fast. Ubuntu databases will be updated in split seconds, Unbelievable. Thanks Barry.

So...I tested woof building, made Precise Puppy more comfortable for me.

If you want to test, feel free, of course bug reports are welcomed, and so on....
UpupPrecise.jpg
 Description   
 Filesize   87.19 KB
 Viewed   5952 Time(s)

UpupPrecise.jpg


Last edited by pemasu on Fri 11 Jan 2013, 18:19; edited 9 times in total
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1467
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sat 17 Nov 2012, 03:37    Post subject:  

I'm downloading now, looking forward to seeing how this runs Cool
_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9255
Location: Stratford, Ontario

PostPosted: Sat 17 Nov 2012, 09:42    Post subject:  

Some CUPS content has gone missing. The home page at localhost:631 cannot be found. Some subpages like localhost:631/admin are visible, but are scrambled.

[Edit] It's the folder /usr/share/doc/cups.

You might also want to look at the newer cups_shell from here.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 17 Nov 2012, 10:07    Post subject:  

Thanks. /usr/share/doc/cups was missing. My 3builddistro patch made it to be removed. The patch has now been updated.

And thanks of the link to the replacement "shell"
cups-fix-0.0.1.pet
Description 
pet

 Download 
Filename  cups-fix-0.0.1.pet 
Filesize  222.16 KB 
Downloaded  542 Time(s) 
Back to top
View user's profile Send private message 
LateAdopter

Joined: 27 May 2011
Posts: 165
Location: Reading UK

PostPosted: Sat 17 Nov 2012, 10:26    Post subject:  

Hello Pemasu

Thanks for this, I have installed it on my Athlon II desktop.

I installed the VLC pet, by clicking on the file, not using the package manager.

A couple of quirks:

It does not install a menu entry or a .desktop file, but does run by clicking on vlc in /usr/bin

It does not include libdvbpsi, so vlc would not play .ts transport stream until I installed that from the Ubuntu repo.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9255
Location: Stratford, Ontario

PostPosted: Sat 17 Nov 2012, 10:34    Post subject:  

LateAdopter wrote:
It does not install a menu entry or a .desktop file, but does run by clicking on vlc in /usr/bin

I'm seeing a similar problem with the Graphic menu. PETS like this one that are classified as X-GraphicUtility are no longer added to the menu. But pre-installed apps that use that category are working.

I believe that it is a woof issue because it also showed up in the final version of Precise.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 17 Nov 2012, 10:42    Post subject:  

LateAdopter. I suppose you mean that you got the vlc from this repo:
http://www.smokey01.com/pemasu/pet_packages-upup/

You were right about those missing things. I must have had mini-stroke. I have missed the /usr/share folder totally. I am amazed it did even work with gui. The vlc pet has been fixed and uploaded. I did add libdvbpsi also. I pondered should I, or just make dependency marking to the pet specs file, but....since I havent activated that repo in PPM, I decided to add that lib to the pet. I havent encountered the need of that lib with other applications. Mplayer, Smplayer and Umplayer stream ok without it. So I suppose mostly vlc needs it and can be in the pet included.
But hey, stream support is there ! and dvb-tuner support...and subtitles support. It was combined effort of Billtoo and me to get vlc compile ok in Precise. Billtoo did the hard work, I just gave comments behind the shoulder.

Thanks of the feedback. Just the kind of feedback so far I really need !!!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 17 Nov 2012, 10:49    Post subject:  

rcrsn51. Your finding might be good to link to the new thread Barry Kauler opened couple of days ago. I could do that. It was about packages categories parsing and filtering and whatever.

EDIT: I posted your finding to that thread.
http://murga-linux.com/puppy/viewtopic.php?p=665182#665182
Back to top
View user's profile Send private message 
LateAdopter

Joined: 27 May 2011
Posts: 165
Location: Reading UK

PostPosted: Sat 17 Nov 2012, 11:36    Post subject:  

Hello Pemasu

Yes that was the .pet that I downloaded.

I have played .ts quite often in Mplayer or SMplayer but the time stamps never seem to decode correctly, so seeking with the slider isn't useable.

With VLC 1.x it was the other way round the seeking with the slider would work but the keyboard commands would not.

VLC 2.x both work, which is why if prefer it.

It's odd because .ts has worked perfectly in Media Player Classic, on Windows, for at least 7 years.

I think libdvbpsi is a separate Videolan project.

Thanks for the updated .pet
Back to top
View user's profile Send private message 
anikin

Joined: 10 May 2012
Posts: 517

PostPosted: Sat 17 Nov 2012, 16:32    Post subject:  

Hi pemasu,
I was going to ask you a question in another thread about transplanting some settings from Precise to Exprimo. And here you come with your own Precise puppy. Feels fast and smooth so far. I'd like to install firefox on this one, have found it in the repository but it is i386 - is there an i686 edition for this puppy? And here's how the desktop looks on my netbook. The background is lightgrey from the original Precise. Actually all my puppies use it. For some reason, they dislike wallpapers and treat bright colors on a desktop with extreme prejudice Smile
lightgrey.png
 Description   
 Filesize   42.85 KB
 Viewed   5689 Time(s)

lightgrey.png

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5464
Location: Finland

PostPosted: Sat 17 Nov 2012, 17:49    Post subject:  

I have reuploaded Upup Precise 54X2 with these initial fixes. I also did update Uget and compiled latest aria2. Uget can use it to download torrent files. You just need to activate aria2 plugin in Uget.

I hacked Lazy Fred Repository Downloader to just download different Precise compatible sources, also my pet_packages-upup repo. I changed the name to the Precise Repository Downloader. Amazing scripts. I hunted about 10 gtk-* icons to get it looking ok in Precise. Thanks RSH.

Cups fixed, cups_shell changed and so on....

Anikin. Firefox-16.0.2 i686 build is now also in the repo. I have to admit I like Firefox more than Seamonkey, so having Firefox in the repo was pleasant addition.

http://www.smokey01.com/pemasu/pet_packages-upup/
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5930
Location: Kentucky

PostPosted: Sat 17 Nov 2012, 18:07    Post subject:  

Quick live pfix=ram test of the first version.........downloading newer version now.
Sound,internet and display all correct on initial boot. No problems yet.

# report-video
VIDEO REPORT: Upup Precise, version 5.4.X.2

Chip description:
oem: NVIDIA
product: MCP61 - mcp61-86 Chip Rev

Driver used by Xorg:
vesa

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
#
Actually using the "nouveau" driver.

# glxgears
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 30
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 30
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 55
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 56
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 59
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 58
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 30
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
4414 frames in 5.0 seconds = 882.797 FPS
4883 frames in 5.0 seconds = 976.576 FPS
4769 frames in 5.0 seconds = 953.611 FPS
4907 frames in 5.0 seconds = 981.355 FPS
4882 frames in 5.0 seconds = 976.385 FPS
4839 frames in 5.0 seconds = 967.666 FPS

-Computer-
Processor : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Memory : 3888MB (213MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Sat 17 Nov 2012 04:04:45 PM CST
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Gallium 0.4 on NV4C
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA NVidia

Code:
# free
             total         used         free       shared      buffers
Mem:       3888484       618208      3270276            0        69448
-/+ buffers:             548760      3339724
Swap:      4300796            0      4300796
precise 5.4.X.2.png
 Description   
 Filesize   263.18 KB
 Viewed   5688 Time(s)

precise 5.4.X.2.png

Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sat 17 Nov 2012, 19:26    Post subject:  

TazOC's latest sys-info[???]-1.4.2 fixes most misreporting of xorg drivers.
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
mikeslr


Joined: 16 Jun 2008
Posts: 814
Location: Union New Jersey USA

PostPosted: Sat 17 Nov 2012, 20:42    Post subject: Upup Precise 54x2 running well  

Hi pemasu:

Thanks for another great Pup. Upup Precise 54x2 is running well on my:
Processor: 4x AMD Phenom(tm) II X4 945 Processor
Memory: 3375MB
ATI Radeon 3100 Graphics supporting 1600x900 pixels
RaLink RT2561/RT61 802.11g PCI.

Seems very fast.

Thanks 01micko for the reminder about the sys-info-1.4.2-noarch.pet. Vague memories of recent posts about it, but I seem to have a mind "like a sponge." I've used that phrase to mean what it should. It seems to have crept into the language, meaning just the opposite. Sponges have no nervous system at all: ergo neither memory nor ability to think. Unless, of course, having a "mind like a sponge," I've mis-recollected that factoid.

The sys-info-1.4.2-noarch.pet. can be downloaded from here: http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=60951

mikesLr
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 814
Location: Union New Jersey USA

PostPosted: Sat 17 Nov 2012, 21:07    Post subject: dbus error in gimp-2.8 &2.8.2-precise sfs (Solved)  

Hi pemasu & all;

Exploring precise sfs downloader, I noticed gimp-2.8.2.-precise.sfs and decided to see if it solved the problem I previously posted about 2.8 in the thread of another precise-pup. No go from menu. Browsed into /usr/bin and tried to start it via the terminal.
It reports an error shown in the attached jpg.
As I also previously mentioned gimp-2.7.2.sfs runs on all precise pups.

mikesLr

Solved by pemasu's technical expertise, and my guess-work.
See http://murga-linux.com/puppy/viewtopic.php?p=665645#665645
gimp_error.jpg
 Description   gimp-DBus error
 Filesize   24.75 KB
 Viewed   5565 Time(s)

gimp_error.jpg


Last edited by mikeslr on Mon 19 Nov 2012, 13:34; edited 1 time in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 11 [163 Posts]   Goto page: 1, 2, 3, ..., 9, 10, 11 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0983s ][ Queries: 12 (0.0048s) ][ GZIP on ]