Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Nov 2014, 17:50
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
'lina-lite - version 005
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 15 Posts_count   Goto page: Previous 1, 2, 3, 4, ..., 13, 14, 15 Next
Author Message
Marv


Joined: 04 May 2005
Posts: 368
Location: SW Wisconsin

PostPosted: Sun 11 Nov 2012, 23:32    Post_subject: xfce4-panel-mounter  

elroy wrote:
Marv wrote:
install (or reinstall) pup-volume-monitor-0.1.8-i486 from the repositor


No, it's not a reinstall. It wasn't included (although I may need to revisit that for 002). There is a newer version of the pup-volume-monitor in the repo - v.0.1.10.


Gotcha, thanks. installed the v.0.1.10. Played a bit more with the xfce4-panel-plugin-mounter. Indeed, it does take its drive info from the fstab in /etc, and pup-volume-monitor via its fstab rules and fstabd is entering sdb and not sdb1 into the fstab. Using pup-volume-monitor-admin --listen -d rv it appears that the volume monitor is reporting an add event for both sdb and sdb1 and then possibly a change event to sdb1 on USB insertion but only the sdb is entered into fstab. Stuck there for now. Brain smoking. Must like puzzles cause pmount works correctly and quickly now in the panel.

_________________
Pups currently in kennel Very Happy X-slacko 2.2.1n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 368
Location: SW Wisconsin

PostPosted: Mon 12 Nov 2012, 01:36    Post_subject: notifications  

Notifications (on save2flash or network setup for example) were not working at all on my 001 install. Installed xfce4-notifyd from the repo ( it said some files were installed but didn't show up in the control panel). Notifications then worked fine, set to default, removed notifyd, and they continue to work. Survived a reboot.

Like pup-volume-monitor, it's not small, but might save some bamboozlement if added in initially.

I can't really find much to eliminate in trade other than icons and fonts. I use hicolor and or Neu blue which are both quite a bit smaller than the Aw0ken_full and swap out the DejaVu for Bitstream Vera and Arial though that fontswap makes it much less international. Limiting icons to hicolor seems fair in a Lite version though.

Pretty minor bumps. Basically it flies as advertised. WELL!

_________________
Pups currently in kennel Very Happy X-slacko 2.2.1n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4818
Location: GB

PostPosted: Mon 12 Nov 2012, 04:35    Post_subject:  

Another hero rides to assist! Well done, M.
After banging on about size for a couple of years, it's extremely encouraging that el has taken up the cudgels, produced the goods and shown that there are multiple benefits from a reduced-fat .iso. So much more skill and insight than just adding an endless succession of libs & co. to placate the bleating hordes! The silent majority will come to realise the magnitude your significant contributions. This distro is seriously G-O-O-D.
Anyone for a 50M version.....
Back to top
View user's profile Send_private_message 
dawg

Joined: 09 Aug 2009
Posts: 113
Location: still here

PostPosted: Mon 12 Nov 2012, 08:21    Post_subject:  

Regarding the version numbering: why 001, and not 003, or is Lite so much different from the Carolina 003 ?
The thing is, it tends to add to the confusion, especially for newcomers, as now you have 3 distros of the same kind (Saluki, Carolina, Lina Lite -??), which, IMO, all could/should have been one. Is all this branching really necessary?
Just something to consider...

Anyhow, Lina Lite - excellent idea and much appreciated!
Thanks, elroy & everyone who contributes to it!

_________________
I used to only like Puppy as a friend, but now I think our relationship is starting to develop into something more... Very Happy
Back to top
View user's profile Send_private_message 
ICQ 
Billtoo


Joined: 07 Apr 2009
Posts: 2156
Location: Ontario Canada

PostPosted: Mon 12 Nov 2012, 10:10    Post_subject: 'lina-lite-001
Sub_title: manual frugal install on emachines D620 laptop
 

Manual frugal install to hard drive on emachines laptop.

VIDEO REPORT: lina-lite, version 001
Chip description:
oem: ATI ATOMBIOS
product: RS690 01.00
Driver used by Xorg:
radeon
Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"
Computer
Processor AMD Athlon(tm) Processor 2650e
Memory 1812MB (164MB used)
Display
Resolution 1280x800 pixels
OpenGL Renderer Software Rasterizer
Version
Kernel Linux 3.2.8-ski (i686)
Compiled #1 SMP PREEMPT Mon Mar 12 16:42:30 EET 2012
OpenGL
Vendor Mesa Project
Renderer Software Rasterizer
Version 2.1 Mesa 7.10.3
Direct Rendering Yes
Network controller Broadcom Corporation BCM4312 802.11b/g LP-PHY

VLC works with the radeon driver.
One problem that I have is that the internal dvd drive
isn't seen by pmount, I plugged in my usb cd/dvd drive and
it is seen and mounts no problem.
Lina-lite is working well apart from the dvd drive problem.

EDIT:Installing pup-volume-monitor in ppm fixed the dvd drive problem.
Screenshot.jpg
 Description   
 Filesize   54.02 KB
 Viewed   986 Time(s)

Screenshot.jpg

Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4818
Location: GB

PostPosted: Mon 12 Nov 2012, 13:58    Post_subject:  

Don't forget to restart X after installing pup-volume-monitor.
Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 368
Location: SW Wisconsin

PostPosted: Mon 12 Nov 2012, 18:48    Post_subject: xfce4-panel-plugin-mount  

This is kind of for Geoffrey and any other very brave souls to try out. I have the xfce4 panel mounter working with my ide-flash and USB drives in 'lina-001. I see this as a pointer in the right direction possibly. The thunar, pmount and desktop mounting is not changed at all. It took 2 changes:

1. In the properties for the panel mount, blacklist the various /dev/loopx and /dev/fd0. Pretty simple, just a space delimited list.

2. I rewrote /etc/udev/rules.d/60-fstabd.rules so that it tests for the volume, not the disk. Probably many ways to skin this cat, but it works for all of my usb drives and is a starting point. I looked at the source for the panel mounter and indeed it does rely on fstab.

BACK UP the original 60-fstabd.rules, substitute these, and have a go at it. The USB drive when plugged in should now show as sdbx etc. in both /etc/fstab and /etc/fstab.d.

Edit: rules updated 11/13/2012 to add mount points if needed.
60-fstabd.rules.gz
Description  Updated rules for /etc/udev/rules.d Updated on 11/13/2012 to add mount points if needed. No cd or dvd support.
gz

 Download 
Filename  60-fstabd.rules.gz 
Filesize  199 Bytes 
Downloaded  482 Time(s) 

_________________
Pups currently in kennel Very Happy X-slacko 2.2.1n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.

Edited_time_total
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 594
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Mon 12 Nov 2012, 21:51    Post_subject:  

Has anyone else noticed that Thunar doesn't show thumbnails even if it is checked in preferences? Also no thumbnails in Ristretto either.

A look in .packages adrive-installed-packages shows lina_xfce-4.10. I installed xfce-4.10-i486 from the repo over top and it seems to have fixed this. Although it did reset my panel and Bulk rename is missing from the menu.

Edit: Bulk rename's category was changed to "BuildingBlocks" in the desktop file. Changed to "FileSystem" fixed this.
lina_xfce-4.10.png
 Description   
 Filesize   61.33 KB
 Viewed   860 Time(s)

lina_xfce-4.10.png

xfce-4.10-i486.png
 Description   
 Filesize   77.71 KB
 Viewed   826 Time(s)

xfce-4.10-i486.png


_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.2
Carolina
X-precise/X-slacko

Edited_times_total
Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 368
Location: SW Wisconsin

PostPosted: Mon 12 Nov 2012, 22:07    Post_subject: dumb question  

In the repository pets, there are sometimes NLS and non-NLS versions. Aah what does NLS stand for?

Quote:
Has anyone else noticed that Thunar doesn't show thumbnails even if it is checked in preferences? Also no thumbnails in Ristretto either.


No thumbnails here either. I'm too lazy to rebuild my panel for now so I'll live with it for a bit.

_________________
Pups currently in kennel Very Happy X-slacko 2.2.1n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 594
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Mon 12 Nov 2012, 22:32    Post_subject:  

@ Marv

I've had no issues with USD drives being shown wrong.
Screenshot.png
 Description   
 Filesize   58.39 KB
 Viewed   842 Time(s)

Screenshot.png


_________________
Carolite-1.2 / Carolina-1.2 / X-precise-2.4 / X-slacko-2.2
Carolina
X-precise/X-slacko
Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 368
Location: SW Wisconsin

PostPosted: Mon 12 Nov 2012, 22:50    Post_subject: USB drives  

Quote:
I've had no issues with USD drives being shown wrong.


rg66,

They have always been fine on the desktop, in thunar, and in pmount. The struggle has been with the xfce mounter plugin for the xfce4 panel. It was ok prior to xfce 4.80 and since then it hasn't, at least for me. Do you use that?

Thanks,

_________________
Pups currently in kennel Very Happy X-slacko 2.2.1n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send_private_message 
rg66


Joined: 23 Jul 2012
Posts: 594
Location: Vancouver, BC Canada / Entebbe, Uganda Africa!?!

PostPosted: Mon 12 Nov 2012, 23:06    Post_subject:  

Sorry Marv my bad, I misread the post. But it is 6 in the morning here, I should make another coffee. Shocked

I just tried the mounter plugin and it lists the USB drive ok but won't mount or unmount anything, just a failed error.

Edited_time_total
Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 368
Location: SW Wisconsin

PostPosted: Mon 12 Nov 2012, 23:11    Post_subject:  

Quote:
But it is 6 in the morning here, I should make another coffee.


Yep, coffee is good, especially with no snowflakes in it.

_________________
Pups currently in kennel Very Happy X-slacko 2.2.1n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.
Back to top
View user's profile Send_private_message 
Geoffrey


Joined: 30 May 2010
Posts: 1475
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Mon 12 Nov 2012, 23:24    Post_subject:  

Thanks Marv, the mounter plugin works fine now for me, no trouble with mounting or unmounting, no apparent adverse effects from the code change, nice to get rid of the loops, looks a lot cleaner.

oops there are loops, not to worry, they are handy for unmounting sfs files Very Happy

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send_private_message 
Marv


Joined: 04 May 2005
Posts: 368
Location: SW Wisconsin

PostPosted: Mon 12 Nov 2012, 23:56    Post_subject: xfce4-panel-plugin-mount  

Quote:
Thanks Marv, the mounter plugin works fine now for me, no trouble with mounting or unmounting, no apparent adverse effects from the code change, nice to get rid of the loops, looks a lot cleaner.


Geoffrey,

I've been using it a bit more and found one oddity, probably not worth fixing, and one improvement. Plugging in more and more usb drives, when I got beyond the empty mount points created in /MNT with thunar or desktop, it wouldn't mount that drive. Once that drive had been mounted, the empty folder (/mnt/sde1 for example) is permanent and the panel mounter is fine. Probably can create a mount point within a rule but I'm not there yet.

I also plugged in a CF card in an adaptor with multiple partitions. My first set of rules wouldn't show the additional partitions on that card. Attached is a set of rules that will. Same drill and cautions apply.

Edited 11/13/2012. Rules updated to add mount points if needed.
60-fstabd.rules.gz
Description  Updated 11/13/2012 to add mount points if needed. No cd or dvd support.
gz

 Download 
Filename  60-fstabd.rules.gz 
Filesize  199 Bytes 
Downloaded  500 Time(s) 

_________________
Pups currently in kennel Very Happy X-slacko 2.2.1n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.14.20 kernel). All lean and steady pups.

Edited_time_total
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 15 Posts_count   Goto page: Previous 1, 2, 3, 4, ..., 13, 14, 15 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0916s ][ Queries: 12 (0.0082s) ][ GZIP on ]