Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Aug 2014, 16:06
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Dpup Wheezy. Woof-CE built debian wheezy 7.2 packages used
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 23 of 48 [706 Posts]   Goto page: Previous 1, 2, 3, ..., 21, 22, 23, 24, 25, ..., 46, 47, 48 Next
Author Message
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Sat 11 May 2013, 11:36    Post subject:  

pemasu wrote:
I have hunted the scripts with "set -x" inside. In /etc/acpi several scripts had it.
Okay...removing "set -x" from those scripts removes a lot "noise" from /tmp/xerrs.log.

I will go through all scripts now with search functions.


Yes, similar to set -ex, the diagnostics mode. Excellent find!
That will certainly help. (Although that is one reason why WheezyPup is so stable: you conducted good diagnostics before the release.)

Bye for now.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Sat 11 May 2013, 11:42    Post subject:  

pemasu wrote:
Okay. I hunted most left over "set -x" debugging command included scripts. Not many....but at least those /etc/acpi scripts produce quite a lot verbose messages which accumulate to the xerrs.log. They are not errors, but disabling that "noise" cleans xerrs.log a lot.

I noticed that libpoppler was left out. It was due to my experimenting pdf readerless build. Using Firefox inbuild pdfreader. But....Cups...Abiword...LibreOffice....heaven knows what else needs it. You cant live without poppler...if you want to print.

I will create 3.5.2.7 version this evening and upload it.


Hi, pemasu.

Just upload the library. You are too dedicated! Smile Your head is in the clouds because of your neighbors, remember? Smile

m0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Sat 11 May 2013, 11:49    Post subject:  

Besides, pfind says that poppler is there :

    /usr/include/poppler
    /usr/include/poppler/glib/poppler-action.h
    /usr/include/poppler/glib/poppler-annot.h
    /usr/include/poppler/glib/poppler-attachment.h
    /usr/include/poppler/glib/poppler-date.h
    /usr/include/poppler/glib/poppler-document.h
    /usr/include/poppler/glib/poppler-enums.h
    /usr/include/poppler/glib/poppler-features.h
    /usr/include/poppler/glib/poppler-form-field.h
    /usr/include/poppler/glib/poppler.h
    /usr/include/poppler/glib/poppler-layer.h
    /usr/include/poppler/glib/poppler-media.h
    /usr/include/poppler/glib/poppler-movie.h
    /usr/include/poppler/glib/poppler-page.h
    /usr/lib/libpoppler.a
    /usr/lib/libpoppler-glib.a
    /usr/lib/libpoppler-glib.so
    /usr/lib/libpoppler-glib.so.4
    /usr/lib/libpoppler-glib.so.5
    /usr/lib/libpoppler-glib.so.6
    /usr/lib/libpoppler-glib.so.8
    /usr/lib/libpoppler-glib.so.8.2.0
    /usr/lib/libpoppler.so
    /usr/lib/libpoppler.so.19
    /usr/lib/libpoppler.so.19.0.0
    /usr/lib/libpoppler.so.4
    /usr/lib/libpoppler.so.7
    /usr/lib/pkgconfig/poppler-cairo.pc
    /usr/lib/pkgconfig/poppler-glib.pc
    /usr/lib/pkgconfig/poppler.pc
    /usr/lib/pkgconfig/poppler-splash.pc
    /usr/share/gir-1.0/Poppler-0.18.gir
    /usr/share/gtk-doc/html/poppler
    /usr/share/vala-0.14/vapi/poppler-glib.deps
    /usr/share/vala-0.14/vapi/poppler-glib.vapi

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3259
Location: Ontario

PostPosted: Sat 11 May 2013, 13:15    Post subject: mhwaveedit 1.4.21  

I compiled mhwaveedit 1.4.21 in wheezy so that it recognizes
ladspa effects

I added a useful config file.

http://www1.datafilehost.com/d/9c29fb40

and here are the locales

http://www1.datafilehost.com/d/716139e8

_________________________________________________
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 11 May 2013, 14:27    Post subject:  

Thanks don570. I uploaded them to the repo.
Back to top
View user's profile Send private message 
anikin

Joined: 10 May 2012
Posts: 460

PostPosted: Sat 11 May 2013, 14:37    Post subject:  

A quick question: the power applet in the tray that shows 'powersave', 'performance' and 'turbo'. What its official name, or is it part of laptop tools? Does it have a source and is it compilable?

Thank you in advance.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 11 May 2013, 15:22    Post subject:  

It is called ppower. And it relies to the scripts in /etc/acpi. There is source for it.

http://www.smokey01.com/jemimah/saluki/source/ppower-jemimah-01.tar.gz
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5721
Location: Kentucky

PostPosted: Sat 11 May 2013, 18:46    Post subject:  

Temporarily have an internet connection so........live pfix=ram.....

# report-video
VIDEO REPORT: Dpup Wheezy, version 3.5.2.6

Chip description:
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS480 [Radeon Xpress 200G Series]
Display controller: Advanced Micro Devices [AMD] nee ATI Radeon Xpress Series (RS480)

Requested by /etc/X11/xorg.conf:
Depth (bits, or planes): 24
Modules requested to be loaded: dbe
Drivers requested to be loaded: radeon

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): radeon
Loaded modules: dbe dri dri2 exa extmod fb glx kbd mouse ramdac record

Actual rendering on monitor:
Resolution: 1024x768 pixels (270x203 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
#

Booted to a prompt,ran xorgwizard and selected "radeon" with correct 1024x768 resolution.

-Computer-
Processor : AMD Athlon(tm) 64 Processor 3400+
Memory : 967MB (111MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Sun 12 May 2013 03:48:08 AM CDT
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : ATIIXP - ATI IXP

Code:
Multimedia audio controller      : Advanced Micro Devices [AMD] nee ATI IXP SB400 AC'97 Audio Controller
VGA compatible controller      : Advanced Micro Devices [AMD] nee ATI RS480 [Radeon Xpress 200G Series]
Display controller      : Advanced Micro Devices [AMD] nee ATI Radeon Xpress Series
Ethernet controller      : Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express


EDIT:

At the prompt after selecting xorgwizard I was given a choice between "modesetting", "radeon" and "vesa" drivers. Naturally I selected the correct "radeon".

EDIT 2:
Linked to Barry K's blog.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 11 May 2013, 19:01    Post subject:  

Dpup Wheezy 3.5.2.7 has been uploaded.

Small fixes mostly. Less "noice" in /tmp/xerrs.log.
I compiled Evince for fast pdf viewing. It is now the default pdf reader.
Some finetuning for font outlook. In bad or good.

Download link : http://www.smokey01.com/pemasu/DpupWheezy/DpupWheezy3527/


If people compile useful applications, I can upload them to the repo from temporary host:
http://www.smokey01.com/pemasu/pet_packages-wheezy/
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 863
Location: London, England

PostPosted: Sat 11 May 2013, 20:16    Post subject:  

Pemasu,
You may wish to consider adding my Linphone to the repo. It is smaller than the Debian version and has all the extra codecs added. The sign-in wizard works too.

http://www.murga-linux.com/puppy/viewtopic.php?t=79803

_________________
Oscar in England

Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 863
Location: London, England

PostPosted: Sat 11 May 2013, 23:33    Post subject:  

I am trying to produce a .PET of the latest NVIDIA legacy driver 173.14.37 for Dpup Wheezy and it all seems to work OK. I am just a little unsure about the post-install and post-uninstall processes.

On my nvidia GeForce FX 5200 computer, the only driver that loads (without tinkering) is nouveau. The nvidia .pet includes the .conf file that disables nouveau (which must be done) so after installation on reboot there is no driver to produce a desktop.

I have to type "xorgwizard" from prompt then select the nvidia driver (and a resolution) and then type "xwin" to get my desktop with the working nvidia driver. Not a major problem, these instructions appear in the prompt dialog, and hopefully it is something you would only have to do once.

Uninstallation restores the nouveau driver and old xorg.conf file, but again requires typing "rmmod nvidia" in prompt screen (or does it?). There is no nv driver so no need to try to restore that.

I have put pop-up messages in which explain and guide the user through this, but maybe someone knows of a smoother way of doing things. Can we avoid reboots or the need to type in prompt screen?

I'm not certain the xorgwizard is completely recognising all the right combinations of disabling drivers and/or rebooting.

Is there some other way to test acceleration / FPS without glxgears?

Nvidia 173.14.37 k3.5.2.Wheezy .pet
download = http://www1.datafilehost.com/d/e4013200
md5sum = a7204548b94b327009f824a4debaf159

_________________
Oscar in England

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 12 May 2013, 02:03    Post subject:  

Thank you OscarTalks. I have uploaded both of your posts suggested packages.

About pinstall.sh and postinstall.sh scripts. I think you get good idea what people have done before by downloading previous pets and check the contents. I suppose 01micko`s repos for Slacko is good library for studying. I dont have nvidia graphics so I cant recommend much.

I remember that Shinobar placed large postinstall script to the /root/Startup but I dont remember what it dit. Extracting those pets and checking would be the method I would use.
Back to top
View user's profile Send private message 
Satori

Joined: 14 Jan 2013
Posts: 25

PostPosted: Sun 12 May 2013, 03:03    Post subject: switched from Squeeze to Wheezy
Subject description: hippups on a Wheezy apps when changing from Squeeze
 

With the release of the 'official' debian 7 and your Dpup Wheezy use of it, I made the change-over for my personal production machines, which were using Dpup Squeeze.

There were no problems with installing the NVidia 319.17 drivers and all went well.

Chrome 26.0 is now able to run but I found that the youtube audio was extremely choppy and really annoying... after googling around, I found that the fix was to add a parameter
to the startup execution, of "--audio-buffer-size=2048". Apparently, this is a known problem for version 26, and now the sound is very smooth.

I see that there is no longer a cpu temperature on the system tray, and that the 'temptray' application from the repositories fails to start. For laptops, it's a neccessary tool.

I would like to see 'GTK-Youtube-Viewer" running under DPup Wheezy, but there seems to be a conflict that prevents it from starting.

The other applications I use, make heavy usage of OpenGL and the apps run pretty well. Altho one older app now fails with a GTK2.pm error, but the newer versions run ok.
I guess that's just progress for you.

Aside from the above minor wish list, I'm pretty happy with this distribution and feel confident that it will support the newer applications that will be coming down the line,
in the near future.

Thanks for your work.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 12 May 2013, 04:19    Post subject:  

Thanks Satori. I add your find audio fix to the Chrome 26 postinstallation hack.
I tested google-chrome 26 and you were right. Hotel California sound was choppy. The fix was needed.

Gtk-youtube-viewer would be a bigger thing to get it working. It will need manual messing with perl .pm files. To add missing perl scripts to the package. I wont promise it soon, lol.

Here is working tempicon tray app as attachment. I have left some temp apps out to diminish memory usage. People with desktop comps usually dont need the temp info.
tempiconsvg-0.19-i486.pet
Description 
pet

 Download 
Filename  tempiconsvg-0.19-i486.pet 
Filesize  10.72 KB 
Downloaded  179 Time(s) 

Last edited by pemasu on Sun 12 May 2013, 04:45; edited 1 time in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 12 May 2013, 04:29    Post subject:  

gtk_youtube_viewer-3.0.2_precise.pet does work in Dpup Wheezy if you have devx sfs loaded. I havent tested it without devx sfs.

http://uploadingit.com/file/t2jhxvvneeazcq2u/gtk_youtube_viewer-3.0.2_precise.pet
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 23 of 48 [706 Posts]   Goto page: Previous 1, 2, 3, ..., 21, 22, 23, 24, 25, ..., 46, 47, 48 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1041s ][ Queries: 12 (0.0107s) ][ GZIP on ]