Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 13:12
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Puppy Mage won't print. I added CUPS, but no go.
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
davec51

Joined: 13 Apr 2006
Posts: 492
Location: Virginia

PostPosted: Mon 20 Aug 2012, 13:19    Post_subject:  Puppy Mage won't print. I added CUPS, but no go.  

I just did a frugal install of Puppy-Mage. I added my printer from my wired network and printed a test page successfully. However, No printing takes place from my computer -- not with Abiword, LibreOffice, or Firefox. Am I missing something in the setup?
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11121
Location: Arizona USA

PostPosted: Mon 20 Aug 2012, 17:15    Post_subject:  

Wait, what? So this is a wireless printer? What make and model?

Would this thread be any use?

Edited_time_total
Back to top
View user's profile Send_private_message 
davec51

Joined: 13 Apr 2006
Posts: 492
Location: Virginia

PostPosted: Mon 20 Aug 2012, 17:23    Post_subject: Can't Print  

Thanks for replying.
I have a wired network. A Windows XP computer is the server. The printer is a Brother all-in-one, MFC 5895cw model. As I said, I have had no trouble printing with other Linux OS's, including numerous Puppies.
Back to top
View user's profile Send_private_message 
scsijon

Joined: 23 May 2007
Posts: 1047
Location: the australian mallee

PostPosted: Mon 20 Aug 2012, 19:27    Post_subject:  

Hi, just come across this thread.

Firstly, which version of Mage and what is the printer type and model please?

It should work as if it can send a test page the problem is not cups, can you try the following please.

-open cups and check the printer name, print driver, Paper size, etc. is correct and matches the actual printer, Leave Cups up at the 'Manage Jobs' tab so you can see if anything arrives or gets stuck!

-open Geany and type a couple of lines
-in geany goto File>Print and check the printer is there under the general tab, then goto the second 'Page Setup' tab and check it's settings for paper size, etc. are matching those in Cups and the actual printer then do a 'Print Preview', if that's all ok, click on the printer so it's highlighted and then the Print Button should come 'alive', press it and see what happens there and in the Cups Manage Jobs Tab.

If that Prints all right, I sugest you check what's set in the other apps with regards to Printer Name and paper size to start with. I have noticed that Mageia has a protection set in it's Cups and won't print wrong / mismatched sizes.

Can you also put a link for this into my Mageia thread please so I can backtrack to this if that is not your problem.

regards
scsijon
ps, this should really be under the Bugs Topic Group, can you also pm a moderator to move it please.

_________________
Puppy T290 - BarryK's Racy but with T2 Version 9.0 is under development.
http://www.murga-linux.com/puppy/viewtopic.php?t=94575
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0429s ][ Queries: 11 (0.0029s) ][ GZIP on ]