Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 22:45
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Drum-sequencer Hydrogen
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [26 Posts]   Goto page: 1, 2 Next
Author Message
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 14 May 2006, 23:09    Post subject:  Drum-sequencer Hydrogen  

Homepage:
http://www.hydrogen-music.org/

This requires libQT.
Install it with Pupget, if you don't use KDE already.

Download (2.9 MB):
http://dotpups.de/dotpups/Multimedia/hydrogen-9.1-1.1.pup

Requires these, too:
http://dotpups.de/dotpups/Multimedia/libaudio2.pup
http://dotpups.de/dotpups/Libraries/libidn.so.11.5.10.pup

Hydrogen already includes several other libraries, so pay attention:
If you UN-install it again, these libraries will be deleted, too.
If you use another program that needs them, you might have to re-install that one again then Exclamation

Here is a list of all included libs from /usr/lib:
AuErrorDB
libcurl.so
libcurl.so.3
libcurl.so.3.0.0
libFLAC.so
libFLAC++.so
libFLAC.so.4
libFLAC++.so.4
libFLAC++.so.4.0.1
libFLAC.so.4.1.2
libFLAC.so.6
libFLAC.so.6.0.1
libjack0.80.0-0
libjack-0.80.0.so.0
libjack-0.80.0.so.0.0.23
liblrdf.so.0
liblrdf.so.0.0.0
libraptor.so.1
libraptor.so.1.1.0
libsndfile.so
libsndfile.so.1
libsndfile.so.1.0.12

Most of them can be found as single dotpups here:
http://dotpups.de/dotpups/Libraries/
http://dotpups.de/dotpups/Multimedia/

I made it from Debian-binaries, as I got an error while trying to compile it with my libQT.

Mark
Back to top
View user's profile Send private message Visit poster's website 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Mon 15 May 2006, 09:56    Post subject:  

will be downloading tonight.
Back to top
View user's profile Send private message AIM Address 
Indy


Joined: 01 Feb 2006
Posts: 65
Location: Sydney, Australia

PostPosted: Mon 15 May 2006, 22:31    Post subject:  

Hi,

I've got it running. Looks (and sounds) good.

Thanks!

I just ran the first three dotpups mentioned (it turned out I already had the QT library when I went into Pupget) and Hydrogen was off and running. Good stuff.

Looks like this will be fun.
Back to top
View user's profile Send private message 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Tue 16 May 2006, 13:46    Post subject:  

Not working so well in grafpup.

Quote:

Hydrogen 0.9.1 [Jan 21 2005] - Copyright 2002-2004 Alessandro Cominu
Compiled modules: (Alsa) (FLAC) (Jack) (OSS) (LRDF)

Hydrogen comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details

Warning: no locale found: /usr/share/hydrogen/i18n/hydrogen.en_US
[WARNING] SongReader [readSong] Trying to load a song created with a different version of hydrogen.
[WARNING] SongReader [readSong] Song [/usr/share/hydrogen/data/DefaultSong.h2song] saved with version 0.9.0
[LadspaFX::getPluginList] reading directory: /usr/lib/ladspa
[LadspaFX::getPluginList] directory /usr/lib/ladspa not found
[LadspaFX::getLadspaFXGroup]
[LadspaFX::getPluginList] reading directory: /usr/lib/ladspa
[LadspaFX::getPluginList] directory /usr/lib/ladspa not found
ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM hw:0
[ERROR] AlsaAudioDriver ALSA: cannot open audio device hw:0: No such file or directory
hydrogen: conf.c:3109: snd_config_update_free: Assertion `update->count > 0 && update->finfo' failed.
Back to top
View user's profile Send private message AIM Address 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Tue 16 May 2006, 13:58    Post subject:  

ok, I rebooted after realizing it was an Alsa audio error...I had just installed the Grafpup alsa package and it needed rebooting...getting a different error now...

Quote:

# ./run-hydrogen
#
Hydrogen 0.9.1 [Jan 21 2005] - Copyright 2002-2004 Alessandro Cominu
Compiled modules: (Alsa) (FLAC) (Jack) (OSS) (LRDF)

Hydrogen comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details

Warning: no locale found: /usr/share/hydrogen/i18n/hydrogen.en_US
[WARNING] SongReader [readSong] Trying to load a song created with a different version of hydrogen.
[WARNING] SongReader [readSong] Song [/usr/share/hydrogen/data/DefaultSong.h2song] saved with version 0.9.0
[LadspaFX::getPluginList] reading directory: /usr/lib/ladspa
[LadspaFX::getPluginList] directory /usr/lib/ladspa not found
[LadspaFX::getLadspaFXGroup]
[LadspaFX::getPluginList] reading directory: /usr/lib/ladspa
[LadspaFX::getPluginList] directory /usr/lib/ladspa not found
ALSA lib seq.c:928:(snd_seq_open_noupdate) Unknown SEQ hw
[ERROR] AlsaMidiDriver Error opening ALSA sequencer
hydrogen: conf.c:3109: snd_config_update_free: Assertion `update->count > 0 && update->finfo' failed.
Back to top
View user's profile Send private message AIM Address 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Tue 16 May 2006, 19:13    Post subject:  

Well it's not going to matter now, as Nathan compiled it and it's working for him, so he's going to include it in usr_multimedia.
Back to top
View user's profile Send private message AIM Address 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Tue 16 May 2006, 21:14    Post subject:  

Also, upgrading to Grafpup 103b appears to have solved the problem with your package. It works fine there.
Back to top
View user's profile Send private message AIM Address 
Nathan F


Joined: 08 Jun 2005
Posts: 1760
Location: Wadsworth, OH (occasionally home)

PostPosted: Tue 16 May 2006, 23:12    Post subject:  

I compiled it using Puppy-109 in order to maintain as much compatibility as possible, so when I make the binaries available they should run on Grafpup or on Puppy. I plan to release it in two formats, both as a standalone dotpup (although it will require a few external dependencies which I will also supply) and as part of the update to usr_multimedia.sfs for Grafpup, which includes a large selection of audio/video/graphics applications. It's been a pet project of mine for a while. Currently included:
Video/Animation
    Cinelerra
    Kino
    dvGrab
    GAP

Audio
    Audacity
    Ardour
    Jack
    Hydrogen (if it checks out)
    CAPS audio plugins
    various LADSPA plugins

3D graphics/Animation
    Blender
    Yafray

In addition there are numerous support libraries including Python, and a few other goodies like PyGimp. I'm also planning to integrate Povray pretty soon. With the exception of Kino which needs GTK2-2.8+ all of these programs seem to run in Puppy as well, so it's a simple matter to rename it to usr_more.sfs for Puppy usage. Or you can try my new squash program, which can load it on the fly in Puppy (see the thread on squash-0.1).

Not intending to hijack the thread at all, sorry. I guess I got carried away.

Nathan

_________________
Bring on the locusts ...
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 16 May 2006, 23:24    Post subject:  

no need for an excuse, that is really good news Exclamation Exclamation
As I wrote somewhere else, I prefer programs compiled in Puppy, I just used the Debian-package here because I got a QT-error when compiling.
So it is great you had success.
And the other ones look even more interesting *slime running out of my mouth* *gimme the bone pleaseplease* Wink
Mark
Back to top
View user's profile Send private message Visit poster's website 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Wed 17 May 2006, 06:03    Post subject:  

Nathan F wrote:
Audio
    Audacity
    Ardour
    Jack
    Hydrogen (if it checks out)
    CAPS audio plugins
    various LADSPA plugins



What about MusE? I've been trying to compile it but been having some difficulties. Hopefully I'll manage to get it sorted soon...
Back to top
View user's profile Send private message 
Nathan F


Joined: 08 Jun 2005
Posts: 1760
Location: Wadsworth, OH (occasionally home)

PostPosted: Wed 17 May 2006, 08:22    Post subject:  

Haven't looked at MuSe yet (not that I won't). What sort of trouble is it giving you in compiling?

Nathan

_________________
Bring on the locusts ...
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Wed 17 May 2006, 09:57    Post subject:  

There are quite a few good programs for creating music in Linux. The music industry just hasn't really recognized this yet.
Back to top
View user's profile Send private message AIM Address 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Wed 17 May 2006, 09:58    Post subject:  

http://www.muse-sequencer.org/

From the screen shots, this looks quite impressive.

I'll probably get to work on compiling this soon, but I really need to finish my CD up first now that I've got a working copy of Hydrogen in Grafpup Linux.

There's even a score editor, looks great for those who need sheet music printed out. Very Happy
Back to top
View user's profile Send private message AIM Address 
Nathan F


Joined: 08 Jun 2005
Posts: 1760
Location: Wadsworth, OH (occasionally home)

PostPosted: Wed 17 May 2006, 10:54    Post subject:  

I released an updated usr_multimedia.sfs today, which can be found at the Grafpup download page http://grafpup.com/download. This now includes Hydrogen and a few more audio plugins than it had before. As I mentioned previously, almost all of these programs will run just fine in Puppy as well as Grafpup, so feel free to give it a try. Also, if you feel inclined to tear it apart and use the binaries in anything else like perhaps megapup go right ahead.

With a couple exceptions (Kino and Cinelerra) all was compiled either in Grafpup or Puppy, mostly in Puppy. Kino wouldn't compile in Puppy or Grafpup so I used Vector, with all the same library versions as are in Grafpup. Cinelerra was taken from a Slax module.

I'll get a few dotpups made shortly for anyone who just wants a certain program and not the whole thing. The whole thing, BTW, is 52 megabytes. I'm going to plug my squash utility here again and mention that it provides a way to run all of this in RAM just like usr_cram does, so if you have the extra memory what you'll get is warp speed using it.

Nathan

_________________
Bring on the locusts ...
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Mon 04 Jun 2007, 22:47    Post subject:  

Trying to get this to work under BarelyPup...installed everything, including FLAC, that I'm aware of that I need to get this working...

Quote:
hydrogen: symbol lookup error: /usr/lib/libFLAC++.so.4: undefined symbol: FLAC__file_decoder_new
Back to top
View user's profile Send private message AIM Address 
Display posts from previous:   Sort by:   
Page 1 of 2 [26 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.8616s ][ Queries: 12 (0.7840s) ][ GZIP on ]