Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 10 Dec 2016, 10:51
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Partview v2016
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [32 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Tue 29 Apr 2014, 11:32    Post subject:  

Code:
export TEXTDOMAIN=partview
export OUTPUT_CHARSET=UTF-8

Thank you. I forgot those lines.

There are two schools of thought about GUI design. Some people like icons on their buttons with a mouseover to describe the function. I prefer an actual word so there is no confusion about what the icon means.

I will give your version some thought.

Bill
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 875
Location: El Salvador

PostPosted: Tue 29 Apr 2014, 21:14    Post subject: Locales en Español
Subject description: Spanish locales
 

Gooood
my friend what about line 107
Code:
  [ "$PART" = "loop1" ] && PART="$(gettext 'savefile')"

anyway i add gettext to the line and translate
partview-2014_NLS-ES.pet
Description  Spanish locales
pet

 Download 
Filename  partview-2014_NLS-ES.pet 
Filesize  1.05 KB 
Downloaded  124 Time(s) 

_________________
My blog | | Github


Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Tue 29 Apr 2014, 21:29    Post subject: Re: Locales en Español
Subject description: Spanish locales
 

nilsonmorales wrote:
Code:
  [ "$PART" = "loop1" ] && PART="$(gettext 'savefile')"

Done and uploaded!

Thanks.
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Thu 01 May 2014, 05:23    Post subject: Re: Locales en Español
Subject description: Spanish locales
 

rcrsn51 wrote:
nilsonmorales wrote:
Code:
  [ "$PART" = "loop1" ] && PART="$(gettext 'savefile')"

Done and uploaded!

If you do that, button "Calculate percentage used" will not work (for save file).
Need to improve the script to can translate <frame $PART ($FS)>

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Thu 01 May 2014, 07:10    Post subject:  

Is this because "savefile" has been translated into a phrase with more than one word?
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Thu 01 May 2014, 07:50    Post subject:  

rcrsn51 wrote:
Is this because "savefile" has been translated into a phrase with more than one word?

Probably, we need to separate variable "PART" and message getexted (used by frame).

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids

Last edited by ASRI éducation on Thu 01 May 2014, 07:53; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Thu 01 May 2014, 07:51    Post subject:  

Post error, sorry.
_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Thu 01 May 2014, 08:32    Post subject:  

ASRI éducation wrote:
rcrsn51 wrote:
Is this because "savefile" has been translated into a phrase with more than one word?

Probably

I have posted a new version dated 2014-05-01 that should fix this problem.
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Thu 01 May 2014, 17:47    Post subject:  

rcrsn51 wrote:
ASRI éducation wrote:
rcrsn51 wrote:
Is this because "savefile" has been translated into a phrase with more than one word?

Probably

I have posted a new version dated 2014-05-01 that should fix this problem.

Yes, this problem is fixed !
Wink

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Thu 01 May 2014, 20:52    Post subject:  

Excellent. Hopefully this will be the last update until 2015.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 10096
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 01 Mar 2016, 03:32    Post subject: downloaded for my precise 5.7.1 Molinux de espana,  

downloaded for my precise 5.7.1 Molinux de espana,
Let us not let partview 2015 flow into the slums of the forum. because some nervous readers will consider it as obsolete.
"How fast was the answer ! Merci !
Not so happy : the size is thee usb stick one, not the save file (248M free 134M).
and..... Can we list the contents of the save file ? have you an idea about that ?
" was my request, 2016 check in topics iinform me that the request was accepted and partview modified. Merci rcrsn51.
sdb1.png
 Description   Sort by size would be better
 Filesize   30.98 KB
 Viewed   191 Time(s)

sdb1.png

savefile.jpg
 Description   what it looks like at home
 Filesize   30.69 KB
 Viewed   200 Time(s)

savefile.jpg


_________________
November : protect your Puppies of frosts (to freeze, Confused froze, frozen)
Back to top
View user's profile Send private message Yahoo Messenger 
scsijon

Joined: 23 May 2007
Posts: 1185
Location: the australian mallee

PostPosted: Sun 05 Jun 2016, 19:36    Post subject: two problems and a request for partview2015  

Hi rcrsn51, I thought you'd solved a problem for me, but..

I know this is getting old but I have a problem or two with partview 2015 when working on barry's quirky april 7.2.1.

First it's displaying drives in the wrong order.
i.e.
sda1; sda11; sda12; sda13; sda2; sda3; etc.

And secondly it's not uninstalling itself properly. it's leaving itself as the default partview.

And a request if I may, that it can be configured to display all drives by default please.

thanks
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Mon 06 Jun 2016, 08:14    Post subject: Re: two problems and a request for partview2015  

scsijon wrote:
First it's displaying drives in the wrong order.

I have added some code to sort these partitions properly, but I don't have an actual setup to test it. Please report.

Quote:
And secondly it's not uninstalling itself properly. it's leaving itself as the default partview.

I have added a post-uninstall script. It works in the few Puppies I checked.

Quote:
And a request if I may, that it can be configured to display all drives by default please.

Uncomment Line 103 of /usr/sbin/partview

Last edited by rcrsn51 on Tue 07 Jun 2016, 07:29; edited 1 time in total
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1185
Location: the australian mallee

PostPosted: Mon 06 Jun 2016, 19:03    Post subject:  

thanks, that works on my base system, i'll try on my backup megasystem this evening and see how it goes.
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 10984
Location: Stratford, Ontario

PostPosted: Thu 09 Jun 2016, 05:09    Post subject:  

scsijon wrote:
i'll try on my backup megasystem this evening and see how it goes.

Are you done testing this new version?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [32 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1277s ][ Queries: 12 (0.0112s) ][ GZIP on ]