(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
and continue your work there. Thank you.

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 20 Oct 2020, 13:14
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Squeezed Arm Puppy for Raspberry Pi, alpha4
Moderators: Flash, Ian, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 16 of 18 [262 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18 Next
Author Message

Joined: 28 Jan 2011
Posts: 75

PostPosted: Sun 12 May 2013, 04:35    Post subject:  

Many thanks for these notes.

I think I'm going to have some fun later this week with another round of experimentation ...

Back to top
View user's profile Send private message 

Joined: 15 Dec 2008
Posts: 4439
Location: West Lothian, Scotland, UK

PostPosted: Sun 26 May 2013, 04:25    Post subject:  

How come the Puppy for RasPi doesn't include the raspi-config command?
So how should I change the RAM-split?
Back to top
View user's profile Send private message 

Joined: 17 Nov 2012
Posts: 8
Location: Wisconsin

PostPosted: Thu 30 May 2013, 12:19    Post subject: config.txt  

The raspi-config command edits various config files but the one that defines the gpu_mem setting is config.txt.

It can be found on the first (boot) partition of the SD card. If running Puppy click on mm0p1 in the bottom left corner of the desktop.

A description of all the various options can be found here http://elinux.org/RPiconfig.
Back to top
View user's profile Send private message 

Joined: 28 Jan 2011
Posts: 75

PostPosted: Thu 06 Jun 2013, 11:12    Post subject:  

@woodenshoe: Thank you for your help. I've had alpha 4 running with the 3.6.11+ kernel for a while now and it's going reasonably well.

For anyone who is interested, here is some feedback on what I've been seeing.

What works?

Let's start with the good stuff. Within 3 hours of first boot I was satisfied that there was enough functionality that simply worked 'out of the box' to make it worth trying to develop the system. Specifically, e-mail, web browsing (+ ad blocking), bit-torrent, playing audio (music) and streaming internet radio all worked at the first attempt. There are blemishes, odd bits of functionality that don't quite work as they should, but the mainline functionality is present and correct.

Since I've run both Debian and Fedora on the RPi, I can happily confirm that (as you would expect) Puppy is an order of magnitude faster than those systems. That's not to say Puppy is fast, but it delivers fairly acceptable response times rather than being forever painfully slow.

What doesn't work

Looking at the system I soon realised I was missing an image viewer. Viewnior wasn't in the system. The package manager listed a Viewnior pet package as being available but could not download it. So I went to the repository and downloaded it manually. It's been omitted for a simple reason. It does not work.

While looking at the repository I noticed the ntfs_3g-20111121-static-armv6.pet package and wondered if it was in the build. I've needed to add it manually on other Puppy systems. It's the same for alpha 4. Fortunately the ntfs_3g package does work and after installing it I could write to my NTFS formatted drives.


The RPi does not have a hardware clock so the functionality to set the hardware clock from an NTP server (which is in the build) seems a little superflous. Unfortunately the 'set date and time' function also seems to be faulty. I can set the date but not the time. Changing the date resets the time to 00:00. There is no other option. If I change the date at midnight I can have the correct date and time for as long as I keep the RPi powered up. But of course after a power-down the time is wrong once more.

Network and optical drives

If I plug a disc into the back of my router I can access it via NAS on most of the systems I use (including Lucid Puppy 525) but it does not seem to work on alpha 4.

I have a couple of old optical drives with their own power supplies. I tried them with alpha 4. When I inserted a CD or DVD nothing happened. However opening a console and mounting the disc from the command line does work (although there is no icon on the Pinboard). Nevertheless, you can make the data available to an application that needs it.

Package Manager
edit -- this paragraph is only half correct, see two posts further.

The Puppy package manager in alpha 4 isn't a great deal of help. The one useful thing it will do is uninstall any unwanted packages you may have tried out as an experiment. I asked the package manager to download database information for the repositories it knew about. It did that quite successfully and then threw up a syntax error for each entry in the databases. That took about 90 minutes. In other words, downloading from the Debian squeeze armel repository via the package manager is off the menu.

Adding applications

Installing Debian applications manually is tedious. Made worse by Debian's habit of splitting everything up into large numbers of tiny packages. But so far I've not found any other option. So I browsed the repository looking for something both small and useful. An image viewer to replace Viewnior seemed the obvious choice. GeeQie is two packages with 9 dependencies. Pfind was able to tell me that three of the dependencies were already resolved. The remaining six dependencies have a further five dependencies of their own (none resolved). So I downloaded the 13 packeges and installed them in more or less bottom up order. I'm happy to say the GeeQie viewer runs very nicely on alpha 4 (and it's a much more capable viewer than Viewnior). I used Geany to edit the 'defaultimageveiwer' script so as to launch 'geeqie-standard' and all is working well.

A real bug?

The various bugs and blemishes I have encountered have been benign. Various little things that don't work as they should, but don't to any damage to the system either. There is one exception. I did once loose the system and need to do a complete re-install. There is something wrong with the functionality that allows the user to make cosmetic changes to the Pinboard. For example, if you select an alternative icon theme, Puppy thereafter shows all drives as unmounted. On the occasion I lost the system the sequence that led up to the crash was: I changed the icon theme, and then edited one of the icons so that it launched a different application. I then noticed that all the drives were being shown as unmounted and decided to switch back to the standard icon theme. A few seconds later X died and took the system down permanently. It was back to the dd command.

To GPU or not to GPU?

The hardware information function tells me that Puppy can see all of the RAM but apparently can't see the GPU. This becomes immediately obvious if you ask Gnome Media Player to play a video. It's clearly trying to render video using the rather slow main processor rather than using the super-fast GPU. I'm also running openELEC on the RPi and have been impressed by the RPi's ability to play h.264 encoded HD video. Even 1920x1080 BD rips play smoothly most of the time. So Puppy seems to be ignoring the RPi's main asset. Then again, I guess that's OK. It's easy enough to swap SD cards and boot the RPi up in openELEC when I want to watch video. What I need from Puppy is a system that will do normal everyday computing tasks on the RPi and in that respect, alpha 4 looks quite promising.

Last edited by amj on Fri 07 Jun 2013, 10:46; edited 1 time in total
Back to top
View user's profile Send private message 

Joined: 18 Jul 2012
Posts: 1555

PostPosted: Thu 06 Jun 2013, 12:22    Post subject:  

I am running SAP Alpha 4 using Berryboot. I've updated it to the most recent kernel that Berryboot uses.

The automatic clock setting from the internet seems to work for me, but I did have to reboot.

As far as the graphics acceleration, the only way to get accelerated video on the R Pi is to use "omxplayer" which is the custom player made for the R. Pi. It seems to be more or less a command line equivalent to mplayer.

So any reasonable video solution is going to have to be some sort of front end for omxplayer. This is what they did to make xbmc work. I don't know how hard it would be, but gmplayer and also the gtk-youtube application might be able to be adapted to use omxplayer as its backend instead of mplayer. I assume that would fix the video issues.

As far as what works, I'd add that CUPS and rdesktop both work well. The main thing I have been using it for is as a print server (freeing my laptop from the desk) and as a thin client to my Windows XP machine.

I installed rdesktop and grdesktop from the Puppy Package Manager without any problem.
Back to top
View user's profile Send private message 

Joined: 28 Jan 2011
Posts: 75

PostPosted: Fri 07 Jun 2013, 10:16    Post subject:  

dancytron wrote:
I installed rdesktop and grdesktop from the Puppy Package Manager without any problem.

Yes, I need to make a correction to what I wrote. As noted above, I screwed up the Puppy Package Manager while trying to update the repo databases. But since then I've made a complete re-install. The Package Manager in it's out of the box state works. I should have left well alone.

So I've been adding applications from the Debian squeeze armel repository. QMMP audio player and Pan newsreader. Both seem to work OK.
Back to top
View user's profile Send private message 

Joined: 28 Jan 2011
Posts: 75

PostPosted: Mon 17 Jun 2013, 10:10    Post subject:  

A few days ago, quite by chance, I noticed a new skeleton for RPi had been posted in the Quirky repository. Just out of curiosity, I downloaded it and wrote it onto an SD card so that I could take a look.

Not very exciting, but I did notice one thing: A gpu_mem=64 command has been added to the end of the config.txt file.

I believe that form of the command is now out of date (though I presume it will still work on older type A RPi's).

During my experiments with alpha 4 I've tried loading the RPi with applications running on all three desktops and it not too difficult to get to the point where resource depletion slows response times to a crawl.

But what the hardware info panel tells me is that no matter how overloaded alpha 4 is, it's still using slightly less than 256Mb of RAM. Hardly supprising since alpha 4 pre-dates the introduction of the type B model RPi.

Given that alpha 4 can't play video and the hardware info panel does not even mention the existance of the GPU, I started to question the value of allocating 64Mb of RAM to the GPU. So I added a gpu_mem_512=16 command to my config.txt file.

That makes a difference. alpha 4 is (of course) still not using the top 256Mb of RAM, but it is now using 240Mb (rather than 192Mb) of the bottom 256Mb of RAM. For things like web surfing and reading newsgroups, there is a modest but noticable improvement in performance.
Back to top
View user's profile Send private message 

Joined: 28 Jan 2011
Posts: 75

PostPosted: Sun 28 Jul 2013, 13:07    Post subject:  

When I was setting up my alpha 4 system on the RPi one thing I noticed was that the unrar function did not work. The Puppy archive manager said it could not find the unrar program. I went to the Debian armel repository and installed it. That made no difference.

At the time there were quite a few things I was trying to sort out and investigating the unrar function was deferred. Once I started doing 'real work' on the RPi the lack of an unrar function became an irritation. Fixing it proved to be fairly simple.

The Debian armel package installs a program called 'unrar-nonfree' in /usr/bin. The Puppy archive manager is looking for a program called 'unrar'. I made a copy of the unrar-nonfree program under the name unrar. Now the Puppy archive manager is able to find it and the unrar function works. The graphical on-screen feedback to show that an unrar is in progress does not work but the 'task completed' message is shown as normal.

A few other odds and ends that come to mind:

The built in Ctorrent works, but can't seem to open the listening port. I switched to Transmission. That works well on the RPi and for the sake of installing libupnp3 you can get Transmission to open the listening port.

Xfe file manager works well on alpha 4. As does Pan newsreader. There is a command line version of the Par2 utility in the Debian armel repository which is simple but effective.

If you add in mhWaveEdit (which is standard in many Puppies but has been omitted from alpha 4) and then augment it with the Lame mp3 package (see the Debian armel backports repository) you'll be able to encode mp3's on your RPi. Though it's slow going.

The weakest part of running Puppy alpha 4 on RPi is web browsing. There is probably no clever soloution to this, the main processor is simply not fast enough. I gave up on Chromium fairly quickly. I now have Midori and Links2 installed and swap between the two depending upon which web sites I am trying to access. There is a build of Links2 in the Puppy quirky arm6 repository. Perhaps it's a shame it was not in the build.

To my amusement, I find I'm now making real use of the RPi. I bought it as a toy. Now I have two of them. One running openELEC and the other running Puppy alpha 4. I'm dumping bit-torrent and usenet work onto the Puppy alpha 4 system rather than have those functions eat up resources on my main laptop.

It's a real shame pnethood does not work on alpha 4.
Back to top
View user's profile Send private message 

Joined: 17 Nov 2012
Posts: 8
Location: Wisconsin

PostPosted: Thu 01 Aug 2013, 21:20    Post subject: Pnethood on alpha4  

I did get Pnethood working with the following pets, and tested it on a samba share from a Puppy computer.

I don't know if it will work with Windows 9x/XP/Vista/7/8. There are a lot of variations of the SMB/CIFS protocol and different authentication methods. I did not compile all of them into the smbclient program.

The new kernels only come with the cifs.ko kernel module so there is no smbmount command anymore. The smbclient program comes from samba-tng, it's a lot smaller than the version from samba.

01micko was experimenting with network_roxapp on the Raspberry Pi and warned about some kind of bug that could cause data loss.
I don't know any specifics about it, whether it was a samba problem or a kernel module. I am using the 3.2.27+ kernel, and the checksums on all of the test files I transfered checked out OK.....
Description  md5sum 5d685f08d11a87dff36b044e40b83f6d

Filename  nbtscan-1.5.1a-armv6.pet 
Filesize  13.94 KB 
Downloaded  792 Time(s) 
Description  md5sum e6ca9646889c6ea823dd9879b3d14c52

Filename  gxmessage-2.20.0-armv6.pet 
Filesize  11.07 KB 
Downloaded  804 Time(s) 
Description  md5sum b433bd2aa2a7f98d95d5d2a87435a28a

Filename  cifs-utils-6.1-armv6.pet 
Filesize  15.41 KB 
Downloaded  776 Time(s) 
Back to top
View user's profile Send private message 

Joined: 10 Oct 2012
Posts: 203
Location: Halifax, Canada

PostPosted: Mon 19 Aug 2013, 21:08    Post subject:  

Personally, I'm thinking of trying to get this up and running on my Pi, and see what's the case with it.

Perhaps I might be able to do something... Though I do wonder what this is built on-top of, if it is Woof + Raspbian? If so I'll try to figure out the version, or perhaps get the Woof scripts onto Raspbian, and build a Woof-based puplet off that, but I would need to figure out how stable it would be.
Back to top
View user's profile Send private message 
Sky Aisling

Joined: 27 Jun 2009
Posts: 1369
Location: Port Townsend, WA. USA

PostPosted: Thu 03 Oct 2013, 12:55    Post subject: Squeezed Arm Puppy for Raspberry Pi, alpha4
Subject description: The life of Pi: Intel to give away Arduino-friendly 'Galileo' tiny-puter

Hi Woofers,
I'm unsure if this is the appropriate place to post this information.
If someone knows a better place please advise me and I'll repost.

The life of Pi: Intel to give away Arduino-friendly 'Galileo' tiny-puter

Intel is now actively attempting to recruit the maker community to aid it in its battle against ARM.

Today at a major gathering of European hardware hackers in Rome, the chip giant announced it has cooked up a Raspberry Pi-style board computer with the blessing of Arduino.

Back to top
View user's profile Send private message 

Joined: 19 Jun 2010
Posts: 3493
Location: www.eussenheim.de/

PostPosted: Fri 04 Oct 2013, 05:42    Post subject:  

amj wrote:
...What doesn't work...

Let me add just one issue:
german keyboard layout in X: up, down,rigjht,left and level3 not working (@ ²³{}\|)

At console (ALT-F2) it is OK.
Back to top
View user's profile Send private message 

Joined: 11 Dec 2008
Posts: 1126

PostPosted: Sun 03 Nov 2013, 19:06    Post subject:  

Has anyone in the community picked up the mantel of continuing development of Puppy for the Raspberry Pi?
Back to top
View user's profile Send private message Visit poster's website 

Joined: 06 May 2009
Posts: 123

PostPosted: Thu 10 Apr 2014, 18:11    Post subject:  woof2 raspbian wheezy  

Whant to know if some have make an img with Woof2 of the Raspbian Wheezy packages?

I try... But something happens in Building part and not finnish the task ...?

Need some help!
Back to top
View user's profile Send private message 

Joined: 29 Jun 2008
Posts: 10548
Location: SwedenEurope

PostPosted: Sat 10 May 2014, 01:30    Post subject:  

Raspberry Pi Rev Model B Rev 2 Ram 512 MB
Would cost me only 349 SEK which is low price

andI want one but thesoftware for Puppy or Debian?????

I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 16 of 18 [262 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.3847s ][ Queries: 12 (0.0659s) ][ GZIP on ]