Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 22:32
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to print pictures with Gimp in Slacko? [Solved]
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [27 Posts]   Goto page: 1, 2 Next
Author Message
chekrout

Joined: 05 Dec 2011
Posts: 26

PostPosted: Fri 15 Jun 2012, 09:38    Post subject:  How to print pictures with Gimp in Slacko? [Solved]  

I need a little help with my gimp 2.6.6 . It is not sending content to my printer when I select 'print' although the printer does start up and prints a blank page. I searched pet dependencies and 3 missing Libs were listed ( libwmf-0.2.so.7 , libpoppler-glib.so.3 and libaa.so.1) Is installing one or all of these what it takes? They are called plugins on the missing dependency list. (yes, printer has ink and prints docs)
Last edited by chekrout on Sun 17 Jun 2012, 08:49; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9365
Location: Stratford, Ontario

PostPosted: Fri 15 Jun 2012, 09:44    Post subject:  

What Puppy are you using? Where did you get the Gimp package?

It may be less trouble to save your work as a JPG or PNG and print it with PeasyPrint.
Back to top
View user's profile Send private message 
chekrout

Joined: 05 Dec 2011
Posts: 26

PostPosted: Fri 15 Jun 2012, 10:14    Post subject:  

rcrsn51 wrote:
What Puppy are you using? Where did you get the Gimp package?

It may be less trouble to save your work as a JPG or PNG and print it with PeasyPrint.

I am using slacko5.3.1 , got gimp from my desktop 'slickpet' I don't have peasyprint or can't find it. It loolks like a handy thing to have for camera pics. I still would like to be able to print from Gimp though.

Last edited by chekrout on Fri 15 Jun 2012, 10:21; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9365
Location: Stratford, Ontario

PostPosted: Fri 15 Jun 2012, 10:16    Post subject:  

Follow the link in blue I posted above.
Back to top
View user's profile Send private message 
aen

Joined: 15 Apr 2010
Posts: 34

PostPosted: Fri 15 Jun 2012, 10:22    Post subject: GIMP Printing
Subject description: Need GIMP print help
 

I've been using GIMP for years and have not experienced this issue.

When you select "print" from the menu, do you get a pop up window which allows you to set up the parameters for printing? In this menu, you have under the General Settings, a place to select your printer, or to print to file. This may be your problem... it may be printing to a file by default.

Also, check the rest of the settings to further fine tune your printer, paper, etc.

Now, if you do not get the pop up window, I would delete your original GIMP and re-install it to see if that solves the problem.
Back to top
View user's profile Send private message 
chekrout

Joined: 05 Dec 2011
Posts: 26

PostPosted: Fri 15 Jun 2012, 10:31    Post subject:  

rcrsn51 wrote:
Follow the link in blue I posted above.


Ok I installed peasyprint 2.0 and will ry it out. Still need too get the Gimp printing...need it's heavy duty features Wink .
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9365
Location: Stratford, Ontario

PostPosted: Fri 15 Jun 2012, 10:50    Post subject:  

chekrout wrote:
Still need too get the Gimp printing...need it's heavy duty features

I checked myself in Slacko and it definitely doesn't work. Even Print Preview and Print to File make a blank page.
Back to top
View user's profile Send private message 
chekrout

Joined: 05 Dec 2011
Posts: 26

PostPosted: Sat 16 Jun 2012, 07:26    Post subject:  

rcrsn51 wrote:
chekrout wrote:
Still need too get the Gimp printing...need it's heavy duty features

I checked myself in Slacko and it definitely doesn't work. Even Print Preview and Print to File make a blank page.
I may just uninstall it and try another. don't want to fool with those three missing libs Rolling Eyes thanks for the help
Back to top
View user's profile Send private message 
chekrout

Joined: 05 Dec 2011
Posts: 26

PostPosted: Sat 16 Jun 2012, 07:27    Post subject: Re: GIMP Printing
Subject description: Need GIMP print help
 

aen wrote:
I've been using GIMP for years and have not experienced this issue.

When you select "print" from the menu, do you get a pop up window which allows you to set up the parameters for printing? In this menu, you have under the General Settings, a place to select your printer, or to print to file. This may be your problem... it may be printing to a file by default.

Also, check the rest of the settings to further fine tune your printer, paper, etc.

Now, if you do not get the pop up window, I would delete your original GIMP and re-install it to see if that solves the problem.
i get the window and all is in order. Sad
Back to top
View user's profile Send private message 
chekrout

Joined: 05 Dec 2011
Posts: 26

PostPosted: Sun 17 Jun 2012, 08:47    Post subject:  

Found the solution. I uninstalled Gimp 2.6.6 and installed ver. 2.7.2 now it works correctly and prints correctly Very Happy
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Thu 16 Aug 2012, 21:24    Post subject: Can't print from Gimp-2.7.1-w5 (and others)  

Nothing appears in the print preview and nothing is printed but the printer gives me a blank page.

I know - this is an "unstable" release, but it came with my package manager for RacyNop-5.2.2, and it does everyting I want except print. Including the new direct text input and single screen. Who knows when Gimp-8 will actually emerge or whether it will work for me when it does . . . Why am I using RacyNop - don't ask; I do have good reasons.

I've tried all the Gimp-7s I can find and they all need files that I can't find. Example:
Code:
# gimp
(gimp:2367): GLib-WARNING **: goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
** Message: Module '/usr/lib/gegl-0.1/ff-load.so' load error: [b]libavformat.so.52[/b]: cannot open shared object file: No such file or directory
This is a development version of GIMP.  Debug messages may appear here.

In this case it's libavformat.so.52 I can't find.

I also tried Gimp-2.7.2 as noted just above, both .pet and .sfs with comparable results but I don't remember the missing files.

Yes, there are lots of workarounds, like peasyprint, printoxx (fine programs), LO-Impress, etc. but i really am used to printing directly from Gimp. So humor me if you have suggestions. Thanks!
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9365
Location: Stratford, Ontario

PostPosted: Thu 16 Aug 2012, 21:28    Post subject:  

This may be a case of Gimp wanting CUPS 1.4 instead of your 1.3.11.
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Thu 16 Aug 2012, 21:45    Post subject:  

Thanks, rcrsn51,

Actually I've been using Cups-1.4.4 for a long time since it was at one point needed for LibreOffice.

An earlier Gimp-2.6 printed fine then with QuirkyNop-1.2, so it may be a Racy deficiency.
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9365
Location: Stratford, Ontario

PostPosted: Thu 16 Aug 2012, 22:00    Post subject:  

If you look in /usr/lib, you will see libavformat.so.53. So you need a symlink
Code:
ln -s libavformat.so.53 libavformat.so.52
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Thu 16 Aug 2012, 23:19    Post subject:  

The symlink took, but the terminal message and print symptoms look the same.

EDIT: No, there's a broken link at
Code:
/root/libavformat.so.52

Code:
# gimp

(gimp:11897): GLib-WARNING **: goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
** Message: Module '/usr/lib/gegl-0.1/ff-load.so' load error: libavformat.so.52: cannot open shared object file: No such file or directory
This is a development version of GIMP.  Debug messages may appear here.

#


I tried installing gegl-0.1.2-q1 and gegl-0.1.2-w5. No difference.
Code:
/usr/lib/gegl-0.1/ff-load.so
is present.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [27 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0795s ][ Queries: 12 (0.0045s) ][ GZIP on ]