Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Apr 2015, 13:58
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Wpa2 troubles
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 20 Mar 2011
Posts: 8

PostPosted: Tue 22 May 2012, 17:53    Post_subject:  Wpa2 troubles  

I'm trying to get an old computer living again for a friend. It's an old laptop with a P3, 800MHz processor and 256mb Ram. Puppy installs well and runs perfectly, with one exception. Wireless.

I've got two wireless usb devices. The first is an old MN-510, which is a usb device with a prism2 chipset. The second is a new rtl8188. The first one installs fine, but doesn't offer WPA2 support. The second one installs fine when I use the two .pets that exist for the rtl8192 (apparently the same chipset) and the right version of puppy for the .pet's, but it also doesn't do WPA2.

I've tried Wary 4.2, and the most recent lucid and wary releases with all the combinations of the above, and whenever I can get it to recognize the device, I get a message saying WPA is not supported. It lets me try anyway, and it's able to scan and ID the networks just fine. When I try to connect to a WPA2 network, though, the progress bar times out and never gets past 'scanning'.

Anybody have a solution? I apologize if there's any missing information, and please ask if there's something I missed.
Back to top
View user's profile Send_private_message 

Joined: 18 Jan 2012
Posts: 103
Location: Oregon

PostPosted: Tue 22 May 2012, 20:20    Post_subject: You didn't mention entering the long ID number...
Sub_title: I think some forget to enter modem/router 20+ diget code.

When I first got my modem from CenturyLink in January, I tried a wireless connection unsuccessfully with a 3-yr old HP laptop --- (NOT PUPPY FAULT) --- MY FAULT --- I think we forget there's a long alpha numeric number on the bottom of your router. You only need to enter it once, but I went one month without wireless -- because I just couldn't imagine entering THAT LONG NUMBER..... Embarrassing? Yes.
Back to top
View user's profile Send_private_message Visit_website 

Joined: 20 Mar 2011
Posts: 8

PostPosted: Wed 23 May 2012, 22:37    Post_subject:  

Dennis -- I appreciate the help, but I don't think that's the case here, although I could be wrong. I believe you're talking about the key, which ive reset to a password of mine.

In the network setup, it only has a field for SSID and one for the key, and I've got both. It seems to be a driver issue: I've had the exact same setup (with the prism 2 USB) working with damn small Linux, but as that distro is dead, I'm trying for puppy.

I've searched a lot, and not come up with anything. Anybody have an idea?
Back to top
View user's profile Send_private_message 

Joined: 03 Feb 2011
Posts: 247
Location: North America; the Western Hemisphere; Yonder

PostPosted: Wed 23 May 2012, 22:46    Post_subject: wpa2 troubles  

I've found that some...some...of my wireless problems come down to what my router is doing, not what is occuring with my distro. You can try changing the WPA2 setting in your router - some allow either aes+tkip encryption, others can be also broadcast solely in AES only. Sometimes, changing to AES only on your router can make a difference with newer kernels.

also, I've had luck with the following re: the endless "scanning". Most of the newer kernels come with power management set to on for wlan0. Most older dongles and cards simply can't function with power management setting on. Try booting into a Live CD, and then setup your wlan0 setting, and then when the wireless starts the endless scanning, open a terminal as root and type in "sudo iwconfig wlan0 power off". The "sudo" may or may not be necessary depending on what you are running. I've had success with this on several older cards, and most of the newer 'buntus, buntu variants, and puppies.

"Everywhere is within walking distance, if you have the time." - Steven Wright
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0466s ][ Queries: 11 (0.0038s) ][ GZIP on ]