Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 23 Aug 2019, 02:49
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Slacko 5.3.3 bug reports and feedback
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 11 of 11 [160 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11
Author Message

Joined: 28 Dec 2009
Posts: 858

PostPosted: Mon 15 Oct 2012, 09:07    Post subject:  

01micko and ICPUG,

You're welcome. Thanks for the kind words.

The new updates manager is a handy addition. Thanks 01micko.

ICPUG wrote:
You must have spent a lot of time researching and checking code.

Yes. Sometimes I start looking into what I think is a simple issue, and before I know it I've run into other issues, and hours or days have gone by. Smile
Back to top
View user's profile Send private message 

Joined: 29 Jun 2008
Posts: 10548
Location: SwedenEurope

PostPosted: Mon 15 Oct 2012, 13:15    Post subject:  

I'm testing Thin slacko just now.
I reused a Grandr pet I found on Smokey
and that one worked well.

Firefox has Namoroka 3.6.28 instead of FF 16.0.01
that my Lupu have now.

Does that make my browsing insecure maybe?
Any suggestion? Should I try to get FF instead
or what?

I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 

Joined: 28 Dec 2009
Posts: 858

PostPosted: Sat 20 Oct 2012, 09:27    Post subject:  

At http://www.murga-linux.com/puppy/viewtopic.php?p=647385#647385,
Baldronicus wrote:
The problem:
A right-click on a clear area of the desktop (under the default configuration) brings up the menu, as expected. After this is cleared (by a left-click), subsequent right-clicks on the desktop icons (including the drive icons) result in the desktop menu appearing, as if they were right-clicks on a clear area of the desktop (or as if the icons were not there, or simply not identified).
A subsequent left-click (or in some/many cases two spaced left-clicks) on one of the icons results in it working as expected. Following this, right-clicking on the icons also works as expected (as if the "problem trigger" had been reset).
Another right-click on a clear area of the desktop recreates the problem, and subsequent left-clicking on an icon clears it again.

ETP wrote:
Bug confirmed. (Also exists in It would seem that we have all been living with it!
Minor as you say, but very confusing for anyone new to Slacko.

Jasper wrote:
It is the same with Slacko 5.3.1 . . .

That is the ROX-Filer "ungrab bug" (a.k.a. "multiple root menus problem"). This has been patched. See Barry's blog entry: ROX-Filer multiple-jwm-menus fix

Note that the .pet offered in that blog entry is no longer the latest ROX-Filer .pet. For the latest, see Barry's blog entry: ROX-Filer squashed log-window

But those .pets may not be best for use with Slacko, since 01micko reports that "For some reason rox needs to be compiled in Slacko or else Fido refuses to work." (See his comment under Barry's blog entry: ROX-Filer focus problem fixed) So it is probably best to compile on Slacko from the patched source, which can be found in the file rox-filer-20111022-patched3.tar.gz at http://bkhome.org/sources/alphabetical/r/.

EDIT: Also note that installing a .pet would have side-effects. For instance, your PuppyPin file would be overwritten with the PuppyPin used for Wary and Racy. So, again, it's best to compile your own from the patched source, or wait for someone to make a Slacko version of the .pet. (Even then, if you have customized your PuppyPin, you would want to back it up before installing the new .pet.)
Back to top
View user's profile Send private message 

Joined: 28 Dec 2009
Posts: 858

PostPosted: Fri 26 Oct 2012, 10:03    Post subject: PPM in Slacko: Some repo check boxes don't work.  

The following lines in pkg_chooser.sh prevent the use of quirky and wary5 repositories in slacko, even though the database files for both are included in the distro, and so check boxes are available in the configuration dialog -- they just don't do anything:

# #100903 if wary5, want to list quirky repo, as has same code base...
# [ "$BASEREPO" = "Packages-puppy-quirky-official" ] && [ "$DISTRO_COMPAT_VERSION" != "wary5" ] && continue #100126 already handled above. 100903
# [ "$BASEREPO" = "Packages-puppy-wary5-official" ] && continue #100903 already handled above.
# [ "$BASEREPO" = "Packages-puppy-lucid-official" ] && continue #100911 already handled above.

To reproduce:

1. In Slacko 5.3.3, run PPM and choose Configure package manager (or, in the Ziggy UI, the button with the screwdriver and spanner).

2. Click either of the check boxes for puppy-quirky-official or puppy-wary5-official. (If you already had 5 boxes checked, you will need to uncheck one so as not to exceed the limit of 5.)

3. Click OK.

4. Exit from the PPM.

5. Run PPM again and note that the newly selected repo is not listed under Repositories.

Perhaps this is intentional to discourage users from installing stuff in Slacko from these older repositories. If that is the case, their database files should probably be removed to prevent them from showing up in the configuration dialog. (Although I am guessing this isn't intentional since the even older Puppy-2, -3, -4, and -5 repositories are available, and don't have this issue.)
Back to top
View user's profile Send private message 
Official Crustacean

Joined: 04 May 2005
Posts: 15460
Location: Paradox Realm

PostPosted: Fri 02 Nov 2012, 01:21    Post subject:  

Openshot with 3D rendering of animated titles from Blender

Raspberry Pi 4 to run Puppi
NEW Slackware Current ScPup 32 and 64bit
Back to top
View user's profile Send private message Visit poster's website 

Joined: 06 Nov 2012
Posts: 2

PostPosted: Tue 06 Nov 2012, 22:38    Post subject: Ziggy_patch-2.pet fixed Puppy Package Manager!!!  

Thank you!!! I am a newbie to linux and thought I had broken my puppy or it's tail beyond all repair. 01micko's post fixed that. I installed the ziggy_patch_ppm-2.pet and that fixed the broken Puppy Package Manager. Tail wagging! Smile Opps sorry-- I think I posted this in the wrong place.
Back to top
View user's profile Send private message 

Joined: 09 Nov 2012
Posts: 2

PostPosted: Sun 11 Nov 2012, 05:08    Post subject:  

Hi there !

My first post, so here goes the mandatory intro: hello to all around here doing a nice job of bringing the super-complicated linux system into puppy level Wink.

And now to the point. Perhaps not a bug as such (although I did stumble upon a few along my 3-day long puppy linux career) but can anyone tell me how to make the download manager in ff/seamonkey open downloaded files according to shell settings (or whatever) and open containing folders (that's in the right-click menu) ?

Using slacky 5.3.3 windows installer (from this forum) clean install, seamonkey as included and namaruka post-installed from a .pet.

EDIT: allright, have managed to get "open containing folder" working by selecting /usr/local/bin/rox on the Open With dialog (and setting as default); should be pre-configured within the puppy, methinks
Back to top
View user's profile Send private message 

Joined: 28 Dec 2009
Posts: 858

PostPosted: Thu 20 Dec 2012, 18:54    Post subject: panel-buttons script corrupts .jwmrc-tray  

The /usr/local/jwmconfig2/panel-buttons script supplied with Slacko 5.3.3 adds one extra comment and deletes one line in /root/.jwmrc-tray every time a button is added to the tray.

The comment added is always a copy of this existing comment:
      <!-- Additional TrayButton attribute: label -->

The line removed is the first non-blank line following the last button added.

If the original /root/.jwmrc-tray supplied with Slacko 5.3.3 is used as a starting point, adding buttons causes the following behavior:

The first time a button is added, the line deleted is just a comment, so the tray is created as expected. But when a second button is added, this line is deleted:

So the pager buttons (for switching desktops) disappear.

Adding a third button just deletes another comment, but adding a fourth button deletes this line:
                <TaskList maxwidth="25"/>

So the task list disappears.

Adding a fifth button deletes this line:

And the dock is gone.

Adding a sixth button just deletes another comment, but adding a seventh deletes only the first line of a comment, which confuses JWM, and everything else vanishes -- in this case, the swallowed program (xload) and the clock.

Adding an eighth and ninth button deletes the last two lines of that same comment, so JWM is no longer confused, and the swallowed program and the clock reappear.

OK, I think I need not continue adding buttons. You get the idea.

The reason that lines are being deleted is that the number of lines remaining in .jwmrc-tray after the last line with a TrayButton definition is sometimes calculated incorrectly. And that happens because the total number of lines in .jwmrc-tray is sometimes calculated wrongly. The total is found using wc -l which counts newline characters, not lines. If the last line in the file has no newline character, the value returned by wc -l will be one shy of the actual number of lines.

The original .jwmrc-tray file supplied with Slacko 5.3.3 has no newline character in the last line.

While supplying a .jwmrc-tray file that ends with a newline character would make this problem go away at least initially, it wouldn't be the most robust solution. A user might manually edit the file and leave off the final newline -- something that is not ruled-out by the JWM documentation, and something that JWM itself is perfectly happy with. It would be better if the panel-buttons script could tolerate a configuration file that didn't end with a newline character.

An earlier version of the panel-buttons script (in jwmconfig2-20111110.pet in the puppy-common-official repository) included an October 2011 solution from Karl Godt, which appended a newline character to the file if it didn't already end with one. That works.

An alternative solution would be to use sed -n $= to count the lines, instead of wc -l. Using sed -n $= counts lines, not newline characters.

So line 62:
total=`wc -l /root/.jwmrc-tray | sed -e 's/ *//' | sed -e 's/ .*//g'` ### get total number of lines

could be replaced by
total=`sed -n $= /root/.jwmrc-tray` ### get total number of lines

As for the extra comment that gets added every time a button is added, that doesn't cause any problems (other than making the file grow unnecessarily), so could be ignored. But it could be fixed by filtering the comment out of CURRENTBTNSCODE by replacing line 24:
CURRENTBTNCODE=$(grep "TrayButton" $HOME/.jwmrc-tray|grep -v "root:3")

CURRENTBTNCODE=$(grep '^[[:blank:]]*<TrayButton' $HOME/.jwmrc-tray|grep -v "root:3")

Line 25 is fine:
CURRENTBTNS=$(grep "TrayButton" $HOME/.jwmrc-tray|grep -v "root:3"|\

But it could be given the same treatment as line 24, by changing it to:
CURRENTBTNS=$(grep '^[[:blank:]]*<TrayButton' $HOME/.jwmrc-tray|grep -v "root:3"|\

That way, if the user happened to add a single-line comment containing the word "TrayButton", it would not become part of CURRENTBTNS, even if it didn't also contain the word "Additional". This would also eliminate the need for line 26.

By the way, although I ran into this problem in Slacko 5.3.3, it looks like the same panel-buttons script is in jwmconfig2-121105.pet, which I think is used by Slacko 5.4.
Description  suggested changes for script

Filename  panel-buttons.diff.gz 
Filesize  702 Bytes 
Downloaded  504 Time(s) 
Description  script revised with suggested changes

Filename  panel-buttons.gz 
Filesize  1.84 KB 
Downloaded  515 Time(s) 
Back to top
View user's profile Send private message 

Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Thu 20 Dec 2012, 21:26    Post subject:  

pupmd5sum has been upgraded to version 1.0

It can save the md5sum to a text file just like gtkhash


Back to top
View user's profile Send private message 

Joined: 11 Oct 2008
Posts: 8699
Location: qld

PostPosted: Wed 16 Jan 2013, 07:06    Post subject:  

This is the latest gtkdialog from Thunor.

It is the same as version 0.8.3 even though it is 0.8.4, it comes straight out of svn which carries the next version number.

This is required for the latest Pburn and the upcoming Pmusic form zigbert (although an ffmpeg update will be required too for that)


NOTE: the VTE package is mandatory! INSTALL IT FIRST!!! thanks to 8-bit for that tip Wink
Description  the main package INSTALL VTE first!!!!!

Filename  gtkdialog-0.8.4-release-slacko-5.3_legacy.pet 
Filesize  92.26 KB 
Downloaded  671 Time(s) 
Description  Documentation and examples

Filename  gtkdialog_DOC-0.8.4-release-slacko-5.3_legacy.pet 
Filesize  172.56 KB 
Downloaded  387 Time(s) 

Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 11 of 11 [160 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2635s ][ Queries: 12 (0.0163s) ][ GZIP on ]