Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Aug 2014, 16:22
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Upup Precise 5.3.3.3 with kernel 3.3.2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 14 of 25 [373 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, ..., 23, 24, 25 Next
Author Message
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Wed 25 Apr 2012, 20:53    Post subject:  

And speaking of a Fat-Precise Upup (you can be fat and still be precise, can't you?) Laughing, these are my substitutions:

Seamonkey, out; opera, in
abiword 2.8.6, out; abiword 2.9 (ttuuxx's pet), in
amaya from Portable Linux Apps, in. (Loads like a charm).
lxp-icewm, in.

For the record more than anything, of course. However, the following may be worthy of note for the writers out there:

ttuuxx's abiword 2.9 has all 48 plugins... which means that you can throw most any text format at abiword (including docx and pdf) and it'll take it. And this version is supposedly more responsive on the screen than previous versions because it now has a double buffer.

BFN.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
linux28

Joined: 05 Apr 2009
Posts: 179

PostPosted: Wed 25 Apr 2012, 23:24    Post subject:  

pemasu wrote:
I have created repository for extra pets:
pet_packages-upup

http://www.smokey01.com/pemasu/pet_packages-upup/

I havent tested many of them...I just want to test that compiling works.

Samba-3.6.4-upup I did test...it is full latest samba.


fbreader?
evince?
Smile
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Thu 26 Apr 2012, 00:40    Post subject:  

@linux28:

Yes good readers would be nice. And in the same line of thought, the real less, which is much more powerful than the busybox one, to read straight *.txt and *.sh files quickly and easily whithout fear of altering any code or content.

BFN.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
jakfish

Joined: 18 Jul 2008
Posts: 756

PostPosted: Thu 26 Apr 2012, 02:09    Post subject:  

Hi, pemasu,

An odd question: which one of your fine puppies (that uses a 3.* kernel) has the lowest CPU temperature for general use?

General use would be: a word processor always running, email_light browsing, wifi/bluetooth turned off when internet not needed.

My Lenovo S10-3t works with all pemasu CPU Frequency_Scaling setups, but S10-3t can't manually control the fan. So even with Power Saving frequency, I have a hard time (with any puppy) keeping an idle temperature below 54 (idle = no wifi/bluetooth, word processing only).

Maybe all puppies burn at that temperature, but if you can suggest one cooler cpu pemasu puppy over another, that would be wonderful.

Many thanks,
Jake
Back to top
View user's profile Send private message 
LateAdopter

Joined: 27 May 2011
Posts: 148
Location: Reading UK

PostPosted: Thu 26 Apr 2012, 06:33    Post subject: Radeon Video Xorg driver  

Hello pemasu

I have just tried upup 5332

Athlon II X2, 785g chipset (RS880G)

On the first boot, the setup screen said it was using the Radeon driver.

Looking at the video info after setup it was actually using VESA.

I used xorgconfig to setup the radeon driver. Then X would not start.

So I changed back to VESA which works.

The RS880G is well supported by Xorg and I have not had a problem with any other puppy.

If the xf86 drivers came from the ubuntu precise repo, would the kernel mismatch break them?

I understand that the ATI proprietary driver does not work with the 3.2.8/3.3+ 32bit kernel without a patch. Even maybe Catalyst 12.4 that was released today. (Kano posting on Phoronix)
Back to top
View user's profile Send private message 
mrokosz

Joined: 28 Jan 2012
Posts: 25

PostPosted: Thu 26 Apr 2012, 07:19    Post subject: Youtube problems  

Hi all,
If anybody is using slow outdated computer like P3 500 MHz with 256 MB RAM (max out) then will have problems with You tube video playback using Mozilla products or Chromium. There is a cure for it, installing Google Chrome browser (not Chromium) cause Chrome has flash player built in will work and You can view video on the You Tube. It apply to all so called lightweight OS-es, that usually people install on the outdated hardware to just to make a use of it. I am not sure if the limitation is processor speed or amount of RAM, but usually outdated hardware has a limitation of the RAM You can install. So I suggest if somebody is using old hardware switch to google chrome, but any hardware starting from netbooks will work fine.
mrokosz
Back to top
View user's profile Send private message 
mrokosz

Joined: 28 Jan 2012
Posts: 25

PostPosted: Thu 26 Apr 2012, 07:27    Post subject: software request  

Hi Pemasu,
I have request for You, thanks for creating repository by the way, could You compile, for Upup Precise of course, a few software packages that are very popular among linux users and add to Yours repo.
1. libreoffice sfs
2. skype pet
3. bleachbit
4. phyton

I installed lucid / lupu version they seems working OK, but compiled for Upup Precise will make me happy.

Michael Rokosz - mrokosz
Back to top
View user's profile Send private message 
mrokosz

Joined: 28 Jan 2012
Posts: 25

PostPosted: Thu 26 Apr 2012, 08:11    Post subject: autoconnect and default apps  

I can not set autoconnect to WPA protected network, each time I have to pick up profile I created, second I loading libreoffice.sfs at boot, but I can not assign libreoffice apps as the default. Is there any fix for it.
mrokosz
Back to top
View user's profile Send private message 
vtpup


Joined: 15 Oct 2008
Posts: 1077
Location: Republic of Vermont

PostPosted: Thu 26 Apr 2012, 09:18    Post subject: Re: autoconnect and default apps  

mrokosz wrote:
I loading libreoffice.sfs at boot, but I can not assign libreoffice apps as the default. Is there any fix for it.
mrokosz

These are general questions, already often answered in the Puppty user sections.
Icons:
Go to where any standard desktop icon you want to change points, eg. write points to /usr/local/bin/defaultwordprocessor which is also a link. Change that link to what you want, eg change defaultwordprocesssor's target action from:
Code:
#!/bin/sh
exec abiword "$@"

to
Code:
#!/bin/sh
exec swriter "$@"


To change from abiword to libre office (or open office) swriter.

For mimetypes (files) not already covered by defaut applications, eg. .xyz files:

1.)right click on a .xyz file
2.)choose set run action,
3.)drag the application you want to run it with into the window, or type its name into the text box below

_________________
New Acer Aspire 5349-2635 dual proc, 4gb ram, re-partitioned with frugal Racy 5.3, dual boot, running rings around Win 7.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1396
Location: Malvern, Worcs, UK

PostPosted: Thu 26 Apr 2012, 11:02    Post subject: New wlan% version of Broadcom-STA wl wifi driver for Precise  

Hi pemasu

[EDIT] 040612 pet attachment deleted - new All-In-One pet now available [/EDIT]

Here is a new version of the Broadcom-STA WL wifi driver for Precise Puppy.

It is the same as the previous version with just 2 changes:

1. now creates wlan% unstead of eth%

2. it is now specific to k3.3.2-upup and puts files directly into the correct place in the file structure

The previous edit to /etc/rc.d/MODULESCONFIG is still required and is of course in the pinstall.sh of the pet:

Code:
grep -q ' ssb:wl ' etc/rc.d/MODULESCONFIG \
 || sed -i -e "s/^PREFLIST='[^']*/&ssb:wl /" etc/rc.d/MODULESCONFIG


Rerwin would have liked to update the driver detection mechanisms but I've reviewed and tested what he suggested and my view is that this is a further change down the line as there are too many residual lupu bits in what he has suggested.

I've tested the pet by both installing it onto precise 5.3.3.1 and as an update to 5.3.3.2

On both, it plays fine with both Frisbee and netwiz, but on both I have failed to get sns to work at all as sns gives dhcpcd errors with both the b43 and wl drivers when I try to setup a WPA connection.

The errors are:
Quote:
STEP1c: ifconfig wlan0 down
STEP2: iwconfig wlan0 mode managed
STEP3: iwconfig wlan0 channel 1
Error for wireless request "Set Frequency" (8B04) :
SET failed on device wlan0 ; Network is down.
STEP4: iwconfig wlan0 essid "SamTheCat2Plus"
STEP5a: ifconfig wlan0 up
STEP5b: wpa_supplicant -B -Dwext -iwlan0 -c"/etc/simple_network_setup/wpa_supplicant.conf-SamTheCat2Plus-00:21:00:C6:68:AA"
STEP6a: dhcpcd wlan0
dhcpcd[15029]: sending commands to master dhcpcd process

*********************************************************
LAST 10 LINES of /var/log/messages:
Apr 26 12:32:14 puppypc32649 daemon.info dhcpcd[15201]: sending commands to master dhcpcd process
Apr 27 03:32:16 puppypc32649 daemon.info dhcpcd[11526]: wlan0: broadcasting for a lease
Apr 27 03:32:16 puppypc32649 daemon.debug dhcpcd[11526]: wlan0: sending DISCOVER (xid 0xa7672f36), next in 4.68 seconds
Apr 27 03:32:16 puppypc32649 daemon.err dhcpcd[11526]: wlan0: send_raw_packet: Network is down
Apr 27 03:32:16 puppypc32649 daemon.debug dhcpcd[11526]: wlan0: executing `/lib/dhcpcd/dhcpcd-run-hooks', reason FAIL
Apr 27 03:32:20 puppypc32649 daemon.info dhcpcd[11526]: wlan0: carrier lost
Apr 27 03:32:20 puppypc32649 daemon.debug dhcpcd[11526]: wlan0: executing `/lib/dhcpcd/dhcpcd-run-hooks', reason NOCARRIER
Apr 27 03:32:24 puppypc32649 daemon.info dhcpcd[11526]: control command: dhcpcd --release wlan0
Apr 27 03:32:24 puppypc32649 daemon.info dhcpcd[11526]: wlan0: removing interface
Apr 27 03:32:24 puppypc32649 daemon.debug dhcpcd[11526]: wlan0: executing `/lib/dhcpcd/dhcpcd-run-hooks', reason STOP


My Broadcom device is supported by both wl and b43 and works correctly with both - what I haven't been able to test of course is what happens with a Broadcom chip that the wl driver doesn't support.

I have tested blacklisting the wl driver when a fallback to b43 happens correctly and in 5.3.3.1 uninstalling the pet when again a fallback to b43 happens correctly.

Cheers
peebee
sns-fail.png
 Description   
 Filesize   30.34 KB
 Viewed   730 Time(s)

sns-fail.png


_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Mon 04 Jun 2012, 07:21; edited 4 times in total
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1513
Location: Maine, USA

PostPosted: Thu 26 Apr 2012, 11:18    Post subject: Broadcom driver brcmsmac not in 5.3.3.2  

pemasu,
I understand that the new open-source Broadcom driver consists of at least 2 modules, brcmfmac and brcmsmac, plus at least one dependency (bcma). I see in 5.3.3.2 that only brcmfmac is present. Did you intentionally leave out brcmsmac?

As I recall, someone in the forum has a device that requires that module. Not sure whether it can use the proprietary wl module.

My interest is to ensure that I provide any preferences or workarounds for mediating conflicts among the various Broadcom wifi drivers (e.g., b43 & wl). There may not be any new issues to handle for the brcm*mac modules, But I cannot verify that until brcmsmac gets added. Thanks for any help with that.
Richard
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 26 Apr 2012, 11:59    Post subject:  

rerwin. If I remember right...there hasnt been before this bcma ie broadcom amba dependency for brcmsmac module. Now there is.

When I did enable bcma in some of kernel experiments....the ssb dependent b43 modules were non working.

I concluded that you cant have both ssb and bcma at the same time.

So....I didnt drop brcmsmac out intentionally....it wasnt selectable because I didnt have bcma enabled...as I have noticed earlier the problem with bcma enabling.

In previous 2.6.39.4 and all 3.1.x and 3.2.x kernels the bcma dependency has not been there....if i remember right.

this from kernel 3.2.14 kernel config:
CONFIG_BRCMUTIL=m
CONFIG_BRCMSMAC=m
CONFIG_BRCMFMAC=m
CONFIG_BCMA_POSSIBLE=y
#
# Broadcom specific AMBA
#
# CONFIG_BCMA is not set

and this from kernel 3.3.2 kernel config:
CONFIG_BRCMUTIL=m
CONFIG_BRCMFMAC=m
CONFIG_BCMA_POSSIBLE=y
#
# Broadcom specific AMBA
#
# CONFIG_BCMA is not set

As you can see the bcma not selected dropped the choice of brcmsmac out.

This has changed with this 3.3.2 kernel.

Now...I fear that if I select bcma....ssb dependent b43 modules wont work...as I have noticed with my dpup kernels before....

I think there are broadcom chips which works only with brcmsmac module...so it would be desired...I just would need new experimental kernel to test...but I am not sure if I have time build that puplet...see below.

I can compile the kernel easily and update it for others to test and build the puplet though.

Last edited by pemasu on Thu 26 Apr 2012, 12:33; edited 1 time in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 26 Apr 2012, 12:26    Post subject:  

This is notice of my next 6 months.

Firstly I have had discussions with 2 of my supervisors. Yeah...I have 2 independent bosses..one would have been enough...well..in fact in paper I have 3 bosses...but luckily the third one does not want to lead from from the distance...My station resides in countryside.

I will have 5-6 projects where I am assigned to lead them. And...I will have one university - county general practice harmonization project. All these starts in May. They include also designing work of specialization of certain professionals. I just got home from the learning session from the university town near by...19.00...and these long days will continue...

Next...to disturb my timetable more...I will go to the major surgery in june...due to rotator cuff rupture or my right shoulder. It will be operated and my right upper extremity will be immobilized with angle pillow 4 weeks and then I start to slowly get permission to add movements during 6 weeks.
Also I will have my normal day work duties before and after operation. This period lasts at least 6 months.

My boss wasnt pleased of my operation and he told me I should be back to work after 6 weeks period. The operator told me I will need vacation 10 weeks...so lets see....

My eldest daughter will graduate 2.6.2012 and I have to start to do arrangements for her celebration.

I have had hard thinking when Barry Kauler asked about the futute of Precise Pangolin based Puppy and when people showed that there would be interest of having it and also...that I could be a candidate of coordinating it.

I have continued to work...test...improve...and experiment with it. But this week conversations with my supervisors and all those other things above mentioned....means....I just dont have time for my Puppy Linux development. I would like to continue...but I just cant.....I wont have even time to woof build and sync woofs with Barrys commits. My time will go to studying....coordinating...reading....writing....and creating reports...and I will also be at least 4 weeks crippled so that I am afraid I cant use computer for writing...except with one hand....also the pain after operation can be severe. I know that some people has gotten pain bump home...

This is long statement...I have given this long mental processing until I now realized that I cant do all I want...I have to concentrate to those things I have to do....and give up for awhile...what I would like to do. This has been hard for me...to give up.

I wil start to update the pet_packages-upup repo so that my build is able to be created with woof...and anyone who wants to build and update the build can do that. I will upload the needed woof specs also. And I will upload the updated build so that pet_packages-repo is available from the puplet.

I wont be out Puppy community...I just cant be as active....starting from the beginning of May....continuing over the summer to autumn...couple of months maybe...not sure...because my supervisors werent that spesific...I have seen just preliminary plans.

Pemasu out.....

Last edited by pemasu on Thu 26 Apr 2012, 12:30; edited 2 times in total
Back to top
View user's profile Send private message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Thu 26 Apr 2012, 12:28    Post subject:  

pemasu wrote:
rerwin. If I remember right...there hasnt been before this bcma ie broadcom amba dependency for brcmsmac module. Now there is.

When I did enable bcma in some of kernel experiments....the ssb dependent b43 modules were non working.

I concluded that you cant have both ssb and bcma at the same time.

So....I didnt drop brcmsmac out intentionally....it wasnt selectable because I didnt have bcma enabled...as I have noticed earlier the problem with bcma enabling.

In previous 2.6.39.4 and all 3.1.x and 3.2.x kernels the bcma dependency has not been there....if i remember right.

t.


pemasu in those previous kernels my wifi would show on wlan0. in precise it comes up on eth1. my system has not changed so think it is something on your end.

glipper has returned to the task tray after some reboots. and opening up same programs running when precise freeze yesterday can not get it to freeze today.

i do not take that as a sign of improvement since no changes made here. while do not see any other reports of precise freezing up and my system has no history of such behavior hence an isolated incident of a probable unstable precise system.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1396
Location: Malvern, Worcs, UK

PostPosted: Thu 26 Apr 2012, 12:38    Post subject:  

jim3630 wrote:

pemasu in those previous kernels my wifi would show on wlan0. in precise it comes up on eth1. my system has not changed so think it is something on your end.


Hi jim3630

This is probably an indication that you are using the proprietary Broadcom wl driver which pemasu built-in to precise 5.3.3.2

You can confirm this by running lsmod in a terminal - if wl is there but not b43 then you are using the wl driver which creates eth1.

I've just posted a modified pet that changes the eth% device to wlan% to be consistent (we don't know why Broadcom chose to be different but it is quite an easy patch to change).

Cheers
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 14 of 25 [373 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, ..., 23, 24, 25 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1143s ][ Queries: 12 (0.0074s) ][ GZIP on ]