Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 04 Sep 2015, 01:45
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
FEEDBACK REQUIRED IF PUPPY2 USB TOTALLY NOT WORKING
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7456
Location: Perth, Western Australia

PostPosted: Sat 29 Apr 2006, 05:13    Post subject:  FEEDBACK REQUIRED IF PUPPY2 USB TOTALLY NOT WORKING  

Some guys have reported no usb stuff is working.
Can you kindly go through the following checklist:

1.
Code:
# lspci -i /usr/share/pci-usb-pcmcia.ids | grep -i "usb"

...see if any lines have text "usb" in them --should have!

2.
Code:
# lsmod | grep --extended-regexp "usb|hcd"

...should have usbcore, uhci-hcd|ohci-hcd, usb-storage loaded.

3.
Code:
# cat /proc/bus/usb/devices | grep -i --extended-regexp "mouse|keyboard"

...any usb mouse or keyboard should show up here.

4.
Code:
# probepart

...should see usb partitions, /dev/sd??.

If step 1 fails, likely the following will also. Ditto for step 2.
Back to top
View user's profile Send private message Visit poster's website 
Leon

Joined: 22 Jun 2005
Posts: 242
Location: Slovenia

PostPosted: Sat 29 Apr 2006, 07:14    Post subject:  

1.
Code:
# lspci -i /usr/share/pci-usb-pcmcia.ids | grep -i "usb"
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 05)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 05)

2.
Code:
# lsmod | grep --extended-regexp "usb|hcd"
usb_storage            84736  0
uhci_hcd               32384  0
usbcore               129124  3 usb_storage,uhci_hcd

3.
Code:
# cat /proc/bus/usb/devices | grep --extended-regexp "mouse|keyboard"

4.
Code:
# probepart
/dev/hdd|iso9660|0|TEAC CD-W552E
/dev/hdc|iso9660|0|_NEC DVD_RW ND-2500A
/dev/hda1|vfat|160826652|Win95 FAT32 (LBA)

Hardware:
http://www.puppyos.com/nfphpbb/viewtopic.php?t=59

My report:
http://www.puppyos.com/nfphpbb/viewtopic.php?t=107

Barry,
I know it's only keyboard version but I like it!
Thanks for your efforts!

Last edited by Leon on Sat 29 Apr 2006, 08:47; edited 1 time in total
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15154
Location: Paradox Realm

PostPosted: Sat 29 Apr 2006, 08:32    Post subject:  

1. (Working motherboard/USB controller on Puppy Singer)
Code:
sh-3.00# lspci -i /usr/share/pci-usb-pcmcia.ids | grep -i "usb"
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller               (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller               (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller               (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)


2. No PCI (PCMCIA) plugged in
Code:
sh-3.00# smod | grep --extended-regexp "usb|hcd"
sh: smod: command not found


3. No USB Keyboard plugged in - I have ps2 - no usb mouse (do not have one to test either)
Code:
sh-3.00# cat /proc/bus/usb/devices | grep -i --extended-regexp "mouse|keyboard"



4. (This is a 64meg Disgo SDA USB Keydrive - very reliable
- not being reported when plugged in or rebooted - also Pupmount and MUT do not recognise -
works in 108 Singer and 109 alpha 2)
Code:
sh-3.00# probepart
ext3
ext3
/dev/hdc|iso9660|0|LITE-ON DVDRW SHW-16H5S
/dev/hdb1|ext3|311082597|Linux Ext3FS
/dev/hdb2|none|1494045|Extended (contains other slice)
/dev/hdb5|swap|1493982|Linux Swap
/dev/hda1|ext3|76854897|Linux Ext3FS
/dev/hda2|none|1301265|Extended (contains other slice)
/dev/hda5|swap|1301202|Linux Swap


4. (2) (I took out the SDA - USB keydrive and plugged in a USB "Smart Media" camera memory reader
- notice the third response line)
Code:
sh-3.00# probepart
ext3
ext3
libcfdisk: unable to open /dev/sda
/dev/hdc|iso9660|0|LITE-ON DVDRW SHW-16H5S
/dev/hdb1|ext3|311082597|Linux Ext3FS
/dev/hdb2|none|1494045|Extended (contains other slice)
/dev/hdb5|swap|1493982|Linux Swap
/dev/hda1|ext3|76854897|Linux Ext3FS
/dev/hda2|none|1301265|Extended (contains other slice)
/dev/hda5|swap|1301202|Linux Swap



Hope that helps Smile

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
rarsa


Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Sat 29 Apr 2006, 09:44    Post subject:  

I did two tests. I booted with one USB and one PS2 mouse plugged in and run the test. Then I rebooted just with the USB plugged in and pfix=ram so the previous settings wouldn't be used.

The main difference is that with just the USB mouse plugged in, test 2 returned nothing!

Here are my results.
1.
Code:
sh-3.00# lspci -i /usr/share/pci-usb-pcmcia.ids | grep -i "usb"
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
01:01.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
01:01.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
01:01.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 63)

2. With PS2 and USB plugged in
Code:
sh-3.00# lsmod | grep --extended-regexp "usb|hcd"
usb_storage            84736  0
ehci_hcd               30360  0
uhci_hcd               32384  0
usbcore               129124  4 usb_storage,ehci_hcd,uhci_hcd

2. With only USB plugged in[code]sh-3.00# lsmod | grep --extended-regexp "usb|hcd"
3.[code]sh-3.00# cat /proc/bus/usb/devices | grep -i --extended-regexp "mouse|keyboard"[/code]
4.[code]sh-3.00# probepart
ext3
ext3
/dev/hdd|iso9660|0|HL-DT-ST DVDRAM GSA-4163B
/dev/hdc|iso9660|0|ATAPI CDRW 52X32
/dev/hdb1|vfat|6297921|Win95 FAT32 (LBA)
/dev/hda1|none|102398247|OS/2 HPFS or NTFS
/dev/hda2|none|199687950|Extended (contains other slice)
/dev/hda5|swap|2104452|Linux Swap
/dev/hda6|vfat|83907432|Win95 FAT32
/dev/hda7|ext3|19551042|Linux Ext3FS
/dev/hda8|ext2|1975932|Linux Ext2Fs
/dev/hda9|ext3|20482812|Linux Ext3FS[/code]

_________________
http://rarsa.blogspot.com Covering my eclectic thoughts
http://www.kwlug.org/blog/48 Covering my Linux How-to
Back to top
View user's profile Send private message Visit poster's website 
Kal

Joined: 05 May 2005
Posts: 624
Location: California, High Desert

PostPosted: Sat 29 Apr 2006, 16:24    Post subject:  

Running off live cd with usb and PS/2 mouse plugged in.

# lspci -i /usr/share/pci-usb-pcmcia.ids | grep -i "usb"
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
# lsmod | grep --extended-regexp "usb|hcd"
usb_storage 84736 0
ehci_hcd 30360 0
uhci_hcd 32384 0
usbcore 129124 4 usb_storage,ehci_hcd,uhci_hcd
# cat /proc/bus/usb/devices | grep -i --extended-regexp "mouse|keyboard"
# probepart
/dev/hdc|iso9660|0|SONY CD-RW CRX230ED
/dev/hdb|iso9660|0|IDE/ATAPI CD-ROM 52XS
/dev/hda1|vfat|79762662|Win95 FAT16 (LBA)
/dev/hda2|reiserfs|42170625|Linux ReiserFS
/dev/hda3|ext2|30218265|Linux Ext2Fs
/dev/hda4|ext2|4144770|Linux Ext2Fs

Side note, VIA onboard sound. now is working with new kernel.
Kal
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7456
Location: Perth, Western Australia

PostPosted: Sat 29 Apr 2006, 20:40    Post subject:  

Quote:
2. No PCI (PCMCIA) plugged in
Code:
sh-3.00# smod | grep --extended-regexp "usb|hcd"
sh: smod: command not found


Lobster,
That should be "lsmod"
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15154
Location: Paradox Realm

PostPosted: Sat 29 Apr 2006, 22:07    Post subject:  

Embarassed I do not have any device plugged in that matches this
Do you still want me to run the test?

_________________
Puppy WIKI

Last edited by Lobster on Sun 30 Apr 2006, 04:59; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7456
Location: Perth, Western Australia

PostPosted: Sun 30 Apr 2006, 02:43    Post subject:  

I think the bug is now fixed. see news for april 30:
http://www.puppyos.com/news.htm
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sun 30 Apr 2006, 07:41    Post subject:  

great Exclamation

I added these lines to /etc/rc.local (System with USB 1):

Code:
rmmod usb-storage
  rmmod ehci-hcd
  rmmod uhci-hcd
 
  modprobe uhci-hcd
  modprobe ehci-hcd
  modprobe usbhid


The "uhci" -entries are just needed for computers with USB1.
The "ehci" -entries are just needed for computers with USB2.

Now mouse and external USB-hardrive work Razz Very Happy

Mark

Last edited by MU on Sun 30 Apr 2006, 19:42; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7456
Location: Perth, Western Australia

PostPosted: Sun 30 Apr 2006, 08:09    Post subject:  

Mark, try "modprobe usbhid" instead of usbmouse
-- the latter is a more limited HID Boot protocol, the usbhid is supposed to be
more powerful.
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sun 30 Apr 2006, 08:56    Post subject:  

yes, works too Smile
I changed my last message.
This is soooo great finally!
Mark
Back to top
View user's profile Send private message Visit poster's website 
rarsa


Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Sun 30 Apr 2006, 11:01    Post subject:  

It also works now on this computer!! Very Happy

One computer ready two to go Smile (the one with th XOrg freezig and the one stopping at boot).

getting closer, eh?

Thank you,

_________________
http://rarsa.blogspot.com Covering my eclectic thoughts
http://www.kwlug.org/blog/48 Covering my Linux How-to
Back to top
View user's profile Send private message Visit poster's website 
pakt


Joined: 04 Jun 2005
Posts: 1094
Location: Sweden

PostPosted: Sun 30 Apr 2006, 11:48    Post subject:  

I seem to have one of the few computers that has USB working "out-of-the-box". I have an external USB keyboard and USB mouse connected to USB2 ports (via a 2-port hub) - both worked rightaway. As a control, I tried adding
Code:
rmmod usb-storage
rmmod uhci-hcd

modprobe uhci-hcd
modprobe usbhid

to /etc/rc.local and then re-booting to see if anything would break. Good news - still works Very Happy

Paul

_________________
Puppy unofficial tester (off and on) since v0.9.2
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1313s ][ Queries: 12 (0.0274s) ][ GZIP on ]