Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Sep 2014, 00:05
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
Bluetooth on Puppy 4.3.1 with trust 17772
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
JackED42

Joined: 29 Jul 2010
Posts: 38

PostPosted: Wed 04 Apr 2012, 04:15    Post subject:  Bluetooth on Puppy 4.3.1 with trust 17772  

Hello. I am trying to set up bluetooth with a Trust 17772 on my puppy 4.3.1, and cannot get it to scan. hcitool dev shows up blank. On dmesg, it shows

Code:
New full speed USB device using uhci_hcd and address 5


It doesnt come up with anything else, so could it be a driver issue? I have tried looking through this to no avail but the second to last post by fractal looks interesting. I have never dealt with git before, would some one be able to compile it to a pet or just the files so I could copy them in: -

(http://translate.google.co.uk/translate?hl=en&sl=it&u=http://forum.ubuntu-it.org/index.php%3Ftopic%3D505079.msg3953575&ei=YQN8T6mFNoie8gPT4a2QDQ&sa=X&oi=translate&ct=result&resnum=1&ved=0CCQQ7gEwAA&prev=/search%3Fq%3Dhttp://forum.ubuntu-it.org/index.php%253Ftopic%253D505079%26hl%3Den%26client%3Dfirefox-a%26hs%3DTCh%26rls%3Dorg.mozilla:en-US:official%26biw%3D1280%26bih%3D856%26prmd%3Dimvnsfd)

Any help would really be appreciated!!!

Cheers

Jack

PS. I have installed ALL of the pets from http://www.murga-linux.com/puppy/viewtopic.php?t=52973&start=30
Back to top
View user's profile Send private message 
JackED42

Joined: 29 Jul 2010
Posts: 38

PostPosted: Thu 05 Apr 2012, 04:15    Post subject: AR3011  

Hello, for some extra information, the drivers I need are the AR3011 (ATH3k).

I do not currently have a big enough install to run the compiling tools to make the ath3k drivers. However, I have found the file needed

Code:
http://packages.debian.org/lenny-backports/all/firmware-atheros/download


I have installed the file, but now I have a ath3k-1.fw file in /lib/firmware. Can someone advise how to actually use this file?

Would it be possible for someone to compile this for 4.3.1 on my behalf if this is what needed? Or if there is another way to install the athk-1.fw file?
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1007
Location: South of Belgium

PostPosted: Mon 09 Apr 2012, 06:05    Post subject:  

Hi,
maybe this could help ..? (see my post towards bottom of page ...)
http://www.murga-linux.com/puppy/viewtopic.php?t=71755&start=1035
Cheers, Charlie
Back to top
View user's profile Send private message 
JackED42

Joined: 29 Jul 2010
Posts: 38

PostPosted: Tue 10 Apr 2012, 05:06    Post subject:  

Thanks for the reply. But it is the drivers of the actual Trust 17772 that is not working. I have got one stage further now after I compiled some drivers, and now I get the following error: -
Code:

ath3k_probe: Error loading firmware
ath3k:probe:2-2:1.0 Failed with error -5


This must have something to do with the /lib/firmware/ath3k-1.fw file I assume...
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0536s ][ Queries: 11 (0.0106s) ][ GZIP on ]