(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Sep 2020, 14:32
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
gtk-youtube-viewer (for lots of pups)
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 32 of 33 [482 Posts]   Goto page: Previous 1, 2, 3, ..., 30, 31, 32, 33 Next
Author Message
sindi

Joined: 16 Aug 2009
Posts: 1088
Location: Ann Arbor MI USA

PostPosted: Wed 22 Apr 2020, 17:30    Post subject: gtk-youtube-viewer very slow to start playing a video  

Something was wromg with the PET package. I started over and the ASUS now plays videos. The SFS also works.

I notice that gtk-youtube-viewer takes much longer to start playing than the non-GUI youtube-viewer. On another 2006 laptop it takes over 2 min to start playing. While loading gtk-youtube-viewer there are numerous complaints about lines 340 and 3502 and plugins.

The lASUS U5F aptop cannot be made to work with Precise Light kernel 44 (noPAE -freezes) or 41 (PAE - does not recognize wifi or eth0 and several keys do not work properly in the vt) or k31456 (noPAE - freezes). If I shut the laptop off (power key) after k41, when I turn it on again the arrow keys do not work to choose between OSes with grub4dos - I can only choose the first or last one listed. The problem fixed itself overnight with laptop off.

Tahr works properly, as does Wary 5.5. Tahr plays youtube.
Back to top
View user's profile Send private message 
vtpup


Joined: 15 Oct 2008
Posts: 1422
Location: Republic of Vermont

PostPosted: Mon 27 Apr 2020, 23:17    Post subject:  

Everything has been working fine Fred for me on Tahrpup 6.0.5.

I just tried it on my C720 converted Chromebook running Bionicpup64, with 32 bit compatibility sfs, and using the cde version of gtk-youtube-viewer. I get video, but no audio. If I run the same video on the same setup in Seamonkey browser, I do get sound, so I think the sound system is working...

MPV is the player.

_________________
Acer Aspire 5349-2635 laptop Tahrpup.
C720 Chromebk Bionicpup64
My homemade foam boat
www.youtube.com/watch?v=4sDubB0-REg
Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4481
Location: holland

PostPosted: Tue 28 Apr 2020, 02:47    Post subject:  

vtpup wrote:
Everything has been working fine Fred for me on Tahrpup 6.0.5.

I just tried it on my C720 converted Chromebook running Bionicpup64, with 32 bit compatibility sfs, and using the cde version of gtk-youtube-viewer. I get video, but no audio. If I run the same video on the same setup in Seamonkey browser, I do get sound, so I think the sound system is working...

MPV is the player.


Hi vtpup, apparently the cde package is not the way to go on 64 bit.
What works is installing first the older version (3.5.3) .pet for bionic64, that I shared Here
https://dl.dropboxusercontent.com/s/h2u0hgayb5fin5q/youtube-viewer-3.5.3-bionic_amd64.pet?dl=1
(it has the perl dependencies inside)
Then install this "upgradable" pet (v3.7.4):
https://dl.dropboxusercontent.com/s/jh5rslf2ljznmxe/youtube-viewer-3.7.4-2_noarch.pet?dl=1

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
vtpup


Joined: 15 Oct 2008
Posts: 1422
Location: Republic of Vermont

PostPosted: Tue 28 Apr 2020, 08:22    Post subject:  

Hi Fred, thanks! I did try that combination earlier, but it resulted in:
Code:

root# gtk-youtube-viewer
Can't locate File/Spec/Functions.pm in @INC (you may need to install the File::Spec::Functions module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.26.1 /usr/local/share/perl/5.26.1 /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/bin/gtk-youtube-viewer line 45.
BEGIN failed--compilation aborted at /usr/bin/gtk-youtube-viewer line 45.


the cde version did run, and play videos, but without sound.

_________________
Acer Aspire 5349-2635 laptop Tahrpup.
C720 Chromebk Bionicpup64
My homemade foam boat
www.youtube.com/watch?v=4sDubB0-REg
Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4481
Location: holland

PostPosted: Tue 28 Apr 2020, 13:43    Post subject:  

Hi vtpup, that's strange, it works for me and the Functions.pm module is included in Bionicpup64:

/usr/lib/perl/5.26.1/File/Spec/Functions.pm

I have Bionicpup64 version 7.9.5
Maybe check if you have that file, and could it be that the 32bit compatibility sfs influences things ? (just guessing)

Edit: I have no idea how to solve the sound problem with the cde-package.

EDIT2: You may also want to check if /usr/lib/x86_64-linux-gnu is correctly linked (should be a symlink to ./ (which is /usr/lib)

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
vtpup


Joined: 15 Oct 2008
Posts: 1422
Location: Republic of Vermont

PostPosted: Tue 28 Apr 2020, 14:27    Post subject:  

Hi Fred,

I checked and there is no usr/lib/perl/5.2.6.1/File/ directory at all.

I checked both the Bionicpup64 8.0 installs on my Chromebook, and on my regular laptop (Acer5349) which normally runs Tahrpup32. The Bionicpup64 8.0 on that one is a fresh install.

Nope, neither has a 5.2.6.1/File/ directory at all

The Chromebook does have both gtk-youtube-viewer 3.5.3 Bionic amd64 pet and 3.7.4-2 noarch.

Is the "File Spec" stuff in devx, maybe? If you'd installed that, it might be an explanation. I don't think the 32 bit compatibility sfs would actually remove anything....

_________________
Acer Aspire 5349-2635 laptop Tahrpup.
C720 Chromebk Bionicpup64
My homemade foam boat
www.youtube.com/watch?v=4sDubB0-REg
Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4481
Location: holland

PostPosted: Tue 28 Apr 2020, 15:57    Post subject:  

vtpup wrote:
I checked and there is no usr/lib/perl/5.2.6.1/File/ directory at all.


Yes, I have Bionicpup64 8.0 now and it is the same as you, so that explains it (I had older Bionicpup previously with perl installed by default)

Installing perl_5.26.1 from PPM makes gtk-youtube-viewer work, just install it (although it's labeled "Already installed", it's probably not completely installed)

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
vtpup


Joined: 15 Oct 2008
Posts: 1422
Location: Republic of Vermont

PostPosted: Tue 28 Apr 2020, 19:27    Post subject:  

Thanks once again Fred! That works perfectly now. Smile Smile
_________________
Acer Aspire 5349-2635 laptop Tahrpup.
C720 Chromebk Bionicpup64
My homemade foam boat
www.youtube.com/watch?v=4sDubB0-REg
Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4481
Location: holland

PostPosted: Fri 29 May 2020, 09:36    Post subject:  

Version 3.7.4 stopped working for playing many video's, here's an "upgradable" pet package that should fix it, v3.7.6:
https://dl.dropboxusercontent.com/s/fo066rbd058oruv/youtube-viewer-3.7.6-2_noarch.pet?dl=1

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3822
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 29 May 2020, 13:33    Post subject:  

Thank you!
But what has to be updated/changed in the standalone version?
Youtube crap! Evil or Very Mad

_________________

Puppy Search
Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4481
Location: holland

PostPosted: Fri 29 May 2020, 14:55    Post subject:  

Argolance wrote:
Thank you!
But what has to be updated/changed in the standalone version?
Youtube crap! Evil or Very Mad


Hi Argolance, Yes, very annoying, those changes everytime.
If you extract the pet then basically the contents of usr/bin should go in cde-root/usr/bin and the contents of usr/share/perl5 (WWW and auto) should go in cde-root/usr/share/perl5 by replacing all.
But not sure what exactly you need to do with the .glade files, but you probably know.
New script in usr/bin is gtk2-youtube-viewer, gtk-youtube-viewer script should execute that one, but in case that doesn't work in the cde environment, you could try renaming gtk2-youtube-viewer to gtk-youtube-viewer

Cheers,

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3822
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 30 May 2020, 11:49    Post subject:  

Thank you fredx181,
Works! Will make new SFS and PET packages soon of the standalone version plublished above...

Cordialement.

_________________

Puppy Search
Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4481
Location: holland

PostPosted: Sat 30 May 2020, 14:52    Post subject:  

Just now I got an error with v3.7.6, 403 Forbidden, hopefully a temporary thing.

EDIT; Next day, now it's working again, I wish I knew the reason why.

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3822
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 31 May 2020, 14:40    Post subject:  

Bonsoir,
Quote:
Will make new SFS and PET packages soon of the standalone version published above...

Arrow DONE!

Cordialement.

_________________

Puppy Search
Back to top
View user's profile Send private message Visit poster's website 
memo

Joined: 28 Jun 2018
Posts: 269

PostPosted: Mon 29 Jun 2020, 05:05    Post subject:  

hi all,

is the gtk-youtube-viewer latest version for xenialpup 32 bit available?

regards,

_________________
Xanialpup 7.5 32 bit
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 32 of 33 [482 Posts]   Goto page: Previous 1, 2, 3, ..., 30, 31, 32, 33 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1285s ][ Queries: 12 (0.0803s) ][ GZIP on ]