Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Jul 2019, 21:49
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
gtk-youtube-viewer (for lots of pups)
Post new topic   Reply to topic View previous topic :: View next topic
Page 26 of 28 [411 Posts]   Goto page: Previous 1, 2, 3, ..., 24, 25, 26, 27, 28 Next
Author Message
fredx181


Joined: 11 Dec 2013
Posts: 3987
Location: holland

PostPosted: Thu 01 Nov 2018, 10:34    Post subject:  

Argolance wrote:
Everything is perfect now, except I don't have the sound anymore!


Yeah.., very perfect Rolling Eyes Weird... sound works for me.
Did you try again ? Maybe sound was disabled at the mpv screen (was set to -/1 see pic)

Anyway, I wasn't satisfied already with the included mpv (if I remember well it uses OSS sound rather than ALSA), so here's another "package" with included the mpv from precise .pet here:
http://www.murga-linux.com/puppy/viewtopic.php?p=859332#859332
Size is more than 10MB bigger (extracted), because of that.

EDIT: Oh, on systems that have gl support (e.g. libgl1-mesa-dri package installed) that mpv doesn't work OOTB, workaround can be changing video output in the Preferences to:
(by adding "--vo xv" to the args)
Code:
                                           mpv => {
                                             arg   => "--really-quiet --vo xv --title *TITLE* --no-ytdl",

https://dl.dropboxusercontent.com/s/3wsds3n7phvswqm/yt-viewer-3.5.1_youtube-dl-2018-11-01.tar.gz?dl=1
(named it yt-viewer-3.5.1..... now)

Didn't think this would become a sort of development thread. Much more issues than I expected !

EDIT:
Quote:
Something else: just for test and not essential: I tried unsuccessfully to make links in /cde-root/usr/bin to /usr/bin/vlc, mplayer etc. already installed on my Puppy and even replacing the /cde-root/usr/bin/mpv with a link to /usr/bin/mpv but all complain about their missing libs...
Too bad!
Isn't there some way around that?


I think the only way is to add the required libs in the cde-root (e.g. in cde-root/usr/lib)
It's a closed environment, so cannot "look" outside AFAIK.

Fred
2018-11-01-152349_183x119_scrot.png
 Description   
 Filesize   14.55 KB
 Viewed   597 Time(s)

2018-11-01-152349_183x119_scrot.png


_________________
Dog Linux website
Tinylinux blog by wiak

Last edited by fredx181 on Thu 01 Nov 2018, 12:05; edited 2 times in total
Back to top
View user's profile Send private message 
icosahedron


Joined: 28 Nov 2011
Posts: 93
Location: UK

PostPosted: Thu 01 Nov 2018, 10:49    Post subject:  

Yay! My vids play now. Very Happy

Dunno what you did with the symlinks, whatever they are, but it fixed it. The latest version works a treat - and I've got sound.

No doubt my Firefox, and my Puppy, will sink further and further into obsolescence, for more and more sites, as time goes on, but for now everything's great.

Thanks for the help, guys, and if my struggles have helped in some small way with your development of the viewer, that's great too. Smile

Cheers.

_________________
Computers: - I just ride 'em, I dunno what makes 'em work.
Console/Terminal? What's that?
I visit the Internet to OBTAIN information, not to PROVIDE it!
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3987
Location: holland

PostPosted: Thu 01 Nov 2018, 11:21    Post subject:  

icosahedron wrote:
Yay! My vids play now. Very Happy

Dunno what you did with the symlinks, whatever they are, but it fixed it. The latest version works a treat - and I've got sound.

No doubt my Firefox, and my Puppy, will sink further and further into obsolescence, for more and more sites, as time goes on, but for now everything's great.

Thanks for the help, guys, and if my struggles have helped in some small way with your development of the viewer, that's great too. Smile

Cheers.


Great !!
Yes, sure you helped, feedback always does, thanks !

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3616
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Thu 01 Nov 2018, 16:46    Post subject:  

Bonjour,
Now sound works!
fredx181 wrote:
Maybe sound was disabled at the mpv screen (was set to -/1 see pic)

The sound was marked as off (-/1) but nothing to do to enable it. Embarassed
Quote:
Didn't think this would become a sort of development thread. Much more issues than I expected !

In reality, it's always the same song with programs and computers but I think you're at the end of your rope now! Very Happy

Thank you for all.
Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 3616
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 02 Nov 2018, 07:53    Post subject:  

Bonjour,
As I wanted gtk youtube viewer to be fully integrated to my Puppy, I did a little script (rough coding, which could probably be improved/shortened but working well!) that I would like to share with those who would be interested. Rolling Eyes

Steps to be followed:
    - Replace /cde-root/usr/share/fonts with a link to the standard Puppy /usr/share/fonts (copy first the "oxygen.ttf" font if you want to keep/use it)
    - Replace /cde-root/usr/share/themes with a link to the standard Puppy /usr/share/themes
    - Replace the original gtk-youtube-viewer.cde with "my" gtk-youtube-viewer.cde (note that the auto update of youtube-dl may be disabled/commented)
    - Copy gtkthemeinteg in the same directory.

Now, when you start gtkyoutube viewer it is automatically displayed using you current gtk theme!
I added 2 desktop files (youtube-dl-update.desktop and youtube-viewer.desktop) to be copied to /usr/share/applications/ and 2 icons to be copied to /usr/share/pixmaps/. Desktop files has to be modified to take the current gtk youtube directory into account. Here it is /usr/local/gtk-youtube-viewer/ I chose for my own use.
Refresh the menu for entries to be displayed.

Cordialement.
ytgtktheme-integ.tar.gz
Description 
gz

 Download 
Filename  ytgtktheme-integ.tar.gz 
Filesize  12.94 KB 
Downloaded  113 Time(s) 
gtkyoutubeviewer.jpg
 Description   
 Filesize   106.54 KB
 Viewed   535 Time(s)

gtkyoutubeviewer.jpg


_________________

Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 3616
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 02 Nov 2018, 11:20    Post subject:  

Something new I didn't get previously (when I run gtkyoutube viewer in console). This seems not to prevent videos to be played properly:
Code:
2018.10.29
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory

_________________

Back to top
View user's profile Send private message Visit poster's website 
dancytron

Joined: 18 Jul 2012
Posts: 1320

PostPosted: Fri 02 Nov 2018, 13:33    Post subject:  

Argolance wrote:
Something new I didn't get previously (when I run gtkyoutube viewer in console). This seems not to prevent videos to be played properly:
Code:
2018.10.29
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory


I think those errors are because mesa-dri isn't set up for your graphics card. You are in Puppy, right?

Open the console and run "glxgears". If it works, then never mind, I don't know what I am talking about.

If it doesn't work and if you don't want to ignore it, then you'll need to figure out what driver you need for your graphics card and install it.

If you don't have glxgears installed, install the package "mesa-utils" (in Debian at least).

If you are using Debian Dog or similar, install mesa-utils and libgl1-mesa-dri and try again.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3987
Location: holland

PostPosted: Fri 02 Nov 2018, 17:31    Post subject:  

Argolance wrote:
Something new I didn't get previously (when I run gtkyoutube viewer in console). This seems not to prevent videos to be played properly:
Code:
2018.10.29
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory


Looks like you use the one from here, see EDIT (adding "--vo xv" to the args in Preferences works for me as workaround ):
http://murga-linux.com/puppy/viewtopic.php?p=1008731#1008731

The one from here doesn't have that problem (different mpv included):
http://murga-linux.com/puppy/viewtopic.php?p=1008723#1008723
You have still no sound with that one ?
(I probably misunderstood, thought you had solved it)

EDIT;
Quote:
This seems not to prevent videos to be played properly

For me the videos won't play when I get these libGL errors.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3616
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 02 Nov 2018, 17:56    Post subject:  

fredx181 wrote:
You have still no sound with that one ?
(I probably misunderstood, thought you had solved it)

No you did not: your latest version solved the sound issue and seems running properly except this message apparently with no incidence that is displayed when gtkyoutube is executed in a terminal.
Sorry if it was not clear, this is what I was meaning:
Argolance wrote:
This seems not to prevent videos to be played properly

_________________

Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 3616
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 03 Nov 2018, 19:48    Post subject:  

Bonsoir,
@dancytron
Sorry, I missed your message. Thank you.
dancytron wrote:
Open the console and run "glxgears". If it works, then never mind, I don't know what I am talking about.

Works fine!
Quote:
If it doesn't work and if you don't want to ignore it, then you'll need to figure out what driver you need for your graphics card and install it.

...
fredx181 wrote:
It's a closed environment, so cannot "look" outside AFAIK.

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 3987
Location: holland

PostPosted: Sun 04 Nov 2018, 04:18    Post subject:  

Smithy wrote:
Forever Still Vids Playing ok for me, BUT all stopped working a few days ago.
Had to do the curl code in the artful pet, the one that puts the new youtube dl py file in usr/local/bin. The other code youtube-dl says bash command not found or something.
I've made a clickable .sh update file for it, but would be cool if it was in the main script Fred. Not a biggie, just glad to be able to watch an occasional youtube vid, since every bugger seems tied to it now. Are google custodians of everyone's life now.


Hi Smithy, I tried the pet on Artful again, when e.g. playing videos from Categories, all plays fine.
I expected some errors (missing HTML...) but noticed that these required perl modulles are already included in Artful, so no need to update the .pet.
(earlier I thought something possibly could be fixed).
But tell me if you notice errors or videos that won/t play

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Smithy


Joined: 12 Dec 2011
Posts: 1033

PostPosted: Sun 04 Nov 2018, 08:31    Post subject:  

Ok Fred, seems to be working fine thanks.

I've made a little updater pet if it decides to stop functioning again.
It appears as a Desktop Menu entry in Multimedia.
I can't get the terminal to come up to show progress but internet activity shows and it does update the usr/local/bin file.

Whether this would be a lot of hassle to incorporate into the Main GTK YouTube Viewer Menu I don't know.
gtk-youtube-viewer-update.pet
Description 
pet

 Download 
Filename  gtk-youtube-viewer-update.pet 
Filesize  13.43 KB 
Downloaded  119 Time(s) 
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3987
Location: holland

PostPosted: Mon 05 Nov 2018, 13:58    Post subject:  

Thanks Smithy, good improvement, I'll upgrade the pet packages later with your updater script included.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3987
Location: holland

PostPosted: Mon 05 Nov 2018, 16:46    Post subject:  

*** Gtk-youtube-viewer pet packages upgrade (v3.5.3) ***

Some fixes by adding missing (HTML) perl modules and added launcher for to upgrade youtube-dl , thanks Smithy !
Run the youtube-dl updater from Menu > Multimedia > GTK-YouTube-Updater
Note: This will install youtube-dl and (if available) update to newest version
@Smithy , slightly changed your script to make it show progress and info from terminal.

Bionic 32 and 64 bit:
https://dl.dropboxusercontent.com/s/nhdfz36y7ob8yfd/youtube-viewer-3.5.3-bionic_i386.pet?dl=1
https://dl.dropboxusercontent.com/s/h2u0hgayb5fin5q/youtube-viewer-3.5.3-bionic_amd64.pet?dl=1
More info here:
http://murga-linux.com/puppy/viewtopic.php?p=1007755#1007755

Artful and Xenial 32-bit:
https://dl.dropboxusercontent.com/s/cl5lri8jhpl10pz/youtube-viewer-3.5.3-artful_i386.pet?dl=1
https://dl.dropboxusercontent.com/s/jcgo7pcbbk9qfwu/youtube-viewer-3.5.3-xenial_i386.pet?dl=1
More info here:
http://murga-linux.com/puppy/viewtopic.php?p=1007944#1007944

Tahr 32-bit:
https://dl.dropboxusercontent.com/s/ghno8mz1zgeqdzu/youtube-viewer-3.5.3-tahr_i386.pet?dl=1
More info here:
http://murga-linux.com/puppy/viewtopic.php?p=1007818#1007818

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Smithy


Joined: 12 Dec 2011
Posts: 1033

PostPosted: Wed 07 Nov 2018, 04:48    Post subject:  

Not tried the latest artful pet yet Fred but will try it out soon.

Just a bit about the mechanics of the app.

I tried downloading a couple of tutorial vids.
Each time it downloads, it progresses to 100% and finishes the download successfully, but then it starts to do it again, so it seems to download twice?
And when I close the app, there is some residual activity going on for a minute or so, just wondering what that is? Maybe some google ghosts..

And if you have a list of all the icons used and where they go that would be cool.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 26 of 28 [411 Posts]   Goto page: Previous 1, 2, 3, ..., 24, 25, 26, 27, 28 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0794s ][ Queries: 12 (0.0183s) ][ GZIP on ]