Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 13 Nov 2018, 03:01
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
gtk-youtube-viewer (for lots of pups)
Post new topic   Reply to topic View previous topic :: View next topic
Page 23 of 27 [399 Posts]   Goto page: Previous 1, 2, 3, ..., 21, 22, 23, 24, 25, 26, 27 Next
Author Message
fredx181


Joined: 11 Dec 2013
Posts: 3524
Location: holland

PostPosted: Wed 17 Oct 2018, 17:04    Post subject:  

Smithy wrote:
Thanks fred and greengeek, I gave your fred version a go earlier, and whilst it searches and finds videos, when I right click to play, it does some internet activity and then something flashes like a quick terminal attempt and then nothing.


I always double-click on one of the results and it plays in mpv (yes indeed mpv is included in the package) did you try that ?
It could be that you need to update youtube-dl first (gtk-youtube-viewer combined with mpv depends on it):
From terminal in directory "yt-viewer-3.1.5_youtube-dl" :
Code:
./youtube-dl.cde -U

@greengeek, does video play in gtk-youtube-viewer work for you ?

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
Smithy


Joined: 12 Dec 2011
Posts: 948

PostPosted: Thu 18 Oct 2018, 01:40    Post subject:  

Oh, that's done it, yes it updated and now it is running, with audio too.
Thanks very much!
Do you know the location where it puts the update?
And just wondering where I can tart it up a bit. The icons seem to be missing for a few buttons. Ah usr/share/icons seems a bit sparse with just a yad.png.
Screenshot.png
 Description   
 Filesize   121.77 KB
 Viewed   456 Time(s)

Screenshot.png

Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5275
Location: Republic of Novo Zelande

PostPosted: Thu 18 Oct 2018, 02:40    Post subject:  

fredx181 wrote:
@greengeek, does video play in gtk-youtube-viewer work for you ?
Funny you should ask - I have not tried the gtk interface for a very long time (I had problems with it and stopped using it...).
However - I just tried it again now and yes, it works perfectly. No reason for me to avoid it now Smile (Using it straight from my pet - no additional update).
EDIT : - seems that the first search works fine, but subsequent searches don't. I have to close the gui and start all over again. Don't have the same problem with the terminal version.
EDIT 2 : Ok - it seems that the second search DOES work but does not clear the first search results out of the way. The second search results just appear below the first search results, in the "next page" section.

thanks for all the help!

Smithy wrote:
What you up to greengeek, a rudolph hess attempt? spark ignition.
I'm looking at methods to ignite a petrol/air mixture in a turbine that has no interruptions to the flame front (unlike an Otto cycle engine). Not sure what Hess did, but, no - I don't think I'm following in his footsteps.

cheers!
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3524
Location: holland

PostPosted: Thu 18 Oct 2018, 07:08    Post subject:  

Smithy wrote:
Oh, that's done it, yes it updated and now it is running, with audio too.
Thanks very much!
Do you know the location where it puts the update?
And just wondering where I can tart it up a bit. The icons seem to be missing for a few buttons. Ah usr/share/icons seems a bit sparse with just a yad.png.

Ok, nice !
The youtube-dl script replaces itself after updating (in cde-root/usr/local/bin)
See attached for the missing icons, just extract in cde-root/usr/share/icons (or cde-root/usr/share/pixmaps) and they should show in gtk-youtube-viewer.
BTW,I re-uploaded the cde-package with the missing icons included, see EDIT here:
http://murga-linux.com/puppy/viewtopic.php?p=991640#991640

greengeek wrote:
fredx181 wrote:
@greengeek, does video play in gtk-youtube-viewer work for you ?
Funny you should ask - I have not tried the gtk interface for a very long time (I had problems with it and stopped using it...).
However - I just tried it again now and yes, it works perfectly. No reason for me to avoid it now Smile (Using it straight from my pet - no additional update).


Ah great, I was wondering already why you mentioned only youtube-viewer command line options in your how-to.

Fred
gtk-youtube-viewer_missing-icons.tar.gz
Description  Extract in cde-root/usr/share/icons
gz

 Download 
Filename  gtk-youtube-viewer_missing-icons.tar.gz 
Filesize  5.81 KB 
Downloaded  25 Time(s) 

_________________
Dog Linux website
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5275
Location: Republic of Novo Zelande

PostPosted: Thu 18 Oct 2018, 13:52    Post subject:  

New version of my pet available - now includes the missing icons from Fredx above, and also adds an updater script & icon alongside the play and download scripts.

PLEASE REMEMBER : Backup your savefile before testing my pet.

https://www.mediafire.com/file/7elt2th7a1z5j8a/youtube-viewer315_gg-0.75.pet
(HowTo posted on previous page)
icons.jpg
 Description   
 Filesize   6.04 KB
 Viewed   393 Time(s)

icons.jpg


Last edited by greengeek on Fri 19 Oct 2018, 01:43; edited 1 time in total
Back to top
View user's profile Send private message 
Smithy


Joined: 12 Dec 2011
Posts: 948

PostPosted: Thu 18 Oct 2018, 19:19    Post subject:  

Nice touch on the updater greengeek, I just threw in a different gtk than the Raleigh just to see on Fred's.
It seemed to take on a quick Polished Blue gtk transplant.

Still on fred's with the icons, but will give yours a whirl at weekend.

Just wondering if all the libs are specific to the app.
I suppose the youtube viewer would have to be compiled to the specific puppy in order for it to use the libs already in the puppy. (I think I have quite a bit already in the puppy but will have a look).

Not too bad at 60 mb considering it is a good quick app though!
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3524
Location: holland

PostPosted: Fri 19 Oct 2018, 14:42    Post subject:  

*** Gtk-youtube-viewer pets for UPup Bionic Beaver and BionicPup64 ***
(not a cde-package)
Version is 3.5 (currently latest)
==============================================================
EDIT 2018-10-21 Download links replaced with fixed version:
Added HTTP::Headers perl modules, this should fix the problem not remembering authentication when logged in
EDIT: and fixed naming issue, removed "-bionic" from name), see also here:
http://murga-linux.com/puppy/viewtopic.php?p=1007929#1007929
==============================================================
EDIT: download here newest version 3.5.3:
http://murga-linux.com/puppy/viewtopic.php?p=1009159#1009159

32-bit (UPup Bionic Beaver):
https://dl.dropboxusercontent.com/s/syydmxkj6q05yv6/youtube-viewer-3.5.2_i386.pet?dl=1
64-bit (BionicPup64)
https://dl.dropboxusercontent.com/s/nek2g1ay4wuawoc/youtube-viewer-3.5.2_amd64.pet?dl=1

For UPup Bionic Beaver I'd recommend to install also youtube-dl but not from PPM (somehow doesn't work)
Download newest version directly from github:
Code:
curl -L https://yt-dl.org/downloads/latest/youtube-dl -o /usr/local/bin/youtube-dl
chmod a+rx /usr/local/bin/youtube-dl

If youtube-dl is not installed then not all videos will play from (gtk-)youtube-viewer.

BionicPup64 has youtube-dl already installed by default.

Run Gtk-youtube-viewer from Menu > Multimedia

Also command-line application "youtube-viewer" is included in the pet packages.
Just example, run from terminal:
Code:
youtube-viewer --res=480p  # resolution 480p

Or for download:
Code:
youtube-viewer --res=480p -d   # resolution 480p and download only video


Fred

_________________
Dog Linux website

Last edited by fredx181 on Mon 05 Nov 2018, 16:54; edited 4 times in total
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 531
Location: Bretagne / France

PostPosted: Fri 19 Oct 2018, 15:13    Post subject:  

gtk-youtube-viewer not work for me, log :

Code:

 [Fri Oct 19 21:09:26 2018]: [501 Protocol scheme 'https' is not supported (LWP::Protocol::https not installed)] Error occured on URL:


Search in PPM

Code:
libcrypt-ssleay-perl


Install

now :

Code:

=>> Previous warnings:
[Fri Oct 19 21:18:32 2018]: [500 Can't connect to www.googleapis.com:443 (Crypt-SSLeay can't verify hostnames)] Error occured on URL: https://www.googleapis.com/youtube/v3/search?key=AIza ...............

_________________
Linux Tahrpup 6.0.6 / 3.14.79
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3524
Location: holland

PostPosted: Fri 19 Oct 2018, 15:27    Post subject:  

fabrice_035 wrote:
gtk-youtube-viewer not work for me, log :
.......


On which Puppy ?

_________________
Dog Linux website
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 531
Location: Bretagne / France

PostPosted: Fri 19 Oct 2018, 16:15    Post subject:  

fredx181 wrote:

On which Puppy ?

Tarhpup 6.0.6

the continuation of the adventure :

Code:

perl -MCPAN -e 'upgrade'


... after a very long time ...

> Reboot computer

gtk work better, can find vidéo but when i try play video :


Code:


root# /usr/bin/perl /usr/bin/gtk-youtube-viewer
Can't load '/usr/share/perl5/auto/JSON/XS/XS.so' for module JSON::XS: /usr/share/perl5/auto/JSON/XS/XS.so: undefined symbol: Perl_xs_boot_epilog at /usr/local/lib/perl/5.18.2/XSLoader.pm line 96.
 at /usr/share/perl5/JSON/XS.pm line 1747.

mplayer: could not connect to socket
mplayer: No such file or directory


_________________
Linux Tahrpup 6.0.6 / 3.14.79
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3524
Location: holland

PostPosted: Fri 19 Oct 2018, 16:25    Post subject:  

Hi fabrice_035,

I assume you tried the pet from my previous post.
It's not made for Tahr, only for Bionic.
(perl version is different)

EDIT: I will try to make a package for Tahr also in the next days.

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3524
Location: holland

PostPosted: Sat 20 Oct 2018, 07:23    Post subject:  

*** Gtk-youtube-viewer v3.5 for TahrPup 32-bit ***
(tested on TahrPup 6.0.6 and X-Tahr)
====================================================
EDIT 2018-10-21 Download link replaced with fixed version:
Added HTTP::Headers perl modules, this should fix the problem not remembering authentication when logged in
====================================================

EDIT: Download here newest version 3.5.3 :
http://murga-linux.com/puppy/viewtopic.php?p=1009159#1009159

youtube-viewer-3.5.1-tahr_i386.pet:
https://dl.dropboxusercontent.com/s/ieakle2v9gbe63s/youtube-viewer-3.5.2-tahr_i386.pet?dl=1

Gtk-youtube-viewer works best with mpv and youtube-dl.
(many video's won't play without youtube-dl installed)

Install mpv-20150814-git-i686-precise.pet (works on Tahr)
https://dl.dropboxusercontent.com/s/63i12yd36ho7rro/mpv-20150814-git-i686-precise.pet?dl=1
Got it from here, thanks jist !
http://www.murga-linux.com/puppy/viewtopic.php?p=859332#859332

Install youtube-dl:
Code:
curl -L https://yt-dl.org/downloads/latest/youtube-dl -o /usr/local/bin/youtube-dl
chmod a+rx /usr/local/bin/youtube-dl


EDIT:
There may be a problem with rxvt (needed for e.g. "Download video")
Change in Preferences to xterm and add -hold :
Code:
  terminal                            => "/usr/bin/xterm",
  terminal_exec                       => "-hold -e '%s'",


Fred

_________________
Dog Linux website

Last edited by fredx181 on Wed 07 Nov 2018, 14:01; edited 4 times in total
Back to top
View user's profile Send private message 
roadkill13

Joined: 10 Aug 2011
Posts: 148
Location: United States

PostPosted: Sat 20 Oct 2018, 15:05    Post subject:  

I installed this on UpupBB 18.0.5 +14 yesterday. It worked wonderfully at that time.

I started the app today and it would not work. I started the program in lxterm. Initially there were no messages in the terminal window. After attempting to search subscriptions (I am logged in) this message displayed in the terminal window:

Quote:
Can't locate HTTP/Headers/Util.pm in @INC (you may need to install the HTTP::Headers::Util module) (@INC contains: /etc/perl /usr/local/lib/i386-linux-gnu/perl/5.26.1 /usr/local/share/perl/5.26.1 /usr/lib/i386-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/i386-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /usr/lib/i386-linux-gnu/perl-base) at /usr/share/perl5/LWP/UserAgent.pm line 375.


No videos were displayed in the viewer interface. I am not able to search for videos by channel or by user either.
Screenshot.png
 Description   
 Filesize   30.37 KB
 Viewed   227 Time(s)

Screenshot.png

Back to top
View user's profile Send private message Yahoo Messenger 
Smithy


Joined: 12 Dec 2011
Posts: 948

PostPosted: Sun 21 Oct 2018, 03:22    Post subject:  

Hi Fred, if you get the chance to make a non-cde pet for Artful that would be great. That MPV for precise works in Artful.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3524
Location: holland

PostPosted: Sun 21 Oct 2018, 08:33    Post subject:  

roadkill13 wrote:
I installed this on UpupBB 18.0.5 +14 yesterday. It worked wonderfully at that time.

I started the app today and it would not work. I started the program in lxterm. Initially there were no messages in the terminal window. After attempting to search subscriptions (I am logged in) this message displayed in the terminal window:

Quote:
Can't locate HTTP/Headers/Util.pm in @INC (you may need to install the HTTP::Headers::Util module) (@INC contains: /etc/perl /usr/local/lib/i386-linux-gnu/perl/5.26.1 /usr/local/share/perl/5.26.1 /usr/lib/i386-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/i386-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /usr/lib/i386-linux-gnu/perl-base) at /usr/share/perl5/LWP/UserAgent.pm line 375.


No videos were displayed in the viewer interface. I am not able to search for videos by channel or by user either.


Yes, not sure, but apparently because of the missing "HTTP::Headers" modules the login authentication isn't remembered, I added these, so should be fixed now, new download links here:
Bionic:
http://murga-linux.com/puppy/viewtopic.php?p=1007755#1007755
Tahr:
http://murga-linux.com/puppy/viewtopic.php?p=1007818#1007818
And thanks for reporting !

@Smithy,
Quote:
Hi Fred, if you get the chance to make a non-cde pet for Artful that would be great. That MPV for precise works in Artful.

I think I can do that, probably tonight or tomorrow.

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 23 of 27 [399 Posts]   Goto page: Previous 1, 2, 3, ..., 21, 22, 23, 24, 25, 26, 27 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1651s ][ Queries: 12 (0.0845s) ][ GZIP on ]