Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 18 Jun 2018, 17:50
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
gtk-youtube-viewer (for lots of pups)
Post new topic   Reply to topic View previous topic :: View next topic
Page 17 of 22 [316 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18, 19, 20, 21, 22 Next
Author Message
sindi

Joined: 16 Aug 2009
Posts: 852
Location: Ann Arbor MI USA

PostPosted: Sun 30 Aug 2015, 20:25    Post subject: smplayer no sound, mplayer and vlc work, tarh 603  

I reinstalled smtube after updating Tahr with fix 7. Smplayer plays full-screen (F or Ctrl-C add or subtract controls
but do not produce a smaller less fuzzy screen) and have no sound. Mplayer and VLC have sound and they play at the expected
size (not full screen unless I ask for it). Maestro 3 sound on a 1GHz Inspiron 8100 Pentium III.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 852
Location: Ann Arbor MI USA

PostPosted: Fri 11 Sep 2015, 21:06    Post subject: smtube for puppy 4  

I added all the required libs to Pulp Linux (puppy 4.1.2) which boots using 10MB RAM, but trying to run smtube or smplayer gives error message:
unresolved symbol: g_main_content_push_thread_default.

I also upgraded to glibc 2.11.

What other lib(s) should I update to fix this problem?

pulp plays videos downloaded with youtube-dl on a 233MHz laptop with 96MB RAM, at 240p.
I use mplayer in framebuffer mode (no X at all).

I want a youtube viewer for a 10 year old on a 475MHz with about 150MB usable RAM, which plays at 360p with the above combo but
the kid cannot handle searching for and typing in the URL. One laptop of this era has only 64MB (bad RAM slots).

I don't think Puppy 5 will fit into 150MB with smtube and mplayer both running.

I kill (with a script) all unneeded processes (cupsd, ROX, everything in the tray) which helps a lot.
Tahr is still using 376MB for X and one terminal with ssh. Wary-lupu-precise are slightly better.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Fri 11 Sep 2015, 21:57    Post subject:  

You really ought to find a way to get computers that are a little more recent and a little less Cretaceous, you know that, right? Razz

The problem is that you need to upgrade your version of GTK.

I can't really help you with that, except to say that upgrading it could easily break stuff -- Puppy relies a LOT on GTK stuff.

You might look here --> http://412collection.neocities.org/system.html
Looks like there might be a few helpful bits there. (I don't know offhand if you'll need to boot into xwin for that page to come up, but as usual it's a safe assumption...)

_________________

Back to top
View user's profile Send private message 
fatguy


Joined: 25 Nov 2017
Posts: 15

PostPosted: Sat 25 Nov 2017, 19:28    Post subject:  

hey I am having trouble installing this on current LOS.


I get a perl error in particular.


http://www.murga-linux.com/puppy/viewtopic.php?p=975224#975224


is anyone out there? please help, I have to go or id write more, my baby is crying.
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 1091
Location: rabat

PostPosted: Mon 19 Mar 2018, 14:33    Post subject: Dogs have Gtk-You Tube Viewer 3.1.5 included  

Dogs have Gtk-You Tube Viewer 3.1.5 included
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 852
Location: Ann Arbor MI USA

PostPosted: Tue 20 Mar 2018, 15:12    Post subject: gtk-youtube-viewer 3  

Are there packages for other puppies?

None listed for Lupu. Anything later has video problems on my fastest laptop (nvidia) but it is the slower laptops that need a viewer. Two from 2004 with 768MB RAM would run Tahr. 360p is jerky in a browser.

I see there is now a 3.2.1 viewer.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3095
Location: holland

PostPosted: Tue 20 Mar 2018, 18:51    Post subject:  

It really depends on the perl version installed (which is different on any puppy)
Best is to build it (probably required to load devx ?), see here:
https://github.com/trizen/youtube-viewer#installation
(latest now is version 3.3.3)
Also I've found that it works best with mpv (or probably vlc, I didn't test though), (in the past it worked with mplayer, but not anymore, I think).
And having youtube-dl installed gives best experience for gtk-youtube-viewer, combined with mpv (otherwise several video's won't play)
Install youtube-dl:
Code:
wget https://yt-dl.org/downloads/latest/youtube-dl -O /usr/local/bin/youtube-dl
chmod a+rx /usr/local/bin/youtube-dl


Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 852
Location: Ann Arbor MI USA

PostPosted: Wed 21 Mar 2018, 11:37    Post subject: compiling latest gtk-youtube-viewer for older puppy linuxes  

It would take me a while to learn to compile on puppy linux.

Could you make a package that works with Lucid 2016 and Wary, including perl if the correct version is not found in their package managers?

By 'dogs' do you mean Fatdog64? My only working 64-bit laptop (2008 with 2GB RAM) has an nvidia video chip that I could not get to work with any puppy linux newer than Lupu. Another laptop (2003 non-PAE) runs Wary but not Lupu. I had these both working with smtube until Youtube broke things, and they need only 512MB RAM (the max for my favorite Pentium III, too slow to play youtube in Palemoon). gtk-youtube-viewer used to work with all puppies 5 too.

I prefer the older laptops (2001-2006) for their non-glare and sometimes non-wide screens. My 2004 1.7GHz DELL 600M cannot quite handle 360p youtube in palemoon (and even the 1.8GHz one cannot manage fullscreen or even theater mode 360p). My post-2004 laptops are widescreen except for one 2006 ASUS.

A temporary solution is youtube-dl plus mplayer. Or if enough RAM to handle browser plus mplayer, download with a downloader add-on.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3095
Location: holland

PostPosted: Wed 21 Mar 2018, 15:24    Post subject:  

Hi sindi, sorry, I spoke too easy about building gtk-youtube-viewer, I've done it in the past on DebianDog and Xenialdog (that's what's meant with 'dogs') but just tried on Lupu and ran into problems that I can't solve (missing dependencies).
The perl included in Lupu is too minimal maybe ? Also I tried installing missing components from PPM, but finally had to give up.
The oldest DebianDog version with (working) gtk-youtube-viewer included (and mpv) is Debiandog Wheezy (openbox version):
https://debiandog.github.io/doglinux/zz02debiandogwheezy.html

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 852
Location: Ann Arbor MI USA

PostPosted: Wed 21 Mar 2018, 16:33    Post subject: DebianDog 9.02 (2015) for gtk-youtube-viewer  

I downloaded the jwm non-PAE iso and extracted all the pieces to a directory including the empty subdirectories.

Would grub4dos recognize them and add to menu.lst?
(It booted fatdog versions 6 and 7).

Or should I copy (and edit) the sample lines give for Porteus
linux to my existing menu.lst?

Lupu perl may be too old. Wary perl has 5.1.0.

Do you know system requirements for the 2015 Debiandog?
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3095
Location: holland

PostPosted: Wed 21 Mar 2018, 17:29    Post subject:  

Hi sindi, it's from years ago I was involved with DebianDog Wheezy, so can't remember well, but from what I tested just now is that JWM version doesn't include gtk-youtube-viewer and also it can't be installed from it, so only way is openbox_xfce version (which is a bit heavier)
No-pae openbox_xfce:
https://github.com/DebianDog/Wheezy/releases/download/v1.0/DebianDog-Wheezy-openbox_xfce-2015-09-02.iso

EDIT: Apparently I made mistake testing JWM version. After second test, gtk-youtube-viewer is indeed not included, but can be installed (and works fine from what I tested),so in terminal:
Code:
apt-get update
apt-get install youtube-viewer

And run from Menu > Multimedia

Note, this isn't supported anymore, by fixing bugs etc...

Quote:
Would grub4dos recognize them and add to menu.lst?


Not sure if you mean "grub4dosconfig" application.
If so, no, it wouldn't recognize DebianDog.
But you can add an entry manually to menu.lst, see (porteus style) boot options examples here:
https://github.com/DebianDog/Jessie/wiki/Porteus-boot

Don't know system requirements for the 2015 Debiandog, runs fine on my old HP laptop from 2008.

EDIT: See EDIT above about JWM version

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 852
Location: Ann Arbor MI USA

PostPosted: Wed 21 Mar 2018, 21:48    Post subject: Debiandog boots with grub4dos on 1.7GHz DELL 600m 2004 with
Subject description: Uses 240MB RAM running elinks
 

I had to add an initrd line to the suggested menu.lst entry (last one). Do I also need to boot to the other three that tell it where to save changes? No ssh or telnet and the cursor here is white on white but this is progress.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 852
Location: Ann Arbor MI USA

PostPosted: Wed 21 Mar 2018, 22:46    Post subject: youtube-viewer works at 720p on 1.7GHz 2004 600M 85% CPU  

I am online with portably installed Palemoon . Debiandog's Dillo would not access this forum (no SSH ability) and elinks was confusing.

I followed instructions to install youtube-viewer and downloaded updates followed by lots of perl-related libraries and mpv. Debiandog already has mplayer. mpv can also be run without a mouse.

gtk-youtube-viewer is a graphical interface. It rarely worked to actually play a video and when it did, 720p was extremely jerky (or stopped a lot?). I did not check CPU usage.

youtube-viewer subject --resolution=480 lists videos on a particular subject and plays them at 480p. (smtube played them at 240p when asked for 480p). It also worked at 720p with only 85% CPU usage and about 8% total memory usage.

Debiandog runs a lot less extraneous stuff than puppy linuxes and there is even a low RAM mode that removes the file manager (which I normally do manually in puppy).

At 720p there were frequent pauses in playing which I diagnosed with testmy.net. My download speed is 848-872 kbps. Comcast promised us 25MBps. Youtube works flawlessly at 480p on this laptop with youtube-viewer so the jerkiness at 360p in a browser was due to the browser using the CPU while playing youtube.

The wifi card or slot on this 2004 DELL 600M is dead. (The slot goes bad so often that I did not even try a different card). I stuck in a pcmcia card. Since my cards are all at least wireless B 11Mbps (or at least half that in real life) the slot or the card could be bad. Another card in another laptop runs at 1.4MBps with Wary Puppy. So I suspected the wireless signal.

A not-so-new iPod clocked 41.8Mbps with our wifi signal. ????

Last I checked, the wired download speed was about 25Mbps.

I may need more help if Debiandog does not save changes.

apt-get install ssh downloaded and installed both the client and the server for openssh.

I like youtube-viewer much better than smtube because it is CLI. What a pleasure to have it back again! And DebianDog turns out to be quite suitable for my older hardware with 512MB RAM and a 1GHz CPU.
If things did not break I would not learn anything new.

My 2008 laptop is 'new' compared to the others that I use, and is now no better than they are at playing youtube videos since it has no better resolution and also has dead wifi, in fact people rarely give us laptops with working wifi.

Many thanks!
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 852
Location: Ann Arbor MI USA

PostPosted: Wed 21 Mar 2018, 23:10    Post subject: how to save changes to debiandog?  

82% CPU use by X and youtube in palemoon browser at 360p
85% by youtube-viewer and mpv at 720p

360p should play at 1/4 of 1.7GHz on a slower laptop with the same speed GPU. Or on a Pentium III 1GHz.

Neither CPU usage should be jerky - it is the wifi signal at fault.

When I rebooted I was back to where I started. I don't understand how to save the changes to changes.dat.

On exit it said Porteus.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 852
Location: Ann Arbor MI USA

PostPosted: Wed 21 Mar 2018, 23:11    Post subject: how to exit debiandog  

I exited with 'wmreboot' like I do in puppy.

If I exit using the menu it asks whether to save changes.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 17 of 22 [316 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18, 19, 20, 21, 22 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0824s ][ Queries: 12 (0.0236s) ][ GZIP on ]