Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 04:00
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Broadcom-STA "wl" wifi drivers - repository of latest
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 8 [119 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Mon 25 Jun 2012, 17:55    Post subject: Wary & Racy 5.3.90 - 5.4 Betas  

BarryK has released the beta versions of Wary and Racy 5.4

These versions have rerwin's new pup_event_backend_modprobe with extended preference processing built-in from woof.

To load the Broadcom wl driver onto Wary 5.3.92:
    1. load the multi-kernel pet from post #1
To load the Broadcom wl driver onto Racy 5.3.90:
    1. load the delta pet for k3.0.25 from post #7

    2. load the multi-kernel pet from post #1

_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Wed 05 Dec 2012, 03:32; edited 6 times in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Sun 15 Jul 2012, 06:23    Post subject: Diffs record
Subject description: The set of changes made to the Broadcom source
 

As a record.....

Open the attached file as text to see all the changes made to the original Broadcom sources.

Cheers
peebee
wl_diffs.gz
Description 
gz

 Download 
Filename  wl_diffs.gz 
Filesize  2.35 KB 
Downloaded  606 Time(s) 

_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Mon 17 Sep 2012, 14:23; edited 1 time in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Thu 09 Aug 2012, 07:21    Post subject: Delta files for Precise Puppy  

Delta files are no longer required for Precise 5.4 - they are now built in to the multi-kernel pet
_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Wed 24 Oct 2012, 06:02; edited 10 times in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Sun 12 Aug 2012, 04:47    Post subject:  

Reserved for future use
_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Fri 05 Oct 2012, 16:25; edited 9 times in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Mon 20 Aug 2012, 11:04    Post subject:  

Reserved for future use
_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Wed 03 Oct 2012, 14:19; edited 2 times in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Sat 25 Aug 2012, 07:09    Post subject: Delta files for Slacko 5.3.7.1 k3.2.33-4g & k3.4.17-PAE  

The delta files for the Beta version of the next version of Slacko:
    Slacko 5.3.7.1 with Kernel 3.2.33-4g and with Kernel 3.4.17-PAE
are attached.

This is another "new generation" pup that does NOT need the rerwin fixes pet.

To install the Broadcom WL driver onto Slacko 5.3.7.1
    1. install the (correct!) delta file attached to this post

    2. install the multi-kernel pet in post #1

    3. reboot
broadcom_wl_delta-k3.2.33-4g.pet
Description  WL Delta for k3.2.33-4g
pet

 Download 
Filename  broadcom_wl_delta-k3.2.33-4g.pet 
Filesize  42.26 KB 
Downloaded  711 Time(s) 
broadcom_wl_delta-k3.4.17-PAE.pet
Description  WL Delta for k3.4.17-PAE
pet

 Download 
Filename  broadcom_wl_delta-k3.4.17-PAE.pet 
Filesize  42.4 KB 
Downloaded  708 Time(s) 

_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Wed 07 Nov 2012, 05:08; edited 12 times in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Sat 25 Aug 2012, 07:15    Post subject: New version uploaded  

Version 9 uploaded on 25 Aug 2012 - from download 343 onwards - see post #1.

For this version I have taken most of the delta files out of the Multi-Kernel pet and provided them individually as posts to the thread - the main pet still directly supports the official release puppies Wary and Slacko.

As before, there are no changes to the actual driver from this change so if you've downloaded and are using a previous version you can stick with it.

Cheers
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Sun 26 Aug 2012, 06:15    Post subject: Precise 5.2.72 & 73 delta added  

I've added the delta file to support Precise 5.2.72 & 5.2.91 k3.2.28-pae as just released by BarryK - see http://murga-linux.com/puppy/viewtopic.php?t=76495&start=10
_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Wed 05 Sep 2012, 05:00; edited 1 time in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Thu 30 Aug 2012, 15:02    Post subject:  

Reserved for future use
_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Wed 03 Oct 2012, 14:20; edited 2 times in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Sat 01 Sep 2012, 13:48    Post subject:  

The delta file for the next Slacko 5.3.5.3 with k3.2.28-4g has been uploaded:

http://murga-linux.com/puppy/viewtopic.php?t=76495&start=20

Cheers
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Thu 06 Sep 2012, 15:38    Post subject:  

Hi Peebee,

I just wanted to ask you if I compile the newer STA drivers,
and install the pet, will it overwrite the older wl driver, or do I have to somehow remove the older wl driver?

Also, I will be compiling for Solidpup (Wary 5.1.1 kernel 2.26.32.28 )
Will I need any special patches for the older kernel?

Great work with the drivers. Wink
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Thu 06 Sep 2012, 16:06    Post subject:  

Peebee,

I forgot to ask you, is it okay for the B43 drivers and the STA drivers to exist alongside one another? I don't have a broadcom wireless adapter, I just want to include the drivers for other forum members.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Thu 06 Sep 2012, 18:37    Post subject:  

Tman wrote:
Hi Peebee,

I just wanted to ask you if I compile the newer STA drivers,
and install the pet, will it overwrite the older wl driver, or do I have to somehow remove the older wl driver?

Also, I will be compiling for Solidpup (Wary 5.1.1 kernel 2.26.32.28 )
Will I need any special patches for the older kernel?

Great work with the drivers. Wink


Hi Tman

Great to have your interest - I'll do my best to answer your questions.

The wl.ko driver has to be compiled specifically for each kernel - as you can see from post #1 the multi-kernel pet directly supports Wary 5.3 with k2.26.32.59 so there should be no problem with Solidpup. The source I use does have a set of patches applied - mainly for later kernels - the patches are attached to: http://www.murga-linux.com/puppy/viewtopic.php?t=76495&start=16.

If you like I can download Solidpup + devx + kernel sources and make a delta pet for k2.26.32.28 - and also test that it works on my laptop with b43 wifi.....

or I can send you the patched source by pm so you can compile your own driver and tell you what you need to do to make the delta yourself.

The delta is tiny so can be built into the iso if you feel so inclined, so that people just need to load the multi-kernel pet.

I'm not sure how to answer your queries about "new" drivers overwriting "old" drivers - other than to say the pets include uninstall logic which should remove the drivers if you uninstall the pet and revert you to the situation before you loaded the pet.
Assuming you used my pets as the blueprint for your pet then there should be no overwriting situations to take care of.
The delta file creates the driver for your kernel dynamically.

Hope this helps
Cheers
PeeBee

_________________
LxPup-14.03 = Puppy + LXDE

Last edited by peebee on Thu 20 Sep 2012, 11:50; edited 2 times in total
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Fri 07 Sep 2012, 00:50    Post subject:  

peebee wrote:

If you like I can download Solidpup + devx + kernel sources and make a delta pet for k2.26.32.28 - and also test that it works on my laptop with b43 wifi.....

or I can send you the patched source by pm so you can compile your own driver and tell you what you need to do to make the delta yourself.


That would be fantastic if you could make a delta pet and test it out for me, thank you. The download links are -> here

But please send me the patched source as well, so that I can duplicate your work to make sure that I know how to do it for next time. I already compiled a broadcom STA driver, included in the February 2012 versions of Solidpup, but I have no hardware to confirm if it's working or not.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1401
Location: Malvern, Worcs, UK

PostPosted: Fri 07 Sep 2012, 14:43    Post subject:  

Tman wrote:
That would be fantastic if you could make a delta pet and test it out for me, thank you.


Hi Tman

Not a success report I'm afraid....
Looks like Wary5.1.1 has a different module loading mechanism than later Woof2 pups....
The Broadcom wl driver compiled OK on solidpup from my patched source but when it was loaded together with the rerwin logic in the multi-kernel pet it did not install.

The driver is fine - I substituted your wl.ko with the wl.ko that I had compiled and it worked fine - the only change of any significance is that the device created is wlan0 rather then eth1 on my laptop. It is the same version of the Broadcom source.

Dmesg shows that both with your in-built driver and my version that both b43 and wl are loaded but in my case wl "wins" the battle and is used.

We would need to ask for rerwin's help if you wanted to get his logic working on Wary5.1.1....

I think the best thing to do is for me to send you the patched source in a PM so you can compile it yourself. The wlan0 change is a good one to have as SNS seems to work better in some circumstances if it finds wlan0.

Sorry I couldn't be of more help. Have you thought of moving to a Wary 5.3 k2.6.32.59 base??

Cheers
peebee
dmesg.gz
Description  open as text
gz

 Download 
Filename  dmesg.gz 
Filesize  27.67 KB 
Downloaded  608 Time(s) 

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 8 [119 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0815s ][ Queries: 12 (0.0052s) ][ GZIP on ]