Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 09:33
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How I got Wake On LAN (WOL) working between two Puppies
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count_1  
Author Message

Joined: 13 Dec 2007
Posts: 59
Location: East Devon, GB

PostPosted: Mon 27 Feb 2012, 16:41    Post_subject:  How I got Wake On LAN (WOL) working between two Puppies  

A number of folk have asked recently about this. There is already material on this forum about WOL and I reference some of it in this post, but at the risk of a bit of repetition I thought that my experience of what I did to get WOL going on a couple of Puppies might also be of interest. It was actually very straightforward.

First things first: I came across a puppy package that does the job nicely. It's the puppy wolandarp.tar.gz package and it may be found at

The readme file that is part of that package contains some useful info and I found it very helpful.

Before I discovered that package I found some other useful info at http://cameacross.wordpress.com/2009/04/28/how-to-set-up-wake-on-lan-on-ubuntu-home-server/ - it's well worth a look.

Also see: http://www.murga-linux.com/puppy/viewtopic.php?t=53507&sid=42340da4376b3455dfc521a261527110 for a little bit more info.

Here is what I did:

For my Celeron machine with Puppy 4 (Dingo), I "installed" wol and arp (ethtool was already installed) from the Puppy wolandarp.tar.gz package as per the instructions in the readme: I simply copied them to /root/my-applications/bin.

Then in a terminal I ran

ethtool eth0

The two "wake-on" lines told me which wake-on-LAN modes the network interface eth0 supports, and if/which mode is enabled. In my case it wasn't enabled - it was "d", not "g" - so I changed it. It wasn't hard: in a terminal I ran

ethtool -s eth0 wol g

and that enabled WOL - ie it set the "g" option, that sets it to wake up that computer on receiving the Magic Packet.

Next (in a terminal) I ran

ifconfig eth0

which identified its MAC number as 00:06:4F:02:04:64

then I shut the system down and left it turned off.

Next I "installed" wol and arp on a second machine (Sony Vaio/Fluppy 8 ).

Both machines were on my LAN.

On the Sony Vaio I opened a terminal and ran

wol 00:06:4F:02:04:64

which started up the Celeron box!

(Note: I am quite happy for this machine's MAC number to be visible here because I recently scrapped it. But before that the above WOL arrangement worked on it without any problems for six months.)

Just for fun I then set everything up to work the other way round (Celeron/Puppy 4 starting the Sony Vaio.Fluppy 8 ), which it did without any problem.

Finally I wrote a simple script that I could run from an icon on the desktop:



# This sends the "Magic Packet" to my desktop machine.

exec wol 00:06:4F:02:04:64


And that was it.

I hope some of this is useful.

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count_1  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0424s ][ Queries: 11 (0.0042s) ][ GZIP on ]