Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 02:23
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 43 of 89 Posts_count   Goto page: Previous 1, 2, 3, ..., 41, 42, 43, 44, 45, ..., 87, 88, 89 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 1434
Location: Malvern, Worcs, UK

PostPosted: Thu 05 Jul 2012, 06:16    Post_subject: Re: pnethood-0.7  

shinobar wrote:
Download the same filename with new time stamp:
pnethood-0.7.i18n.pet 05-Jul-2012 18:31 18k
http://shino.pos.to/party/bridge.cgi?puppy/test/


Now works - thanks - Very Happy

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send_private_message 
feelsub

Joined: 20 Jun 2012
Posts: 39

PostPosted: Thu 05 Jul 2012, 07:32    Post_subject:  

Quote:
Have you tried Geeqie ? I would like to know if it is fast enough.

OK now, the numbers on a test laptop 32bits
CPU: Celeron M 1.4Ghz (with SSE2)
RAM 512Mb
a folder with jpeg btw 5 to 7 Mb
To browse through 10 of them
Viewnor : 24,8 sec
Gthumb 2.11.5 : 24,8 sec (on Dpup crashes if edit>preferences)
Gthumb 2.10.11: 23.6 sec (under 3headed dog)
Geeqie 1.0: 19,7 sec (on Dpup)
Picasa 3.0 beta: 9sec (under 3headed dog)

Now same under WinXP with anti-virus:
Picasa 3.9: 11sec
FastStone: 10 sec

Quote:
Dpup is 32 bits. There is FatDog which is 64 bit and also LHP 64. I think there isnt any other 64 bits Puppy. Also there is Iguleder`s new roar-ng which builds natively 64 bit small distro. So...if you dont build your own distro or use one of those 64 bits Puppy distros, you are at safe side.

Quote:

I dont target to the old hardware. My kernel has been optimized core 2 and up.

With all respect, you seem to have a miss conception, to match your objective you should build it as at least as 64bits, see my thread http://murga-linux.com/puppy/viewtopic.php?p=638579#638579
No particular issues with 3headed dog, so far no luck with Dpup (also coming from compilation options?)

FYI: cvlc runs fine, Gnome Mplayer opens correctly but does NOT play files even mp3(Pmusic OK)
to come back on VLC
Quote:
If you install from the PPM using exprimo repo

I did (Ppack Package Manager)
Quote:
and typing vlc and then check dependencies

Well here the result of dependencies check
Code:
File /usr/lib/vlc/plugins/codec/liblibmpeg2_plugin.so has these missing library files:
 libmpeg2.so.0
File /usr/lib/vlc/plugins/codec/libzvbi_plugin.so has these missing library files:
 libzvbi.so.0
File /usr/lib/vlc/plugins/codec/liblibass_plugin.so has these missing library files:
 libass.so.4
File /usr/lib/vlc/plugins/codec/libsdl_image_plugin.so has these missing library files:
 libSDL_image-1.2.so.0
File /usr/lib/vlc/plugins/video_output/libxcb_xv_plugin.so has these missing library files:
 libxcb-xv.so.0 libxcb-shm.so.0
File /usr/lib/vlc/plugins/video_output/libxcb_window_plugin.so has these missing library files:
 libxcb-keysyms.so.1
File /usr/lib/vlc/plugins/video_output/libxcb_x11_plugin.so has these missing library files:
 libxcb-shm.so.0
File /usr/lib/vlc/plugins/gui/libqt4_plugin.so has these missing library files:
 libQtGui.so.4 libQtCore.so.4
File /usr/lib/vlc/plugins/gui/libskins2_plugin.so has these missing library files:
 libtar.so.0
File /usr/lib/vlc/plugins/services_discovery/libmtp_plugin.so has these missing library files:
 libmtp.so.8
File /usr/lib/vlc/plugins/audio_filter/libdtstofloat32_plugin.so has these missing library files:
 libdca.so.0
File /usr/lib/vlc/plugins/audio_filter/liba52tofloat32_plugin.so has these missing library files:
 liba52-0.7.4.so
File /usr/lib/vlc/plugins/demux/libmpc_plugin.so has these missing library files:
 libmpcdec.so.6
File /usr/lib/vlc/plugins/demux/libts_plugin.so has these missing library files:
 libdvbpsi.so.6
File /usr/lib/vlc/plugins/demux/libmkv_plugin.so has these missing library files:
 libmatroska.so.5 libebml.so.3
File /usr/lib/vlc/plugins/mux/libmux_ts_plugin.so has these missing library files:
 libdvbpsi.so.6
File /usr/lib/vlc/plugins/access/liblinsys_sdi_plugin.so has these missing library files:
 libzvbi.so.0
File /usr/lib/vlc/plugins/access/libaccess_mtp_plugin.so has these missing library files:
 libmtp.so.8
File /usr/lib/vlc/plugins/access/libaccess_dv_plugin.so has these missing library files:
 libavc1394.so.0 librom1394.so.0
File /usr/lib/vlc/plugins/access/libxcb_screen_plugin.so has these missing library files:
 libxcb-composite.so.0 libxcb-xfixes.so.0 libxcb-shape.so.0
File /usr/lib/vlc/plugins/access/liblibbluray_plugin.so has these missing library files:
 libbluray.so.1
File /usr/lib/vlc/plugins/access/libdtv_plugin.so has these missing library files:
 libdvbpsi.so.6
File /usr/lib/vlc/plugins/control/libglobalhotkeys_plugin.so has these missing library files:
 libxcb-keysyms.so.1
File /usr/lib/vlc/plugins/access_output/libaccess_output_shout_plugin.so has these missing library files:
 libshout.so.3
Back to top
View user's profile Send_private_message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Thu 05 Jul 2012, 08:33    Post_subject:  

feelsub wrote:

Quote:
If you install from the PPM using exprimo repo

I did (Ppack Package Manager)


Hello feelsub,
Regarding issues with missing dependencies with Ppack Package Manager - Please see my reply to your previous post here:
http://murga-linux.com/puppy/viewtopic.php?p=638400#638400

There is two package managers on current Expriomo:
Puppy Package Manager ( official Puppy package manager )
Ppack Package Manager ( un-official and now broken package manager )
If Ppack is broken why is it included in Exprimo? - An oversight on my part, i was unaware that Ppack is now broken so never informed Pemasu of this issue.

In the meantime i would recommend un-installing any broken / none working packages that have been installed with Ppack then re-install them through the official Puppy Package Manager so any missing dependencies are resolved.

To make sure you are using the correct Puppy Package Manager open a terminal and enter the command: ppm &
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 05 Jul 2012, 08:37    Post_subject:  

Quote:
I did (Ppack Package Manager)

I have always meant Puppy Package Manager when I type PPM. Puppy Package Manager do have dependency checking. As stu90 previously wrote ( even before above post ), which you have have seemed to be missing.... Ppack Package Manager does not have dependency checking. It could be that I should repost what every other posters post, but that would pollute this thread.
Quote:
Hi feelsub,

Puppy Package Manager has been updated somewhere along the way and from what i can tell will now dependency check puppy packages as well as host repo packages - this is something Ppack doesn't do so that is why some packages are now failing to work when installed with ppack.
I will suggest to Pemasu that Ppack be removed from his next build until i get time to review the code.

Here it is again. Puppy Package Manager ie PPM has dependency checking, Ppack Package Manager does not have. So that things will be even more easier in the next release....I will remove Ppack Package Manager as stu90 suggested.

I try to post more clearly right on, so that there isnt so much possibilites for misunderstanding.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 05 Jul 2012, 08:52    Post_subject:  

Quote:
Now, if you need to recompile VLC, I suggest the latest release and at least and i686 compile( if not with SSE2)

Here is the compile specs of the VLC-2.0.1 which is in exprimo repo (previously compiled...not new compile)....using PPM ie Puppy Package Manager:
Quote:
libvlc configuration
--------------------
version : 2.0.1
system : linux
architecture : i686 mmx sse sse2
optimizations : yes
vlc aliases : cvlc rvlc svlc qvlc
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-run-as-root --enable-pvr --enable-real --enable-realrtsp --disable-notify --disable-sid --disable-goom --disable-decklink --disable-smb --disable-gme --disable-taglib --enable-non-utf8 --disable-pulse --disable-fluidsynth --disable-libproxy --disable-projectm --disable-portaudio --disable-jack --disable-kate --disable-kai --disable-tiger --disable-upnp --disable-kva --disable-live555 --disable-crystalhd --disable-speex --disable-schroedinger --disable-dirac --enable-merge-ffmpeg --without-kde-solid --enable-mkv --disable-caca
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1010
Location: South of Belgium

PostPosted: Thu 05 Jul 2012, 11:48    Post_subject: black screen upon X server restart  

Hi,
note: this is not specific to exprimo !! also encountered on Slacko and others.
here on pentium IV + video chip description:
- 2.0 VGA compatible controller
Intel Corporation 82845G/GL[Brookdale-G]/GE Mad Chipset Integrated Graphics Device (rev 01)
oem: Intel(r)845G/845GL/845GE/845GV Graphics Chip Accelerated VGA BIOS
product: Intel(r)845G/845GL/845GE/845GV Graphics Controller Hardware Version 0.0
what happens:
- on all exprimos (first tested was 5X14 with k2.6.39.4) (but also on slacko ans wary ...this is not specific to exprimo) black screen upon X server restart (this is common using that very Brookdale video chip)
details:
- when booting for 1st time (pfix=ram), X desktop displays OK; when setups are done (keyboard, locale, time) the user is asked to restart X; here begins the "story". The behaviour of X looks to be unpredictable, sometimes it starts OK; some other times only a few icons together with the tray bar are displayed on a black background; some other times there is only a black screen with only the mouse cursor (moving according to mouse displacements).
- I get a X desktop OK when booting on a squeezesave file (even if that file has been created after getting a "black desktop" upon pristine boot - as when doing Ctrl-Alt-BackSpace, it is asked to make a save file).
- running on a squeezesave file and doing an X restart often returns a black desktop; doing Ctrl-Alt-BackSpace and once in console mode, (only !) xwin (not xorgwizard to avoid xorg.conf rewriting ...!), sometimes works and returns the X desktop again, sometimes not,...Then the only solution is to return to console mode ( doing Ctrl-Alt-BackSpace ) and once in console mode, do reboot ... Rolling Eyes

This was already the case
during forum member 01micko's Slacko development - a long story...- He has to edit the xorgwizards script including some lines specific to the Brookdale video chip hardware.

extract from /usr/sbin/xorgwizard Slacko 5.3.1, line nr. 1497 and following
Code:
...
# MHHP 110910,  If Brookdale, run /usr/sbin/BROOKDALE with whatever fixes needed #added 110918 01micko
BROOKYRUS="`lspci|grep -iE "vga"|grep -iE "Brookdale"`" #adjusted test 110924
if [ "$BROOKYRUS" ];then
#Added dialog choice #cowboy 111002 replace "systwm" w "configuration"
CHOICE="It seems you have an Intel Brookdale graphics adapter. \nThere are known issues with these. You should ensure \nthat Video Memory is set to 8 M in your computer's BIOS. \nAfter setting up X it is a good idea to install \n\"mesa\" from the Puppy Package Manager. If you choose \n\"Yes\" then a modification to your configuration will \nbe made to try to improve things. If you are not sure \nchoose \"Yes\". \nPlease Choose, you can always run \"xorgwizard\" \nlater if you have problems."
dialog --title "Brookdale enhancement" --yes-label "Yes" --no-label "No" --yesno "$CHOICE" 0 0
case $? in
0)[ -f /usr/sbin/BROOKDALE ] && . /usr/sbin/BROOKDALE ;;
*)echo ;;
esac
fi
...


This is like a "stone in the boot": it does not avoid to use exprimo (or others), I can live with it ... Wink

Thanks considering this.
Cheers, Charlie
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 05 Jul 2012, 11:54    Post_subject:  

I apologize above irritated post. I have checked the Packages-puppy-exprimo-official database file in /root/.packages and it really misses the vlc-2.0.1-deps-dpup dependecy definition. Also Clementine missed dependencies definition for gstreamer-deps.

Here is the updated database file. It has other new uploads also included. Install the pet. Reboot or removing content from /tmp would be needed to flush PPM ie Puppy Package Manager.
Packages-puppy-exprimo-official-update-0.0.1.pet
Description 
pet

 Download 
Filename  Packages-puppy-exprimo-official-update-0.0.1.pet 
Filesize  5.4 KB 
Downloaded  117 Time(s) 
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 05 Jul 2012, 14:02    Post_subject:  

In dpup history...there has been problems with PPM ie Puppy Package Manager installed applications and saving them in certain medias...after savefile creation and rebooting in some medias the installed pets have vanished.
For example usb or sd card medias may not have preserved them after savefile creation and rebooting. Shinobar has fixed that problem with his alternative petget package which can be installed overwriting existing files. Only caveout. Change the UI to be Classic before doing the overwrite installation. Shinobars petget does not support Ziggy UI. Reboot would be good or using PPM only after installing shinobars pet or removing content from /tmp so that PPM files will be flushed. I have noticed that sometimes otherwise the PPM does not start.

It is due to aufs layered saving. In dpup layered saving does not always work in all medias.
It is possible that remastering failure ie preinstalled applications by PPM usage does not preserve in remaster.

I have now woof /usr/local/petget folder. So...there is situations when the Shinobars modified petget results preserving of the installed pets after savefile creation and rebooting.

Here is the link to the latest Shinobars petget. It is dpup compliant. Many improvements in Shinobars petget has been done based on feedback in dpup threads. Shinobars petget also warns if existing files will be overwrited. It also has dependency checking for pet repos.

http://shino.pos.to/linux/puppy/petget-20120418.pet

Why I dont have it preinstalled. I had...and it is ok and good. I just wanted to see how woof generic petget stuff behaves. It has had several improvements which I like....like Mavrothals improvement to suggest which repos to search, possibility to use Ziggy UI, which I like, and woof petget always has the improvements through woof when you download latest woof.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 05 Jul 2012, 14:26    Post_subject:  

Charlie6. Brookdale and X problem. I pm'd 01micko about his Brookdale fix. Lets see....
And thank you of the feedback and pointer to the possible solution.
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7805
Location: qld

PostPosted: Thu 05 Jul 2012, 17:13    Post_subject:  

Hi pemasu

Attached is the Slacko hacks which made it into 531. It includes the hacked xorgwizard and supporting scripts. Pull it apart and take what you need. Unfortunately though, I haven't kept a backup of the original xorgwizard at the time so can't offer a diff. As you know things in woof are very dynamic so there would be several changes since that time.

Cheers
z_base_hacks-111211.pet
Description 
pet

 Download 
Filename  z_base_hacks-111211.pet 
Filesize  201.45 KB 
Downloaded  108 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 05 Jul 2012, 18:56    Post_subject:  

Charlie6. I created a pet of the modified xorgwizard and included BROOKDALE script to be called from xorgwizard.

Should you install xorg-high also ?
brookdale-fix-0.0.1.pet
Description 
pet

 Download 
Filename  brookdale-fix-0.0.1.pet 
Filesize  25.03 KB 
Downloaded  118 Time(s) 
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2630
Location: Japan

PostPosted: Thu 05 Jul 2012, 22:03    Post_subject: PPM in woof  

pemasu wrote:
Mavrothals improvement to suggest which repos to search, possibility to use Ziggy UI

The 2 improvement has brought new bug and I cannot fix them for now. That is why i do not sync with the woof,

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
charlie6


Joined: 30 Jun 2008
Posts: 1010
Location: South of Belgium

PostPosted: Fri 06 Jul 2012, 00:12    Post_subject: Brookdale and X problem  

Hi Pemasu,
Hi 01micko,
At first, many thanks for your time !
pemasu wrote:
Charlie6. I created a pet of the modified xorgwizard and included BROOKDALE script to be called from xorgwizard.

Should you install xorg-high also ?

I will test that pet ... although I resist to install mesa, libdrm and extra xorg-server-intel (because lot of trials with few good results) , excepted if really needed of course.

Last edited: below is the post where i told about "good news" ...as X restarted several times repeatidly last night ... afterwards i went to bed thinking "problem solved ...but maybe too simplist fix ? ". This morning ...bad news ... the link mentioned below could be of interest ! then .... Aaargh ...!
also please disregard what charlie6 last night wrote:

Next, good news: here maybe a way to fix:
I retrieved yesterday that thread with title " [SOLVED] Intel 82845G "
http://www.linuxquestions.org/questions/slackware-14/intel-82845g-788563/page3.html
and did the following:
Quote:
Another possible solution for the 82845G video driver problem:
1.) put the following in /etc/X11/xorg.conf in Section "Device":
Code:

Section "Device"
Identifier "Card0"
Driver "intel"
Option "Shadow" "true"
Option "DRI" "false"
BoardName "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)"
BusID "PCI:0:2:0"
EndSection

To find out the exact BoardName and revision Nr., run "lspci | grep VGA" to find out the "BusID" and the "BoardName", for example:
Code:
 # lspci | grep VGA

and still moreover added in /etc/X11/xorg.conf :
Quote:
Code:
Section "Extensions"
Option "Composite"    "Disable"
EndSection

I moreover created a /etc/X11/xorg.conf.d folder where I placed this two files:
Quote:

/etc/X11/xorg.conf.d/i845G.conf
Code:
Section "Device"
    Identifier    "Card0"
    Driver    "intel"
    Option    "Shadow"    "true"
    Option    "DRI"      "false"
    BoardName    "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)"
    BusID    "PCI:0:2:0"
EndSection

/etc/X11/xorg.conf.d/disable-composite.conf
Code:
Section "Extensions"
    Option    "Composite"    "Disable"
EndSection

All this now works OK: X desktop restart either at each X restart or Ctrl-Alt-BackSpace + doing 'xwin' once in console mode (here currently doing 'xwin icewm' as icewm has been installed Very Happy ).
To be tested for different Brookdale revision ids ... I remember forum members CowBoy, MHHP, maybe szindian also if i good remember ... 01micko also owns one of those Brookdale-featured-clunker ... Wink

now continuing testings ...
Cheers, Charlie
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1010
Location: South of Belgium

PostPosted: Fri 06 Jul 2012, 04:26    Post_subject: Brookdale 82845G X restart problem  

Hi Pemasu,
have made some tests using the above brookdale-fix-0.0.1.pet:
tests performed
1st) on a fresh 5X3422 pfix=ram session without configuring locale, keyboard, etc ... to not be asked to ... restart X;
results: see below under 3)
2nd) on my current work squeezesave session (using icewm); (after; of course removing te previously created /etc/X11/xorg.conf.d folder; as also backuped /usr/sbn/xorgwizard ans /etc/X11/xorg.conf ...one never knows... Wink )
3) results:
both tests results in a dramatic improvment Very Happy :
3.1) using jwm
-step #1: /Menu/Session/Restart X --> X desktop restart OK
-step #2: again /Menu/Session/Restart X --> black X desktop + only mouse cursor working;
-step #3: do Ctrl-Alt-BackSpace to switch to consle mode; there do 'xwin' --> then X desktop restart OK
-step #4: go back to step #1 and loop repeatidly through #2 to #4; (tested ca. 10 loops )
it looks acting like a toggle switch ... one time restarting X from desktop Menu, on the next time having to do it using Ctrl-Alt-BackSpace; and again and again ..
conclusion: imho it is a dramatic improvment as i do no longer have to reboot Very Happy

3.2) using icewm
-step #1: open a console and do 'restartwm icewm' --> X desktop restart OK
here it works OK;
Avoid restarting X doing /Menu/Session/Restart X --> black X desktop + mouse cursor; here need to do Ctrl-Alt-BackSpace and reboot (doing 'xwin icewm' or 'xwin' dooes not help)
Using icewm, do /Menu/Other/Restart Icewm instead .

To Pemasu and 01micko, also many thanks for this improvment !
Charlie
Back to top
View user's profile Send_private_message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Fri 06 Jul 2012, 14:20    Post_subject:  

I tried installing the browser-plugin-vlc 2.01 from debian's website but when I try to play youtube, Firefox crashes. Sad

Some help?

How do I get the VLC 2.01 plugin to work?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 43 of 89 Posts_count   Goto page: Previous 1, 2, 3, ..., 41, 42, 43, 44, 45, ..., 87, 88, 89 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1770s ][ Queries: 12 (0.0447s) ][ GZIP on ]