Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 06:14
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 42 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 40, 41, 42, 43, 44, ..., 87, 88, 89 Next
Author Message
feelsub

Joined: 20 Jun 2012
Posts: 39

PostPosted: Wed 04 Jul 2012, 06:12    Post subject:  

I'm glad I convinced you, master, for NTFS and FFmpeg; hope you may convince other Puppies administrators, so that everyone is on same foot.

Now, if you need to recompile VLC, I suggest the latest release and at least and i686 compile( if not with SSE2); indeed on my old laptop Celeron M 1.4Ghz, if Puppy is faster than WinXP to browse, I can NOT watch a H264 film HD ready under Puppy(CPU overloaded), while OK under WinXP with anti-virus.... By the way SMPlayer shows to be less CPU extensive than VLC.

Quote:
Gthump is out. It needs polluted gnome-common and other stuff which has been cleaned out in dpup exprimo. In fact...I dont know any Puppy with gnome-common package.

Well in Lucid 5.2.X, 3headed dog and I think Slacko it installs successfully from PPM.
My motivation for Gthumb in place Viewnor is the same than for HD ready films, Viewnor is slow; AV Linux has been convinced and has dumped Viewnor for Gthumb.

Puppy Package Manager bug:
If you check "puppy-lucid-official" in the configure properties, it does NOT appear in the repositories.


Some failed installs from Ppack Package Manager (name is confusing with Puppy Package Manager); Exprimo repository:

SMPlayer 0.8 (installs without error, terminal run:)
Quote:
# smplayer
smplayer: error while loading shared libraries: libQtXml.so.4: cannot open shared object file: No such file or directory


"abiword-2.8.6-gnumeric-1.10...." failed to install.

Gnumeric-1.10-13dpup
Quote:
# gnumeric
gnumeric: error while loading shared libraries: libgoffice-0.8.so.8: cannot open shared object file: No such file or directory



Skype 4.0 failed to install


From Puppy Package Manager; exprimo repository:
Skype 4.0 failed to download
LibreOffice 3.5.0 failed to install.

=========


If you change the country setting from say en_US to fr_BE, at X restart, all icons are repositioned to their origal desktop location; if you just perform an X restart, this does not happen. Country locals have had a problem with Puppies, I already reported bugs about this, some were fix, I still believes issues with character sets encoding are linked with improper locals.

End of test.
Thanks
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Wed 04 Jul 2012, 06:28    Post subject:  

I made a little change to the Aurora GTK theme - instead of the background being white it is now gray to match more with the rest of the theme.
Aurora2.tar.gz
Description 
gz

 Download 
Filename  Aurora2.tar.gz 
Filesize  3.18 KB 
Downloaded  112 Time(s) 
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Wed 04 Jul 2012, 06:41    Post subject:  

feelsub wrote:


Some failed installs from Ppack Package Manager (name is confusing with Puppy Package Manager); Exprimo repository:


Hi feelsub,

Puppy Package Manager has been updated somewhere along the way and from what i can tell will now dependency check puppy packages as well as host repo packages - this is something Ppack doesn't do so that is why some packages are now failing to work when installed with ppack.
I will suggest to Pemasu that Ppack be removed from his next build until i get time to review the code.

cheers.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 04 Jul 2012, 08:32    Post subject:  

Quote:
Now, if you need to recompile VLC, I suggest the latest release and at least and i686 compile( if not with SSE2)

VLC-2.01 in exprimo repo has been compiled i686 with SSE2. And it is the latest release.

I dont target to the old hardware. My kernel has been optimized core 2 and up. I tend to support more or less somewhat newer hw because I have such. Wary, 214X are the ones for better support to the older hw.
Gthumb is also in squeeze repo. You can try that. When I checked the compile specs, it insisted gnome-common needs to be present. That is my line, no gnome-common for me. You could try to compile it and I will add it to the exprimo repo gladly and willingly. Have you tried Geeqie ? I would like to know if it is fast enough. That one has been compiled in Dpup.
Quote:
If you check "puppy-lucid-official" in the configure properties, it does NOT appear in the repositories.

That repo has been there for Ppack usage. PPM declines to use other distro repositories. Squeeze - dpup and exprimo for Dpup. Lucid Puppy repo has been excluded. Of course that could be circumvented, but I stay now with woof PPM. Just for a while. Ppack Manager is not anymore PPM compliant and it will be removed until stu90 improves it. Thank you of the report of failing installations.
Quote:
From Puppy Package Manager; exprimo repository: Skype 4.0 failed to download .

I dont have Skype 4.0 in exprimo repo. I have http://smokey01.com/pemasu/pet_packages-exprimo/skype-static-2.1.0.81.sfs only.
Quote:
LibreOffice 3.5.0 failed to install.
I will check that. Anyway...Use from the menu > document > Get Libre office ... and you get the more recent version as sfs.
EDIT: LibreOffice 3.5.0 pet installed from PPM - exprimo repo ok. And it appeared to the menu and the Writer started ok.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1459
Location: Malvern, Worcs, UK

PostPosted: Wed 04 Jul 2012, 09:19    Post subject:  

pemasu wrote:
I dont have Skype 4.0 in exprimo repo.


Hi pemasu

I have Skype 4.0.0.7 from http://www.murga-linux.com/puppy/viewtopic.php?t=79077 running on squeeze_5.X.3.1.10.3

but it needed qt-4.8.0-basic-with-qtwebkit-dpup.pet to work......

Cheers
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
feelsub

Joined: 20 Jun 2012
Posts: 39

PostPosted: Wed 04 Jul 2012, 10:30    Post subject:  

All those package manager & repositories are confusing me.

Quote:
VLC-2.01 in exprimo repo has been compiled i686 with SSE2. And it is the latest release.

Well, this laptop is 32bits, if you compile 64bits better to indicate it. still no luck for me

Code:
 # vlc
VLC media player 2.0.1 Twoflower (revision 2.0.1-0-gf432547)
[0x80cd660] main interface error: no suitable interface module
[0x804e3f0] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x804e3f0] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x80cd660] [cli] lua interface: Listening on host "*console".
VLC media player 2.0.1 Twoflower
Command Line Interface initialized. Type `help' for help.


Quote:
Use from the menu > document > Get Libre office ... and you get the more recent version as sfs.

Doesn't work on USB key.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 04 Jul 2012, 11:07    Post subject:  

Quote:
# vlc
VLC media player 2.0.1 Twoflower (revision 2.0.1-0-gf432547)

If you install from the PPM using exprimo repo and typing vlc and then check dependencies ---> PPM find dependencies: qt-basic-with-webkit...and vlc-2.0.1-deps-dpup and installing them along with vlc-2.0.1 and VLC should work.
Quote:
Well, this laptop is 32bits, if you compile 64bits better to indicate it. still no luck for me
Dpup is 32 bits. There is FatDog which is 64 bit and also LHP 64. I think there isnt any other 64 bits Puppy. Also there is Iguleder`s new roar-ng which builds natively 64 bit small distro. So...if you dont build your own distro or use one of those 64 bits Puppy distros, you are at safe side.
Last edited by pemasu on Wed 04 Jul 2012, 11:32; edited 1 time in total
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5854
Location: Kentucky

PostPosted: Wed 04 Jul 2012, 11:26    Post subject:  

pemasu wrote:
Quote:
# vlc
VLC media player 2.0.1 Twoflower (revision 2.0.1-0-gf432547)

If you install from the PPM using exprimo repo and typing vlc and then check dependencies ---> PPM find dependencies: qt-basic-with-webkit...and vlc-2.0.1-deps-dpup and installing them along with vlc-2.0.1 and VLC should work.


For what it's worth, I just downloaded and installed VLC 2.0.1 and the dependencies from the Exprimo repo and it works here on the frugal install on my Athlon XP box.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 04 Jul 2012, 11:34    Post subject:  

pemasu wrote:
Thanks Shinobar - Peebee of the bug hunting. Can I do the modification to the 0.6.9 version and include it to the bug fix release using latest woof ?

I am not sure what is the fundamental cause.
'man 8 mount.cifs' shows 'netbiosname' as an option and it is accepted by that on most of puppy. But it is refused on the Dpup.

It is a mystery why the Dpup refuses the option. The 'netbiosname' need only with Windows 9x, i suppose. Anyway, i will try to modify the pnethood to be more universal.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9195
Location: Stratford, Ontario

PostPosted: Wed 04 Jul 2012, 13:40    Post subject:  

@shinobar: netbiosservername is a valid option in Dpup. It just doesn't want to be the FIRST option.
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Wed 04 Jul 2012, 13:47    Post subject:  

I installed VLC 2.01 in my ubuntu Laptop and it works nice.
But I also installed Mozilla-Plugin-VLC 2.01 and it works amazing. The web interface has been completely redesigned. It loads videos quickly, it has a menu and progress bar.

I am wishing VLC 2.01 was available in .pet or .sfs so I could use that plugin to watch youtube.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 04 Jul 2012, 19:03    Post subject:  

rcrsn51 wrote:
@shinobar: netbiosservername is a valid option in Dpup. It just doesn't want to be the FIRST option.

Thanks. the servernetbiosname as a single (separate) option got success.
Quote:
mount.cifs //192.168.11.3/mydoc /mnt/network/PUPPYPC7123/mydoc -o servernetbiosname=PUPPYPC7123 -o username=root,password=woofwoof,nounix,noserverino,iocharset=utf8

I don't know why there is difference between slacko and dpup.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 04 Jul 2012, 21:43    Post subject: pnethood-0.7  

pnethood-0.7.i18n.pet
http://shino.pos.to/party/bridge.cgi?puppy/test/
NOTE: does not contain nbtscan.

#12jan2011 shinobar: refresh button, scanspeed 2 seconds, check if the rcfile exists
#23mar2012 shinobar: use mount.cifs with 'nounix' option(func_mount), UTF-8 encording default
#17may2012 shinobar: extracting sharename
#17may2012 shinobar: i18n
#20jun2012 shinobar: export GTKDIALOG for other func
#5jul2012 shinobar: fix was failed on Dpup Exprimo (servernetbiosname in func_mount)
VERSION=0.7.i18n #shinobar

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 1459
Location: Malvern, Worcs, UK

PostPosted: Thu 05 Jul 2012, 04:36    Post subject: Re: pnethood-0.7  

shinobar wrote:
pnethood-0.7.i18n.pet
VERSION=0.7.i18n #shinobar


Hi Shinobar

Regret to report new version doesn't work - don't think you've included the changed func_mount in this pet???

Thanks
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Thu 05 Jul 2012, 05:37    Post subject: Re: pnethood-0.7  

peebee wrote:
don't think you've included the changed func_mount in this pet???

Oops. Thanks for notifying me.
Download the same filename with new time stamp:
pnethood-0.7.i18n.pet 05-Jul-2012 18:31 18k
http://shino.pos.to/party/bridge.cgi?puppy/test/

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 42 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 40, 41, 42, 43, 44, ..., 87, 88, 89 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1131s ][ Queries: 12 (0.0157s) ][ GZIP on ]