Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 13:04
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 33 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 31, 32, 33, 34, 35, ..., 87, 88, 89 Next
Author Message
smokey01


Joined: 30 Dec 2006
Posts: 1795
Location: South Australia

PostPosted: Wed 20 Jun 2012, 06:54    Post subject:  

shinobar your getnvidia-0.1.pet worked as billtoo described above however, when I installed the pet file it created, it did not work. The sfs it created worked fine although hardinfo didn't display the correct driver information, in fact it just said unknown.

getnvidia-0.1.pet installed the driver correctly and the details can be displayed in hardinfo.

Thanks

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 20 Jun 2012, 10:33    Post subject:  

Gnuxo et al.....
I have now struggled with gstreamer, qupzilla webm support, clementine and got some packages done.

Gstreamer-plugins-deps is mega pack for full gstreamer support and with all needed other libs, bunch of audio-video-etc libs. Full squeeze stuff which has been pulled together by famous trial and error method.

And I have learnt more about gstreamer. If you dont have dependency installed for gstreamer plugin the plugin will be blacklisted. After installing the dependent lib, you need to remove /root/.gstreamer-0.10/registry.i486.bin file and launch the application again.
gst-inspect-0.10 binary launched in console displays the working and blacklisted plugins and give error messages.
# gst-inspect-0.10 -b
Blacklisted files:
libgstmodplug.so
Total count: 1 blacklisted file

Yeah, I was nasty, I left that one unsatisfied. Installing libmodplug and then removing that stupid database file mentioned above and you are ready to go.

What I have. I have that gstreamer-plugins-deps as pet and sfs, which enables clementine and gets webm support for qupzilla. At least sometimes. There is probably still work to be done with webm - html5 -h264 -x264 etc support.

You will need this qt-4.8.0 for gstreamer support:
http://smokey01.com/pemasu/pet_packages-exprimo/qt-4.8.0-phonon-gstreamer-qtwebkit-dpup.pet
http://smokey01.com/pemasu/pet_packages-exprimo/qt-4.8.0-phonon-gstreamer-qtwebkit-dpup.sfs
....or this one
http://smokey01.com/pemasu/pet_packages-exprimo/qt-4.8.0-webkit-phonon-gstreamer-opengl-dpup.pet
http://smokey01.com/pemasu/pet_packages-exprimo/qt-4.8.0-webkit-phonon-gstreamer-opengl-dpup.sfs
..... if you need opengl support like for stellarium.

Gstreamer-plugins-deps.0.0.1: is needed for Clementine and for Qupzilla webm-html5 video support. Maybe other gstreamer apps will be coming....oh yeah...probably powerpoint audiosupport works also with this....
http://smokey01.com/pemasu/pet_packages-exprimo/gstreamer-plugins-deps-0.0.1.pet
http://smokey01.com/pemasu/pet_packages-exprimo/gstreamer-plugins-deps-0.0.1.sfs

Clementine-1.0.1-dpup:
http://smokey01.com/pemasu/pet_packages-exprimo/clementine-1.0.1-dpup.pet
http://smokey01.com/pemasu/pet_packages-exprimo/clementine-1.0.1-dpup.sfs

Stellarium: ---> needs opengl version: qt-4.8.0-webkit-phonon-gstreamer-opengl-dpup, but not gstreamer-plugins-deps package.
http://smokey01.com/pemasu/pet_packages-exprimo/stellarium-0.11.2.pet
http://smokey01.com/pemasu/pet_packages-exprimo/stellarium-0.11.2.sfs

I think these are ok, if you use other qt apps also, like qupzilla, smplayer, umplayer, etc....Then the big sizes is not so overwhelming. Yeah, these stuff are not slim and light, they are fat and high, lol. Dont hung me, I have sore - aching - painful shoulder already.
qupzilla-webm-video.jpg
Description 
jpg

 Download 
Filename  qupzilla-webm-video.jpg 
Filesize  347.32 KB 
Downloaded  180 Time(s) 
clementine.jpg
Description 
jpg

 Download 
Filename  clementine.jpg 
Filesize  697.41 KB 
Downloaded  184 Time(s) 
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Wed 20 Jun 2012, 14:10    Post subject:  

Wow! I can't believe the effort you put in.

Qupzilla always has this error where even if gstreamer is installed, it keeps asking for libgstapp.so.0

Edit: Oh...I forgot to install the deps.pet. Nevermind, Qupzilla works and Html5 works fast.
Better then flash. When I talked to the developers of Qupzilla, they told me that the newest qtwebkit would allow html5 to run fast, but I didn't expect it to work this nice.

Thank you!!!!!!!!!!!!!!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 20 Jun 2012, 15:32    Post subject:  

Good to know Smile Gnuxo. Thank you of the feedback.
One important missing plugins are libgstffmpeg plugins. I have newer ffmpeg and to have working ffmpeg gstreamer plugin, I need to compile it against that newer ffmpeg devel files. I acquired the sgueeze source, patched it with the patch which makes it squeeze version, but....I dont know what ./configure options should I give for it. Ffmpeg has tons of them and what gstreamer expects...I really dont have a glue. It compiles fine but that it can be used for compression and what ever...I need assistance. Maybe I will find them from the net...when I have inspiration to hunt them.
I compiled Thoggen DVD back up dvdripper. It worked. It though was complaining that it would be more happy with ffmpeg gstreamer plugin installed. Something about interlacing would like it. Dunno, lol. The video file was acceptaple. Latest X-men looked just fine.
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Wed 20 Jun 2012, 16:32    Post subject:  

Pemasu, I didn't realize you replied about razorqt.

Anyway, I think that razorqt should be used with eggwm as window manager because it's all qt. I didn't realize how it was to be used. I'll definitely try it out now that I know how to get it working.
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Wed 20 Jun 2012, 18:31    Post subject:  

Hey Pemasu, I took all the .pets for qt-4.8.0 + deps and plugins that you provided, and turned them into an even bigger .sfs

Including focuswriter, clementine and qupzilla.

Of course, I did it as a test of Lazypup's sfs making ability but dpup people can use it too.

Cool

I have no clue where to upload though.
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3215
Location: Ontario

PostPosted: Wed 20 Jun 2012, 19:23    Post subject:  

I describe how I got MyPaint 1.0 to work on Porteus HERE

Using Geoffrey's fine work
I had to make packages for python 2.7.2
and numpy 1.6.2 and then mypaint 1.0

Is it possible to make the packages for Exprimo as well.
I don't have internet connection or I would try myself Crying or Very sad




________________________________________________________
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2057
Location: Ontario Canada

PostPosted: Wed 20 Jun 2012, 22:29    Post subject: Dpup Exprimo 5.X.3.4.2.1 with 3.4.2 kernel.
Subject description: Midnight Commander
 

I made pets of the most recent Midnight Commander file manager, it
needs the slang pet as a dependency.
mcscrn.jpg
 Description   
 Filesize   56.17 KB
 Viewed   1056 Time(s)

mcscrn.jpg

mc-4.8.1.3-i686.pet
Description 
pet

 Download 
Filename  mc-4.8.1.3-i686.pet 
Filesize  940.05 KB 
Downloaded  155 Time(s) 
mc_NLS-4.8.1.3-i686.pet
Description 
pet

 Download 
Filename  mc_NLS-4.8.1.3-i686.pet 
Filesize  715.46 KB 
Downloaded  143 Time(s) 
mc_DOC-4.8.1.3-i686.pet
Description 
pet

 Download 
Filename  mc_DOC-4.8.1.3-i686.pet 
Filesize  689.47 KB 
Downloaded  146 Time(s) 
slang-2.2.4-i686.pet
Description 
pet

 Download 
Filename  slang-2.2.4-i686.pet 
Filesize  456.94 KB 
Downloaded  150 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 21 Jun 2012, 07:51    Post subject:  

Thanks Billtoo. I have played with your mc. Only non-Puppy feature was that the config files are in /usr/etc/mc...not in /etc/mc...

This incantation helps... ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
Sorry...couldnt resist....Smile

I have puppified the /usr/etc/mc/mc.ext config file.
With attached modified config file...you can browse .pet files content...music files open in Pmusic and starts to play, image files open in Viewnior...video files in Gnome-Mplayer.

Since I use LibreOffice....and Geany of course...I changed the default document file opener to be LibreOffice 3.5. Time to change to that. Lol. It opens now also pptx, docx, xlsx files in LibreOffice also. It is easy to change them to your liking in that mc.ext file as you want.
Pdf files opens in epdfview which is in fact Evince in dpup. Symlink only left.

Test mc...it is nice...best in console state filemanager.
mc-puppified-conf-file-0.0.1.pet
Description 
pet

 Download 
Filename  mc-puppified-conf-file-0.0.1.pet 
Filesize  6 KB 
Downloaded  158 Time(s) 

Last edited by pemasu on Thu 21 Jun 2012, 16:17; edited 1 time in total
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2057
Location: Ontario Canada

PostPosted: Thu 21 Jun 2012, 08:19    Post subject:  

pemasu wrote:
Thanks Billtoo. I have played with your mc. Only non-Puppy feature was that the config files are in /usr/etc/mc...not in /etc/mc...

This incantation helps... ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
Sorry...couldnt resist....Smile

I have puppified the /usr/etc/mc/mc.ext config file.
With attached modified config file...you can browse .pet files content...music files open in Pmusic and starts to play, image files open in Viewnior...video files in Gnome-Mplayer.

Since I use LibreOffice....and Geany of course...I changed the default document file opener to be LibreOffice 3.5. Time to change to that. Lol. It opens now also pptx, docx, xlsx files in LibreOffice also. It is easy to change them to your liking in that mc.ext file as you want.
Pdf files opens in epdfview which is in fact Evince in dpup. Symlink only left.

Test mc...it is nice...best in console state filemanager.


Thanks, I thought launching applications and opening mp4 files was pretty good but this is better Smile

BTW.. I added xine and xine ui from the squeeze repo, it's working well, it plays one movie dvd that we bought while gnome mplayer, vlc, etc can't play it.
image-11.jpg
 Description   
 Filesize   51.32 KB
 Viewed   1002 Time(s)

image-11.jpg

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 21 Jun 2012, 09:34    Post subject:  

Billtoo. If we forget about mc and speak about Rox-Filer, there should be Rox right click for mediaplayer launching, it should recognize most audio - video formats and just right clicking the file you can launch it.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 21 Jun 2012, 13:35    Post subject:  

I tested how latest Deadbeef-0.5.5 compiles from source, installs, plays audio files, streams net radios and converts audio formats to other ones. Conversion from audio format to mp3 and ogg and from cd audio to mp3 for example works. Just right click the track or tracks and select convert and tick the boxes or select from drop downs.
I placed the oggenc to the pet so that conversion to ogg works.

I couldnt get the .aac to play whatever I tried. It hasnt worked for me earlier, so no news. I just dont know what devel libs should I install or what libs I am missing. Checking whatever dependencies does not reveal anything for .aac.

I didnt enable all possible formats for Deadbeef. Here is list what works and what doesnt:
Plugin Summary:
stdio: yes - Standard IO plugin
gme: no - chiptune music player based on GME
nullout: no - NULL output
alsa: yes - ALSA output
sid: no - SID player based on libsidplay2
ffap: no - Monkey's audio (APE) decoder
lastfm: yes - last.fm scrobbler
mpgmad: yes - mpeg player based on libmad
vorbis: yes - ogg vorbis player
flac: yes - flac player
wavpack: yes - wavpack player
sndfile: yes - PCM (wav,aiff,etc) player based on libsndfile
vtx: no - vtx file player (ay8910/12 emulation)
adplug: no - adplug player (OPL2/OPL3 emulation)
vfs_curl: yes - http/ftp streaming support
cdda: yes - cd audio player
gtkui: yes - GTK user interface
hotkeys: yes - Global hotkeys support
ffmpeg: yes - ffmpeg codecs
oss: no - oss output plugin
pulse: no - PulseAudio output plugin
artwork: yes - Cover art plugin
supereq: yes - Equalizer based on Super EQ library by Naoki Shibata
notify: no - notification-daemon support plugin
shellexec: yes - shell commands plugin
musepack: no - musepack player plugin
wildmidi: yes - WildMidi player plugin
tta: no - TTA player plugin
dca: no - libdca (DTS Audio) player plugin
aac: yes - AAC player (m4a, aac, mp4) based on FAAD2
mms: yes - mms streaming support
dsp_src: yes - High quality samplerate conversion using libsamplerate
m3u: yes - M3U and PLS playlist support
vfs_zip: no - zip archive support
converter: yes - plugin for converting files to any formats
psf: no - PSF format plugin, using AOSDK
dumb: no - DUMB module plugin, for MOD, S3M, etc
shn: no - SHN plugin based on xmms-shn
mono2stereo: yes - mono2stereo DSP plugin
shellexecui: yes - GTK user interface for configuring shellexec plugin

Libiconv is nowadays mandatory dependency. I compiled it and upload it also.
If you want to replace existing deadbeef, remove first /usr/lib/deadbeef folder from the preinstalled 0.4.4 version. Overwriting might work, but if there is differently named plugins, you will get errors of unknown symbols or something like that.
And to make it default audioplayer, change /usr/local/bin/defaultaudioplayer to deadbeef, then you can use rox right click > defaultaudioplayer or better....just click the audio file.
deadbeef_NLS-0.5.5.pet
Description 
pet

 Download 
Filename  deadbeef_NLS-0.5.5.pet 
Filesize  303.16 KB 
Downloaded  148 Time(s) 
deadbeef-0.5.5.pet
Description 
pet

 Download 
Filename  deadbeef-0.5.5.pet 
Filesize  762.99 KB 
Downloaded  179 Time(s) 
libiconv-1.14.pet
Description 
pet

 Download 
Filename  libiconv-1.14.pet 
Filesize  1.29 MB 
Downloaded  178 Time(s) 

Last edited by pemasu on Fri 22 Jun 2012, 13:05; edited 1 time in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 21 Jun 2012, 16:24    Post subject:  

Billtoo. I was wondering about thas slang dependency in mc ie midnight commander. I checked the ./configure --help and yes....slang and ncurses are choicable. Ncurses is already included in dpup.

I compiled it with this:
# ./configure --prefix=/usr --sysconfdir=/etc --with-screen=ncurses --without-gpm-mouse --disable-doxygen-doc --disable-doxygen-dot --disable-doxygen-html

Without slang and somehow also the mc compile as packaged is smaller.

This one has the puppified /etc/mc/mc.ext included.
Sorry about my duplicate work, but since I like mc and I have mc-4.8.1 already in exprimo repo, I wanted that extra dependency checked...it really bothered me....
mc-4.8.3.pet
Description 
pet

 Download 
Filename  mc-4.8.3.pet 
Filesize  589.87 KB 
Downloaded  141 Time(s) 
mc_NLS-4.8.3.pet
Description 
pet

 Download 
Filename  mc_NLS-4.8.3.pet 
Filesize  754.91 KB 
Downloaded  148 Time(s) 
mc_DOC-4.8.3.pet
Description 
pet

 Download 
Filename  mc_DOC-4.8.3.pet 
Filesize  691.38 KB 
Downloaded  151 Time(s) 

Last edited by pemasu on Thu 21 Jun 2012, 17:00; edited 1 time in total
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2057
Location: Ontario Canada

PostPosted: Thu 21 Jun 2012, 16:46    Post subject:  

pemasu wrote:
Billtoo.
This one has the puppified /etc/mc/mc.ext included.
Sorry about my duplicate work, but since I like mc and I have mc-4.8.1 already in exprimo repo, I wanted that extra dependency...it really bothered me....


No problem Smile

Have you tried to compile xine in exprimo, I couldn't, problem with ffmpeg,I tried to compile the latest ffmpeg by using the ./configure line that you have, got into a bit of a mess.
I restored my backup savefile and all is good again.
My compiling skills are weak but I try Smile
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 21 Jun 2012, 16:58    Post subject:  

Billtoo. No..I havent ever compiled xine. You could install the ffmpeg dev pet from the link. It should be in the devx sfs, but you never know.
I have succesfully used the ffmpeg dev stuff, when I have compiled ffmpeg dependent apps.
But Xine is new for me.
Yeah. Ffmpeg is sometimes tricky. And dont install ffmpeg devel stuff from squeeze repos. They conflict with mine compile.

http://smokey01.com/pemasu/pet_packages-exprimo/ffmpeg_DEV-0.9.1.pet
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 33 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 31, 32, 33, 34, 35, ..., 87, 88, 89 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1280s ][ Queries: 12 (0.0229s) ][ GZIP on ]