Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 27 Aug 2014, 21:19
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.4.12 with 3.4.2 kernel.
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 15 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 87, 88, 89 Next
Author Message
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Mon 09 Apr 2012, 11:04    Post subject: sfs_load  

pemasu wrote:
I havent managed to crash kernel or sfs_load in 5.X.3.2.14 with several google-chrome.sfs loading-unloading cycle.

Jemimah's patch nicely avoids the kernel crash. But i found the sfs_load-1.3, due to its another bug, consumes the loop devices when we load/unload multiple sfs's.
http://www.murga-linux.com/puppy/viewtopic.php?p=618565#618565

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 09 Apr 2012, 11:50    Post subject:  

Ok. I will reupload 5.X.3.2.14 with your updated sfs_load...soon.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 09 Apr 2012, 12:38    Post subject:  Dpup Exprimo 5.X.3.2.14 with cpu 2 and up optimization  

Also works great on my laptop with intel i7 processor, although I was lazy and just updated my save file versus a fresh install on the desktop. Very Happy It's very fast.

Thanks,
Jim
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 09 Apr 2012, 16:31    Post subject:  

I have reuploaded Dpup Exprimo 5.X.3.2.14. Sfs_load has been updated to the Shinobar`s latest. That is the main fix. Pburn updated to the latest. I also noticed the wrong suffix in /lib/modules/3.2.14-ski... not the meant -dpup. Fixed also. I used kernel builder script from the saluki 3.2.13-pae and forgot to change that suffix in script. I just changed the package name suffix...lol. One fine tuning to the e17 so that Lxterminal is shown in ibar.
Otherwise the same as original. Overall...I recommend to use this version. I am Sorry...to those whom have already downloaded the first version.

Download link: http://www.smokey01.com/pemasu/DpupSqueeze5X/DpupExprimo5X3214/

Kernel sources: http://www.smokey01.com/pemasu/Kernel_sources/kernel-3.2.14/
DpupExprimo-5.X.3.2.14-jwm-desktop.jpg
 Description   
 Filesize   31.41 KB
 Viewed   624 Time(s)

DpupExprimo-5.X.3.2.14-jwm-desktop.jpg

Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1802
Location: South Australia

PostPosted: Mon 09 Apr 2012, 18:25    Post subject:  

pemasu, so far looks nice and works well. Posting from 3.2.14 now.

I have discovered that the IP Info gui will not close when invoked from the tray. The cancel button does not work.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5720
Location: Kentucky

PostPosted: Mon 09 Apr 2012, 19:22    Post subject:  

Fresh manual frugal install of 5.X.3.2.14 on the Athlon XP box. Sound,internet and display all working and correct on initial boot. GetFlash worked too. Laughing

# report-video
Dpup Exprimo, version 5.X.3.2.14 on Mon 9 Apr 2012

Chip description:
0.0 VGA compatible controller
nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1)
oem: NVidia
product: NV18 () Board Chip Rev A2

X Server: Xorg
Driver used: is

X.Org version: 1.7.7
dimensions: 1440x900 pixels (411x263 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
#
"nv" actual driver.

-Computer-
Processor : AMD Athlon(tm) XP 2400+
Memory : 1033MB (182MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Mon 09 Apr 2012 06:21:01 PM CDT
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : VIA8233 - VIA 8235


Also did a full install on an old P4 test box....uptime about 15 minutes and the mouse is still working.Going to reboot and see what happens.
Exprimo 5.X.3.2.14.png
 Description   
 Filesize   173.52 KB
 Viewed   606 Time(s)

Exprimo 5.X.3.2.14.png

Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5720
Location: Kentucky

PostPosted: Mon 09 Apr 2012, 19:25    Post subject:  

Well, that was quick..........rebooted the full install of 5.X.3.2.14 and mouse was immediately frozen as soon as desktop became visible.

No such problem on the frugal install.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 09 Apr 2012, 19:56    Post subject: Dpup Exprimo 5.X.3.2.14 with cpu 2 and up optimization  

Something happened with the reuploaded version. Now, the usb logitech receiver for the wireless mouse has to be removed and reinserted in order to work after reboot.. I just used the same save file that had been generated with a fresh installation of the original upload. It had one other problem, the Nividia driver was trashed and had to be reinstalled. Now, except for the mouse problem, everything appears to be working properly.

I will try it without a save file and report back if there is any change.

EDIT: New save file does not have the mouse problem reported above.

Last edited by Jim1911 on Mon 09 Apr 2012, 20:06; edited 1 time in total
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5720
Location: Kentucky

PostPosted: Mon 09 Apr 2012, 19:57    Post subject:  

In a different frugal Exprimo install....

A snippet of the Xorg.0.log from 5.X.3.2.14....


Code:
(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Device: "/dev/mouse"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: always reports core events
(**) Option "Device" "/dev/mouse"
(EE) xf86OpenSerial: Cannot open device /dev/mouse
   No such file or directory.
(EE) Mouse0: cannot open input device
(EE) PreInit failed for input device "Mouse0"
(II) UnloadModule: "mouse"
(**) Option "CoreKeyboard"
(**) Keyboard0: always reports core events
(**) Option "Protocol" "standard"



After the ps/2 mouse froze trying a usb mouse failed as well.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5720
Location: Kentucky

PostPosted: Mon 09 Apr 2012, 21:13    Post subject:  

Just for comparison purposes, I just did a full install of Saluki 018......... no mouse problems yet and I've rebooted twice.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 09 Apr 2012, 22:37    Post subject: Dpup Exprimo 5.X.3.2.14 with cpu 2 and up optimization  

Double post.
Last edited by Jim1911 on Mon 09 Apr 2012, 22:40; edited 1 time in total
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 09 Apr 2012, 22:38    Post subject: Dpup Exprimo 5.X.3.2.14 with cpu 2 and up optimization  

Upgraded 5.X.3.2.11 save file on an old Dell desktop with a 2 core intel processor. Upgrade was fine and everything appears to be working including a usb logitech wireless mouse, identical to those on my other systems.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Tue 10 Apr 2012, 00:29    Post subject: mount command for ntfs  

Not a big problem but note.
Suppose sda1 is a ntfs partition. Next command fails on Dpup Exeprimo 3.X.3.2.14.
Code:
mkdir -p /mnt/sda1
mount /dev/sda1 /mnt/sda1

Whereas no problem on lupu-528 nor wary-5.3. I remember some old version of puppy has the same problem.
With '-t ntfs' option is safe for Dpup Exeprimo and also most of Puppy.
Code:
mount -t ntfs /dev/sda1 /mnt/sda1

I suspect the version issue of the mount-FULL.
versions:
ntfs-3g
lupu 2010.3.6
dpup 2010.3.6
wary 2010.8.8

mount-FULL
lupu util-linux 2.13-pre7
dpup util-linux-ng 2.17.2
wary util-linux-ng 2.18

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 10 Apr 2012, 01:22    Post subject:  

James C. In full install somehow the symlink from /dev/input/mice to /dev/mouse does not appear or alternatively symlink from /dev/psaux to /dev/mouse

ln -snf /dev/input/mice /dev/mouse or ln -snf /dev/psaux /dev/mouse
should fix the freezing mouse. I suspect that something with PUI or with rc.sysinit does not function properly in dpup builds.

About mounting ntfs. Needs inspection.

Last edited by pemasu on Tue 10 Apr 2012, 02:26; edited 1 time in total
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2617
Location: Japan

PostPosted: Tue 10 Apr 2012, 01:38    Post subject: ANOUNCE: updated pupsaveconfig-2.2  

Long persistent bug of pupsaveconfig.
Was failed with the bootfash comboformat install. Thanks to Ghost Dog who reported this.
# v2.2 8apr12: fix was failed with no space partition(tnx to Ghost Dog), fix was failed with SAVEMARK, fix was failed mmc card, default partition and folder, exit 0 (thanks to don)
# v2.2 10apr12: sync with woof 20409, kill acpid (rc.shutdown)
http://www.murga-linux.com/puppy/viewtopic.php?p=618719#618719

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 15 of 89 [1330 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 87, 88, 89 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0875s ][ Queries: 12 (0.0117s) ][ GZIP on ]