Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 23 Oct 2017, 11:42
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Misc
What PETs work with what versions of Puppy?
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
anewuser

Joined: 05 Feb 2012
Posts: 69

PostPosted: Tue 14 Feb 2012, 18:53    Post subject:  What PETs work with what versions of Puppy?
Subject description: What exactly is the extent of PETs usage between revisions? - info.
 

I'm a newbie *bares chest with n00b tatoo on it* I would like to ask for help, I just didn't know where to put these doubts and hoped a mod would sort in the proper place. Hope you can help =)

About pets (aka little plugins-extensions-programs that add more functionality to the OS)

1. What does it mean for a .PET to be compiled in a particular OS&revision of that OS to the end user (eg 'compiled in wary5.0' 'compiled in racy 5.25' etc)?

2. Are .PETs interchangeable between puppies? (eg something compiled for Slacko would work on wary?)

3. A .PET compiled on 'puppy4.2.x' would work on Wary5.0?

4. .PETs compiled in a higher revision of a dev line would in a lower revision of that dev line? (eg say revision 5.1 or 5.1.1 or even Wary Puppy 5.2.2's PET would work on wary puppy 5.0?)

Thank you in advance, and here's hoping I made myself clear without repeting myself much.

PD: tiny request? .PET of audacious for wary5.0 please (the ones on the board gave me missing libraries (which I'll post the moment I get a chance) Reason to this is to find a way to play module file formats on linux/puppy. There is no xmplay on linux afaik.
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Tue 14 Feb 2012, 19:09    Post subject:  

Pets should never be assumed interchangeable between versions. Sometimes it works - sometimes not.

An older pet is more likely to work on a newer puppy than the reverse.

When you compile a package, it looks at all the specifics of your OS and builds the program customized for that OS. Simpler programs need fewer specifics than complex ones - so simple stuff tends to be more portable.
Back to top
View user's profile Send private message Visit poster's website 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Tue 14 Feb 2012, 19:48    Post subject:  

I built this on Saluki - it hopefully should work on wary5.
http://smokey01.com/saluki/pet_packages-saluki/audacious-3.2-i486.pet

It needs dbus and dbus-glib
http://smokey01.com/saluki/pet_packages-saluki/dbus-1.4.16-i486.pet
http://smokey01.com/saluki/pet_packages-saluki/dbus-glib_DEV-0.98-i486.pet
Back to top
View user's profile Send private message Visit poster's website 
anewuser

Joined: 05 Feb 2012
Posts: 69

PostPosted: Sun 19 Feb 2012, 12:46    Post subject:  

Makes sense all around.

Downloaded pets. Will post back if they work on a wary set up without customizations of any kind.

ty
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2544
Location: near here

PostPosted: Sun 19 Feb 2012, 14:50    Post subject:  

here's some more info-

http://puppylinux.org/wikka/Pets

@jemimah i've included some of your post there - hope that's cool Arrow

_________________
helping Wiki for help
Back to top
View user's profile Send private message Visit poster's website 
anewuser

Joined: 05 Feb 2012
Posts: 69

PostPosted: Tue 21 Feb 2012, 18:29    Post subject: OFFTOPIC  

OFFTOPIC @ community
@jemimah
jemimah wrote:
I built this on Saluki - it hopefully should work on wary5.
http://smokey01.com/saluki/pet_packages-saluki/audacious-3.2-i486.pet

It needs dbus and dbus-glib
http://smokey01.com/saluki/pet_packages-saluki/dbus-1.4.16-i486.pet
http://smokey01.com/saluki/pet_packages-saluki/dbus-glib_DEV-0.98-i486.pet


Nope, no go.

Missing libraries (horrible settings for the png btw) http://img832.imageshack.us/img832/6590/missingh.png

Log at http://pastebin.com/hC3ak0QB

What would be next besides trying to find the missing libraries? This is on a machine with no internet access, and no hdd (my os and applications are fixed so to speak meaning that I can't add to the current CD more updated files) I bring this up in hope that those libraries (or the files needed could be loaded as pet in the sense that the OS will load from pendrive instead of CD certain files. Wonder if a restart of the current system used in RAM could be used...(for sfs/devx loading)
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Tue 21 Feb 2012, 19:37    Post subject:  

Opps the pet is bad. I will reupload it in a bit.
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15235
Location: Paradox Realm

PostPosted: Tue 21 Feb 2012, 21:07    Post subject:  

Quote:
I'm a newbie *bares chest with n00b tatoo on it*


Pah Smile

We will have you penguinated in no time . . .
http://www.murga-linux.com/puppy/viewtopic.php?p=526#526

Puppy Linux
Immune to Kryptonite

_________________
YinYana AI Buddhism
Back to top
View user's profile Send private message Visit poster's website 
anewuser

Joined: 05 Feb 2012
Posts: 69

PostPosted: Mon 12 Mar 2012, 15:36    Post subject:  

OT

Found an audacious pet with a -w5.pet on the site (or its repositories, can't find where atm). But the label means it was compiled within wary, whish is the branch I'm using.

Working fine all around.
Phew, finding pets for older setups is difficult even with all the community help.

@lobster I'm really n00b, or I'm too used to windows and its hierarchy system, and it's ways and conceptions...yuk! Slowly getting used to this new naming scheme&hierarchy.
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 30 Jun 2016, 06:16    Post subject: Audacious 3.7.2 will run only with Xenialpup 7.0.2 as GTK3  

2016 : Audacious 3.7.2 will run only with Xenialpup 7.0.2 as GTK3 needed.
However, our french compiler Medor did a version Audacious 3.7.2 Gtk2 for his Slaxen (Slacko 5.9.3)
Information Medor, by a click

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
learnhow2code

Joined: 12 Jun 2016
Posts: 1015

PostPosted: Thu 30 Jun 2016, 07:25    Post subject: Re: What PETs work with what versions of Puppy?
Subject description: What exactly is the extent of PETs usage between revisions? - info.
 

anewuser wrote:
Are .PETs interchangeable between puppies? (eg something compiled for Slacko would work on wary?)


mine are in python, so if you install in tahr they work; but if you install in a puppy without python, you will also need the dev sfs. or python 2, which the dev sfs provides.

_________________
users | devs
fig os 1.3 md5
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Misc
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0474s ][ Queries: 11 (0.0036s) ][ GZIP on ]