Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 09:29
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Songbird 2.3.0a nightly builds (unstable)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Author Message
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sat 04 Feb 2012, 16:48    Post subject:  Songbird 2.3.0a nightly builds (unstable)
Subject description: music manager dot-pets
 

Songbird is an extensible music manager and web browser.
http://getsongbird.com/

These packages may be unstable! If you would like to use the last stable release, please see this thread instead.

Songbird dropped official support and testing for Linux a while ago, but nightly builds are still available. (If you want an alternative with official Linux support, maybe take a look at Nightingale, which is a fork of Songbird.)

I've installed and tested it on Slacko-531. It complains about a few gstreamer libraries and such on startup, but everything seems to work well nonetheless.


2.3.0a, build 2452
songbird-2.3.0a-2452-i686.pet (22.3 MB)

Checksums (MD5) for all packages
md5sum.txt
----------------------
A few extensions/plugins can be found at the links below, and several from the Songbird plugins site also seem to work nicely.
2.3.0a, build 2452
----------------------

I keep Songbird installed mainly for its 7digital plugin, that being one of too-few ways to download music from an online store from Puppy, but it's a good media player in its own right. The browser seems stable, too- I actually used it to make this thread, Yes playing in the background. Cool

Last edited by TheAsterisk! on Thu 14 Feb 2013, 20:49; edited 34 times in total
Back to top
View user's profile Send private message Visit poster's website 
darkcity


Joined: 23 May 2010
Posts: 2411
Location: near here

PostPosted: Sat 04 Feb 2012, 19:08    Post subject:  

Downloaded and working on Puppy 5.28 Cool Cool

using dogmazic search engine.

Can Songbird access internet radios ?

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5458
Location: Finland

PostPosted: Sun 05 Feb 2012, 04:48    Post subject:  

Thank you of this treasure. Songbird definitively plays internet radios with Shoutcast plugin. I tested it and then I did implement it to the base package so that it is preinstalled. Worked fine...didnt even ask would you like to install the plugin...it just was there.
Songbird complains about missing libpulse and gstreamer pulse dependencies but Puppy does not need them and it does not hurt the usage.
Shoutcast plugin was non working when I did upload my first Snow Puppy and then I removed Songbird. Now Songbird offers working Shoutcast again. That is great. No more need for Python and Streamtuner2 which by the way takes space as much.

Thanks. I tested this in dpup exprimo. Libwavpack was the only missing lib I did add.
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2411
Location: near here

PostPosted: Sun 05 Feb 2012, 06:45    Post subject:    

Songbird + Shoutcast working in Puppy 5.29

nice work

Twisted Evil

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 05 Feb 2012, 06:56    Post subject:  

Happy it's wanted and working so far!

pemasu wrote:
Thanks. I tested this in dpup exprimo. Libwavpack was the only missing lib I did add.

Ah. Sorry about that.

I see, looking back, that somehow I've included symlinks to the library, but not the library itself. Embarassed

I've been running it like that for a while with no noticeable downside, though, so I guess I don't have any *.wv files. I thought I did, though... Anyway, it might be better if everyone were to install a wavpack package for their own Puppy version. I'll see if the forums have already delivered that, or if I need to make a few packages myself.

Sorry, everyone!

EDIT: I'm going to cut out wavpack from my package, and link to a few wavpack packages in the first post instead. I'm also going to cut out the extra (not the built-in) gstreamer libraries I'd added before, since it would likely be better to use gstreamer packages known to work with your Puppy version, if possible. I'll link to a thread with some of those packages, too.

Last edited by TheAsterisk! on Sun 05 Feb 2012, 08:47; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 05 Feb 2012, 08:19    Post subject:  

Package trimmed slightly, reuploaded. Information added to first post. (See previous post, above, for further information & clarification.)

No version change.
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sat 18 Feb 2012, 18:57    Post subject:  

I originally wanted to make a package of version 1.10.2, which is more or less the last stable version- even though that version is also unsupported on Linux- but couldn't find a download anywhere. (The Songbird wiki had some links, but they were dead.) That's why I ended up making a package of one of the nightly builds.

Well, I've found a way. On GetDeb.net, a sort of auxiliary repository for Ubuntu, down in the guts of their server (no public link to it, just manually editing the URL), next to their Ubuntu packages for Songbird, they had also uploaded the generic binaries.


I am most pleased.

(For future reference, the link in question is http://archive.getdeb.net/ubuntu/rpool/.)

I'll probably make a package for that, now that I can get at it.

I think I'll still update the nightly builds here, too- in fact, a new package should be up this evening, and I'll update the thread once it is.
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sat 18 Feb 2012, 21:51    Post subject:  

Updated from build 2208 to build 2214. Both versions still available.

I've also made a thread for a (stable) package of Songbird 1.10.2. Click the appropriate link in the first post, or just head up one level to the Multimedia sub-forum and browse.
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 04 Mar 2012, 12:59    Post subject:  

Updated to 1.12.0a, build 2222. Older packages are still available, should you need or want them.
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 11 Mar 2012, 12:54    Post subject:  

Updated to 1.12.0a, build 2230. Older packages are still available, should you need or want them.
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Mon 16 Apr 2012, 11:34    Post subject:  

UPDATED to 1.12.0a, build 2273.
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sat 28 Apr 2012, 09:15    Post subject:  

Updated to 1.12.0a build 2276

Older builds removed (post or PM if you need a copy). Two most recent (1.12.0a, builds 2276 and 2273) retained.
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Fri 01 Jun 2012, 15:55    Post subject:  

UPDATED to version 2.1.0 alpha build 2301

Older builds will be removed soon.
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sun 03 Jun 2012, 00:12    Post subject:  

Updated to 2.1.0 alpha build 2303
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Fri 29 Jun 2012, 14:01    Post subject:  

Updated to 2.1.0 alpha build 2318
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0625s ][ Queries: 11 (0.0039s) ][ GZIP on ]