Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Sep 2014, 05:51
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Old story - Broadcom wifi driver problem
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
japfin

Joined: 29 Nov 2011
Posts: 7

PostPosted: Wed 30 Nov 2011, 05:40    Post subject:  Old story - Broadcom wifi driver problem  

First of all. This will be my last broadcom wifi laptop that I own. What a hassle always to get the wifi to work.

So, I am planning to do a USB puppy with Japanese and Chinese reading-writing support for Firefox and LibreOffice. Nice idea that I probably have to postpone until I get a new laptop with different wifi manufacturer.

First I tried Lucid Puppy 5.2.8 and everything looked good. Lucid was able to locate Broadcom and I was able to connect internet by wifi without problem. First linux distro ever to do that for me. Big thumps up for that!

Unfortunately, it was not going to last. It worked flawlessly even after many reboots until I made a save file. After restarting puppy with save file Lucid lost wifi. I checked this many times and Lucid always found wifi without save file, but with save file nothing.

No problem, I came here and found piratesmack pet file to solve problem.
http://www.murga-linux.com/puppy/viewtopic.php?p=421596#421596

I read whole topic and tried different ways to get my wifi working again, without avail. I got my wifi button to light up once, but it never got to show me a list of available modems.

So, I thought to try other versions of puppies. Shinobar's TOP 4.2.1, no wifi, Slacko 5.3, no wifi.

Then I got tired. This is not a puppy's fault, but that lousy Broadcom hardware. Curse them for their lack of linux support.

So, this topic is my last try. If anyone can give me any hint what to do, I would really appreciate it. If my case is a lost case, then I will just wait until I renew my laptop and try puppy again.

Thanks!

05:02.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)

Compaq Presario V2000 PV340AV-ABA
AMD Turion(tm) 64 Mobile Technology ML-28

Ps. I tried Frisbee. No use after losing wifi.
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3411
Location: Sydney Australia

PostPosted: Wed 30 Nov 2011, 06:16    Post subject:  

japfin:

Good day mate....welcome to Puppy.

Hang in there for Sir Tempe or others to help you out.

I know your pain.

I have a friend's EEE Pc...cannot get wireless to work.

BROADCOM crapola.

Sees the network....never connects.
And I'm a great cheater.

Meantime...why not get a wireless dongle >> Raylink etc.
Cheap these days.

Beat the frustration.

I have one 4 testing.

>>> rt2870.inf = N150

= N150 ....rt3572sta-v2.5.0.0-k2.6.33.2.pet

"""""""

I had one I gave to my daughter N300

Both worked great....with Pets.

Chris.
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3411
Location: Sydney Australia

PostPosted: Wed 30 Nov 2011, 06:43    Post subject:  

I also saw this.

Why not try it to see if the save works.

""""""""

http://www.murga-linux.com/puppy/viewtopic.php?t=70855&start=645

playdayz

" There is an updated version of the Lucid 5.2.8 ISO now posted in
the first message of this thread.

It contains all current updates so nothing else is necessary."

""""""""""

Just saw this.

nickdobrinich

" Miracle of miracles,

LHP64 has the correct drivers for Dell laptop Broadcom wireless cards.

I have struggled for months with 5.03g getting only occasional
wireless connectivity on various Dell laptops.
Bless you. "

http://www.murga-linux.com/puppy/viewtopic.php?t=73762

Chris.
Back to top
View user's profile Send private message 
japfin

Joined: 29 Nov 2011
Posts: 7

PostPosted: Wed 30 Nov 2011, 07:00    Post subject:  

cthisbear:

External USB wifi could be one solution. I will give it a thought. Somehow it just makes me mad to play with Broadcom.

Will try updated version.

Thanks!
Back to top
View user's profile Send private message 
japfin

Joined: 29 Nov 2011
Posts: 7

PostPosted: Wed 30 Nov 2011, 07:55    Post subject:  

Unfortunately updated version of Lucid is doing the same thing. Without save file wifi is working and after save file is created lucid puppy cannot connect wifi anymore.

It is the same wifi log notice as before

"Microcode not responding"
Back to top
View user's profile Send private message 
japfin

Joined: 29 Nov 2011
Posts: 7

PostPosted: Wed 30 Nov 2011, 08:06    Post subject:  

dmesg output:

b43-phy0: Broadcom 4318 WLAN found (core revision 9)
ATI IXP MC97 controller 0000:00:14.6: PCI INT B -> GSI 17 (level, low) -> IRQ 17
MC'97 0 converters and GPIO not ready (0x1)
ATI IXP AC97 controller 0000:00:14.5: PCI INT B -> GSI 17 (level, low) -> IRQ 17
phy0: Selected rate control algorithm 'minstrel'
Registered led device: b43-phy0::radio
Broadcom 43xx driver loaded [ Features: PML, Firmware-ID: FW13 ]
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (10059 buckets, 40236 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
b43 ssb0:0: firmware: requesting b43/ucode5.fw
b43 ssb0:0: firmware: requesting b43/pcm5.fw
b43 ssb0:0: firmware: requesting b43/b0g0initvals5.fw
b43 ssb0:0: firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0 ERROR: Initial Values Firmware file-format error.
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.

lspci output

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc SB400 AC'97 Modem Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
05:09.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Wed 30 Nov 2011, 10:56    Post subject:  

Haven't had any bcm4318 problem on a Dell d610 using
Wary.

http://murga-linux.com/puppy/viewtopic.php?search_id=505989724&t=47587

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
japfin

Joined: 29 Nov 2011
Posts: 7

PostPosted: Wed 30 Nov 2011, 11:00    Post subject:  

Deleted the message. See below.
Last edited by japfin on Wed 30 Nov 2011, 11:39; edited 1 time in total
Back to top
View user's profile Send private message 
japfin

Joined: 29 Nov 2011
Posts: 7

PostPosted: Wed 30 Nov 2011, 11:38    Post subject:  

OK now I understand my problem little bit more. Still, I do not know what to do with it.

I have Ubuntu 11.10 installed in this laptop. It seems like puppy and ubuntu are in conflict with wifi driver.

Following cause of action turn wifi on in puppy:

Open ubuntu, turn wifi off and on again by pressing wifi button. Shut down ubuntu ja open puppy -> wifi works.

Close puppy and open puppy -> wifi does not work.

Open ubuntu, press wifi button off and on again, open puppy -> wifi works.

So, does my ubuntu install somehow interfere puppy configuration? What could I do?
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Wed 30 Nov 2011, 12:28    Post subject:  

japfin wrote:


So, does my ubuntu install somehow interfere puppy configuration? What could I do?


Sometimes, after being booted into XP or another Puppy,
my connection will have dropped.
A right click on the connect icon, then "autoconnect"
usually fixes it.

I never bother with off-on button.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
japfin

Joined: 29 Nov 2011
Posts: 7

PostPosted: Thu 01 Dec 2011, 10:23    Post subject:  

Thank you for your reply!

Unfortunately, it did not work with my problem. Because of some reason, puppy do not load broadcom drivers in start up. I assume that it has something to do with shut down process, when puppy is shutting down wifi. If another linux distro uses wifi then puppy also finds it. Maybe something to do with improper loading of wifi driver in my case.

I will leave it here. If I need wifi in puppy I can always come through ubuntu.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0750s ][ Queries: 11 (0.0076s) ][ GZIP on ]