Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 00:12
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Saluki
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 50 of 250 Posts_count   Goto page: Previous 1, 2, 3, ..., 48, 49, 50, 51, 52, ..., 248, 249, 250 Next
Author Message
mavrothal


Joined: 24 Aug 2009
Posts: 1731

PostPosted: Tue 24 Jan 2012, 15:34    Post_subject:  

Luki is looking good so here are few little usability things you may want to take care at some point, for a good first impression Very Happy

some folders in /root have 700 permissions (so apps ca not write in them)
no savefile-size option in the new first shutdown savedialog
no save icon on the desktop if legacy save is picked (legacy...)
"save" in the shutdown screen is easy to miss
no builtin_files in the adrv
the mixer icon on the tray is hardly visible
geany fonts too big
geany save file dialog too big if dpi is adjusted (more than 900px vertical)

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send_private_message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Tue 24 Jan 2012, 17:50    Post_subject: xgamma-gui  

It seems there is a very old version of xgamma-gui in Saluki which is buggy.
fix:
replace /usr/sbin/xgamma-gui with this version
details about bugfix here
Cool emil
Back to top
View user's profile Send_private_message Visit_website 
Billtoo


Joined: 07 Apr 2009
Posts: 2138
Location: Ontario Canada

PostPosted: Tue 24 Jan 2012, 19:03    Post_subject: Saluki
Sub_title: goggles music manager
 

@jemimah

I made an sfs file of Goggles Music Manager 0.12.6 (approx 10mb) but
when I tested it it gave an error about libgcrypt version conflict and seg faulted, if I install the libgcrypt pet that I made and try it again it works.

I put libgcrypt-1.4.6-i686.pet that I made in 008 in the sfs, maybe I
should wait for the final Saluki and try again?
Screenshot-2.jpg
 Description   
 Filesize   111.38 KB
 Viewed   927 Time(s)

Screenshot-2.jpg

Back to top
View user's profile Send_private_message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Tue 24 Jan 2012, 20:10    Post_subject: R, gnuplot  

I was very positive surprised to find the gfortran compiler in the devx package. I couldn't resist to rebuild the R package for Saluki:
http://murga-linux.com/puppy/viewtopic.php?p=599104#599104

Also Gnuplot package seems to work:
http://murga-linux.com/puppy/viewtopic.php?t=72356

octave sfs package for slacko seems to work too:
http://murga-linux.com/puppy/viewtopic.php?t=72406

Yacas package seems to work too
http://murga-linux.com/puppy/viewtopic.php?t=72388

maybe those could go to the repos?
Back to top
View user's profile Send_private_message Visit_website 
Geoffrey


Joined: 30 May 2010
Posts: 1441
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Tue 24 Jan 2012, 22:11    Post_subject:  

I can't get Thoggen DVD ripper to work, don't no if it is to do with anything I've done, can someone comfirm if it runs at all.
Code:
thoggen
registering static thoggen plugins
 :: GStreamer core version: 0.10.35.0
 :: System: Linux puppypc29488 2.6.39-ski #1 SMP PREEMPT Wed Dec 14 01:47:00 UTC 2011 i686 GNU/Linux
 :: dbus_bus_get(DBUS_BUS_SYSTEM) failed at th-device-pool.c:222!

** WARNING **: dbus_bus_get(DBUS_BUS_SYSTEM) failed at th-device-pool.c:222!

 :: libhal_ctx_init() failed at th-device-pool.c:232!

** WARNING **: libhal_ctx_init() failed at th-device-pool.c:232!

 :: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
 :: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
process 8278: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 3483.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2138
Location: Ontario Canada

PostPosted: Wed 25 Jan 2012, 00:22    Post_subject:  

Geoffrey wrote:
I can't get Thoggen DVD ripper to work, don't no if it is to do with anything I've done, can someone comfirm if it runs at all.


It worked for me, it produced an ogv file playable in xnoise or vlc etc.
I just set the screen size and away it went.
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2138
Location: Ontario Canada

PostPosted: Wed 25 Jan 2012, 00:25    Post_subject:  

.
Back to top
View user's profile Send_private_message 
Geoffrey


Joined: 30 May 2010
Posts: 1441
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Wed 25 Jan 2012, 00:28    Post_subject:  

Billtoo wrote:
Geoffrey wrote:
I can't get Thoggen DVD ripper to work, don't no if it is to do with anything I've done, can someone comfirm if it runs at all.


It worked for me, it produced an ogv file playable in xnoise or vlc etc.
I just set the screen size and away it went.


I'll have to back track what I've done that caused this to happen, thanks Billtoo.
Back to top
View user's profile Send_private_message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Wed 25 Jan 2012, 00:53    Post_subject:  

Geoffrey wrote:
Billtoo wrote:
Geoffrey wrote:
I can't get Thoggen DVD ripper to work, don't no if it is to do with anything I've done, can someone comfirm if it runs at all.


It worked for me, it produced an ogv file playable in xnoise or vlc etc.
I just set the screen size and away it went.


I'll have to back track what I've done that caused this to happen, thanks Billtoo.


This happens when the window manager starts dbus before rc.services starts it. Try this:

Exit to the prompt
Code:
/etc/init.d/dbus stop
/etc/init.d/dbus start
xwin


Hopefully this will be fixed in 009.
Back to top
View user's profile Send_private_message Visit_website 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Wed 25 Jan 2012, 00:55    Post_subject: Re: Saluki
Sub_title: goggles music manager
 

Billtoo wrote:
@jemimah

I made an sfs file of Goggles Music Manager 0.12.6 (approx 10mb) but
when I tested it it gave an error about libgcrypt version conflict and seg faulted, if I install the libgcrypt pet that I made and try it again it works.

I put libgcrypt-1.4.6-i686.pet that I made in 008 in the sfs, maybe I
should wait for the final Saluki and try again?


It'll probably need to be recompiled.
Back to top
View user's profile Send_private_message Visit_website 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Wed 25 Jan 2012, 00:56    Post_subject: Re: xgamma-gui  

emil wrote:
It seems there is a very old version of xgamma-gui in Saluki which is buggy.
fix:
replace /usr/sbin/xgamma-gui with this version
details about bugfix here
Cool emil

Got it. Thanks.
Back to top
View user's profile Send_private_message Visit_website 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Wed 25 Jan 2012, 02:36    Post_subject:  

aarf wrote:
after some checking i am at a complete loss to explain why the produced 008 is only 40M. Can someone with both 007 (or 006) and 008 produce the delta, then move 007 and delta to a new folder and try to create 008 from 007 plus delta and see if it is the real deal 008 that is produced. Check the md5sum of the produced 008. I think xdelta is failing because of some unknown characteristic of 008. Clicking open the produced 008, it will look ok but you cant copy the whole contents out of the mounted folder to a new folder. (To do the usual manual frugal.) My failures are happening in both racy and luci003. All on ext3 partitions.

Icafe downloaded the offending 008. Md5sum matched the one posted by jemimah. But now cant proceed because my 007 was on my virtually new toshiba 500G external which has developed a strange clicking sound and then EeePc blackscreens and all indicator lights are out. This strange clicking sound first occurred when trying to produce 008 from the smokey01 hosted strange deltas yesterday. Only today when plugged in does the external hard toshiba kill all puppies. Remove external. Reboot. Click open icafe 008 try to copy contents to SDcard. Hangs at luki.sfs. Wont copy. Then EeePc fails to shutdown. Plugin external hard toshiba. >once again it kills EeePc.
Proceed at own risk. All happening in racy and luci003.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
cthisbear

Joined: 29 Jan 2006
Posts: 3442
Location: Sydney Australia

PostPosted: Wed 25 Jan 2012, 03:14    Post_subject:  

aarf:

Why not try the old trick of disconnecting your mains power,

taking out the battery.....

and holding down your power button to discharge your lappy.

Instead of 10 seconds....make it at least 30 seconds.

Regards....Chris.
Back to top
View user's profile Send_private_message 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Wed 25 Jan 2012, 03:40    Post_subject:  

cthisbear wrote:
aarf:

Why not try the old trick of disconnecting your mains power,

taking out the battery.....

and holding down your power button to discharge your lappy.

Instead of 10 seconds....make it at least 30 seconds.

Regards....Chris.
will this fix my external harddrive? Other times in the past when i cant shutdown i just holddown the power button and it will shutdown. I thought i'd try the new plug in the toshiba external HD shutdown method to see how effective it was.

Edit: Tried the battery removal trick. External toshiba still kills racy522 when it is plugged in and accessed. Takes about 30 seconds to get its act going. In the interum can see content of the external drive. Whoa it actually restarted not shut down now i can get the 007 off of the external HD. Perhaps it has something to do with the USB flashdrive i was using at the icafe. Because it warmt plugged when the succesful copy from the external HD went through. Will investigate.
Edit: could be my battery is past its useful life. As also indicated by in the unusable screen popups about power mentioned earlier in this saluki thread..sorry for side tracking saluki again jemimah.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Wed 25 Jan 2012, 05:19    Post_subject:  

Locally in both racy522 and Puppeeerc2 using 007 and 008 to generate a delta (66 M) then using 007 and the generated delta to create 008 produces a 008 with the correct md5sum. So back to not having any clue as to not why the online created deltas failed so consistently.
And have copied the content out of the 008.iso to SSD and booted saluki from it via xorgwizard and xwin.
Previous failure to copy was probably due to my defective SDcard writer.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 50 of 250 Posts_count   Goto page: Previous 1, 2, 3, ..., 48, 49, 50, 51, 52, ..., 248, 249, 250 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1211s ][ Queries: 12 (0.0276s) ][ GZIP on ]