Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Sep 2014, 08:04
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Saluki
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 72 of 250 [3742 Posts]   Goto page: Previous 1, 2, 3, ..., 70, 71, 72, 73, 74, ..., 248, 249, 250 Next
Author Message
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Fri 10 Feb 2012, 18:37    Post subject:  

I've upload the following to the repo:

    pburn
    pmusic
    pbackup
    pmirror
    pwebcam
    cire
    pup-advert-blocker
    goggles music manager
    xournal
    audacity
    gsudoku
    ace of penguins
    sdl-ball


I'll be adding more over the next few days. Requests?
Back to top
View user's profile Send private message Visit poster's website 
Iguleder


Joined: 11 Aug 2009
Posts: 1907
Location: Israel, somewhere in the beautiful desert

PostPosted: Fri 10 Feb 2012, 18:42    Post subject:  

Discovered movgrab today, it's really nice and amazingly fast. I've been using youtube-dl for some time, but it requires Python, while the former is written in C.

It's very small; a Yad frontend could be an amazingly nice addition to Saluki. Wink

_________________
My homepage
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Fri 10 Feb 2012, 18:51    Post subject:  

Soliver wrote one - it just needs testing/debugging.
http://murga-linux.com/puppy/viewtopic.php?t=44960&start=180
Back to top
View user's profile Send private message Visit poster's website 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Fri 10 Feb 2012, 19:42    Post subject:  

jemimah wrote:
It is probably as suggested above, that this kernel is too old for your graphics card.

My laptop is similar, and am using one of pemasu's 3.1 kernels - but I am finding it really unstable.

I'm not sure if the broadcom module loading problem is fixed yet. If so we can try a newer kernel at some point.
Doubt that is the problem, as I understand that you are trying to maintain compatibility with Racy. Attached is a sys-info report generated by Racy 5.2.2 running on the same laptop that is having trouble with Saluki. Possibly it has some clues as to the problem.

Regards,
Jim
image-1.jpg
Description 
jpg

 Download 
Filename  image-1.jpg 
Filesize  67.22 KB 
Downloaded  148 Time(s) 
sys-info-120210.gz
Description 
gz

 Download 
Filename  sys-info-120210.gz 
Filesize  9.02 KB 
Downloaded  117 Time(s) 
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Fri 10 Feb 2012, 19:58    Post subject:  

Jim1911 wrote:
jemimah wrote:
It is probably as suggested above, that this kernel is too old for your graphics card.

My laptop is similar, and am using one of pemasu's 3.1 kernels - but I am finding it really unstable.

I'm not sure if the broadcom module loading problem is fixed yet. If so we can try a newer kernel at some point.
Doubt that is the problem, as I understand that you are trying to maintain compatibility with Racy. Attached is a sys-info report generated by Racy 5.2.2 running on the same laptop that is having trouble with Saluki. Possibly it has some clues as to the problem.

Regards,
Jim


Racy has a 3.0 kernel - Saluki does not. There is no other difference in the video drivers.
Back to top
View user's profile Send private message Visit poster's website 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Fri 10 Feb 2012, 20:38    Post subject:  

jemimah wrote:
I'll be adding more over the next few days. Requests?


neveroid1 is cli. couldn't find it so the upload is from my pets.

numptyphytics from my pets

billiards from my pets

martian_memory
enigma
lmarbles

the above are all pets from murga. only dependency is sdl-1.2.9
all work ok in slacko 5.3.3.

thanks
billiards-1.0.pet
Description 
pet

 Download 
Filename  billiards-1.0.pet 
Filesize  761.15 KB 
Downloaded  131 Time(s) 
numptyphysics_0.2.pet
Description 
pet

 Download 
Filename  numptyphysics_0.2.pet 
Filesize  235.35 KB 
Downloaded  119 Time(s) 
nevernoid1-1.2-i486.pet
Description 
pet

 Download 
Filename  nevernoid1-1.2-i486.pet 
Filesize  201.28 KB 
Downloaded  116 Time(s) 

Last edited by jim3630 on Fri 10 Feb 2012, 21:04; edited 2 times in total
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Fri 10 Feb 2012, 20:40    Post subject: Re: azerty keyboard
Subject description: azerty keyboard
 

Tasgarth wrote:
Problem with my keyboard (azerty). I always get qwerty (Saluki 10 or 11).
or keyboard layout must be always 'azerty' for France.
No problem with Slacko or Luci.

Saluki 11 is good for my PC
(Asus M2V, 4G RAM)


I just got the Xfce keyboard layout tool to work so try the next release and let me know if it works better.
Back to top
View user's profile Send private message Visit poster's website 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Fri 10 Feb 2012, 20:43    Post subject:  

movgrab

http://murga-linux.com/puppy/viewtopic.php?t=70399&start=1770
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1377
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Fri 10 Feb 2012, 22:32    Post subject:  

jim3630 wrote:
jemimah wrote:
I'll be adding more over the next few days. Requests?


neveroid1 is cli. couldn't find it so the upload is from my pets.

numptyphytics from my pets

billiards from my pets

martian_memory
enigma
lmarbles

the above are all pets from murga. only dependency is sdl-1.2.9
all work ok in slacko 5.3.3.

thanks


I tried these,
billiards doesn't run
Code:
libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/games/billard-gl)

numptyphytics needs LibSDL1.2-forDoom and the transparency compositor turned off.

neveroid1 also needs the transparency compositor turned off

edit: there is no menu entry for neveroid1, type nevernoid in the terminal.

Edit: these have been fixed, see jemimah's post next page

Last edited by Geoffrey on Sat 11 Feb 2012, 18:17; edited 2 times in total
Back to top
View user's profile Send private message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Fri 10 Feb 2012, 22:41    Post subject:  

forgot iirc used this for billiards in slacko.

thanks for pet for the LibSDL1.2-forDoom
GLIBCXX_FIX-1.pet
Description 
pet

 Download 
Filename  GLIBCXX_FIX-1.pet 
Filesize  483.02 KB 
Downloaded  131 Time(s) 
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1377
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Fri 10 Feb 2012, 23:14    Post subject:  

jim3630 wrote:
forgot iirc used this for billiards in slacko.

thanks for pet for the LibSDL1.2-forDoom


No worries, I stripped out the doc files to make it a bit smaller

Edit deleted files, not needed for Billiards game, it has been recompiled.

Last edited by Geoffrey on Sat 11 Feb 2012, 18:28; edited 1 time in total
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Fri 10 Feb 2012, 23:35    Post subject:  

Quote:
Requests?


. . . since you ask . . . Smile

pdf-cube
imagination
ATI crystal graphics and NVidia accelerated drivers
GLX drivers
Blender
Openshot 1.4.2 (for me requires ATI, GLX and Python)
Xaralx
plogo (Puppy prog)
zensound (Puppy prog)
latest Chromium
xchat (ready to go Pidgin needs setting up to go to Puppy IRC)

Enclosed is Growl Security for Saluki (I am in Slacko, so has not been tried in Saluki)
Code:
#! /bin/bash
# Growl v 1.6 Feb 2012
# created by Shadow and Lobster
# security enhancements and probes for Puppy Linux
# New for 1.6: Updated for Puppy 'Saluki'
# browser run in safe mode, edit file added, update gtkdialog4, LastPass Password Manager,
#
# New for 1.3: Puppy Security, Last Password, Fido non root in Help, Hide My Ass

export Grrr='
<window title="GROWL" window-position="1">
<vbox>
  <menubar>
    <menu>
        <menuitem>
             <label>Hide My Ass</label>
             <action>defaultbrowser http://hidemyass.com/ &</action>
         </menuitem>
         <menuitem>
            <label>Run Firewall</label>
            <action>rxvt -e /usr/sbin/firewall_install.sh</action>
         </menuitem>
         <menuitem>
            <label>Run as spot</label>
            <action>`Xdialog --wrap --screencenter --left --title "Run as spot" --msgbox "Run as Super User. \n SPOT" 600x0`</action>
            <action>rxvt -e su spot &</action>
            <action>exit</action>
         </menuitem>
         <menuitem>
           <label>Run IRC Chat securely</label>
            <action>`Xdialog --wrap --screencenter --left --title "Run IRC securely" --msgbox "Puppy is on freenode server. \n in #puppylinux Network super user SPOT" 600x0`</action>
            <action>su spot -c defaultchat &</action>
         </menuitem>
         <menuitem>
             <label>Install Noscript</label>   
             <action>`Xdialog --wrap --screencenter --left --title "install noscript" --msgbox "Install noscript. \n As super user SPOT" 600x0`</action>
             <action>rxvt -e su spike &</action>           
             <action>rxvt -e defaultbrowser https://addons.mozilla.org/en-US/seamonkey/addon/722 &</action>
             <action>exit</action>
         </menuitem>
         <menuitem>
          <label>LastPass Password Manager</label>
          <action>`Xdialog --wrap --screencenter --left --title "install LastPass" --msgbox "Install Encrypted Password Manager. \n As super user SPOT" 600x0`</action>
          <action>rxvt -e su spike &</action>           
          <action>rxvt -e defaultbrowser https://addons.mozilla.org/en-US/seamonkey/addon/lastpass-password-manager/ &</action>
          <action>exit</action>
         </menuitem>
         <menuitem>
            <label>Run Browser securely</label>
            <action>`Xdialog --wrap --screencenter --left --title "Run browser securely" --msgbox "Default browser will look plain whilst running securely. \n as super user SPOT" 600x0`</action>
            <action>su spike -c&</action>
            <action>seamonkey -safe-mode &</action>
         </menuitem>
         <menuitem>
             <label>Encrypt a File: bycrypt</label>
             <action>rxvt -e /usr/sbin/bcrypt_gui &</action>
         </menuitem>
         <menuitem>
             <label>Ccrypt install</label>
             <action>rxvt -e defaultbrowser http://puppylinux.org/wikka/ccrypt &</action>
         </menuitem> 
         <menuitem>
                 <label>Enhanced Lock Screen</label>
                 <action>rm -f /root/.xlockrc</action>
                 <action>xmodmap -e "keycode 37="</action>
                 <action>xmodmap -e "keycode 109="</action>
                 <action>rxvt -e /usr/local/apps/Xlock/AppRun &</action>
                 <action>`Xdialog --wrap --screencenter --left --title "reactivating ctrl keys" --msgbox "reactivating ctrl keys. \n deactivated whilst using lockscreen" 600x0`</action>
                 <action>xmodmap -e "keycode 37=Control_L"</action>
                 <action>xmodmap -e "keycode 109=Control_R"</action>
        </menuitem>
        <menuitem>
               <label>Remove Flash cookies</label>
               <action>rm -rf /root/.macromedia</action>
               <action>rm -rf /intrd/pup_rw/root/.macromedia/</action>         
        </menuitem>
               <menuitem stock="gtk-quit">
               <action>echo You selected the quit menu item</action>
               <action type="exit">exit by menu</action>
        </menuitem>
      <label>Security</label>
    </menu>
    <menu>
        <menuitem>
               <label>Shields Up</label>
               <action>defaultbrowser https://www.grc.com/x/ne.dll?bh0bkyd2 &</action>
        </menuitem>       
        <menuitem>
               <label>Hackermode</label>
               <action>defaultbrowser http://hackerwatch.org/probe/ &</action>
        </menuitem>
        <menuitem>
               <label>Pcflank</label>
               <action>defaultbrowser http://www.pcflank.com/scanner1.htm &</action>
        </menuitem>
    <label>Probes</label>
    </menu>       
    <menu>
        <menuitem>
           <label>Credits</label>
            <action>`Xdialog --wrap --screencenter --left --title "About" --msgbox "Growl v 1.4\n23 Sept 2011\nCreated by Lobster and Shadow" 600x0`</action>
        </menuitem>
        <menuitem>
             <label>About Flash Cookies</label>
             <action>defaultbrowser http://www.murga-linux.com/puppy/viewtopic.php?p=340237#340237 &</action>
         </menuitem> 
         <menuitem>
             <label>Security Tips</label>
             <action>defaultbrowser http://puppylinux.org/wikka/security &</action>
         </menuitem>
         <menuitem>
             <label>Seamonkey Security</label>
             <action>defaultbrowser https://addons.mozilla.org/en-US/seamonkey/browse/type:1/cat:46 &</action>
         </menuitem>
         <menuitem>
             <label>ISP shaping traffic?</label>
             <action>defaultbrowser http://broadband.mpi-sws.org/transparency/glasnost.php &</action>
         </menuitem>
         <menuitem>
           <label>Fido non root</label>
           <action>defaultbrowser http://bkhome.org/blog/?viewDetailed=02240 &</action>
         </menuitem>
         <menuitem>
           <label>FAQ</label>
           <action>`Xdialog --wrap --screencenter --left --title "FAQ" --msgbox "Lock screen - security protection level = low, suitable for young children, colleagues at work and Window users \n Load firewall - security protection level = high \n Run as spot, run browser as spot, run Puppy browser as spot - security protection level = high \n Encrypt a file bycrypt - security protection level = high \n Tip: Restart x server - flushes memory \n Tip: Use Encrypt save file if saving \n Tip: Make sure adblock is enabled (low) or install noscript (high security)" 600x0`</action>
         </menuitem>
          <menuitem>
           <label>Last Password</label>
           <action>defaultbrowser https://lastpass.com/ &</action>
         </menuitem>
         <menuitem>
           <label>Edit source</label>
           <action>geany GROWL16 &</action>
         </menuitem>
         <menuitem>
           <label>Build a tin hat</label>
           <action>defaultbrowser http://zapatopi.net/afdb/ &</action>
         </menuitem>
    <label>Help</label>
   </menu>   
  </menubar>
  <frame>
       <pixmap>
         <input file>/usr/share/midi-icons/lock-screen48.png</input>
       </pixmap>
       <text><label>Saluki GROWL 1.6</label></text>
   </frame>
   <hbox>
      <button cancel></button>
  </hbox>
</vbox>
 </window>'

gtkdialog4 --program Grrr
unset Grrr

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Fri 10 Feb 2012, 23:47    Post subject:  

here are others
Martian-Memory.pet
Description 
pet

 Download 
Filename  Martian-Memory.pet 
Filesize  301.17 KB 
Downloaded  119 Time(s) 
Back to top
View user's profile Send private message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Fri 10 Feb 2012, 23:50    Post subject:  

trouble uploading. seems can only do one at a time
lmarbles-1.0.8-i486.pet
Description 
pet

 Download 
Filename  lmarbles-1.0.8-i486.pet 
Filesize  652.41 KB 
Downloaded  124 Time(s) 
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4351

PostPosted: Fri 10 Feb 2012, 23:58    Post subject:  

did anyone try making a symlink for libstdc++.so.6, rather than adding a whole library, that is the kind of stuff that adds unnecessary bloat and also means that it was compiled in a different development environment (which _can_ be bad "juju" ?sp?)
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 72 of 250 [3742 Posts]   Goto page: Previous 1, 2, 3, ..., 70, 71, 72, 73, 74, ..., 248, 249, 250 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1514s ][ Queries: 12 (0.0332s) ][ GZIP on ]