Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 20:43
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Wary Puppy 5.2.2, 18 Nov. 2011
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 10 of 25 [361 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 23, 24, 25 Next
Author Message
tronkel


Joined: 30 Sep 2005
Posts: 1101
Location: Vienna Austria

PostPosted: Tue 18 Oct 2011, 14:15    Post subject:  

Just tried the pet from rcrsn51

On a first attempt I got no joy. I then remembered I had allowed a version update from 5.1.106beta2 the first time I booted into 5.2, so I thought I'd try a pristine pup_save.

Then installed the printer driver plus the pet from rcrsn51 for good measure. Printing now works in the normal fashion!

After a day of playing about with this problem, I've still got no idea what the real cause was. Was there some change in udev rules maybe between 5.2 and its predecessor? Or something in the pup_save itself?

Anyway that's a relief. Doesn't seem to have anything to do directly with the CUPS version.

I had also compiled the source for the latest CUPS version 1.5 and installed it. Compiled no problem in Wary 5.2, but didn't make any difference at all to the printing problem.

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
rcrsn51


Joined: 05 Sep 2006
Posts: 8939
Location: Stratford, Ontario

PostPosted: Tue 18 Oct 2011, 14:19    Post subject:  

The change is the rebuild/upgrade of GTK. The old version sent data to CUPS in Postscript form. The new version sends it in PDF form. Hence the need for the additional filter.

You can confirm this by taking the GTK CUPS backend from an old Wary where printing did work and dropping it into Wary 5.2.
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 18 Oct 2011, 14:23    Post subject:  

rcrsn51 wrote:
The change is the rebuild/upgrade of GTK. The old version sent data to CUPS in Postscript form. The new version sends it in PDF form. Hence the need for the additional filter.

You can confirm this by taking the GTK CUPS backend from an old Wary where printing did work and dropping it into Wary 5.2.


So why do I get the scrambled characters in Racy, any idea?

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3956
Location: Kiel,Germany

PostPosted: Tue 18 Oct 2011, 16:28    Post subject:  

rcrsn51 wrote:
The change is the rebuild/upgrade of GTK. The old version sent data to CUPS in Postscript form. The new version sends it in PDF form. Hence the need for the additional filter.

You can confirm this by taking the GTK CUPS backend from an old Wary where printing did work and dropping it into Wary 5.2.

Inside the pet is a single binary , that replaces the link to /usr/bin/pdftops from /usr/lib/cups/filter directory .

15 -rwxr-xr-x 1 root root 14264 2011-09-21 19:02 pdftops
15 -rwxr-xr-x 1 root root 14288 2011-09-16 23:36 pdftops-orig


Printing seems to work on Wary-Racy here,too .

Had not tried Drake because of the former .rpm problems in earlier puppies (dotpuphandler&puppybasic) or busybox rpm not being able to extract but installs with no trace of the files to uninstall again ...

I had also an error message in cups pstoraster failed , but
find /usr/lib/cups -iname "*pstoraster*"
/usr/lib/cups/filter/pstoraster
# file /usr/lib/cups/filter/pstoraster
/usr/lib/cups/filter/pstoraster: POSIX shell script text executable

is a shell script , nice to learn about cups command line syntax .

Anyway printing is working [ tried to install a ghoscript 9-04pet by dingo which seems not to have helped , applying cupsd.conf from quirky-130 , where i remembered cups-1.3.11 was working , investigating /etc/*shadow files ... ] .

Thanks , rcrsn51 !
Back to top
View user's profile Send private message Visit poster's website 
LoboGrande

Joined: 07 Aug 2009
Posts: 55

PostPosted: Tue 18 Oct 2011, 17:52    Post subject: More USB weirdness
Subject description: Kernel panic
 

My computer runs Wary 5.1.4 and 5.2 fine from the live CD but won't run them from USB. I get a kernel panic. I've tried both Uni and Bootable Flash installs and it will open, start to load and then get a kernel panic message.

P4 3.0ghz w/800fsb, 4gb ddr/ Asus P4V800 mobo/ 80gb SATA HD

USB 16gb Sandisk Cruzer
Back to top
View user's profile Send private message 
Jades

Joined: 07 Aug 2010
Posts: 433
Location: Somewhere in Blighty.

PostPosted: Tue 18 Oct 2011, 20:19    Post subject:  

Tried moving the K6 into the Study to test printing on the Canon i865 in there. Somewhat surprisingly, the machine still worked! Unfortunately, I got the same results as with the BJC-70. Test page worked, printing from Abiword and Gnumeric didn't. Same error as before.

I've seen rcrsn51's post with his pet and will report back after testing it tomo^h^h^h^hlater today (it being 1:18am).

_________________
Zhaan - AMD K6 2 500, 512MB RAM, ATI Rage 128 VR. Full install Wary 5.5 HardInfo Report
Merlin - Pentium D 3.4GHz, 2GB RAM, Radeon X1650 Pro AGP. LiveCD of 5.25. HardInfo Report
Back to top
View user's profile Send private message Visit poster's website 
nubc


Joined: 23 Jan 2007
Posts: 1019
Location: USA

PostPosted: Tue 18 Oct 2011, 23:52    Post subject:  

I substituted a 'bookmarks.html' file into the .mozilla folder in root, but the bookmarks do not appear in SM 2.3.1, even after a reboot.

The version of Flashplayer does not put a temporary flash file in tmp directory. So I obtained a 'libflashplayer.so' file from Wary 5.1.1 which does put the flash temp in tmp. After rebooting, the flash file still does not show in tmp. Incidentally, I don't see a YT download app in the menu tree.

Clicking the "Playback" tab in 'Adobe Flash Player preferences' causes the gui to crash and close.

While typing this feedback, I accidentally hit the Windows key on my Dell QuietKey keyboard. This caused the window to suddenly and completely disappear from all three desktops. However, the window was reconstituted with text (whew!) when I clicked the Browse icon. Not a pleasant experience, really.

Edit: The accidental keystroke might have been the Print key.

Last edited by nubc on Wed 19 Oct 2011, 11:39; edited 1 time in total
Back to top
View user's profile Send private message 
broomdodger


Joined: 09 May 2008
Posts: 269
Location: Santa Cruz, CA

PostPosted: Wed 19 Oct 2011, 00:45    Post subject:  

nubc wrote:
I substituted a 'bookmarks.html' file into the .mozilla folder in root, but the bookmarks do not appear in SM 2.3.1, even after a reboot
go to the Bookmarks menu
+ select Manage bookmarks
+ Tools menu
+ Import HTML
+ File
+ navigate to your bookmarks.html
! done
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5687
Location: Kentucky

PostPosted: Wed 19 Oct 2011, 01:37    Post subject:  

Fresh full install of Wary 5.20 on my old P3 test box.Internet,sound and display all working and correct on initial boot.Overall,looking good.

-Computer-
Processor : Pentium III (Coppermine)
Memory : 253MB (108MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Wed 19 Oct 2011 12:34:45 AM CDT
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Mesa GLX Indirect
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : ICH - Intel 82801AA-ICH
VGA compatible controller : Intel Corporation 82810E DC-133
Ethernet controller : Intel Corporation 82557/8/9/0/1 Ethernet Pro 100
wary-5.20.png
 Description   
 Filesize   19.94 KB
 Viewed   1217 Time(s)

wary-5.20.png

Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Wed 19 Oct 2011, 08:39    Post subject:  

nubc wrote:
While typing this feedback, I accidentally hit the Windows key on my Dell QuietKey keyboard. This caused the window to suddenly and completely disappear from all three desktops. However, the window was reconstituted with text (whew!)

Almost certainly the Inset key, a known issue. http://murga-linux.com/puppy/viewtopic.php?t=69175
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1019
Location: USA

PostPosted: Wed 19 Oct 2011, 09:02    Post subject:  

I can state with some confidence that it wasn't the Insert key, since fingers of my right hand were dragging along the bottom edge of the keyboard. The three suspect keys are therefore Ctrl, Print, MSWindows, and less likely Alt. The puzzling thing is that I can't reproduce the disappearing act, so maybe it's a key combination.
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4777
Location: GB

PostPosted: Wed 19 Oct 2011, 11:31    Post subject:  

Broken record checking in.
Wary is fantastic - I use it all the time for a range of functions on many machines and peripherals. One of the most useful for the liveCD is checking, diagnostics, passwords, settings & co.
So here come the buts - every so often it jumps up and bites you in the butt.

Just what will it take to persuade BK to dump this worthless browser? All I wanted to do today was change my router settings. The important parts of the config monitor weren't displayed. Whether this needed Java, javascript, flash, w.h.y., it was easier to d/l & install Opera! So unnecessary when one's in a hurry!
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Wed 19 Oct 2011, 13:31    Post subject:  

nubc wrote:
I substituted a 'bookmarks.html' file into the .mozilla folder in root, but the bookmarks do not appear in SM 2.3.1, even after a reboot.

Incidentally, I don't see a YT download app in the menu tree.
.


I move my saved bookmarks file to root, then use bookmarks
manager to import.

For youtube:
Install video download helper 4.9.5 from here.

https://addons.mozilla.org/en-US/firefox/addon/video-downloadhelper/versions/

When installed right click around navigation bar until you see
a little window with "customize" at the bottom. Click customize.
Drag the little colored balls up between the printer and search
icons.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
p3m4la5

Joined: 15 Apr 2011
Posts: 16

PostPosted: Thu 20 Oct 2011, 00:53    Post subject:  

I am install fresh Wary 52 ( frugal ). everything ok, like detect my huawei e173 modem etc until klick power off > save file > Administrator .........
and until wait.... there is nothing happen ( wary not shutdown ). Did i miss something ?
sorry for bad english.....
Back to top
View user's profile Send private message 
popguy

Joined: 15 Oct 2007
Posts: 31

PostPosted: Thu 20 Oct 2011, 04:41    Post subject:  

Hi, I'm booting wary on my Portege 2000 (PIII 750, 512, 20GB, Trident Microsystems cyberblade XPAi1-rev d2), after giving up booting with lupu 5.2.8. (hangs after "ISOLINUX.." writing flashes). However, when wary gets to the point where it says "Setting up services (network, printing, etc.)... it hangs.
Thanks for any help!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 10 of 25 [361 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 23, 24, 25 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0994s ][ Queries: 12 (0.0101s) ][ GZIP on ]