Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 20:44
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Slacko B4
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 10 of 12 [179 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12 Next
Author Message
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Mon 26 Sep 2011, 00:46    Post subject:  

Do we still have Porteus module compatibility? What does this mean? Where are the modules? Cool
http://porteus.org/distro-download/porteus-scripts.html

Any changes needed on Wiki?
http://puppylinux.org/wikka/Puppy53

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
charlie6


Joined: 30 Jun 2008
Posts: 1020
Location: South of Belgium

PostPosted: Mon 26 Sep 2011, 01:57    Post subject:
Subject description: Slacko versus Brookdale
 

Hi Mick,

01micko wrote:
Charlie, you can do it manually anyway, drop to the prompt and run xorgwizard, then before you type xwin run "BROOKDALE" (caps, no quotes.) Smile run xwin and all is happy in Brookdale virtual land.


Thanks Mick! ...this only works here at the conditions that «...drop to the prompt and run xorgwizard...»
doing it FAST ENOUGH BEFORE ANY DIALOG BOX POPS UP
and NOT running xorgwizard now.

Instead: afterwards exit to prompt, entered BROOKDALE without starting xorgwizard;
and at prompt entered xwin.
Then X restarts nice and the settings may continue without any X problems.

Here on Brookdale rev01 + B4 me noticed that immediately after live-cd boot and before any rox window popup, background is displayed OK.
Afterwards, upon any dialog box window popup, - whatever Personalize settings popup, or opening a rox window such as clicking on Files icon to open /root files window - the screen filckers ± 0.1 sec to black + stripped lines and comes back again. From here not any longer chance to get X working: menu texts disappear etc ...

All this tested several (enough) times on fresh live-cd bootups to check its reproducibility.

Charlie
Back to top
View user's profile Send private message 
eternal-sunshine

Joined: 20 Feb 2011
Posts: 59

PostPosted: Mon 26 Sep 2011, 02:16    Post subject:  

01micko
Thanks for your reply and explanation re deps. Away from my test rig now for 24 hrs but will report back then.
Cheers
Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 655
Location: Chatswood, NSW

PostPosted: Mon 26 Sep 2011, 02:25    Post subject:
Subject description: Still no power-off with Slacko
 

G'day 01micko,
Tried the acpid-2.0.12-s.pet on a Frugal & Full B4 on this desk-top.
Still goes to re-boot ("requested re-boot" message displayed after Slacko quits so I know what's coming).
Exiting to Prompt then typing 'poweroff' gives same re-boot situation.

Desktop sysinfo report (first bit, in case this helps) reads:
Slacko Puppy 4.99.6

89 Tasks, 1 Running. Uptime: 13 min, load average: 0.00, 0.02, 0.04

Current window manager: JWM (starts from C.L. with: 'xwin jwm')

JWM vsvn-500
ROX-Filer 2.10

Network Interface

=== report-video ===

Slacko Puppy, version 4.99.6 on Mon 26 Sep 2011

Chip description:
0.0 VGA compatible controller
ATI Technologies Inc Cedar PRO [Radeon HD 5450]
oem: ATI ATOMBIOS
product: CEDAR 01.00

X Server: Xorg
Driver used: radeon

X.Org version: 1.9.5
dimensions: 1600x900 pixels (423x238 millimeters)
depth of root window: 24 planes
[ 14.867]
X.Org X Server 1.9.5
Release Date: 2011-03-17
[ 14.867] X Protocol Version 11, Revision 0

=== Kernel command line ===

root=/dev/sda14 pmedia=atahd

=== /etc/rc.d/PUPSTATE ===

PUPMODE=2
#ATADRIVES is all internal ide/pata/sata drives, excluding optical, excluding usb...
ATADRIVES='sda sdb '
#ATAOPTICALDRIVES is list of non-usb optical drives...
ATAOPTICALDRIVES='sr0 sr1 '
PUP_HOME='/'
PDEV1='sda14'
DEV1FS='ext3'

=== probepart ===

/dev/sda1|ntfs|41029946
/dev/sda2|ext3|5751270
/dev/sda3|ext3|5847660
/dev/sda4|none|2
/dev/sda5|ext2|771360848
/dev/sda6|ext3|6217092
/dev/sda7|ext3|103056912
/dev/sda8|ext3|6201026
/dev/sda9|ext3|6168896
/dev/sda10|ext3|6201026
/dev/sda11|ext2|5976116
/dev/sda12|ext3|5638752
/dev/sda13|ext3|6120702
/dev/sda14|ext3|6152832
/dev/sdb1|ext2|6144000
/dev/sdb2|ext2|6144000
/dev/sdb3|swap|643072
/dev/sdb4|none|2
/dev/sdb5|ext2|520376320
/dev/sdb6|ext3|20480000
/dev/sdb7|ext3|20480000
/dev/sdb8|ext3|5187584
/dev/sdb9|ext3|5298176
/dev/sdb10|ext3|5410816
/dev/sdb11|ext3|5453824
/dev/sdb12|ext3|5429248
/dev/sdb13|ext3|7559168
/dev/sdb14|ext3|8192000
/dev/sdb15|ext2|8318976
/dev/sdc|none|0
/dev/sr0|none|2097150
/dev/sr1|none|2097150

=== df -h ===

Filesystem Size Used Avail Use% Mounted on
/dev/sda14 2.9G 1.3G 1.5G 46% /
shmfs 504M 0 504M 0% /dev/shm
/dev/sda5 363G 86G 259G 25% /mnt/sda5
/dev/sdb5 245G 91G 141G 40% /mnt/sdb5

=== free ===
total used free shared buffers
Mem: 2074544 176136 1898408 0 10000
Swap: 321532 0 321532
Total: 2396076 176136 2219940

2026 MiB total physical RAM (less shared video--unauthoritative)

=== CUPS 1.4.6 ===

DefaultPrinter CUPS-PDF
Printer fujixerox

=== /initrd/tmp/EXTRASFSS ===

=== User Installed Pkgs (PPM) ===
Package Description
avidemux2-AllInOne-2.5.1-i486
eremove-1.4 spam deleter from server
FileManagersNew-110101 Geany text editor
Games 5ball game
Graphics The Gimp
Java1.6.0.24 Java Control Panel
pwidgets_DS-pwidgets-2.2.4 Pwidgets tiny desktop apps
LHP_sys_info-0.5 Lighthouse System Information & Video Report
softmakeroffice2008 TextMaker2008
wine1317-programs Word 97 editor
evince-2.30.3-i386 View multi-page documents
wine-1.3.28-i486_v1 Wine Windows Program Loader
acpid-2.0.12-s acpi deamon with dialog box and lid supend

=== /initrd/tmp/bootinit.log (Disregard any 'FATAL' messages) ===

=== /tmp/bootsysinit.log ===

VERSION UPDATE
LOAD KERNEL MODULES
LOAD SWAP
MISC. SYSTEM SETUP
ln: creating symbolic link `/mnt/home/': File exists
WAIT MODULES LOADED
USER SELECTED MODULES
SETUP SERVICES
RECOGNISE MEDIA DEVICES
Waiting for interfaces to initialize...
cat: /etc/fontmap: No such file or directory
configuring network interface eth0
cheching if interface eth0 is alive...yes
MISC. DESKTOP STUFF
PERSONAL BOOT SCRIPT
Success!
cups: started scheduler.
Starting system message bus: /usr/bin/dbus-uuidgen --ensure ; /usr/bin/dbus-daemon --system
Starting HAL daemon: /usr/sbin/hald --daemon=yes
pcd-run-hooks', reason CARRIER
dhcpcd[3482]: eth0: reading lease `/var/db/dhcpcd-eth0.lease'
dhcpcd[3482]: eth0: rebinding lease of 192.168.2.3
dhcpcd[3482]: eth0: sending REQUEST (xid 0x4dd9454d), next in 4.94 seconds
dhcpcd[3482]: eth0: acknowledged 192.168.2.3 from 192.168.2.1
dhcpcd[3482]: eth0: checking for 192.168.2.3
dhcpcd[3482]: eth0: sending ARP probe (1 of 3), next in 1.14 seconds
3
dhcpcd[3482]: eth0: sending ARP probe (2 of 3), next in 1.71 seconds
6
9
dhcpcd[3482]: eth0: sending ARP probe (3 of 3), next in 2.00 seconds
12
15
dhcpcd[3482]: eth0: leased 192.168.2.3 for 31536000 seconds
dhcpcd[3482]: eth0: adding IP address 192.168.2.3/24
dhcpcd[3482]: eth0: adding route to 192.168.2.0/24
dhcpcd[3482]: eth0: adding default route via 192.168.2.1
dhcpcd[3482]: eth0: writing lease `/var/db/dhcpcd-eth0.lease'
dhcpcd[3482]: eth0: executing `/usr/libexec/dhcpcd-run-hooks', reason BOUND
dhcpcd[3482]: forking to background
dhcpcd[3482]: forked to background, child pid 3781

=== whiteout(.wh.*) files in /bin /etc /lib /sbin /usr ===

=== xdriinfo ===

xdriinfo: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

=== report-video ===

Slacko Puppy, version 4.99.6 on Mon 26 Sep 2011

Chip description:
0.0 VGA compatible controller
ATI Technologies Inc Cedar PRO [Radeon HD 5450]
oem: ATI ATOMBIOS
product: CEDAR 01.00

X Server: Xorg
Driver used: radeon

X.Org version: 1.9.5
dimensions: 1600x900 pixels (423x238 millimeters)
depth of root window: 24 planes "

and so on.

Thanks and regards,
David S.
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4817
Location: GB

PostPosted: Mon 26 Sep 2011, 02:25    Post subject:  

Possible that ssz has other HW issues because B4 now works with all my SiS video systems. They did release a PCI card about a decade ago which did give endless grief in 'doze. I used to have one somewhere but can't find it now. If it turns up I'll test it.
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 26 Sep 2011, 02:54    Post subject:  

eternal-sunshine wrote:
01micko
Thanks for your reply and explanation re deps. Away from my test rig now for 24 hrs but will report back then.
Cheers


eternal-sunshine (cool name) I have Dropbox running just fine without Python. Will build you a .pet for it in a couple of hours. The Chromium you need is the one packaged by Playdayz for Slacko (Chromium 16). Posting from it now with no problems. It is somewhere in this or the B3 thread. Will also locate that for you when I get a moment.
Open Office... sorry, no clue.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Tasgarth

Joined: 06 Oct 2008
Posts: 202
Location: France, Besancon

PostPosted: Mon 26 Sep 2011, 03:19    Post subject:  

Davids45 wrote :
Quote:
Tried the acpid-2.0.12-s.pet on a Frugal & Full B4 on this desk-top.
Still goes to re-boot ("requested re-boot" message displayed after Slacko quits so I know what's coming).
Exiting to Prompt then typing 'poweroff' gives same re-boot situation.

Same thing for me Crying or Very sad
Same problem with sound.
Quote:
pfix=ram,acpi=force

no action
Same problem with sound
Back to top
View user's profile Send private message Visit poster's website 
charlie6


Joined: 30 Jun 2008
Posts: 1020
Location: South of Belgium

PostPosted: Mon 26 Sep 2011, 04:07    Post subject: PCTel 789 pci dialup modem not detected ?  

Hi,
PCTel chip 789 pci dialup modem not detected, this already on Slacko B1 and later
...although /lib/modules/all-firmware/pctel.tar.gz is present...as also «PCTel Inc HSF MicroModem 56» reported in Hardinfo System Information under PCI Devices.
Do I have missed something?
thanks for any advice
Charlie
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Mon 26 Sep 2011, 04:28    Post subject:  

hi Charlie,
Most dialup modems will not work in later kernels, depends on third party support. The firmware is part of the woof template. Anything on your pci bus should be recognised, whether supported or not is another matter. Sorry I couldn't do better in answering!

HTH

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 1516
Location: Worcestershire, UK

PostPosted: Mon 26 Sep 2011, 04:45    Post subject:  

Quote:
The Chromium you need is the one packaged by Playdayz for Slacko (Chromium 16). Posting from it now with no problems. It is somewhere in this or the B3 thread. Will also locate that for you when I get a moment.


Chromium16 is in the slacko official repository - using it now....

Cheers
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 26 Sep 2011, 04:51    Post subject:  

DaveS wrote:
eternal-sunshine wrote:
01micko
Thanks for your reply and explanation re deps. Away from my test rig now for 24 hrs but will report back then.
Cheers


eternal-sunshine (cool name) I have Dropbox running just fine without Python. Will build you a .pet for it in a couple of hours. The Chromium you need is the one packaged by Playdayz for Slacko (Chromium 16). Posting from it now with no problems. It is somewhere in this or the B3 thread. Will also locate that for you when I get a moment.
Open Office... sorry, no clue.


Dropbox.pet is here http://puppylinuxstuff.meownplanet.net/DaveS/dropbox/
username: puppy
password: linux

It will autostart on boot and can also be started from the internet menu. If you want to disable autostart, go to /root/Startup and delete dropboxd

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4817
Location: GB

PostPosted: Mon 26 Sep 2011, 04:56    Post subject:  

Quote:
pfix=ram,acpi=force

Necessary to try acpi=off and acpi=on (cf. discussions of ~5yrs ago/ search:Dougal). I prefer not to use the comma delimiter but space when using equalities; not because I know anything about coding - I don't - but it doesn't seem to sit comfortably mathematically. Probably irrelevant!
ie pfix=ram acpi=off
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 26 Sep 2011, 06:16    Post subject:  

I still get no joy with unmounting an SD card. My laptop has a built in SD card slot as do most now, and inserting a card is fine, puppy displays a desktop icon, and clicking the icon mounts the card and opens Rox, but clicking the little red X does not unmount it as it should. Instead, it just opens it in Rox again.
Right click unmount from menu works fine.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Mon 26 Sep 2011, 06:47    Post subject:  

hi all

That acpid pet I uploaded before is broken Rolling Eyes

[note to self : RTFM! ]

This one is ok, someone please test if shutting the lid suspends? Do we want a battery script?

edit: Nah.. on battery script.. only knows when plug is in or out.. no use

Dave.. that's one for BK (card slot), it would affect all pups I expect.
acpid-2.0.12-1-s.pet
Description 
pet

 Download 
Filename  acpid-2.0.12-1-s.pet 
Filesize  18.66 KB 
Downloaded  160 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |

Last edited by 01micko on Mon 26 Sep 2011, 07:08; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 26 Sep 2011, 06:52    Post subject:  

01micko wrote:
hi all

That acpid pet I uploaded before is broken Rolling Eyes

[note to self : RTFM! ]

This one is ok, someone please test if shutting the lid suspends? Do we want a battery script?

Dave.. that's one for BK (card slot), it would affect all pups I expect.


It does.. posted to his blog.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 10 of 12 [179 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1070s ][ Queries: 12 (0.0080s) ][ GZIP on ]