Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 01:27
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.1.10.3 SMP multicore optimized version
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 28 of 70 [1047 Posts]   Goto page: Previous 1, 2, 3, ..., 26, 27, 28, 29, 30, ..., 68, 69, 70 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sat 31 Dec 2011, 09:08    Post subject:  

Peebee. Nope. The /usr/lib/libgconf-2.so.4 and corresponding real lib has been there and gnome-mplayer does not complain of it in my dpup.
I suppose you have installed some lucid puppy pet which has overwritten the existing lib. I suggest you to restore the original ones from /initrd/pup_ro2.

About Pupserver and unmounting smb-cifs netshare. That seems tricky thing. The share has been mounted as:
/mnt/network/PUPSERVER/usr=root passwd=woofwoof and that long share name with space in the name is the reason that umount does not work. Umount does not like share names with spaces.
First I would need figure out how to umount that kind mount name. Then the fix could be transferred to the script.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1516
Location: Worcestershire, UK

PostPosted: Sat 31 Dec 2011, 11:24    Post subject:  

pemasu wrote:
Peebee. Nope. The /usr/lib/libgconf-2.so.4 and corresponding real lib has been there and gnome-mplayer does not complain of it in my dpup.
I suppose you have installed some lucid puppy pet which has overwritten the existing lib. I suggest you to restore the original ones from /initrd/pup_ro2.


Thanks pemasu - that was the answer - I'd installed chromium-17.0.945.0-slacko.pet

both chromium and gnome-mplayer worked after i'd restored your libgconf-2.so.4.1.5

Thanks and very sorry to have been a nuisance
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sat 31 Dec 2011, 11:32    Post subject:  

Peebee. No problem. I have already learnt that this distro hopping presents problems which one puplet creator need to recognize. Nice that I was correct in my assumption, it helped to fix the bug asap.

Billtoo sent me nice multimedia package with umplayer and vlc with needed qt4 framework. I removed the stuff from the sfs which is not needed and I added Spotify into it. Now I have multimedia-vlc-umplayer-spotify-qt-4.8.0 sfs in 30 Mb. Not bad.

I tested the Umplayer and VLC mediaplayer with xvid packaged avi, mkv and mp4, all worked, also finnish subtitles worked oob.

Billtoo, thank you of your sfs and that you sent pm to me.

http://smokey01.com/pemasu/pet_packages-exprimo/multimedia-vlc-umplayer-spotify-qt-4.8.0.sfs

Oh yeah. Happy Next Year !!!!! Let Your Puppy shine with you.
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2154
Location: Ontario Canada

PostPosted: Sun 01 Jan 2012, 09:54    Post subject: Dpup Exprimo 5.X.10.3 SMP multicore optimized version
Subject description: full install
 

I did a full install to my emachines D620 laptop.
I installed the new multimedia-vlc-umplayer-spotify-qt-4.8.0.sfs

Sun 1 Jan 2012 Operating System: Dpup Exprimo SMP-5.X.10.3 Linux 3.1.0
5.0 VGA compatible controller: ATI Technologies Inc RS690M
[Radeon X1200 Series]
oem: ATI ATOMBIOS product: RS690 01.00

X Server: Xorg Driver: radeon
X.Org version: 1.7.7
dimensions: 1280x800 pixels (338x211 millimeters)
depth of root window: 24 planes


AMD Athlon(tm) Processor 2650e
Core 0: 1595 MHz

It's working nice on this laptop.
exprimoscrn.jpg
 Description   
 Filesize   174.16 KB
 Viewed   1136 Time(s)

exprimoscrn.jpg

Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Sun 01 Jan 2012, 10:14    Post subject:  

Hi Pemasu,
I haven't posted much lately - built the latest version of XBMC-11.0-Eden-Beta1 for D-lite will test it on Exprimo also.


http://i.imgur.com/lkRl9r.jpg

cheers.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 01 Jan 2012, 11:05    Post subject:  

Billtoo and Stu90.
Good to hear that multimedia section works and will have possibly new addtions. Inspired by Billtoo, I compiled latest Qt-4.8.0 final, released Qt4 library with 2 different configurations. The first one includes the usual stuff with Qtwebkit. The second one is the same but has Phonon-Gstreamer-support included.
Both does not have stupid libicu (19 Mb installed) dependency. Now I know how to not have it. It is autochecked if you have it and you cant disable it, if you have for some reason installed libicu stuff (by the need of some app). Now I made sure I dont have it.

Now I am going to go through which my previously compiled ( compiled with RC Qt-4.8.0 development libs) Qt apps works straight and what might need recompile. Then I will create dpup Qt4 repo with pets to have base qt libs, development environment and plain apps as single pets. That way ppl can choose what they want. Base qt libs and some single apps, want to compile them more (rare occasion) and what kind of qt libs they want. Gstreamer apps is option with that other qt libs set.

Umplayer and Smplayer worked straight with new qt libs.

Oh....qt libs will be installed to the /opt and I have made separate init pet to have that location recognized. Restart X is enough for /opt/qt to be recognized.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 01 Jan 2012, 14:36    Post subject:  

I have now compiled and packaged QT-4.8.0 libs.
And also compiled Smplayer (new version was released in december 2012) and Umplayer. Billtoo`s VLC-1.1.12 has been packaged to contain VLC files only.

There are now in libs folder 3 QT packages. Package which provide plain libs for using QT apps (qtconfig included) and 2 full packages for those who need more or want to compile Qt apps. The dev packages are separated.

So...you want to run Qt apps in dpup, install this: http://smokey01.com/pemasu/QT-4.8.0-dpup/libs/qt-4.8.0-libs-essentials-only-dpup.pet
Restart X so...the /opt/qt4 location will be noticed.

And then from apps folder application pet or sfs: http://smokey01.com/pemasu/QT-4.8.0-dpup/apps/

If you need Qt-4.8.0 with full installed stuff, install this instead: http://smokey01.com/pemasu/QT-4.8.0-dpup/libs/qt-4.8.0-basic-with-qtwebkit-dpup.pet

If your app needs phonon-gstreamer support, install this full set instead of the above basic one: http://smokey01.com/pemasu/QT-4.8.0-dpup/libs/qt-4.8.0-phonon-gstreamer-qtwebkit-dpup.pet

If you want to compile, install this also: http://smokey01.com/pemasu/QT-4.8.0-dpup/libs/qt_DEV-4.8.0-basic-with-qtwebkit-dpup.pet

And if you want to compile gstreamer-phonon application, intall this corresponding pet: http://smokey01.com/pemasu/QT-4.8.0-dpup/libs/qt_DEV-4.8.0-phonon-gstreamer-qtwebkit-dpup.pet

It is possible that phonon-gstreamer wants also QtOpenGl lib, no worry, I am atm compiling third set with Qtwebkit-phonon-gstreamer-OpenGl support. That is for real demanding apps like Clementine. I wish good luck with compiling it. Done it once.

Sfs packages will become later. My comp compiles now so hot that I dont dare do mksquashfs at the same time.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 04 Jan 2012, 22:35    Post subject: Nvidia drivers for Dpup Exprimo  

UPDATE: nvidia-glx-sdl-290.10-1.sfs which supports Dpup Exprimo both with kernel 2.6.39 or 3.1.0.
http://www.murga-linux.com/puppy/viewtopic.php?t=72405

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
tubeguy


Joined: 28 Aug 2009
Posts: 1332
Location: Park Ridge IL USA

PostPosted: Thu 05 Jan 2012, 00:04    Post subject:  

pemasu wrote:
Tubeguy posted about hanging shutdown when there is samba shared mount established. I have now tried to produce that bug. I have mounted windows comp share, opened text file there and then rebooted when that file is open. It....just....shuts...down....as...it....should.
I used Pnethood for scanning and mounting.

How can I create the hanging situation. I know there could be a improvement to offer...as Karl Godt has posted in Racy thread. But I dont like to include code to the woof2 provided scripts if I cant be sure it is needed and it will fix the problem.

EDIT. Now I tracked the tubeguy`s post: http://www.murga-linux.com/puppy/viewtopic.php?p=590126#590126

Using PupServer, it is not windows share. It is something else. NFS ? I am not familiar with connecting PupServer, yet...lol.
It is probably something with not unmounting that filesystem which PupServer provides. So....I would need to figure out first what filesystem is not unmounting properly.

Haven't kept up for a few days due to a move across town.

All I can tell you about PupServer is it is based on 4.3.1 and I have it frugally installed on an ext4 partition. I dumped Windows on that box so no NTFS stuff. I don't have the issue on lucid or spup. I actually forgot about this until now though so it doesn't seem like that big a deal for me, Exprimo is still my daily driver. Smile

_________________
MSI 970A-G46/AMD FX-8150/Plextor 128GB SSD/Corsair Vengeance 8GB: Tahr Pup 6
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Thu 05 Jan 2012, 02:25    Post subject:  

Tubeguy. I believe that the problem is the name of the mounted share. It has space in its name. Pupserver offers the mounted shares through smb/cifs. So it uses the usual way how to mount stuff from ntfs filesystem.
I just didnt invent cure, how to unmount that long mountname with space in its name. The mount point is under /mnt/network/Pupserver...if I remember right.
Trying to umount it from command line fails due to that mount point name. Better than me is needed to fix the problem.
Back to top
View user's profile Send private message 
tubeguy


Joined: 28 Aug 2009
Posts: 1332
Location: Park Ridge IL USA

PostPosted: Fri 06 Jan 2012, 10:25    Post subject:  

pemasu wrote:
Tubeguy. I believe that the problem is the name of the mounted share. It has space in its name. Pupserver offers the mounted shares through smb/cifs. So it uses the usual way how to mount stuff from ntfs filesystem.
I just didnt invent cure, how to unmount that long mountname with space in its name. The mount point is under /mnt/network/Pupserver...if I remember right.
Trying to umount it from command line fails due to that mount point name. Better than me is needed to fix the problem.

No problemo. Wink

_________________
MSI 970A-G46/AMD FX-8150/Plextor 128GB SSD/Corsair Vengeance 8GB: Tahr Pup 6
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Fri 13 Jan 2012, 04:10    Post subject:  

I decided to install Exprimo 5.X.10.3 (k-3.10) on one of my old P4 backup boxes a few minutes ago and was surprised by no network driver.Checked all of them...no go.
Don't expect a driver,just reporting.It's my backup,backup box so no big deal. In case anyone else runs into this though the nic is a AMDtek NC100 Fast Ethernet.

No problems from the install on my Athlon XP box... still working great. Smile
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Fri 13 Jan 2012, 04:41    Post subject:  

James C.
Quote:
AMDtek NC100 Fast Ethernet

I am interested what driver is in use in the Puppy where it works. Could you check it with working Puppy, I am sure you can easily find out what driver is loaded when it works. Barrys Simple Network Setup ie SNS shows the driver used/loaded nicely.

Then I could check if the driver exists or is the problem somewhere else.

When you know the driver name, you can also by yourself check the existence in 5.X.10.3, in console:
Code:
find /lib -name "DRIVERNAME*"
replace the drivername with the loaded driver name.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Fri 13 Jan 2012, 04:53    Post subject:  

pemasu wrote:
James C.
Quote:
AMDtek NC100 Fast Ethernet

I am interested what driver is in use in the Puppy where it works. Could you check it with working Puppy, I am sure you can easily find out what driver is loaded when it works. Barrys Simple Network Setup ie SNS shows the driver used/loaded nicely.

Then I could check if the driver exists or is the problem somewhere else.

When you know the driver name, you can also by yourself check the existence in 5.X.10.3, in console:
Code:
find /lib -name "DRIVERNAME*"
replace the drivername with the loaded driver name.


Since it's almost 3 am here I'm not doing much more checking until I get some sleep Laughing but Lucid uses the "tulip" driver. Description "Digital 21*4* Tulip ethernet driver". Assume Slacko uses the same since it's installed and working too.
I'll check after I get some sleep but I'm pretty certain it wasn't included in the list of drivers.... I tried most of them..... Laughing
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Fri 13 Jan 2012, 05:05    Post subject:  

And the result is.....

Code:
# find /lib -name "tulip"
#


Time for sleep. Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 28 of 70 [1047 Posts]   Goto page: Previous 1, 2, 3, ..., 26, 27, 28, 29, 30, ..., 68, 69, 70 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1113s ][ Queries: 12 (0.0155s) ][ GZIP on ]