Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 08:32
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.1.10.3 SMP multicore optimized version
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 21 of 70 [1047 Posts]   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, ..., 68, 69, 70 Next
Author Message
Warrior522

Joined: 03 Aug 2010
Posts: 91

PostPosted: Sun 20 Nov 2011, 10:58    Post subject:  

pemasu wrote:
Warrior522. Exprimo ships with 2 window managers.
I presume you mean e17 - enlightenment.
Left click desktop > settings > settings panel > input > mouse buttons > search right click + alt, delete that key binding > apply > close. Done.


Nope, the other one... and I meant to post this in the other Exprimo thread, but I was in a rush and misread the title... >.<
Back to top
View user's profile Send private message 
csshin

Joined: 14 Oct 2007
Posts: 25

PostPosted: Sun 27 Nov 2011, 21:47    Post subject: Asix USB ethernet adapter Driver
Subject description: How to compile driver for Asix USB ethernet adapter
 

I am using Exprimo 5.X.10.2 on Asus Zenbook UX31 which got an Asix USB ethernet adapter. It cannot be recognized by Icepuppy014, Exprimo 5X9 and 5X10. I downloaded new driver from Asix

http://www.asix.com.tw/FrootAttach/driver/AX88772B_772A_760_772_178_LINUX_Driver_v4.2.0_Source.zip

It consists of 4 files: asix.c asix.h MakeFile and a readme.

I installed the devx sfs for Exprimo 5.X.10 and try to compile. However when I navigated to the directory containing the above driver files and typed "make", I got the error "cannot find the build directory in /lib/module/.... If I create the build directory first. The error became "cannot find rule to make" .

The same


I appreciate any help.
Back to top
View user's profile Send private message 
csshin

Joined: 14 Oct 2007
Posts: 25

PostPosted: Sun 27 Nov 2011, 21:48    Post subject: Battery low warning missing
Subject description: Miss the battery low warning in Puppeee and Exprimo 5X9
 

I am using Exprimo 5X10 on Asus Zenbook UX31. It got a battery indicator in the tray that shows the remaining charge and nothing else.

I used Exprimo 5X9 before and the same battery indicator shows the remaining time as well as charge. Also it will give a pop-up warning when the battery is getting low and critically low, at remaining charge percentages specified by user. The same functionality as that in Puppeee which I have used on a EEEpc. Such additional information (esp. the battery low warning) is highly useful. Without it I encountered sudden switch off of the laptop in the middle of work due to used up battery.

I compare Exprimo 5X9 and 5X10 and find the difference may be due to a missing vattery program in the start-up and the accompanying vattery-acpitool and vattery-ibam. I tried to copied from 5X9 but these failed to run with an error of segmentation fault.

Is it possible to have the battery warning back in Exprimo 5X10?
Back to top
View user's profile Send private message 
csshin

Joined: 14 Oct 2007
Posts: 25

PostPosted: Sun 27 Nov 2011, 21:50    Post subject:
Subject description: How to get external monitor to work on Laptop
 

I running Exprimo 5.X.10.2 on a Asus Zenbook UX31.

When I plug the external monitor in before booting the laptop, all display went to the external monitor and the laptop got a black screen. If I hot plug it, the external monitor was not recognized.

The laptop used intel's shared graphic (Sandy bridge, with a core i7 cpu). Do I need to install some additional driver to get a dual monitor, able to switch between the monitors and change the resolution of the monitors independently?
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1819
Location: South Australia

PostPosted: Mon 28 Nov 2011, 04:45    Post subject:  

pemasu I have been using your wonderful pups for quite some time, however only with an ethernet internet connection.

I have just discovered that my wifi connection is not working.

Do you have the ar9179usb wifi driver included? I'm pretty sure it's included in puppy 525 and 528.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Mon 28 Nov 2011, 08:50    Post subject:  

Hi Pemasu,
Run into a few problems on Exprimo 5.X.10.2.

No B43 wireless - copied b43 from D-lite but have to use a script in /etc/init.d to modprobe b43 to get it to load on boot.

Ugly/clipped font rendering - rolled back to earlier fontconfig in /etc/font

/etc/acpi/sleep.sh is not working - first run complained of ehci_hcd not found in /proc/modules - plugged in unplugged a USB drive then run sleep.sh again in terminal no error message but script does not sleep/suspend ?
EDIT:
using the command echo mem > /sys/power/state will suspend system Smile

cheers.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 28 Nov 2011, 11:33    Post subject:  

Forum is now working, it seems, lol. I will check the reported problems.

csshin. To compile kernel module driver you need devx sfs and kernel source sfs of used kernel. Both can be found from smokey01.com/pemasu folders.

About Vattery. Yes it is out. I will include now the pet without vattery-acpitool. It seqfaults but vattery and vattery-ibam works.

About ar9179usb module. It looks like I dont have it included. I will check my kernel compile .config specs and I try to trace the needed module.
Smokey01, is that ar9179usb the exact kernel module which is missing

B43 firmware loading and b43 autoloading does not work with 3.X kernels. Even Barry Kauler has not found solution, yet. I am clueless.

Sleep.sh does not suspend anymore if you have usb plugged in. Not sure if it is good thing or bad thing. But Beem reported that usb plugged in and suspending causes change of hdd naming like sda1 to sdb1 or something like that. But your solution, stu90, seems to work also. Might try that also.

About font rendering. I will check to what I have changed it.

My next month. I will be very busy. Firstly I am at Lapland, Saariselkä, skiing with 38 other skiers 2.12 - 10.12. I will organize that ski camp. When I come back from that vacation, I will have more work than I would like to have. I wont be very active with Puppy until January 2012.
vattery-0.0.1.pet
Description 
pet

 Download 
Filename  vattery-0.0.1.pet 
Filesize  51.94 KB 
Downloaded  98 Time(s) 
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Mon 28 Nov 2011, 11:58    Post subject:  

Pemasu - no problem.
If you happen to see Santa Claus when you are skiing in Lapland can you ask him to bring me a new laptop for Christmas Laughing
Wish we had some snow here in the UK - had a heap last year but none so far this year not even a frost Sad
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 28 Nov 2011, 12:17    Post subject:  

You should check the finnish santa claus movie called Rare exports:
http://www.imdb.com/title/tt1401143/

I recommend it. Have seen it.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5760
Location: Kentucky

PostPosted: Tue 29 Nov 2011, 02:26    Post subject:  

EDIT;
Post removed as problem was already solved by pemasu.

Last edited by James C on Tue 29 Nov 2011, 02:31; edited 1 time in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 29 Nov 2011, 02:27    Post subject:  

James C. In 5.X.10.2 I have applied that fix in building stage. So....the woof has applied it already. It is preinstalled.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5760
Location: Kentucky

PostPosted: Tue 29 Nov 2011, 02:29    Post subject:  

pemasu wrote:
James C. In 5.X.10.2 I have applied that fix in building stage. So....the woof has applied it already. It is preinstalled.


Guess I tried to fix something that wasn't broken. Laughing
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 29 Nov 2011, 16:14    Post subject:  

James C. No problem. Activity and helpful posts is what we need. I just hurried to tell that bug should be fixed already.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Tue 29 Nov 2011, 17:35    Post subject: Dell Laptop  

Hi pemasu,

Frugal installation on my Dell laptop is flawless. Everything appears to be working as it should including video setup, wifi setup, wireless mouse, touchpad, etc.

This distribution is your best to date.

Thanks,
Jim Very Happy
Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 448

PostPosted: Wed 30 Nov 2011, 02:46    Post subject:
Subject description: Firewall status
 

In Exprimo 5.X.10.2, the firewall wizard reports successful sanity checks and a secure network address, but it seems the corresponding ip_tables (kernel modules) are not actually loaded.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 21 of 70 [1047 Posts]   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, ..., 68, 69, 70 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0877s ][ Queries: 12 (0.0115s) ][ GZIP on ]