Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Jan 2019, 19:37
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
XP on raw partition in Virtual box fails (SOLVED)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message

Joined: 13 Jun 2008
Posts: 173
Location: City Of Lights

PostPosted: Wed 17 Aug 2011, 21:12    Post subject:  XP on raw partition in Virtual box fails (SOLVED)  

I am trying to use Virtual Box to access XP on a raw partition using lupu 5.2.5 and the Virtual Box 4.0.0 SFS.
IBM Thinkpad R50p Centrino 1G ram
I have tried so many things I will hit the highlights.
I installed XP SP3 (first by running restore to get all the needed drivers, then a clean install and got everything working using the factory drivers I saved)
I booted lupu 5.2.5. Repartitioned to sda1 15G ntfs XP, sda2 18G ext4 puppy, left sda3 4G factory restore, sda4 extended, sda5 1G swap.
Installed lupu, installed GRUB to boot XP and Puppy (on MBR and /boot on sda2).
Both systems boot and run fine.
Installed VB4.0.0 SFS from Quick Pet (and a bunch of other stuff, all worked)
Copied an XP vdi file from another computer and it ran fine under VB.
Created a raw image: VBoxManage internalcommands createrawvmdk -filename xpraw.vmdk -rawdisk /dev/sda -partitions 1 -relative
Created a boot CD as per http://ubuntuforums.org/showthread.php?t=769883
Created virtual machine with above disks.
Booted to GRUB, chose XP and it stops at "Starting up ..." with a few random colored blocks on the screen.

Tried making a small virtual disk and installing GRUB to it as first disk, XP as second. Same thing.
Created larger disk and installed lupu and GRUB with XP as second disk. Lupu worked, XP same thing.
Tried every combination of GRUB commands and partitions I could think of, no go. (map, root, etc.)
Created new raw image using -partitions 1,2,3 and boot cd with GRUB entries for XP and lupu, same as on the real disk (with pfix=ram as not to corrupt the running save file).
Lupu from the raw image starts fine!! XP still the same.
Tried setting machine variables as here: http://forums.virtualbox.org/viewtopic.php?t=9697
No diff.
Used XP CD to do a "Repair" on the raw image inside VB. Same. Broke real install and had to run repair on it.
I have also tried VB 4.0.6
Because it comes to a compleat stop with no messages, I have no more info on whats happening.
Not sure if it is a VBox problem, a GRUB problem, or an XP problem.

Any suggestions on where to go now?

After a good nights sleep, I found the answer near the end on the Ubuntu thread about setting:
in the /vmdk file. Appears to be a common problem with IBM\Lenovo Thinkpads.
Apparently there is a small link on the first post about "disk read error" but I didn't even notice it since I had no idea what was going on. Shocked
I will leave my experience to maybe help someone else
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0255s ][ Queries: 11 (0.0060s) ][ GZIP on ]