Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 11:16
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy 5.2.8 - Updated ISO Version 005 - APR 05 2012
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 170 of 190 Posts_count   Goto page: Previous 1, 2, 3, ..., 168, 169, 170, 171, 172, ..., 188, 189, 190 Next
Author Message
keniv

Joined: 06 Oct 2009
Posts: 200
Location: Scotland

PostPosted: Thu 31 Oct 2013, 07:17    Post_subject:  

Hi All

First can I say how much I appreciate all of the work that is being done to update Lucid Puppy 528. It is my favorite puppy and I use it daily. It works well with my old Toshiba Satellite Pro 4200 800MHz 320MB. I have various versions of 528 and other puppies as frugal installs as well as XP (rarely used) on my hd booting with grub. I have 528.005 with two save files and I installed the set of update pets produced by rerwin in one of these for testing. These are show below. All seemed well and every thing seemed to work.
I decided I would give the new isos a try and selected lupu-5.2.8.6-2 0131028. I did a manual install. I installed the appropriate video driver and other applications that I use. I had been using Opera 11.50. I decided to update to 12.16 which is the most up to date version in quickpet. I set up Opera with my favorites etc. but I found that some of the dialogue boxes do not display properly (see attached). You get to this from opera-settings-preferences-advanced.
I thought I would go back to see if there were any problems with Opera in the updated 528.005 that I had not noticed and found there were (see attached). This is in Opera 11.5. This only happens in the savefile I updated and so I assume it is caused by something that was in the update pets and has carried forward into the isos.
I am sorry that I seem to have got the attachments in reverse order. I am not sure how to correct this.

Regards,

Ken.
opera1150.jpg
 Description   Opera 11.50 in updated 528.005 with partly corrupted dialog box
 Filesize   21.8 KB
 Viewed   621 Time(s)

opera1150.jpg

opera1216.jpg
 Description   Opera 12.16 with partly corrupted dialogue box
 Filesize   44.79 KB
 Viewed   632 Time(s)

opera1216.jpg

updates.jpg
 Description   Update pets installed in 528.005
 Filesize   43.37 KB
 Viewed   627 Time(s)

updates.jpg

Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1519
Location: Maine, USA

PostPosted: Thu 31 Oct 2013, 10:36    Post_subject:  

keniv,
Thanks for reporting this. With the 20131028 version I introduced a check for pet conflicts with a replacement version of lupu528. I would expect it to pop up a window the first time you boot after changing the lupu_528.sfs file. Note that it is not perfect, in that many packages do not follow the usual naming conventions regarding version numbers.

I would expect the popup to list all of those packages you installed because their versions should match the ones built into 20131028. The popup should recommend that you uninstall all of those packages, in case the new version of something is better that the pet version.

One thing to note: the gtkdialog4 package is older that the gtkdialog package included in 5.2.8.6. So, regardless of whether it showed up in the popup window, that package must be uninstalled in order to make the newest version available to the "p" packages (e.g., pBurn) that need it.

Be sure you keep a copy of your pupsaves in case things do not go perfectly. This will be a good test of the process of upgrading lupu under an existing, package-enhanced pupsave environment. Please keep us informed as to how it goes.
Richard
Back to top
View user's profile Send_private_message 
keniv

Joined: 06 Oct 2009
Posts: 200
Location: Scotland

PostPosted: Thu 31 Oct 2013, 14:33    Post_subject:  

Hi Richard

Thanks for your reply. With 528.005 I updated an existing savefile so I can see why there could be version conflicts. However, with the lupu-5.2.8.6-2 0131028 iso I made a new savefile and then installed Opera 12.16 from quick pet. The only thing that has come from a previous version of Opera was my bookmarks which I imported via Opera rather than manually swapping the bookmarks.adr file in .opera. I also added the urlfilter.ini file to .opera. I did install other pet packages but so far have only noticed a problem with Opera. I will keep testing to see if it occurs with dialogue boxes in other applications. Could the gtkdialog package included in 5.2.8.6. be newer than Opera 12.16 expects? If this is the case could this cause my problem or are the updates back compatible. I also thought of uninstalling the pets from 528.005 one at a time, gtkdialog first. However, I am not sure if this would leave the older original version or would it have been overwritten. Is it worth trying this? It would be interesting to know if anybody else is using Opera with the new iso and whether they are having any problems. I am at a bit of a loss as to what to try with this one.

Regards,

Ken.
Back to top
View user's profile Send_private_message 
keniv

Joined: 06 Oct 2009
Posts: 200
Location: Scotland

PostPosted: Thu 31 Oct 2013, 15:28    Post_subject:  

Uninstalled gtkdialog4-0.8.3-486i.pet from 528.005 test savefile. Made no difference to my problems with Opera. Have re-installed the pet.

Regards,

Ken.
Back to top
View user's profile Send_private_message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 421
Location: Philadelphia, PA

PostPosted: Thu 31 Oct 2013, 15:45    Post_subject: dialog boxes  

(Portions snipped)
keniv wrote:
Thanks for your reply. With 528.005 I updated an existing savefile so I can see why there could be version conflicts. However, with the lupu-5.2.8.6-2 0131028 iso I made a new savefile and then installed Opera 12.16 from quick pet. The only thing that has come from a previous version of Opera was my bookmarks which I imported via Opera rather than manually swapping the bookmarks.adr file in .opera. I also added the urlfilter.ini file to .opera. I did install other pet packages but so far have only noticed a problem with Opera. I will keep testing to see if it occurs with dialogue boxes in other applications. Could the gtkdialog package included in 5.2.8.6. be newer than Opera 12.16 expects? If this is the case could this cause my problem or are the updates back compatible. I also thought of uninstalling the pets from 528.005 one at a time, gtkdialog first. However, I am not sure if this would leave the older original version or would it have been overwritten. Is it worth trying this? It would be interesting to know if anybody else is using Opera with the new iso and whether they are having any problems. I am at a bit of a loss as to what to try with this one.

I tried to check on this:
A day or two ago, I had downloaded
lupumini-5.2.8.6-20131028.iso It's size was 167938048

I put its vmlinuz, initrd.gz, and .sfs files into a new directory in my frugal
/mnt/home/ directory
Booted it.
Made a save file, rebooted, and added opera-12.16-1860.i386.opt.sfs to be autoloaded.

I have not done any of the update files you did.

To test, I did Tools->Preferences-Advanced, and did _not_ see the dialog box problem in Tabs

However, when I did the Bookmarks, right-clicked a bookmark, and clicked Properties, I saw the problem you showed.

It doesn't happen with the old 528.005.

Regarding your thought about gtkdialog, may I just say: I'd had lots of problems with Pmusic because of that, ie it was "expecting" some version of gtkdialog that wasn't there, or ???
Zigbert knows a lot about this stuff; as does, I guess, 01micko.

_________________
Dell E6410: Windows XP, LuPu Super 2 & various Puppys;Dell D610: Windows XP, Puppy Linux 5.2, 'lina-lite; Intel D865GBF: Windows XP, Puppy Linux 5.2;
Acer Aspire One: Windows XP, Puppy Linux 5.2; ASUS P5A: MS-Windows 98SE, Puppy Linux 2.14X
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Thu 31 Oct 2013, 16:57    Post_subject:  

Quote:
Regarding your thought about gtkdialog, may I just say: I'd had lots of problems with Pmusic because of that, ie it was "expecting" some version of gtkdialog that wasn't there, or ???
Zigbert knows a lot about this stuff; as does, I guess, 01micko.

This is exactly the reason why I'm continuing the numbering of gtkdialog. Versions above gtkdialog 0.8.0 are renamed to gtkdialog5 and if I will enter any new issue/problem in a newer gtkdialog, I will use gtkdialog6 for its newer version. Since I'm using strictly SFS files (plus some RoxApps), I'm converting the (each) PET to SFS. Before that I'm just editing the scripts (for example of Pmusic) to change the gtkdialog calls and then including the gtkdialog binary into the new created SFS file.

I really don't care on the SFS files size to load and use a mount point for. And some of these SFS-Apps are automatically unloaded after exiting the application.

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1519
Location: Maine, USA

PostPosted: Thu 31 Oct 2013, 17:08    Post_subject:  

keniv,
Thanks for pursuing the problem. But, please, uninstall all of the pets you mentioned above. The gtkdialog version in 5.2.8.6 is the latest and is (I believe) required for pmusic and pburn and probably other utilities. When you uninstall a program, the original from the current lupu ISO (puppy layer, /initrd/pup_ro2) replaces the previously installed program. So, be sure to uninstall only when you are running with 5.2.8.6, to get its version of each restored file.

Just to be sure you have the correct versions of gtkdialog, please verify -- after you uninstall the gtkdialog4 package -- that /usr/sbin contains gtkdialog (as well as gtkdialog2 & gtkdialog3) as an executable and that gtkdialog4 is a link to gtkdialog (which is the latest version, now).
Code:
# ls -l /usr/sbin/gtkdialog*
-rwxr-xr-x 1 root root 237400 2013-06-08 22:27 /usr/sbin/gtkdialog
-rwxr-xr-x 1 root root  82588 2005-09-10 18:20 /usr/sbin/gtkdialog2
-rwxr-xr-x 1 root root 134332 2011-07-04 08:46 /usr/sbin/gtkdialog3
lrwxrwxrwx 1 root root      9 2013-09-29 17:28 /usr/sbin/gtkdialog4 -> gtkdialog

If you don't have the correct files operating, you can clean things up by going to /initrd/pup_rw/usr/sbin and deleting any gtkdialog* file you see there. That should let the released versions of those files be used.

If you still see the problem then we probably need the help of zigbert or thunor in the 'gtkdialog development' thread, to determine if gtkdialog is at fault.

BTW: I just now uploaded a replacement for the pfbpanel package (as -0.2.1) here:
http://www.murga-linux.com/puppy/viewtopic.php?p=733415#733415

Edited_time_total
Back to top
View user's profile Send_private_message 
mikeslr


Joined: 16 Jun 2008
Posts: 783
Location: Union New Jersey USA

PostPosted: Thu 31 Oct 2013, 17:31    Post_subject: pfbpanel-0.3.1-lucid.pet working well  

Hi rerwin &All,

pfbpanel-0.3.1-lucid.pet, http://murga-linux.com/puppy/viewtopic.php?p=733415&sid=5149eb710024947728d56557bac779b4#733415 appears to be working fine in your LupuLibre.
I booted out of LupuLibre, created a Protected SaveFile, deleted the SaveFile and edited GRUB4Dos's menu.lst to boot LupuLibre pfix=ram. Booted into LupuLibre, created a new SaveFile, rebooted and installed your pet. Restarting X showed the default two launchers, “show-desktop” and (I think) default browser. Accessing the Configurator from the desktop submenu, I was able to easily add two more launchers, one in the 3rd configuration position, the second in the 7th configuration position which, there being no launchers assigned to the 4th thru 6th configuration positions, showed up in the 4th panel position. Both new launchers worked to start the applications assigned to them.
Because of about an hour's customization to LupuLibre preserved on my original SaveFile, I've reverted to it. But on the next version of Lupu I customize from scratch, I'll be sure to use your pet.

mikesLr
Back to top
View user's profile Send_private_message 
keniv

Joined: 06 Oct 2009
Posts: 200
Location: Scotland

PostPosted: Thu 31 Oct 2013, 18:22    Post_subject:  

Hi All

Based on the post by sheldonissac where he ran Opera from an sfs I thought I would try it and see what happened. I had used opera-12.11-1661.i386.opt.sfs before and had a copy on a flash drive which I copied to my hd. After booting 5286 I loaded it "on the fly" and ran it. It started with my home page and with all my bookmarks, toolbars etc. I believe it is using the .opera from the 12.16 version I have installed from a pet. I checked opera-help-about opera to check that I was running the 12.11 version and I was (see attached). But guess what, now all the dialogue boxes display properly! Does this mean the problem is version specific?

Richard

Are you suggesting that I uninstall the pets from the 528.005 version. If this is the case then I'm not sure what you mean here.
Quote:
So, be sure to uninstall only when you are running with 5.2.8.6, to get its version of each restored file.

To me this seems to suggest that I would be running 528.005 in order to uninstall the update pets but at the same time be running 5286 in some way. Sorry if I am being a bit thick here.

Regards,

Ken.
aboutopera.jpg
 Description   Info in "About Opera" about version running
 Filesize   8.61 KB
 Viewed   342 Time(s)

aboutopera.jpg

Back to top
View user's profile Send_private_message 
keniv

Joined: 06 Oct 2009
Posts: 200
Location: Scotland

PostPosted: Thu 31 Oct 2013, 19:14    Post_subject:  

Have uninstalled all of the update pets from 528.005 and rebooted. This has not completely cleared the problem. If I right-click on the bookmarks toolbar then choose "properties" I get the corrupted bookmarks properties box shown in my earlier post. If I choose opera-settings-preferences-advance I get an uncorrupted box. Shown below is what I have in /usr/sbin. I am more concerned that Opera works in 5286 and based on my experience with opera-12.11-1661.i386.opt.sfs I do still wonder if it is version specific.

Regards,

Ken.
usrsbin.jpg
 Description   gtkdialog files left in /usr/sbin
 Filesize   5.11 KB
 Viewed   304 Time(s)

usrsbin.jpg

Back to top
View user's profile Send_private_message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 421
Location: Philadelphia, PA

PostPosted: Thu 31 Oct 2013, 20:32    Post_subject: re the messed-up dialog boxes  

Quote:
Booted it.
Made a save file, rebooted, and added opera-12.16-1860.i386.opt.sfs to be autoloaded.

I have not done any of the update files you did.

To test, I did Tools->Preferences-Advanced, and did _not_ see the dialog box problem in Tabs

However, when I did the Bookmarks, right-clicked a bookmark, and clicked Properties, I saw the problem you showed.

Oops.

I just booted the 5.2.8.6 without a save file, and did the SFS-Load on-the-fly of the Opera .sfs.

The Bookmarks properties box looks fine!

I guess something in my save-file is messed up.

Sheldon

_________________
Dell E6410: Windows XP, LuPu Super 2 & various Puppys;Dell D610: Windows XP, Puppy Linux 5.2, 'lina-lite; Intel D865GBF: Windows XP, Puppy Linux 5.2;
Acer Aspire One: Windows XP, Puppy Linux 5.2; ASUS P5A: MS-Windows 98SE, Puppy Linux 2.14X
Back to top
View user's profile Send_private_message 
bigpup


Joined: 11 Oct 2009
Posts: 5170
Location: Charleston S.C. USA

PostPosted: Thu 31 Oct 2013, 22:55    Post_subject:  

Clean frugal install of Lupu3HD 5.2.8.6

Installed the Opera -12-lucid pet offered in Quickpet->Internet pets
I get the same display problems as keniv in opera-settings-preferences-advanced.

Wonder if this pet is made proper for Puppy.

Did a dependency check on Opera install and got this:
opera dependency check.jpg
 Description   
 Filesize   32.88 KB
 Viewed   274 Time(s)

opera dependency check.jpg


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 
bigpup


Joined: 11 Oct 2009
Posts: 5170
Location: Charleston S.C. USA

PostPosted: Thu 31 Oct 2013, 23:27    Post_subject:  

Installed Opera-12.16.1860-i386.pet from here:
http://distro.ibiblio.org/quirky/pet_packages-common/
No display problems using this pet of Opera 12.16

However, this one did not make an entry in the menu->Internet
Had to run it from terminal.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5799
Location: Kentucky

PostPosted: Thu 31 Oct 2013, 23:38    Post_subject:  

Had to get in on the browser testing fun......

Latest Lucid test release...fresh frugal install. Opera from Quickpet.....not good.
Opera from Quickpet.jpg
 Description   
 Filesize   20.59 KB
 Viewed   270 Time(s)

Opera from Quickpet.jpg

Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5799
Location: Kentucky

PostPosted: Thu 31 Oct 2013, 23:39    Post_subject:  

Continued..... Opera downloaded directly from Opera........ looks good.
Direct from Opera.jpg
 Description   
 Filesize   39.73 KB
 Viewed   283 Time(s)

Direct from Opera.jpg

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 170 of 190 Posts_count   Goto page: Previous 1, 2, 3, ..., 168, 169, 170, 171, 172, ..., 188, 189, 190 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1477s ][ Queries: 12 (0.0459s) ][ GZIP on ]