Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 06:22
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy 5.2.8 - Updated ISO Version 005 - APR 05 2012
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 11 of 190 [2845 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13, ..., 188, 189, 190 Next
Author Message
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Sun 28 Aug 2011, 23:40    Post subject:  

***Experimental***

Audacious 3.0.2. It was compiled in Lucid 5.2.8. The pet includes libgtk-3.0.8 which is required (as Audacious now uses either gtk3 or a version later than we have of gtk2). The pet also includes the most recent official release of the ffmpeg multimedia libraries 0.8.2.

http://diddywahdiddy.net/Puppy500/Audacious-3.0.2-lucid528.pet
.

Last edited by playdayz on Thu 01 Sep 2011, 13:27; edited 1 time in total
Back to top
View user's profile Send private message 
majorfoo

Joined: 07 Mar 2011
Posts: 445
Location: Wish I knew

PostPosted: Mon 29 Aug 2011, 00:48    Post subject:  

playdayz wrote:
***Experimental***

Audacious 3.0.2. It was compiled in Lucid 5.2.8. The pet includes libgtk-3.0.8 which is required (as Audacious now uses either gtk3 or a version later than we have of gtk2). The pet also includes the most recent official release of the ffmpeg multimedia libraries 0.8.2.

http://diddywahdiddy.net/Puppy500/Audacious-3.0.2-lucid528
.


Playdayz - d/l and tried in lucid 5.28

couple of things on this one
1. Had to add .pet to end of your file before would install as pet

2. When I try to play .mp3 file, receive error message
No decoder found for file xxxxx.mp3

additional information when I run from command line

/root
# audacious

** (audacious:23860): WARNING **: Desktop file '/usr/share/applications/audacious.desktop' has malformed Icon key 'audacious.png'(should not include extension)
/root
#

nap time for me - will be back in few hours

majorfoo
Back to top
View user's profile Send private message 
majorfoo

Joined: 07 Mar 2011
Posts: 445
Location: Wish I knew

PostPosted: Mon 29 Aug 2011, 08:29    Post subject:  

playdayz -
i got the new version of audacious to work by making following changes

1. /usr/share/applications/audacious.desktop line 32 changed audacious.png to audacious - removed .png extension

2. copied /usr/lib/libmpg123.so.0.25.1 and symlink libmpg123.so.0 from
lucid 529 -
Edit 8-30-11 - I just determined that these libs are not in original iso for lucid 529. I had audacious 3.0 loaded on full install of 529 and these libs are in 3.0 but not in 3.2

it now works. great sound

Perhaps this is not way to do things, but it worked for me

Last edited by majorfoo on Tue 30 Aug 2011, 11:50; edited 1 time in total
Back to top
View user's profile Send private message 
Brown Mouse


Joined: 09 Jun 2009
Posts: 449
Location: Tenerife Canary Islands

PostPosted: Mon 29 Aug 2011, 09:58    Post subject:  

playdayz wrote:
Quote:
I'm not having much luck today.I installed the Mplayer 34026-002.pet and get a fatal error of 'skin default not found'.
Tried a reboot to no avail.

Oh, Maybe I left a desktop file for the gui in the pet. I will check. You never need to start mplayer-gnome-mplayer does all the work for you. You can type mplayer at a console to see the svn number from the version you are using--should be 34026.


Sorry Playdayz!

I had been seeing this error whilst trying to launch Mplayer from the Multimedia menu entry.My mistake I believe!
You are correct about the version I see from within in a console which is 34026.
Back to top
View user's profile Send private message 
openwell2

Joined: 25 Jun 2011
Posts: 19
Location: Port St Lucie, Florida USA

PostPosted: Tue 30 Aug 2011, 10:02    Post subject: firewall problem in Puppy 528
Subject description: firewall icon shows on after right-click and confirm want it off
 

Hi,
I have a full install Puppy 528 and firewall does not seem to work correctly.
Right click on the icon.
You get the dialog box to turn it off.
Confirm Ok to turn it off, and firewall is still ON?
Anyone else have any ideas?

I looked at the rc.firewall text file and it seems to have different line numbers than Puppy 525?
Not sure what is different.
I usually only use the Line # 45 PERMIT " "
It is now line number 60 or 70 something?
This allows me to have firewall on and open specific ports for Transmission to use.
many thanks,
Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 460

PostPosted: Tue 30 Aug 2011, 10:07    Post subject:
Subject description: PupControl-1.7
 

UPDATE: PupControl-1.7 includes Pup-SysInfo, a new and comprehensive system information module.

http://www.murga-linux.com/puppy/viewtopic.php?t=61961
Pup-SysInfo.png
 Description   
 Filesize   22.76 KB
 Viewed   1986 Time(s)

Pup-SysInfo.png

Back to top
View user's profile Send private message 
tasmod


Joined: 04 Dec 2008
Posts: 1461
Location: North Lincolnshire. UK

PostPosted: Tue 30 Aug 2011, 10:55    Post subject:  

openwell2,

You're correct there has been a change in rc.firewall, so the script won't work.

I have only cursorily looked so will report back later when I've studied it.

EDIT:

DOH ! Must remember which puppy version I'm in when i do a check ! Embarassed


OK it's a gtk change that's caused the problem but I've fixed it.

Fix posted in Additional Software, under Network

_________________
Rob
-
The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send private message Visit poster's website 
openwell2

Joined: 25 Jun 2011
Posts: 19
Location: Port St Lucie, Florida USA

PostPosted: Tue 30 Aug 2011, 14:41    Post subject: firewallstate 2.0 fixed the firewall on/off in Puppy 528
Subject description: firewall on/off right click works
 

@tasmod,

Many thanks,

Fixed Puppy 528 firewall

firewallstate 2.0 installed

and on/off switching works great!

Find it here:
http://www.murga-linux.com/puppy/viewtopic.php?t=57725
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Tue 30 Aug 2011, 16:17    Post subject: Updates for lupu 5.2.8 instant update package  

playdayz,
As promised, here is my complete set of changes (as of now) that can go into the instant update package for lupu 5.2.8. The attached package is similar to the "-1" version but has additional minor touch-ups and most of shinobar's firstrun-1.8.4 package. I have omitted his new capability, "extralangs", because I cannot assess the "sfs" part of it; the function can be added by dot-pet package, if desired. Here is a summary of the changes:
    # 1. Update /etc/rc.d/MODULESCONFIG.
    # 2. Reduce occurrences of DNS not being set for ppp connections to some USB-modem ISPs. (/etc/ppp/wvdial)
    # 3. Retain access to prename script if devx also loaded (with a different script of the same name) (usr/share/applications/prename.desktop).
    # 4. Set "show_msg=NO" configuration option for both of dillo's dillorc files (adding the one in /etc/dillo).
    # 5. Correct missing "fi" statement in bareview script.
    # 6. Personal Settings updates:
    # . . a. Complete the hostname-change process by cycling connections and prompting user to log out.
    # . . b. Simplify numlock preset logic.
    # . . c. Avoid "barks" during full country-settings display but retain them for first runs with no pupsave files or full installations.
    # . . d. Integrate firstrun-1.8.4 into lupu version of personal settings script but exclude new "extralang" support (which could be provided by a dot-pet package).

shinobar,
I also attach the difference listing comparing 1.8.4 to the merged lupu version of countrywizard.qs, to help you evaluate my result. I omitted extralangs by simply not including the extralangs script, so countrywizard.qs just skips it. Please verify that the script still does what you intend, other than the extralangs part.

Both,
The lupu version adds a line of text to the "FULLMSG" string. Playdayz, is the text still important to keep? If so, shinobar, then a translation of it is needed for language support. To keep things simple, I treat the added text as a separate string, so FULLMSG has two gettext components. The text to be translated is:
    'To change UTF-8 status, choose your language from the drop-down menu and click OK. If you are booting a USB disk and want to use a USB Wifi device, you should Shut Down and create a save file *before* you set up networking.'
For now, though, that part of the combined message text will be in English.

UPDATE: In the updated (-3) package there are more text strings for translation:
    "When requested to do so in text mode, please enter 'logout' and then 'xwin'"
    "to run the Video Wizard and return to the desktop."
    "to return to the desktop."
Thank you, both, for helping me wrap this up.
Richard
lupu528_rerwin_patch-3.pet
Description  Contributions to instant update, also for user testing.
Adds translatable dialog messages about restart for hostname change and Xorgwizard request.
pet

 Download 
Filename  lupu528_rerwin_patch-3.pet 
Filesize  55.75 KB 
Downloaded  163 Time(s) 
diff-countrywizard.qs_vs_1.8.4.txt.gz
Description  New difference listing versus firstrun-1.8.4
gz

 Download 
Filename  diff-countrywizard.qs_vs_1.8.4.txt.gz 
Filesize  2.48 KB 
Downloaded  154 Time(s) 

Last edited by rerwin on Thu 01 Sep 2011, 14:35; edited 2 times in total
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Tue 30 Aug 2011, 18:11    Post subject:  

Battleshooter discovered that the headers for the ffmpeg multimedia libraries (needed to compile some apps) were missing in lupu_devx_528. Here they are in lupu_devx_528-2.sfs.

http://distro.ibiblio.org/puppylinux/puppy-5.2.8/lupu_devx_528-2.sfs
fa969da4a46c64040317f33a4c16ef94

Kernel sources for 2.6.33.2 kernel (also needed to compile some apps) ->
ftp://distro.ibiblio.org/puppylinux/pet-packages-lucid/kernel_src_L4-2.6.33.2-patched.sfs
78a989b17552d10bd2d7ba2f2c3c1217

Both of these thing are now listed in the first message of this thread.

-----------------------------------------------------------------------------

Thanks rerwin. I will get moving in a few days--soon as I catch up with my other job.

----------------------------------------------------------------------------

majorfoo, Thanks for doing all the debugging for me Wink I will repair the pet ASAP. I was actually amazed that it worked at all--it has gtk3 plus ffmpeg 0.8.2. Yes, the libmpg123 needed to be there. I am not sure why you had to delete the png extension--was that only to eliminate the "error" message in the console. Without the .png extension some apps do not display the icon in the jwm menu--so the choice is either the message (harmless) or the icon (which people complain about if it is not there!).

EDIT-> Weird. My install played an mp3 without libmpg123 being present. What it did was to use ffmpeg/ffaudio to play it (I am pretty sure). Perhaps you could take a look at File -> Preferences -> Plugin -> Input and compare what you see to my picture. I want to make sure that you are getting the ffmpeg support (last line on mine).

The link at the top of this page now has the repaired Audacious 3.0.2 pet. It is still experimental, until we see if it breaks anything!

I should say that for non-fanatics (me and majorfoo being fanatics) Audacious 2.5.4 is fully functional (like Data).
http://distro.ibiblio.org/puppylinux/pet-packages-lucid/audacious-2.5.4.pet




.
aaudacious302-528.png
 Description   
 Filesize   127.51 KB
 Viewed   551 Time(s)

aaudacious302-528.png


Last edited by playdayz on Tue 30 Aug 2011, 18:51; edited 1 time in total
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Tue 30 Aug 2011, 18:50    Post subject:  

Firewallstate update and PupControl update will be in Instant Update 001 for Lucid 5.2.8. Coming soon to a computer near you.

Thanks radky and tasmod.

---------------------------------------------------------------------------------------

Brown Mouse, Yes, I needed to fix the pet, which I have now done. Thanks for helping debug. This one is still experimental too. It has the latest ffmpeg libraries built-in, so it is less likely to cause problems

http://diddywahdiddy.net/Puppy500/mp34026-002.pet
Back to top
View user's profile Send private message 
majorfoo

Joined: 07 Mar 2011
Posts: 445
Location: Wish I knew

PostPosted: Tue 30 Aug 2011, 21:09    Post subject:  

playdayz wrote:


majorfoo, Thanks for doing all the debugging for me Wink I will repair the pet ASAP. I was actually amazed that it worked at all--it has gtk3 plus ffmpeg 0.8.2. Yes, the libmpg123 needed to be there. I am not sure why you had to delete the png extension--was that only to eliminate the "error" message in the console. Without the .png extension some apps do not display the icon in the jwm menu--so the choice is either the message (harmless) or the icon (which people complain about if it is not there!).

EDIT-> Weird. My install played an mp3 without libmpg123 being present. What it did was to use ffmpeg/ffaudio to play it (I am pretty sure). Perhaps you could take a look at File -> Preferences -> Plugin -> Input and compare what you see to my picture. I want to make sure that you are getting the ffmpeg support (last line on mine).

The link at the top of this page now has the repaired Audacious 3.0.2 pet. It is still experimental, until we see if it breaks anything!

I should say that for non-fanatics (me and majorfoo being fanatics) Audacious 2.5.4 is fully functional (like Data).
http://distro.ibiblio.org/puppylinux/pet-packages-lucid/audacious-2.5.4.pet
.


agree the .png extension is harmless - does not prevent application from running.

when I first tried Audacious 3.02, using gui entry in multimedia, I received error regarding codecs.

went to command line and that is where I saw msg about .png extension and missing library.

Audacious - file - preferences - plugins
my copy is exactly same as your example.

You provided link to audacious 2.54 pet -- I have been running audacious 3.0-lucid.pet since you first posted and have not had any problems with it.

Not sure about the fanatic part - I just try to understand why something does not work - my very, very limited knowledge of linux sometimes keeps me from explaining problem so others can understand what I am trying to communicate.

majorfoo
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5231
Location: Charleston S.C. USA

PostPosted: Tue 30 Aug 2011, 21:38    Post subject:  

Pburn just got updated to V3.3.5
http://www.murga-linux.com/puppy/viewtopic.php?t=23881

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
majorfoo

Joined: 07 Mar 2011
Posts: 445
Location: Wish I knew

PostPosted: Wed 31 Aug 2011, 08:35    Post subject:  

playdayz wrote:
***Experimental***

Audacious 3.0.2. It was compiled in Lucid 5.2.8. The pet includes libgtk-3.0.8 which is required (as Audacious now uses either gtk3 or a version later than we have of gtk2). The pet also includes the most recent official release of the ffmpeg multimedia libraries 0.8.2.

http://diddywahdiddy.net/Puppy500/Audacious-3.0.2-lucid528
.


playdayz
I booted original 528 cd and downloaded new audacious-3.0.2-lucid528
that you mentioned in lucid 529 thread on 8-30-11

renamed audacious-3-0.2-lucid528 to
audacious-3.02-lucid528.pet so would install as pet file

ran this from console and received following:

sh-4.1# audacious

** (audacious:4500): WARNING **: Desktop file '/usr/share/applications/audacious.desktop' has malformed Icon key 'audacious.png'(should not include extension)
params.c:OpenConfFile() - Unable to open configuration file "/root/.smb/smb.conf":
No such file or directory
params.c:OpenConfFile() - Unable to open configuration file "/root/.smb/smb.conf.append":
No such file or directory
Using netbios name PUPPYPC.
Using workgroup TNG-WORKGROUP.
socket(): Address family not supported by protocol
pulseaudio: Failed to connect to server: Connection refused

we know that the .png extension is harmless

non of the above prevented application from working, sounds great

this for your information

majorfoo
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Wed 31 Aug 2011, 09:39    Post subject:  

Don't know if anyone else had this problem with a similar wireless card but the microcode for my intel centrino advanced-n wireless card (iwlagn driver) was missing, fixed it with pet below.
iwlwifi-6050-4.pet
Description 
pet

 Download 
Filename  iwlwifi-6050-4.pet 
Filesize  209.41 KB 
Downloaded  172 Time(s) 

_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 11 of 190 [2845 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13, ..., 188, 189, 190 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1285s ][ Queries: 12 (0.0236s) ][ GZIP on ]