Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 01:46
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to change Puppy 4.2.1 menu language to Danish?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Insomniacno1

Joined: 24 Jul 2009
Posts: 75

PostPosted: Thu 11 Aug 2011, 13:20    Post_subject:  How to change Puppy 4.2.1 menu language to Danish?  

Hi all, I have asked this before in other threads but never got an answer:

Is it possible to change the menu's to Danish language? Just like when you change the locale in ubuntu or other distro's.

I hope Barry K and other of the "old ones" see this post, since its relevant if you want to "sell" puppy to other countries.

Hope someone can help:)

With kind regards

Jan

EDIT: I had to move to 4.2.1 for other reasons, so I changed the name of this thread from "How to change Lucid 5.2.5-2.6.30.5 menu language to Danish?" How to change Puppy 4.2.1 menu language to Danish?
Back to top
View user's profile Send_private_message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Mon 15 Aug 2011, 16:11    Post_subject:  

That will be a monumentous task.

I am not sure why you want to use the old and outdated 421, but if you do, then use pfind and search for "menu". You will find the menu files probably at /etc/xdg/menus.
You may translate them, but do make backup copies.

This should all be easier in Lucid, with this reference as a starting point
http://murga-linux.com/puppy/viewtopic.php?t=59142

Edited_time_total
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 15 Aug 2011, 16:17    Post_subject:  

If you make reference to other threads, please post the corresponding link of those threads.
Nobody is interested in chasing down your threads.

When you did the first run (after first boot) was there a possibility to choose the danish language?

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
Insomniacno1

Joined: 24 Jul 2009
Posts: 75

PostPosted: Tue 16 Aug 2011, 02:33    Post_subject:  

wuwei wrote:
That will be a monumentous task.

I am not sure why you want to use the old and outdated 421, but if you do, then use pfind and search for "menu". You will find the menu files probaly at /etc/xdg/menus.
You may translate them, but do make backup copies.

This should all be easier in Lucid, with this reference as a starting point
http://murga-linux.com/puppy/viewtopic.php?t=59142


Hi and welcome, first of all what are you refering to when you say monumentous task?

Second, thank you very much for the info:)

And third, the reason is that I had great trouble getting Lucid to accept and configure the ATI Rage 128 Pro card in the pc:) Its not working with openGL in Lucid, but it works now, in 4.2.1.

Jan
Back to top
View user's profile Send_private_message 
Insomniacno1

Joined: 24 Jul 2009
Posts: 75

PostPosted: Tue 16 Aug 2011, 02:45    Post_subject:  

Béèm wrote:
If you make reference to other threads, please post the corresponding link of those threads.
Nobody is interested in chasing down your threads.

When you did the first run (after first boot) was there a possibility to choose the danish language?


Aah the other threads, I'm afraid they are gone by now. That was long time ago.

Only the keyboard language, where I chose DK Denmark and it works(one thing Lucid could learn from). But the menu is still in US english.

With kind regards

Jan

oh my other threads:
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 16 Aug 2011, 05:21    Post_subject:  

No post are lost here.
So if you login to the forum, you can see all your post (you only have 46) and find rapidly the one(s) you are referring at.
Up to you.

As for your answer on the language, it isn't very precise.

What is your country setup? (something like xx_YY)

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Tue 16 Aug 2011, 05:44    Post_subject:  

Quote:
what are you refering to when you say monumentous task?


It is a long time ago since I used 421.
If I am not mistaken, it didn't have a country wizard as Lucid now has.

In other words, if you can't find a Danish localisation with this search engine
http://www.google.com/cse?cx=015995643981050743583%3Aabvzbibgzxo&q=localisation+Danish&sa=Search&cof=FORID%3A0
(only 3 entries) then you'd be left to translate a bunch of files at the above mentioned location. And that....is a very big task!
Back to top
View user's profile Send_private_message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Tue 16 Aug 2011, 06:02    Post_subject:  

Other approach:

Use Lucid 525 (or 528 http://www.murga-linux.com/puppy/viewtopic.php?t=70688 ) and get the driver for your card with the Puppy Package Manager.

Or get it from ATI.
http://support.amd.com/us/psearch/Pages/psearch.aspx?type=2.4.1&product=2.4.1.3.28&contentType=GPU+Download+Detail&ostype=Linux+x86&keywords=&items=20

But then you'd need devx.sfs and kernelsources.sfs. The first is on the 528 website, the second can possibly be obtained by asking playdayz, also via this website.

Once you have the driver from ATI and the 2 SFS, you can compile the driver for Lucid.

I did it with nvidia drivers and it worked just fine.
Back to top
View user's profile Send_private_message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Tue 16 Aug 2011, 13:02    Post_subject:  

And one last idea:

This is a link to Akita Puppy Linux
http://murga-linux.com/puppy/viewtopic.php?p=552240#552240
based on Puppy 420 and Wary.

The author sc0ttman has requested translations for menus and messages to German on the German forum. So one should conclude that any other language could be accomodated, as well.

If you try Akita and if it works satisfactorily, you might contact sc0ttman and offer to do the Danish translation.

The Puppy is visually appealing and much more up-to-date than 4.2.1.
Back to top
View user's profile Send_private_message 
Insomniacno1

Joined: 24 Jul 2009
Posts: 75

PostPosted: Wed 17 Aug 2011, 03:57    Post_subject:  

As far as I understand from Mikeb then there is no way of getting the ATI card to work in lucid since the Xorg doesn't support it, its too new.

Only option is to use a puppy with an older Xorg.

But enough about the ATI card:) This is a thread for the Menu:) I were asked by the admin flash to split my thread and that I will keep:)
Back to top
View user's profile Send_private_message 
Insomniacno1

Joined: 24 Jul 2009
Posts: 75

PostPosted: Fri 19 Aug 2011, 15:03    Post_subject:  

I switched to Wary 5.1.3 since I kept running into missing dependencies in 4.2.1, and in Wary 5.1.3 OpenGL works with the ATI Rage 128 Pro AGP 4x 16MB card - after installing the following:

Xorg_xorg_base-7.3.1-p4.pet
Xorg_xorg_full_dri-7.3.pet
Xorg_xorg_servers-7.3-1.pet

You can get them here http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/

DO NOT use the ones from the PPM, since they are for the Intel Videocard.
-------------------------

Back to the menu problem, this persists:( Though I helped Sc0ttman with the danish translation for Akita, not all the files though:)

My hope is that if his project works then the translations can be ported to Wary:)

With kind regards

JBJ
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0688s ][ Queries: 11 (0.0030s) ][ GZIP on ]