Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 20 Jul 2018, 01:15
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Squeeze 5x D-Lite
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 7 of 9 [130 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message
stu90


Joined: 25 Feb 2010
Posts: 1399
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Sun 14 Aug 2011, 06:19    Post subject:  

New D-lite 5.0.8 download on page one.
Back with 2.6.39-4 kernel
Update to Ymount 0.9
earlier feh version
update downloader

There has been some talk on Barry's blog about possible problems during the build process with woof and 2.6.39.x kernel - i haven't noticed anything missing but then i don't know the ins and outs of puppy that well to tell for sure, this build seems to work ok for me though so i think i will stick with 5.0.8 for a while and see what pans out.

I will have a look through the other dpup threads and see if there are any bugs i can fix on D-lite - theres also a couple of other little things i want to look into at as well - and maybe try and build a pet for printer use.
Back to top
View user's profile Send private message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Sun 14 Aug 2011, 14:34    Post subject:  

frugal manual install 508 to ext4 but unlike 507 broadcom wl.ko driver is not there Crying or Very sad
Back to top
View user's profile Send private message 
Payoon

Joined: 26 May 2010
Posts: 30
Location: Duisburg, Germany on the banks of the Rhine

PostPosted: Mon 15 Aug 2011, 05:28    Post subject: Frugal Install Of DPUP Lite
Subject description: Can't install frugal
 

Hi,
After booting with pfix=ram and trying to do a frugal install it always ends up with the following:
installer tells me that he can't unmount my harddisk. When I check with pmount, I find that the harddisk is unmounted. I have tried another harddisk with ext3, freshly formatted and bootable. Same problem. I have to mention that I have installed many puppies (barry's dpup, lucid puppy etc.) and never had this occur. What could be wrong. BTW the dpup lite is great.
Has anyone an idea?

Payoon
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1399
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Mon 15 Aug 2011, 06:23    Post subject: Re: Frugal Install Of DPUP Lite
Subject description: Can't install frugal
 

Payoon wrote:
Hi,
After booting with pfix=ram and trying to do a frugal install it always ends up with the following:
installer tells me that he can't unmount my harddisk. When I check with pmount, I find that the harddisk is unmounted. I have tried another harddisk with ext3, freshly formatted and bootable. Same problem. I have to mention that I have installed many puppies (barry's dpup, lucid puppy etc.) and never had this occur. What could be wrong. BTW the dpup lite is great.
Has anyone an idea?

Payoon


Hello Payoon,
this is probably due to gparted partition manager not being installed as default - you can download the .pet from here:
http://ubuntuone.com/p/1APW/
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1399
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Mon 15 Aug 2011, 06:55    Post subject:  

jim3630 wrote:
frugal manual install 508 to ext4 but unlike 507 broadcom wl.ko driver is not there Crying or Very sad


Hi jim3630,
507 was using Pemasu's lupe kernel - but i had some problems with that build with mega error floods numbering in the several thousands - not sure what was causing it, bad build, something not copied over in woof, broken script? so i have gone back to using 2.6.39-4 kernel for the time being.

I really have no experience at all with things like compiling kernels and wifi drivers - Could the wl.ko be copied from 507?
Perhaps Iguleder or Pemasu could offer some advice on what is need to get this wifi to work?
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5484
Location: Finland

PostPosted: Mon 15 Aug 2011, 07:37    Post subject:  

Kernel module drivers are usually compiled kernel spesific. The specs needs to be really similar that you can cross-use them.
Probably my compiled wl module wont work in Iguleders kernel.
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1399
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Mon 15 Aug 2011, 09:59    Post subject:  

Thanks for information Pemasu - i had a feeling it wouldn't be so simple Sad
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1399
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Mon 15 Aug 2011, 10:27    Post subject:  

First test for new update downloader feature in D-lite-5.0.8.



This is a very crude update downloader aimed for those who maybe don't visit the forums so often or have the time to read through multi page threads - it is not automated or anything like that - its main aim is for low level update, missing libs, fixing .desktop icons, broken symlinks general small bug fixes etc

Ideally i would have liked to have had the update automatically install after downloading but i guess some people would freak out at such a prospect so you just download the .pet to your chosen download location and click on it to install as normal.

Once an update is installed it will show up in the dpup-update GUI under 'Already installed updates:'
Once an update has been installed it is best not to uninstall as some things may break!
If you accidentally uninstall an update reinstall it or redownload it from the dpup-update gui.

Update name format - UPDATE-5.0.8_01_15-08-2011.pet

UPDATE = means it is an update
5.0.8 = is the D-lite version (only updates for that version will be displayed)
_01_ = being the update number 01 first 02 second 03 third etc
15-08-2011 = is the date the update was added.

How to use:
open a terminal and enter the command: dpup-update


-included updates in 01 :
- menu item / desktop file for dpup-update in Puppy > Setup Puppy (run the updater from there after first update)
- updated Packages-puppy-exprimo-official repo file
- fixed Desk top mode bug in roxicon
- fixed desktop mode bug in desktop icon switcher

cheers.
Back to top
View user's profile Send private message 
Payoon

Joined: 26 May 2010
Posts: 30
Location: Duisburg, Germany on the banks of the Rhine

PostPosted: Mon 15 Aug 2011, 11:45    Post subject:  

[img]Stu90 wrote:
Hello Payoon,
this is probably due to gparted partition manager not being installed as default - you can download the .pet from here:
http://ubuntuone.com/p/1APW/
[/img]

Hi Stu90,
You were exactly right. After installing the gparted pet I could do a frugal install without problems. Looks fine and is fast.Thanks for the advice and for Squeeze D-Lite.

Payoon
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5484
Location: Finland

PostPosted: Mon 15 Aug 2011, 12:56    Post subject:  

Stu90. I will stole your Dpup updater at some stage. As exchange here is fixed sfsget-manager-0.0.4 which now accepts names with _ . At least sfsget which I modified is from the woof which supports that. It can be that 15.8 woof /usr/local/petget scripts are needed also.
It connects to the exprimo`s sfs repo. It can be difficult to keep apps sfs files compatible with Dpup Lite, but lets try. Many sfs apps anyway will be compatible with small modifications.
sfsget-manager-0.0.4.pet
Description 
pet

 Download 
Filename  sfsget-manager-0.0.4.pet 
Filesize  7.41 KB 
Downloaded  237 Time(s) 
Back to top
View user's profile Send private message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Mon 15 Aug 2011, 14:41    Post subject:  

stu90 wrote:
jim3630 wrote:
frugal manual install 508 to ext4 but unlike 507 broadcom wl.ko driver is not there Crying or Very sad


Hi jim3630,
507 was using Pemasu's lupe kernel - but i had some problems with that build with mega error floods numbering in the several thousands - not sure what was causing it, bad build, something not copied over in woof, broken script? so i have gone back to using 2.6.39-4 kernel for the time being.

I really have no experience at all with things like compiling kernels and wifi drivers - Could the wl.ko be copied from 507?
Perhaps Iguleder or Pemasu could offer some advice on what is need to get this wifi to work?


Hi Stu, actually Slacko's 2.6.37.6 kernel has a broadcom pet that worked in three headed aka luci-529 and for the 2.6.33.2 kernel on the board here is a broadcom_sta-5.6.48.36-i486.pet which worked in puppy rescue os.
pemasu never posted broadcom pets for his 2.6.39xx series, the wl driver were built-in. Iguleder doesn't provide wifi drivers or include 3rd party drivers in his builds.

---
used the same broadcom pet for 262 thru 268,527rc and 528. it's been my experience same pet will work as long as same kernel.

Last edited by jim3630 on Tue 16 Aug 2011, 10:25; edited 1 time in total
Back to top
View user's profile Send private message 
Darkgame

Joined: 18 Mar 2011
Posts: 203

PostPosted: Tue 16 Aug 2011, 10:13    Post subject:  

can this installs with debs?
If so, can it install lxde?
Back to top
View user's profile Send private message 
Iguleder


Joined: 11 Aug 2009
Posts: 2031
Location: Israel, somewhere in the beautiful desert

PostPosted: Tue 16 Aug 2011, 14:09    Post subject:  

Usually I provide ndiswrapper, Sysprof and some modem drivers, this time I didn't due to lack of time.

If you make any working packages, please upload them and make sure you share them so others can enjoy them too.

Thanks Smile

_________________
My homepage
My GitHub profile
Back to top
View user's profile Send private message Visit poster's website 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Tue 16 Aug 2011, 16:31    Post subject:  

Stu, thanks for trying the wl.ko pet as i pm'd here is a thread for someone with more skills than me.

http://www.murga-linux.com/puppy/viewtopic.php?p=421596#421596

Since BK has suggested Iguleder to lead in a community dpup effort maybe he will be able to find some time for troublesome third party wifi drivers. Laughing
Back to top
View user's profile Send private message 
BHINTZ

Joined: 08 Aug 2006
Posts: 144

PostPosted: Tue 16 Aug 2011, 21:06    Post subject:  

I am enjoying D-LITE and would like to change weather in Conky to my own locale. Can someone give me a clue how to do that?

bob
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 7 of 9 [130 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0624s ][ Queries: 12 (0.0134s) ][ GZIP on ]