Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 15 Sep 2014, 00:05
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.15
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 148 [2207 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 146, 147, 148 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 04:12    Post subject:  

Quick post from work. Puppy installer is sensitive of right type of extlinux, syslinux etc.., disktype and probably gparted also. It will need profound testing to get it recognizing the partitions right.
I have faced that problem in Snow Puppy/Ice Puppy development.
At this stage. Dont use Puppy installer if you have ext4 partition. Use manual installing or other tools.

Getting PUI working is not my top priority. I would like to update gparted first.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 01 Aug 2011, 04:13    Post subject:  

pemasu,
Thanks for the explanation.
I understand now better this thread's title.
And what's going on.

The annoying thing is, that I can't combine the radeon driver with the Belgian keyboard. Same issue as in 4.99.2
I don't know enough about graphics drivers to evaluate the differences between the radeon and the vesa one.
But I can work as it is with the vesa one.
And if this is a one shot, no need to look into it, unless it interests you.

Code:
# report-video
VIDEO REPORT: Puppy Squeeze, version 5.0.0

Chip description:
oem: ATI MOBILITY RADEON 7500

Driver used by Xorg:
vesa

Video mode used by Xorg:
Resolution:  Depth 24  Depth: "Display"

...the above also recorded in /tmp/report-video
#

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Ray MK


Joined: 05 Feb 2008
Posts: 764
Location: UK

PostPosted: Mon 01 Aug 2011, 06:43    Post subject:  

Hi pemasu

Luvly Puppy - works well on my 9/10yr old Acer TravelMate 243LC.
Celeron 2.5Ghz proc. 256mb ram. 800ish mb swap partition.
Manual frugal to ext3.
booting via grub4dos. wifi via pcmcia Belkin card.

A small suggestion.
Adding grub4dos to the ISO would make it very easy for n00bs
to install to any media,
without having to re-size or create partitions on a first encounter with Puppy.

It seems to be reliable and a very easy way to setup booting from a
USB stick or an SDcard,
plus it eliminates the need for a n00b to worry about partitions and Gparted,
at least until a better understanding is acquired.

Alternatively, maybe a link to and a guide for grub4dos in the help page?

Anyway, a super Puppy - many thanks and much appreciation.

Very best regards - Ray
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1412
Location: Malvern, Worcs, UK

PostPosted: Mon 01 Aug 2011, 08:27    Post subject:  

Hi pemasu (& iguleder)

Frugal install on my HP 550 laptop.

Love having Frisbee as the network manager - works great on this laptop.

Also congrats on FlSynclient working ATB to configure my synaptics touchpad

Seem to have a problem with PNethood - doesn't find my samba shares - and setting the scan time does not seem to make the scan any longer??

No grub4dos installed??

Clicking on the loudspeaker just mutes sound - can't change sound levels without going into mixer? (Sound is working BTW).

Looking really good....

Thanks for all your hard work and outstanding innovations.
Cheers
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 08:29    Post subject:  

Thank you all of the feedback.
Beem. I cant say anything wise atm. But I wont forget your problem. Sometimes the problems have habit to find solution.

About included applications. I have got requests of xcompmgr, grub4dos, sfs load on the fly. Dave S would probably benefit that drivers and firmware tarballs are inside the main sfs. I will collect other wishes also.

Above suggestions are good and I will gladly include them to next version.
So far I will stick with Iguleders choice of sound tray application. But I noticed that lack of volume slider also. Iguleder reads this thread also, I think. He will notice that volume slider missing problem. I believe it is the default outlook of this application. I mean that you have to open the application before you get settings in hand.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 09:56    Post subject:  

Puppy Universal Installer, called now as PUI. I have struggled with it before.

I got it recognizing my ext3-ext4 partitions right by changing diskype binary.

Typically Puppies are built with woof using syslinux package from pet and disktype from the base distro.

Well. It does not always work with PUI.

First test. Change disktype binary to the one which has worked before with my builds. Done. I got better results.
Lets test does PUI work now better.

If not. Then next thing is to face syslinux package and that is tricky one.
disktype_bin_fixed-0.0.1.pet
Description 
pet

 Download 
Filename  disktype_bin_fixed-0.0.1.pet 
Filesize  42.13 KB 
Downloaded  223 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 10:15    Post subject:  

Beem. Interesting thing that you dont have whole xorg.conf section:

I have and I changed into be keyboard. Difficult to write with azerty keyboard.

Anyway. Try to manually add this section:

Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbRules" "xorg"
   Option      "XkbModel" "pc105"
   Option      "XkbLayout" "be" #xkeymap0
EndSection


And the whole xorg.conf. Remove phony .gz

How do I get finnish keyboard at first boot. I have pkeys=fi boot parameter in every frugal puppy install.
I have it in kernel row in menu.lst.

So far fatdog64 has been the only puppy which refuses to boot with that parameter. Rasistic puppy. Lol.

How about pkeys=be boot parameter.
xorg.conf.gz
Description 
gz

 Download 
Filename  xorg.conf.gz 
Filesize  6.81 KB 
Downloaded  225 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 10:55    Post subject:  

Iguleder et al.
Latest woof atm does not include this hack which calls pngoverlay from /usr/sbin/delayedrun after X is started.

I picked this lacking piece of script from drake-puppy.

Code:
  #110727 temporary hack (i hope)...
  #/usr/sbin/icon_switcher_cli is called from /etc/rc.d/rc.update, uses 'pngoverlay' to create overlay desktop icons.
  #however, pngoverlay requires X to be running. so, do that part here...
  if [ -f /usr/sbin/pngoverlay -a -e /usr/local/lib/X11/pixmaps/closebox_outline48.png ];then #overlay app created by vovchik (see source /usr/sbin/pngoverlay.bac)
   rm -f /usr/local/lib/X11/pixmaps/*_mntd*.png 2>/dev/null
   cd /usr/local/lib/X11/pixmaps
   cp -f /usr/sbin/pngoverlay /usr/local/lib/X11/pixmaps/ #dumb, but needs to be in same folder.
   for ONEDRV in card drive floppy optical usbdrv
   do
    ./pngoverlay ${ONEDRV}48.png closebox_outline48.png ${ONEDRV}_mntd48.png #background foreground output.
    ./pngoverlay ${ONEDRV}48.png locked_outline48.png ${ONEDRV}_mntd_boot48.png
   done
   rm -f /usr/local/lib/X11/pixmaps/pngoverlay
   cd /root
  fi


And the whole delayedrun script is here. Remove the phony .gz

I suppose this is the needed piece to get pngoverlay to show mounted drive icons after first boot without extra hassling with change drive icons switcher.
delayedrun_from_puppy_drake.gz
Description 
gz

 Download 
Filename  delayedrun_from_puppy_drake.gz 
Filesize  14.65 KB 
Downloaded  237 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 11:22    Post subject:  

Yep. I did quick edit sfs build of main sfs and that missing code fixed the mounted drive icon not pngoverlaid. It works now !!!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 11:56    Post subject:  

Uploading now the quickly rebuild of 5.0.0 beta version. I used edit sfs, not remastering since I dont trust to remasterpup or remasterpup2 enough.
New version is 5.0.0.2. I hope I dont step in Iguleders shoes. I need to think about renamings soon.

I upload it first to the same folder as 5.0.0. I fix the location later.

Anyway the rebuild has pngoverlay fix, disktype binary fix, sfs load on the fly, edit sfs, grub4dos and xcompmgr.
I will create proper woof build with kernel modules and firmware soon.

I will go now to roller skating. I leave this to upload and check permissions when I come back.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 01 Aug 2011, 12:41    Post subject:  

Frugal installation on ext4 partition looks great including installation of latest NVIDIA driver, however, I'll wait for new download before testing more.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 01 Aug 2011, 13:35    Post subject:  

Allright. Upload finished. Permissions checked. This version only has fixes for those bugs so far found. Pngoverlay should work now straight.
Disktype binary for proper PUI handling changed, seamonkey default handling improved including symlink for moz-scripts. Nouveau and fbdev removed so Nvidia should install straight.
Sfs load on the fly, edit sfs, grub4dos and xcompmgr added. No gcompmgr included.

Still separate z....sfs. Sorry Dave S. For Beem only my above psychic support for be azerty, non real fixes.

Download link in the first page.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 01 Aug 2011, 15:28    Post subject:  

Thank you pemasu.
I am preparing for a 5 day leave.
If I have time later, I'll look into the xorg.conf.
And yes, I forgot that there is a possibility to set the keyboard at boot.
Will adapt the kernel line.
Strange that it is only the 499.2 and 5.0.0 presenting this issue.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Ray MK


Joined: 05 Feb 2008
Posts: 764
Location: UK

PostPosted: Mon 01 Aug 2011, 15:50    Post subject:  

Hi pemasu

Just to let you know that all works extremely well on my new E732
Emachines laptop.

Fantastic stuff.

Now to try 5.0.0.2 - thanks again.

Very best regards - Ray
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 01 Aug 2011, 15:51    Post subject:  

Béèm wrote:
Thank you pemasu.
I am preparing for a 5 day leave.
If I have time later, I'll look into the xorg.conf.
And yes, I forgot that there is a possibility to set the keyboard at boot.
Will adapt the kernel line.
Strange that it is only the 499.2 and 5.0.0 presenting this issue.
OK I took some time.
Tried the radeon, radeonhd, ati ati and intel intel divers.
They all bring me to a qwerty keyboard.
The generated config is attached with a phony gz.
All sections of devices have disappeared.

So I am back in vesa.
xorg.conf.gz
Description 
gz

 Download 
Filename  xorg.conf.gz 
Filesize  2.64 KB 
Downloaded  215 Time(s) 

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 148 [2207 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 146, 147, 148 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0983s ][ Queries: 12 (0.0143s) ][ GZIP on ]