Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 02:30
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.15
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 106 of 148 Posts_count   Goto page: Previous 1, 2, 3, ..., 104, 105, 106, 107, 108, ..., 146, 147, 148 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 16 Jan 2012, 17:58    Post_subject:  

Gcmartin. I have been sidetracked and then maintracked by the sidetrack of glibc-charsets-locales and missing pieces. I have played with strace to track system calls and what it find missing when launching certain programs. What I have found. fi_FI.UTF-8 needs to be in /usr/lib/locale.

Another thing which is missing is..../usr/lib/gconv/gconv-modules.cache which causes that several gtkdialog apps launches slower than they should.

Here is the fixing pet for that problem. I suggest all to install it. You get snappier response for many applications starting.

It took long for me to find this fix. I have tracked the cause to Barry`s gconv template which has implicit NOEXCEPTIONS flag...which effectively rules out that file.

Anyway....I have been testing now the latest jwm-576 which has even more bug fixes, now screen resolution change will lead to the jwm -restart. It seems to behave. Now...I am quite ready for next test build....which can be even at release stage.
gconv-fix-0.0.1.pet
Description 
pet

 Download 
Filename  gconv-fix-0.0.1.pet 
Filesize  10.97 KB 
Downloaded  121 Time(s) 
Back to top
View user's profile Send_private_message 
edoc


Joined: 07 Aug 2005
Posts: 4390
Location: Southeast Georgia, USA

PostPosted: Tue 17 Jan 2012, 15:24    Post_subject: gphoto2 fails to recognize USB 2.0 Webcam ArkMicro  

gphoto2 fails to recognize USB 2.0 Webcam ArkMicro

It was recognized and worked fine in Skype and other apps under Fluppy. I rarely have occasion to use a Webcam but just tried it and was surprised that it failed.

Is there an alternative Webcam/photo app to gphoto2 that may be more likely to work?

EDIT: Just loaded and tested Skype on this laptop and it recognizes the ArkMicro fine.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Tue 17 Jan 2012, 15:44    Post_subject:  

Have you tried guvcwiew from multimedia menu ?
Back to top
View user's profile Send_private_message 
edoc


Joined: 07 Aug 2005
Posts: 4390
Location: Southeast Georgia, USA

PostPosted: Tue 17 Jan 2012, 15:54    Post_subject:  

I am definitely in need of more coffee ... sigh.

That app works fine thanks!

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send_private_message Visit_website 
backi

Joined: 27 Feb 2011
Posts: 460
Location: GERMANY

PostPosted: Wed 18 Jan 2012, 12:44    Post_subject:  

Hi folks !

Here is something which looks quite interesting .

Compressing RAM with zRam .

I am not a a Linux expert but maybe someone more skilled can use this idea to make use of it in Puppy or elsewhere .


http://weirdfellow.wordpress.com/2011/05/04/compressed-ram-with-zram/
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Wed 18 Jan 2012, 14:00    Post_subject:  

Iguleder`s 2.6.39.4 does not have zram module enable ie not not compiled in kernel. But I took the script to the safe deposit. When I next time compile kernel, I might include it. Not sure how useful it really is. You create compressed zram to the ram, which you dont have enough already. So swapping to the hdd increases. Okay....swapping to the ram is faster, but what is the result.
For me....with 4 Gb ram, more useful would be editing parameters...which does not use swap to the hdd so early.....I have read that even with enough ram...there is swapping to the hdd.
Back to top
View user's profile Send_private_message 
soundNICK

Joined: 13 Oct 2010
Posts: 126

PostPosted: Wed 18 Jan 2012, 22:08    Post_subject:
Sub_title: pemasu - no 5x12 thread yet / but I DL'd it anyway
 

pemasu - I looked this afternoon, and there was 5x12 in the repository_
soundNICK does 5x12 first comment dance Smile

I see lots of changes in 5x12... I like the big clock default. You changed
back to old system for deleting apps in PPM... I liked the older way, so
this is good.

JWM is default windowmanager, it works very well, as does flash installer

real problem #1 I had was with PPM... it keeps looping on "examine dependencies"
and never displays them (the dependencies)... it doesnt let you download them,
and doesnt display them, even though there are many for some known apps.

you've added something to allow savefile entries before exiting, which is good_
however, still I have problem of only one savefile allowed... I have to move any older
savefiles to deep dir for 5x12 not to freeze at startup - shorter way to say, only
one savefile is allowed... hmm

It looks good otherwise

soundNICK
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Thu 19 Jan 2012, 02:31    Post_subject:  

Soundnick. It was not supposed to be downloaded and reported yet. Lol. But...you seem to have found serious bug in it. Somehow one of Shinobars petget folder files has been replaced. I have placed petget as zzzzpetget to the distro specs so it really should have not be possible to happen. I dont know the reason for this. But...I will rebuild the 5.X.12 and place manually Shinobar`s petget to the rootfs-complete to be sure. I have now also removed the petget folder from rootfs-skeleton.
Anyway...the reason to the dependency checking misbehavior has been found.

Okay....if someone else wants tasty and likes some obscure bug hunting, I dont remove the 5.X.12 from repo...but it will be replaced today....after my work...in the evening....in the Finland.

Thanks Soundnick.
Back to top
View user's profile Send_private_message 
soundNICK

Joined: 13 Oct 2010
Posts: 126

PostPosted: Thu 19 Jan 2012, 07:16    Post_subject:  

pemasu wrote:
Soundnick. It was not supposed to be downloaded and reported yet. Lol. But...you seem to have found serious bug in it /snip/

Anyway...the reason to the dependency checking misbehavior has been found.

/snip/if someone else wants tasty and likes some obscure bug hunting, I dont remove the 5.X.12 from repo. /snip/

Thanks Soundnick.


pemasu ooooo... so sorry to jump the gun... well, Im glad if something could
be fixed from my complaining Smile

I did find one more thing which probably isnt right... in the 5x12 original version
I downloaded, "Personalize Settings" menu pops up every reboot, no matter
if changes were made and saved before... this is the one for setting time and so forth.

continued good luck with 5x series - my favorite ! !

soundNICK
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Thu 19 Jan 2012, 10:38    Post_subject:  

Soundnick. That problem have been noticed and fixed. I removed some stuff from Shinobars firstrun script, which I dont need. And I accidentally removed the checking if firstrun has been lauched before. It has been fixed in the fixed version.

But....if you find something else....that is another bug, becauce nothing else will be changed.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Thu 19 Jan 2012, 13:03    Post_subject:  

petget-20120108.pet created by Shinobar seems to loop dependencies in exprimo. Hmm...I just would like to upload this 5.X.12 soon with fixed firstrun. Maybe I switch to use Barry`s original petget folder, from today uploaded commit woof2. Lets see if it has still usb booting and ppm pet installation saving problem. At least it checks dependencies ok, and offers to download and install them.
Back to top
View user's profile Send_private_message 
soundNICK

Joined: 13 Oct 2010
Posts: 126

PostPosted: Thu 19 Jan 2012, 13:31    Post_subject:  

pemasu wrote:
/snip/
But....if you find something else....that is another bug, becauce nothing else will be changed.


pemasu... OK... two things after getting 5x12 now in repo... this had
a different checksum and I assumed it was your corrected version... dunno for sure.

New BUG #1: when another partition is mounted_ left click shows folders on that
(by RoxFiler)... but... a right click is /supposed/ to show menu where you can
unmount or do other... instead of that, the menu which pops up is: Convert to MP3 /
dir2pet / dir2sfs /...lots of other. Ive seen this before, but sorry cant tell you
which button it is usually for.
This is a mixup for clicking on the mounted drive, Im sure.

2nd thing I wanted to mention... but I see you added post about looking at
options to fix that looping dependency problem.. wasnt working yet when
I downloaded most recent, but you already know by your comment before
this one.

I would rather be known as "the happy user of 5x10", than as "the guy who
keeps telling me what went wrong with 5x12" Smile Dont worry too much...
there are several in this series which work fine already !

Anyway, hope this bug report helps.

soundNICK
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Thu 19 Jan 2012, 16:15    Post_subject:  

There is an irritating bug in Exprimo version 11

When the user clicks on the default audio mixer button
in the mhwaveedit window retrovol doesn't pop up
like in previous versions of exprimo.

The problem is that mhwaveedit needs to be compiled with the
option for default audio mixer.

A quick solution is to use a configuration file in /root.
This has a line that sets the default audio mixer.
It's an alternative method that you might find desirable.

http://www.murga-linux.com/puppy/viewtopic.php?p=595116#595116

____________________________________________
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Thu 19 Jan 2012, 17:13    Post_subject:  

Yeah. I know what irritation means. Been hunting today the bug which Soundnick found. I mean right click bug. I believe I have found the reason, but...I dont know the cause exactly....so I am not posting the solution yet. I am going to make another test build to see if it is fixed.

Don570. I will hunt your suggestion and implement it.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Thu 19 Jan 2012, 18:55    Post_subject:  

Dpup Exprimo 5.X.12 has been uploaded.
- Ffmpeg-0.91
- Gnome-mplayer-1.0.5
- Mplayer2-svn
- Latest Radky`s PupApplications, PupControl-1.8.8
- Shinobar`s Firstrun ie Personalize settings added....hostname changing now possible without messing the rox-filer search speed.
- GFTP updated to use Ttuuxxx`s icons and compiled in dpup with that edited source.
- Gnewpet (under heavy development) added under the Utilility. It enables the installed pet repetting straight from ./packages storaged database file...you can grab a installed pet from other puplet and make installable pet with gnewpet.
- JWM-576, no more flickering when installing pet, also resolution change automatically restarts jwm.
- PUI-2, Jemimah`s new Puppy Universal Installer, old version as choice also.
- Couple of jwm themes additions, Aurora gtk theme with engine added.
- Gconv-fix which makes the starting of gtkdialog apps as they should. Annoying delay has been vanished. - This has been long term hunt, fix found by nice strace app which captures all system calls by launched app and the output can be directed to the text file, where the not found libs and files can be traced.
- Iguleders Packages-puppy-dpup-official has been removed. I havent had time and energy to create - database file for those uploaded 465 pets for the pet_packages-dpup repo in smokey01.com where I uploaded those pets I had from Iguleders site. I had almost all.
- Puppizard removed, the scripts repo also vanished.
- Winfonts added for easy Windows fonts sharing, helps Windows OS users. Dont hang me, lol.
- Also Smokey01`s simple DVDCopy app in Multimedia. I suspect Smokey01 will improve it still.
- Pmusic-2.3.0 with all dependencies.
- Oh yeah...using latest woof2...those scripts which are updated by Shinobar excluded. Otherwise up to date woof2 build....except /usr/local/bin/drive_all updated script has been left out. It broke drive icons right click content. At least in Exprimo.

Download link: http://www.smokey01.com/pemasu/DpupSqueeze5X/DpupExprimo5X12/
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 106 of 148 Posts_count   Goto page: Previous 1, 2, 3, ..., 104, 105, 106, 107, 108, ..., 146, 147, 148 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1170s ][ Queries: 12 (0.0264s) ][ GZIP on ]