Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 21:56
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
How to make Intel 2200BG WiFi work in Dell Latitude 510
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 15 Mar 2006
Posts: 8
Location: Florida

PostPosted: Sun 26 Mar 2006, 02:43    Post_subject:  How to make Intel 2200BG WiFi work in Dell Latitude 510  

I made it work.
Puppy 1.0.8rc1

1. Download ipw2200-1.0.1.tar.gz
2. Copy ipw2200-1.0.1.tar.gz to /
3. Open console
4 . cd /
5. tar -zxvf ipw2200-1.0.1.tar.gz
6. depmod I got an error here about audio (???) but everything still works.
7. modprobe ipw2200
8. iwconfig eth0 essid YOUR_SSID key YOUR_KEY mode Managed
I had an error:
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device eth0 ; Operation not supprted.

I changed eth0 to eth1:
iwconfig eth1 essid YOUR_SSID key YOUR_KEY mode Managed
and that worked fine...
9. dhcpcd -t 20 -h puppypc -d eth1
10. DONE! - Open Browser and surf.


1. I downloaded ipw2200-1.0.1.tar.gz from
note the version number and get the correct version!!!
I'm not too smart about these things, all I know is that the version I used worked.

2. I don't know if the file has to be in / I put it there and had success.

6. The full error was:
Unresolved symbols in lib/modules/2.4.29/sound/oss/viaaudiocombo.o.gz
I don't know what "Unresolved sysmbols" means. I don't know why references are made to sound/oss/viaaudiocombo.o.gz I do know that this error never kept the wireless from working.

8. I boot Puppy 1.0.8rc1 from a Memorex TravelDrive 512 USB. It operates under Windows XP when booting from the hard disk. When I asked windows about the wireless, it reported a MAC address. In the console of Puppy the command ifconfig -a displayed information about eth0, eth1 and lo. The MAC address of eth1 matched the address reported by XP. So that was why I tried the change from eth0 to eth1. It worked and I guess I did the right thing.

9. I use BellSouth.net as my ISP. The router they gave me assigns an IP address automagically. So I used dhcpcd. If you have a static IP address you'll probably have to do some thing different here.

I did it just like this and it worked. I really don't know much about Puppy or Linux. If you send technical questions to me I probably won't be able to help you.

After I did this I restarted Puppy. No Wireless!!!! Crap! I had to do it all over again. but...

1. Rename ipw2200-1.0.1.tar.gz to ipw2200-1.0.1
2. Make a copy of /root/.etc/rc.d/rc.local0
I named my copy /root/.etc/rc.d/rc.local0_ORIGINAL
3. Edit /root/.etc/rc.d/rc.local0 and add the following:
#Wireless up at boot time
#Intel 2200BG - Dell Latitude 510 - Puppy 1.0.8rc1
cd /
tar -zxvf /root/ipw2200-1.0.1
modprobe ipw2200
iwconfig eth1 essid YOUR_SSID key YOUR_KEY mode Managed
dhcpcd -t 20 -h puppypc -d eth1
#That should do it
4. Save the file and restart - Open the Browser and surf.

Good luck with all this. I hope that it will be useful to someone.

in sunny south Florida
Back to top
View user's profile Send_private_message Visit_website 
Official Dog Handler

Joined: 04 May 2005
Posts: 11463
Location: Arizona USA

PostPosted: Sun 26 Mar 2006, 06:55    Post_subject:  

Good job, revdoug! Smile Thanks for the excellent writeup. I'm sure other beginners will find it helpful.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0449s ][ Queries: 11 (0.0034s) ][ GZIP on ]